cad/gmsh: Update to version 4.0.2 and reset maintainer to ports@
Upstream change log: https://gitlab.onelab.info/gmsh/gmsh/blob/master/CHANGELOG.txt
This commit is contained in:
parent
6a752510b9
commit
74a51579ef
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482317
4 changed files with 128 additions and 293 deletions
|
@ -2,19 +2,17 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gmsh
|
||||
DISTVERSION= 3.0.6
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 4.0.2
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= http://gmsh.info/src/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
|
||||
DIST_SUBDIR= gmsh
|
||||
|
||||
MAINTAINER= jrm@FreeBSD.org
|
||||
COMMENT?= Automatic 3D finite element mesh generator
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Automatic 3D finite element mesh generator
|
||||
|
||||
LICENSE= AGPLv3+ APACHE20 GPLv3+ GPLv2+ LGPL21
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_FILE_GPLv2+= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
BROKEN_FreeBSD_12_i386= fails to build on FreeBSD 12 i386 due to a clang bug: https://llvm.org/bugs/show_bug.cgi?id=21903
|
||||
BROKEN_powerpc64= fails to build: .rodata._Z7pow_intRKdRKi referenced in section .got of CMakeFiles/gmsh.dir/Numeric/bezierBasis.cpp.o: defined in discarded section
|
||||
|
@ -27,7 +25,7 @@ LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
|
|||
libsz.so:science/szip
|
||||
RUN_DEPENDS= getdp:science/getdp
|
||||
|
||||
USES= blaslapack cmake fortran jpeg tar:tgz
|
||||
USES= blaslapack cmake fortran gl jpeg tar:tgz
|
||||
USE_GL= gl glu
|
||||
USE_XORG= x11 xcursor xext xinerama xfixes xft xrender
|
||||
|
||||
|
@ -37,12 +35,12 @@ MAKE_JOBS_UNSAFE= yes
|
|||
|
||||
CMAKE_ARGS= -DCMAKE_SKIP_RPATH:BOOL=YES
|
||||
|
||||
OPTIONS_DEFINE= CGNS DOCS MED OCC SHARED STATIC
|
||||
OPTIONS_DEFAULT= MED
|
||||
OPTIONS_DEFINE= CGNS MED OCC SHARED STATIC
|
||||
OPTIONS_DEFAULT= CGNS MED OCC
|
||||
|
||||
CGNS_DESC= Enable experimental CGNS mesh support
|
||||
CGNS_DESC= Enable CGNS mesh import
|
||||
MED_DESC= Enable MED mesh and post file formats
|
||||
OCC_DESC= Enable Open CASCADE geometrical models
|
||||
OCC_DESC= Enable OpenCASCADE geometrical models
|
||||
SHARED_DESC= Build shared library and install header files
|
||||
STATIC_DESC= Build static library
|
||||
|
||||
|
@ -59,21 +57,22 @@ CGNS_LIB_DEPENDS= libcgns.so:science/cgnslib
|
|||
DOCS_CMAKE_BOOL= INSTALL_DOCS
|
||||
MED_CMAKE_BOOL= ENABLE_MED
|
||||
MED_LIB_DEPENDS= libmed.so:french/med
|
||||
OCC_CFLAGS= -DHAVE_CONFIG_H -DHAVE_WOK_CONFIG_H -DFREEBSD
|
||||
OCC_CMAKE_BOOL= ENABLE_OCC
|
||||
OCC_CMAKE_ON= -DOCC_INC=${LOCALBASE}/include/OpenCASCADE
|
||||
OCC_CONFLICTS= gmsh-[23].*
|
||||
OCC_CONFLICTS_OFF= gmsh-occ-[23].*
|
||||
OCC_LIB_DEPENDS= libopenblas.so:math/openblas libTKernel.so:cad/opencascade
|
||||
OCC_USES= gnome
|
||||
OCC_USE= gnome=cairo
|
||||
SHARED_ALL_TARGET= shared
|
||||
SHARED_CMAKE_BOOL= ENABLE_BUILD_SHARED
|
||||
SHARED_VARS= USE_LDCONFIG=yes
|
||||
STATIC_ALL_TARGET= lib
|
||||
STATIC_CMAKE_BOOL= ENABLE_BUILD_LIB
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|share/doc/gmsh|${DOCSDIR_REL}|" \
|
||||
-e 's|share/man/man1|man/man1|' ${WRKSRC}/CMakeLists.txt
|
||||
|
||||
post-install-SHARED-on:
|
||||
${RM} -r ${STAGEDIR}/wrkdirs
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1510157284
|
||||
SHA256 (gmsh/gmsh-3.0.6-source.tgz) = 9700bcc440d7a6b16a49cbfcdcdc31db33efe60e1f5113774316b6fa4186987b
|
||||
SIZE (gmsh/gmsh-3.0.6-source.tgz) = 12663776
|
||||
TIMESTAMP = 1538528267
|
||||
SHA256 (gmsh/gmsh-4.0.2-source.tgz) = f3c993408153961bd0bbd762458231abe50aeaabe7ab2466462975f2971e5c0d
|
||||
SIZE (gmsh/gmsh-4.0.2-source.tgz) = 12764404
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Fltk/Main.cpp.orig 2016-08-28 23:27:04 UTC
|
||||
+++ Fltk/Main.cpp
|
||||
@@ -3,7 +3,7 @@
|
||||
// See the LICENSE.txt file for license information. Please report all
|
||||
// bugs and problems to the public mailing list <gmsh@onelab.info>.
|
||||
|
||||
-#include <stdlib.h>
|
||||
+#include <cstdlib>
|
||||
#include <string>
|
||||
#include "Gmsh.h"
|
||||
#include "GmshMessage.h"
|
|
@ -1,269 +1,116 @@
|
|||
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CREDITS.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/baffles.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/boolean.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/coherence.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/component8.step
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/compsolid.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/compsolid2.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/extrude.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/extrude2.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/fillet.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/fillet2.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/fillet3.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/fragment_numbering.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/hybrid_occ_builtin.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/import.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/import2.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/intersect_line_volume.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/neuron.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/periodic.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/pipe.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/primitives.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/revolve.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/revolve2.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/simple.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/simple2.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/simple3.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/simple4.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/simple5.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/simple6.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/simple7.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/spline.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/thicksolid.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/thrusections.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/transfinite.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/transform.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/boolean/twist.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/anim.script
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/encode.script
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/isosurf.script
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/lowmem-anim.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/multislice.script
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/plot2d.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/primitives.pos
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/rotate.script
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/title.script
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/post_processing/view_groups.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/antenna.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/antenna.i1
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/cone.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/cube.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/fields.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/filter.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/hex.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/homology.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/indheat.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/machine.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/machine.i1
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/machine.i2
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/piece-extr-rec.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/piece-extr.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/piece.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/pripyrtet.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/sphere-discrete.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/sphere-surf.stl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/sphere.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/splines.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/square_regular.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/tower.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/tower.i1
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/tower.i2
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/tower.i3
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/tower.i4
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/tower.i5
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/simple_geo/transfinite.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/struct/Exists_GetForced.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/demos/struct/struct.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/bgmesh.pos
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/image.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t1.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t10.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t11.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t12.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t13.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t13_data.msh
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t14.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t15.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t16.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t17.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t17.pos
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t2.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t3.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t4.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t5.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t6.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t7.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t8.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t9.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view1.pos
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view2.pos
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view3.pos
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view4.pos
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view5.msh
|
||||
%%SHARED%%include/gmsh/BasisFactory.h
|
||||
%%SHARED%%include/gmsh/CADDistances.h
|
||||
%%SHARED%%include/gmsh/CGNSOptions.h
|
||||
%%SHARED%%include/gmsh/Cell.h
|
||||
%%SHARED%%include/gmsh/CellComplex.h
|
||||
%%SHARED%%include/gmsh/Chain.h
|
||||
%%SHARED%%include/gmsh/ChainComplex.h
|
||||
%%SHARED%%include/gmsh/ColorTable.h
|
||||
%%SHARED%%include/gmsh/CondNumBasis.h
|
||||
%%SHARED%%include/gmsh/Context.h
|
||||
%%SHARED%%include/gmsh/ElementType.h
|
||||
%%SHARED%%include/gmsh/FuncSpaceData.h
|
||||
%%SHARED%%include/gmsh/GEdge.h
|
||||
%%SHARED%%include/gmsh/GEdgeCompound.h
|
||||
%%SHARED%%include/gmsh/GEdgeLoop.h
|
||||
%%SHARED%%include/gmsh/GEntity.h
|
||||
%%SHARED%%include/gmsh/GFace.h
|
||||
%%SHARED%%include/gmsh/GFaceCompound.h
|
||||
%%SHARED%%include/gmsh/GModel.h
|
||||
%%SHARED%%include/gmsh/GPoint.h
|
||||
%%SHARED%%include/gmsh/GRbf.h
|
||||
%%SHARED%%include/gmsh/GRegion.h
|
||||
%%SHARED%%include/gmsh/GRegionCompound.h
|
||||
%%SHARED%%include/gmsh/GVertex.h
|
||||
%%SHARED%%include/gmsh/GaussIntegration.h
|
||||
%%SHARED%%include/gmsh/GenericEdge.h
|
||||
%%SHARED%%include/gmsh/GenericFace.h
|
||||
%%SHARED%%include/gmsh/GenericRegion.h
|
||||
%%SHARED%%include/gmsh/GenericVertex.h
|
||||
%%SHARED%%include/gmsh/Gmsh.h
|
||||
%%SHARED%%include/gmsh/GmshConfig.h
|
||||
%%SHARED%%include/gmsh/GmshDefines.h
|
||||
%%SHARED%%include/gmsh/GmshMessage.h
|
||||
%%SHARED%%include/gmsh/GmshSocket.h
|
||||
%%SHARED%%include/gmsh/GmshVersion.h
|
||||
%%SHARED%%include/gmsh/Hash.h
|
||||
%%SHARED%%include/gmsh/Homology.h
|
||||
%%SHARED%%include/gmsh/Integration3D.h
|
||||
%%SHARED%%include/gmsh/JacobianBasis.h
|
||||
%%SHARED%%include/gmsh/Levy3D.h
|
||||
%%SHARED%%include/gmsh/MEdge.h
|
||||
%%SHARED%%include/gmsh/MEdgeHash.h
|
||||
%%SHARED%%include/gmsh/MElement.h
|
||||
%%SHARED%%include/gmsh/MElementCut.h
|
||||
%%SHARED%%include/gmsh/MElementOctree.h
|
||||
%%SHARED%%include/gmsh/MFace.h
|
||||
%%SHARED%%include/gmsh/MFaceHash.h
|
||||
%%SHARED%%include/gmsh/MHexahedron.h
|
||||
%%SHARED%%include/gmsh/MLine.h
|
||||
%%SHARED%%include/gmsh/MPoint.h
|
||||
%%SHARED%%include/gmsh/MPrism.h
|
||||
%%SHARED%%include/gmsh/MPyramid.h
|
||||
%%SHARED%%include/gmsh/MQuadrangle.h
|
||||
%%SHARED%%include/gmsh/MTetrahedron.h
|
||||
%%SHARED%%include/gmsh/MTriangle.h
|
||||
%%SHARED%%include/gmsh/MTrihedron.h
|
||||
%%SHARED%%include/gmsh/MVertex.h
|
||||
%%SHARED%%include/gmsh/MVertexBoundaryLayerData.h
|
||||
%%SHARED%%include/gmsh/MeshOpt.h
|
||||
%%SHARED%%include/gmsh/MeshOptCommon.h
|
||||
%%SHARED%%include/gmsh/MeshOptObjContrib.h
|
||||
%%SHARED%%include/gmsh/MeshOptObjContribFunc.h
|
||||
%%SHARED%%include/gmsh/MeshOptObjContribScaledNodeDispSq.h
|
||||
%%SHARED%%include/gmsh/MeshOptObjectiveFunction.h
|
||||
%%SHARED%%include/gmsh/MeshOptPatch.h
|
||||
%%SHARED%%include/gmsh/MeshOptVertexCoord.h
|
||||
%%SHARED%%include/gmsh/MeshOptimizer.h
|
||||
%%SHARED%%include/gmsh/MeshQualityObjContribIdealJac.h
|
||||
%%SHARED%%include/gmsh/MeshQualityObjContribInvCond.h
|
||||
%%SHARED%%include/gmsh/MeshQualityOptimizer.h
|
||||
%%SHARED%%include/gmsh/Numeric.h
|
||||
%%SHARED%%include/gmsh/OS.h
|
||||
%%SHARED%%include/gmsh/Octree.h
|
||||
%%SHARED%%include/gmsh/OctreeInternals.h
|
||||
%%SHARED%%include/gmsh/OctreePost.h
|
||||
%%SHARED%%include/gmsh/OpenFile.h
|
||||
%%SHARED%%include/gmsh/OptHOM.h
|
||||
%%SHARED%%include/gmsh/OptHomFastCurving.h
|
||||
%%SHARED%%include/gmsh/OptHomIntegralBoundaryDist.h
|
||||
%%SHARED%%include/gmsh/OptHomMesh.h
|
||||
%%SHARED%%include/gmsh/OptHomObjContribCADDist.h
|
||||
%%SHARED%%include/gmsh/OptHomObjContribMetricMin.h
|
||||
%%SHARED%%include/gmsh/OptHomObjContribScaledJac.h
|
||||
%%SHARED%%include/gmsh/OptHomRun.h
|
||||
%%SHARED%%include/gmsh/Options.h
|
||||
%%SHARED%%include/gmsh/PView.h
|
||||
%%SHARED%%include/gmsh/PViewData.h
|
||||
%%SHARED%%include/gmsh/PViewDataGModel.h
|
||||
%%SHARED%%include/gmsh/PViewDataList.h
|
||||
%%SHARED%%include/gmsh/PViewOptions.h
|
||||
%%SHARED%%include/gmsh/Pair.h
|
||||
%%SHARED%%include/gmsh/ParamCoord.h
|
||||
%%SHARED%%include/gmsh/PluginManager.h
|
||||
%%SHARED%%include/gmsh/Range.h
|
||||
%%SHARED%%include/gmsh/SBoundingBox3d.h
|
||||
%%SHARED%%include/gmsh/SOrientedBoundingBox.h
|
||||
%%SHARED%%include/gmsh/SPoint2.h
|
||||
%%SHARED%%include/gmsh/SPoint3.h
|
||||
%%SHARED%%include/gmsh/STensor3.h
|
||||
%%SHARED%%include/gmsh/SVector3.h
|
||||
%%SHARED%%include/gmsh/StringUtils.h
|
||||
%%SHARED%%include/gmsh/ThinLayer.h
|
||||
%%SHARED%%include/gmsh/VertexArray.h
|
||||
%%SHARED%%include/gmsh/Voronoi3D.h
|
||||
%%SHARED%%include/gmsh/adaptiveData.h
|
||||
%%SHARED%%include/gmsh/bezierBasis.h
|
||||
%%SHARED%%include/gmsh/boundaryLayersData.h
|
||||
%%SHARED%%include/gmsh/cartesian.h
|
||||
%%SHARED%%include/gmsh/crossConfTerm.h
|
||||
%%SHARED%%include/gmsh/directions3D.h
|
||||
%%SHARED%%include/gmsh/discreteEdge.h
|
||||
%%SHARED%%include/gmsh/discreteFace.h
|
||||
%%SHARED%%include/gmsh/discreteRegion.h
|
||||
%%SHARED%%include/gmsh/discreteVertex.h
|
||||
%%SHARED%%include/gmsh/dofManager.h
|
||||
%%SHARED%%include/gmsh/drawContext.h
|
||||
%%SHARED%%include/gmsh/elasticitySolver.h
|
||||
%%SHARED%%include/gmsh/elasticityTerm.h
|
||||
%%SHARED%%include/gmsh/femTerm.h
|
||||
%%SHARED%%include/gmsh/fullMatrix.h
|
||||
%%SHARED%%include/gmsh/gmp_blas.h
|
||||
%%SHARED%%include/gmsh/gmp_matrix.h
|
||||
%%SHARED%%include/gmsh/gmp_normal_form.h
|
||||
%%SHARED%%include/gmsh/gmshLevelset.h
|
||||
%%SHARED%%include/gmsh/groupOfElements.h
|
||||
%%SHARED%%include/gmsh/laplaceTerm.h
|
||||
%%SHARED%%include/gmsh/linearSystem.h
|
||||
%%SHARED%%include/gmsh/linearSystemCSR.h
|
||||
%%SHARED%%include/gmsh/linearSystemFull.h
|
||||
%%SHARED%%include/gmsh/linearSystemGMM.h
|
||||
%%SHARED%%include/gmsh/linearSystemMUMPS.h
|
||||
%%SHARED%%include/gmsh/linearSystemPETSc.h
|
||||
%%SHARED%%include/gmsh/mathEvaluator.h
|
||||
%%SHARED%%include/gmsh/mathex.h
|
||||
%%SHARED%%include/gmsh/meshGEdge.h
|
||||
%%SHARED%%include/gmsh/meshGFace.h
|
||||
%%SHARED%%include/gmsh/meshGFaceDelaunayInsertion.h
|
||||
%%SHARED%%include/gmsh/meshGFaceOptimize.h
|
||||
%%SHARED%%include/gmsh/meshMetric.h
|
||||
%%SHARED%%include/gmsh/meshPartition.h
|
||||
%%SHARED%%include/gmsh/meshPartitionOptions.h
|
||||
%%SHARED%%include/gmsh/mpz.h
|
||||
%%SHARED%%include/gmsh/nodalBasis.h
|
||||
%%SHARED%%include/gmsh/onelab.h
|
||||
%%SHARED%%include/gmsh/onelabUtils.h
|
||||
%%SHARED%%include/gmsh/orthogonalTerm.h
|
||||
%%SHARED%%include/gmsh/partitionEdge.h
|
||||
%%SHARED%%include/gmsh/partitionFace.h
|
||||
%%SHARED%%include/gmsh/partitionVertex.h
|
||||
%%SHARED%%include/gmsh/picojson.h
|
||||
%%SHARED%%include/gmsh/pointsGenerators.h
|
||||
%%SHARED%%include/gmsh/polynomialBasis.h
|
||||
%%SHARED%%include/gmsh/simple3D.h
|
||||
%%SHARED%%include/gmsh/simpleFunction.h
|
||||
%%SHARED%%include/gmsh/sparsityPattern.h
|
||||
%%SHARED%%include/gmsh/thermicSolver.h
|
||||
%%SHARED%%include/gmsh/yamakawa.h
|
||||
%%SHARED%%lib/libGmsh.so
|
||||
%%SHARED%%lib/libGmsh.so.%%VE%%
|
||||
%%SHARED%%lib/libGmsh.so.%%VER%%
|
||||
%%STATIC%%lib/libGmsh.a
|
||||
%%DOCSDIR%%/CHANGELOG.txt
|
||||
%%DOCSDIR%%/CREDITS.txt
|
||||
%%DOCSDIR%%/LICENSE.txt
|
||||
%%DOCSDIR%%/demos/boolean/baffles.geo
|
||||
%%DOCSDIR%%/demos/boolean/boolean.geo
|
||||
%%DOCSDIR%%/demos/boolean/coherence.geo
|
||||
%%DOCSDIR%%/demos/boolean/component8.step
|
||||
%%DOCSDIR%%/demos/boolean/compsolid.geo
|
||||
%%DOCSDIR%%/demos/boolean/compsolid2.geo
|
||||
%%DOCSDIR%%/demos/boolean/extrude.geo
|
||||
%%DOCSDIR%%/demos/boolean/extrude2.geo
|
||||
%%DOCSDIR%%/demos/boolean/fillet.geo
|
||||
%%DOCSDIR%%/demos/boolean/fillet2.geo
|
||||
%%DOCSDIR%%/demos/boolean/fillet3.geo
|
||||
%%DOCSDIR%%/demos/boolean/fragment_numbering.geo
|
||||
%%DOCSDIR%%/demos/boolean/hybrid_occ_builtin.geo
|
||||
%%DOCSDIR%%/demos/boolean/import.geo
|
||||
%%DOCSDIR%%/demos/boolean/import2.geo
|
||||
%%DOCSDIR%%/demos/boolean/intersect_line_volume.geo
|
||||
%%DOCSDIR%%/demos/boolean/neuron.geo
|
||||
%%DOCSDIR%%/demos/boolean/periodic.geo
|
||||
%%DOCSDIR%%/demos/boolean/pipe.geo
|
||||
%%DOCSDIR%%/demos/boolean/primitives.geo
|
||||
%%DOCSDIR%%/demos/boolean/revolve.geo
|
||||
%%DOCSDIR%%/demos/boolean/revolve2.geo
|
||||
%%DOCSDIR%%/demos/boolean/simple.geo
|
||||
%%DOCSDIR%%/demos/boolean/simple2.geo
|
||||
%%DOCSDIR%%/demos/boolean/simple3.geo
|
||||
%%DOCSDIR%%/demos/boolean/simple4.geo
|
||||
%%DOCSDIR%%/demos/boolean/simple5.geo
|
||||
%%DOCSDIR%%/demos/boolean/simple6.geo
|
||||
%%DOCSDIR%%/demos/boolean/simple7.geo
|
||||
%%DOCSDIR%%/demos/boolean/spline.geo
|
||||
%%DOCSDIR%%/demos/boolean/thicksolid.geo
|
||||
%%DOCSDIR%%/demos/boolean/thrusections.geo
|
||||
%%DOCSDIR%%/demos/boolean/transfinite.geo
|
||||
%%DOCSDIR%%/demos/boolean/transform.geo
|
||||
%%DOCSDIR%%/demos/boolean/twist.geo
|
||||
%%DOCSDIR%%/demos/post_processing/anim.script
|
||||
%%DOCSDIR%%/demos/post_processing/encode.script
|
||||
%%DOCSDIR%%/demos/post_processing/isosurf.script
|
||||
%%DOCSDIR%%/demos/post_processing/lowmem-anim.geo
|
||||
%%DOCSDIR%%/demos/post_processing/multislice.script
|
||||
%%DOCSDIR%%/demos/post_processing/plot2d.geo
|
||||
%%DOCSDIR%%/demos/post_processing/primitives.pos
|
||||
%%DOCSDIR%%/demos/post_processing/rotate.script
|
||||
%%DOCSDIR%%/demos/post_processing/title.script
|
||||
%%DOCSDIR%%/demos/post_processing/view_groups.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/antenna.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/antenna.i1
|
||||
%%DOCSDIR%%/demos/simple_geo/cone.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/cube.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/fields.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/filter.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/hex.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/homology.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/indheat.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/machine.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/machine.i1
|
||||
%%DOCSDIR%%/demos/simple_geo/machine.i2
|
||||
%%DOCSDIR%%/demos/simple_geo/piece-extr-rec.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/piece-extr.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/piece.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/pripyrtet.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/sphere-discrete.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/sphere-surf.stl
|
||||
%%DOCSDIR%%/demos/simple_geo/sphere.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/splines.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/square_regular.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/tower.geo
|
||||
%%DOCSDIR%%/demos/simple_geo/tower.i1
|
||||
%%DOCSDIR%%/demos/simple_geo/tower.i2
|
||||
%%DOCSDIR%%/demos/simple_geo/tower.i3
|
||||
%%DOCSDIR%%/demos/simple_geo/tower.i4
|
||||
%%DOCSDIR%%/demos/simple_geo/tower.i5
|
||||
%%DOCSDIR%%/demos/simple_geo/transfinite.geo
|
||||
%%DOCSDIR%%/demos/struct/Exists_GetForced.geo
|
||||
%%DOCSDIR%%/demos/struct/struct.geo
|
||||
%%DOCSDIR%%/tutorial/bgmesh.pos
|
||||
%%DOCSDIR%%/tutorial/image.png
|
||||
%%DOCSDIR%%/tutorial/t1.geo
|
||||
%%DOCSDIR%%/tutorial/t10.geo
|
||||
%%DOCSDIR%%/tutorial/t11.geo
|
||||
%%DOCSDIR%%/tutorial/t12.geo
|
||||
%%DOCSDIR%%/tutorial/t13.geo
|
||||
%%DOCSDIR%%/tutorial/t13_data.msh
|
||||
%%DOCSDIR%%/tutorial/t14.geo
|
||||
%%DOCSDIR%%/tutorial/t15.geo
|
||||
%%DOCSDIR%%/tutorial/t16.geo
|
||||
%%DOCSDIR%%/tutorial/t17.geo
|
||||
%%DOCSDIR%%/tutorial/t17.pos
|
||||
%%DOCSDIR%%/tutorial/t2.geo
|
||||
%%DOCSDIR%%/tutorial/t3.geo
|
||||
%%DOCSDIR%%/tutorial/t4.geo
|
||||
%%DOCSDIR%%/tutorial/t5.geo
|
||||
%%DOCSDIR%%/tutorial/t6.geo
|
||||
%%DOCSDIR%%/tutorial/t7.geo
|
||||
%%DOCSDIR%%/tutorial/t8.geo
|
||||
%%DOCSDIR%%/tutorial/t9.geo
|
||||
%%DOCSDIR%%/tutorial/view1.pos
|
||||
%%DOCSDIR%%/tutorial/view2.pos
|
||||
%%DOCSDIR%%/tutorial/view3.pos
|
||||
%%DOCSDIR%%/tutorial/view4.pos
|
||||
%%DOCSDIR%%/tutorial/view5.msh
|
||||
%%SHARED%%lib/libgmsh.so
|
||||
%%SHARED%%lib/libgmsh.so.%%VE%%
|
||||
%%SHARED%%lib/libgmsh.so.%%VER%%
|
||||
%%STATIC%%lib/libgmsh.a
|
||||
bin/gmsh
|
||||
bin/onelab.py
|
||||
%%SHARED%%include/gmsh.h
|
||||
%%SHARED%%include/gmsh.h_cwrap
|
||||
%%SHARED%%include/gmshc.h
|
||||
%%SHARED%%lib/gmsh.jl
|
||||
%%SHARED%%lib/gmsh.py
|
||||
man/man1/gmsh.1.gz
|
||||
|
|
Loading…
Reference in a new issue