update to 0.7.41

PR:	ports/72363
Reviewed by:	holger@e-gitt.net (maintainer)
Approved by:	adamw (mentor)
This commit is contained in:
Michael Johnson 2004-10-30 16:26:30 +00:00
parent acf4bb4465
commit 74a9f6eff6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120493
20 changed files with 89 additions and 343 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= avifile
PORTVERSION= 0.7.38
PORTREVISION= 4
PORTVERSION= 0.7.41
PORTEPOCH= 2
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@ -23,7 +22,7 @@ USE_SUBMAKE= yes
USE_REINPLACE= yes
USE_XLIB= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=13
USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
LIBTOOLFILES= acinclude.m4
@ -65,26 +64,8 @@ PLIST_SUB+= QT="@comment "
.include <bsd.port.pre.mk>
# fix compile with gcc-3.4.x
.if ${OSVERSION} >= 502126
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include::aviplay.h \
${FILESDIR}/extra-patch-include::avm_map.h \
${FILESDIR}/extra-patch-include::avm_stl.h \
${FILESDIR}/extra-patch-lib::aviread::AsfNetworkInputStream.cpp \
${FILESDIR}/extra-patch-lib::common::image.cpp \
${FILESDIR}/extra-patch-plugins::libvorbis::libvorbis.cpp \
${FILESDIR}/extra-patch-ffmpeg::libavcodec::i386::dsputil_mmx.c \
${FILESDIR}/extra-patch-ffmpeg::libavcodec::i386::motion_est_mmx.c \
${FILESDIR}/extra-patch-ffmpeg::libavcodec::i386::simple_idct_mmx.c \
${FILESDIR}/extra-patch-ffmpeg::libavcodec::liba52::resample_mmx.c \
${FILESDIR}/extra-patch-plugins::libmp3lame_audioenc::lame3.70::quantize-pvt.c
.endif
WITHOUT_XVID=yes # Does not support xvid 1.0.x
.if (${ARCH} != "i386") && (${ARCH} != "amd64")
WITHOUT_A52=yes
WITHOUT_XVID=yes
BROKEN= "Does not compile on !i386"
.endif
@ -112,8 +93,9 @@ PLIST_SUB+= AC3_PASS="@comment "
.if !defined(WITHOUT_A52)
LIB_DEPENDS+= a52.0:${PORTSDIR}/audio/liba52
# --enable-ffmpeg-a52bin breaks build
CONFIGURE_ARGS+= --enable-a52 \
--enable-ffmpeg-a52bin \
--enable-ffmpeg-a52 \
--with-a52-prefix=${LOCALBASE}
PLIST_SUB+= A52=""
.else
@ -175,7 +157,6 @@ PLIST_SUB+= VORBIS="@comment "
# xvid
.if !defined(WITHOUT_XVID)
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
CONFIGURE_ARGS+= --with-xvid-prefix=${LOCALBASE}
PLIST_SUB+= XVID=""
.else
@ -298,6 +279,14 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's|^subdirs[[:space:]]*=.*libmad.*$$||' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
# int_fast16/32_t are not in 4.x
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|int_fast16_t|int16_t|g; \
s|int_fast32_t|int32_t|g' \
${WRKSRC}/ffmpeg/libavcodec/jfdctfst.c \
${WRKSRC}/ffmpeg/libavcodec/jfdctint.c \
${WRKSRC}/ffmpeg/libavcodec/ffv1.c
.endif
post-configure:
@${LN} -sf ${LIBTOOL} ${WRKSRC}/libtool

View file

@ -1,2 +1,2 @@
MD5 (avifile-0.7-0.7.38.tar.gz) = db90c4bc0a8a8182b1ec084feca86bbb
SIZE (avifile-0.7-0.7.38.tar.gz) = 2888580
MD5 (avifile-0.7-0.7.41.tar.gz) = a08911965d81a02ded95ddb95f63e1cf
SIZE (avifile-0.7-0.7.41.tar.gz) = 3498203

View file

@ -1,13 +0,0 @@
--- ffmpeg/libavcodec/i386/dsputil_mmx.c.orig Fri Aug 6 13:59:15 2004
+++ ffmpeg/libavcodec/i386/dsputil_mmx.c Fri Aug 6 14:07:13 2004
@@ -29,8 +29,8 @@
static const uint64_t mm_wone __attribute__ ((aligned(8))) = 0x0001000100010001ULL;
static const uint64_t mm_wtwo __attribute__ ((aligned(8))) = 0x0002000200020002ULL;
-static const uint64_t ff_pw_20 __attribute__ ((aligned(8))) = 0x0014001400140014ULL;
-static const uint64_t ff_pw_3 __attribute__ ((aligned(8))) = 0x0003000300030003ULL;
+static const uint64_t ff_pw_20 __attribute__ ((aligned(8))) __attribute__((used)) = 0x0014001400140014ULL;
+static const uint64_t ff_pw_3 __attribute__ ((aligned(8))) __attribute__((used)) = 0x0003000300030003ULL;
static const uint64_t ff_pw_16 __attribute__ ((aligned(8))) = 0x0010001000100010ULL;
static const uint64_t ff_pw_15 __attribute__ ((aligned(8))) = 0x000F000F000F000FULL;

View file

@ -1,11 +0,0 @@
--- ffmpeg/libavcodec/i386/motion_est_mmx.c.orig Fri Aug 6 13:59:15 2004
+++ ffmpeg/libavcodec/i386/motion_est_mmx.c Fri Aug 6 14:08:21 2004
@@ -26,7 +26,7 @@
0x0002000200020002,
};
-static __attribute__ ((aligned(8))) uint64_t bone= 0x0101010101010101LL;
+static __attribute__((aligned(8))) __attribute__((used)) uint64_t bone= 0x0101010101010101LL;
static inline void sad8_mmx(uint8_t *blk1, uint8_t *blk2, int stride, int h)
{

View file

@ -1,13 +0,0 @@
--- ffmpeg/libavcodec/i386/simple_idct_mmx.c.orig Fri Aug 6 13:59:15 2004
+++ ffmpeg/libavcodec/i386/simple_idct_mmx.c Fri Aug 6 14:09:00 2004
@@ -45,8 +45,8 @@
#define ROW_SHIFT 11
#define COL_SHIFT 20 // 6
-static const uint64_t __attribute__((aligned(8))) wm1010= 0xFFFF0000FFFF0000ULL;
-static const uint64_t __attribute__((aligned(8))) d40000= 0x0000000000040000ULL;
+static const uint64_t __attribute__((aligned(8))) __attribute__((used)) wm1010= 0xFFFF0000FFFF0000ULL;
+static const uint64_t __attribute__((aligned(8))) __attribute__((used)) d40000= 0x0000000000040000ULL;
static int16_t __attribute__((aligned(8))) temp[64];
static int16_t __attribute__((aligned(8))) coeffs[]= {
1<<(ROW_SHIFT-1), 0, 1<<(ROW_SHIFT-1), 0,

View file

@ -1,17 +0,0 @@
--- ffmpeg/libavcodec/liba52/resample_mmx.c.orig Fri Aug 6 13:59:15 2004
+++ ffmpeg/libavcodec/liba52/resample_mmx.c Fri Aug 6 14:09:51 2004
@@ -7,10 +7,10 @@
and it would mean (C / MMX2 / MMX / 3DNOW) versions
*/
-static uint64_t __attribute__((aligned(8))) magicF2W= 0x43c0000043c00000LL;
-static uint64_t __attribute__((aligned(8))) wm1010= 0xFFFF0000FFFF0000LL;
-static uint64_t __attribute__((aligned(8))) wm0101= 0x0000FFFF0000FFFFLL;
-static uint64_t __attribute__((aligned(8))) wm1100= 0xFFFFFFFF00000000LL;
+static uint64_t __attribute__((aligned(8))) __attribute__((used)) magicF2W= 0x43c0000043c00000LL;
+static uint64_t __attribute__((aligned(8))) __attribute__((used)) wm1010= 0xFFFF0000FFFF0000LL;
+static uint64_t __attribute__((aligned(8))) __attribute__((used)) wm0101= 0x0000FFFF0000FFFFLL;
+static uint64_t __attribute__((aligned(8))) __attribute__((used)) wm1100= 0xFFFFFFFF00000000LL;
static int a52_resample_MONO_to_5_MMX(float * _f, int16_t * s16){
int32_t * f = (int32_t *) _f;

View file

@ -1,13 +0,0 @@
--- include/aviplay.h.orig Fri Aug 6 12:35:41 2004
+++ include/aviplay.h Fri Aug 6 12:36:36 2004
@@ -12,8 +12,8 @@
#include "image.h"
#include "avm_args.h"
-typedef void (*KILLHANDLER)(int, void* p = 0);
-typedef int (*AUDIOFUNC)(void* srcdata, unsigned int size, void* p = 0);
+typedef void (*KILLHANDLER)(int, void* p);
+typedef int (*AUDIOFUNC)(void* srcdata, unsigned int size, void* p);
AVM_BEGIN_NAMESPACE;

View file

@ -1,12 +0,0 @@
--- include/avm_map.h.orig Fri Aug 6 12:35:41 2004
+++ include/avm_map.h Fri Aug 6 12:37:10 2004
@@ -198,7 +198,8 @@
{
// cast to the needed type - used to prevent internal compiler error
// for old egcc
- avm_map<Key, Value, Compare, Equal>::_Tnode* node = (avm_map<Key, Value, Compare, Equal>::_Tnode*) n;
+ //avm_map<Key, Value, Compare, Equal>::_Tnode* node = (avm_map<Key, Value, Compare, Equal>::_Tnode*) n;
+ _Tnode* node = (_Tnode*) n;
if(node->entry)
{

View file

@ -1,61 +0,0 @@
--- include/avm_stl.h.orig Fri Aug 6 12:35:41 2004
+++ include/avm_stl.h Fri Aug 6 12:41:47 2004
@@ -74,6 +74,10 @@
m_Type = new Type[m_uiCapacity];
}
~qring() { delete[] m_Type; }
+ qring<Type>(const qring<Type>& t) : m_Type(0)
+ {
+ operator=(t);
+ }
qring<Type>& operator=(const qring<Type>& t)
{
if (this != &t)
@@ -149,7 +153,6 @@
// disabled for now
qring<Type>() {}
- qring<Type>(const qring<Type>& t) {}
uint_t bpos() const { return (m_uiPos > 0) ? m_uiPos - 1 : m_uiCapacity - 1; }
uint_t fpos() const { return (m_uiSize > m_uiPos) ? m_uiPos + m_uiCapacity - m_uiSize: m_uiPos - m_uiSize; }
@@ -167,9 +170,21 @@
static const uint_t invalid=(uint_t)(~0);
typedef Type* iterator;
typedef const Type* const_iterator;
- vector<Type>(int prealloc = 0);
+ vector<Type>()
+ :m_Type(0), m_uiCapacity(0), m_uiSize(0)
+ {
+ }
+
+ vector<Type>(int prealloc)
+ :m_Type(0), m_uiCapacity(prealloc), m_uiSize(prealloc)
+ {
+ if (m_uiCapacity > 0 )
+ m_Type = new Type[m_uiCapacity];
+ //printf("vector %p (%d)\n", this, m_uiSize);
+ }
+
// we will not count references - we have to program with this in mind!
- vector<Type>(const vector<Type>& t) :m_Type(0), m_uiCapacity(0), m_uiSize(0)
+ vector<Type>(const vector<Type>& t) :m_Type(0)
{
operator=(t);
}
@@ -270,15 +285,6 @@
uint_t m_uiSize;
void copy(const Type* in, uint_t size, uint_t alloc);
};
-
-template <class Type>
-vector<Type>::vector<Type>(int prealloc)
- :m_Type(0), m_uiCapacity(prealloc), m_uiSize(prealloc)
-{
- if (m_uiCapacity > 0 )
- m_Type = new Type[m_uiCapacity];
- //printf("vector %p (%d)\n", this, m_uiSize);
-}
template <class Type>
void vector<Type>::remove(const Type& t)

View file

@ -1,39 +0,0 @@
--- lib/aviread/AsfNetworkInputStream.cpp.orig Fri Aug 6 12:35:40 2004
+++ lib/aviread/AsfNetworkInputStream.cpp Fri Aug 6 12:46:32 2004
@@ -793,22 +793,24 @@
return -1;
}
-int AsfNetworkInputStream::write(const void* buffer, uint_t size)
+int AsfNetworkInputStream::write(const void* b, uint_t size)
{
+ const char* buffer = (const char*) b;
int wsize = size;
while (wsize > 0)
{
int i = ::write(m_iSocket, buffer, wsize);
if (i <= 0)
return i;
- (const char*)buffer += i;
+ buffer += i;
wsize -= i;
}
return size;
}
-int AsfNetworkInputStream::dwrite(const void* buffer, uint_t size)
+int AsfNetworkInputStream::dwrite(const void* b, uint_t size)
{
+ const char* buffer = (const char*) b;
if (m_lfd < 0)
{
if (m_lfd == -12345)
@@ -843,7 +845,7 @@
int i = ::write(m_lfd, buffer, size);
if (i < 0)
return i;
- (const char*)buffer += i;
+ buffer += i;
size -= i;
}
fsync(m_lfd);

View file

@ -1,11 +0,0 @@
--- lib/common/image.cpp.orig Fri Aug 6 12:35:40 2004
+++ lib/common/image.cpp Fri Aug 6 12:47:59 2004
@@ -954,7 +954,7 @@
fillMembers();
if (!copy)
{
- (const uint8_t*) m_pPlane[0] = data;
+ m_pPlane[0] = (uint8_t*) data;
}
else
{

View file

@ -1,45 +0,0 @@
--- plugins/libmp3lame_audioenc/lame3.70/quantize-pvt.c.orig Fri Aug 6 13:59:16 2004
+++ plugins/libmp3lame_audioenc/lame3.70/quantize-pvt.c Fri Aug 6 14:11:28 2004
@@ -976,6 +976,7 @@
{
int rx[4];
__asm__ __volatile__(
+ "\n\npush %%edx\n\t"
"\n\nloop1:\n\t"
"fld" F8type " 0(%1)\n\t"
@@ -1007,18 +1008,18 @@
"dec %4\n\t"
"movl %5, %%eax\n\t"
- "movl 4+%5, %%ebx\n\t"
+ "movl 4+%5, %%edx\n\t"
"fxch %%st(1)\n\t"
"fadd" F8type " (%2,%%eax," F8size ")\n\t"
"fxch %%st(3)\n\t"
- "fadd" F8type " (%2,%%ebx," F8size ")\n\t"
+ "fadd" F8type " (%2,%%edx," F8size ")\n\t"
"movl 8+%5, %%eax\n\t"
- "movl 12+%5, %%ebx\n\t"
+ "movl 12+%5, %%edx\n\t"
"fxch %%st(2)\n\t"
"fadd" F8type " (%2,%%eax," F8size ")\n\t"
"fxch %%st(1)\n\t"
- "fadd" F8type " (%2,%%ebx," F8size ")\n\t"
+ "fadd" F8type " (%2,%%edx," F8size ")\n\t"
"fxch %%st(3)\n\t"
"fistpl -16(%3)\n\t"
@@ -1028,9 +1029,10 @@
"fistpl -4(%3)\n\t"
"jnz loop1\n\n"
+ "pop %%edx\n\n"
: /* no outputs */
: "t" (istep), "r" (xr), "r" (adj43asm), "r" (ix), "r" (576 / 4), "m" (rx)
- : "%eax", "%ebx", "memory", "cc"
+ : "%eax", "memory", "cc"
);
}
#elif defined (USE_MSC_ASM)

View file

@ -1,29 +0,0 @@
--- plugins/libvorbis/libvorbis.cpp.orig Fri Aug 6 12:35:41 2004
+++ plugins/libvorbis/libvorbis.cpp Fri Aug 6 12:49:27 2004
@@ -96,7 +96,7 @@
op.packet = NULL;
op.b_o_s = 1; /* beginning of stream for first packet */
op.bytes = hdrsizes[0];
- (const void*) op.packet = vorbishdr;
+ op.packet = (unsigned char*) vorbishdr;
vorbishdr += op.bytes;
if (vorbis_synthesis_headerin(&vi, &vc, &op) < 0)
{
@@ -106,7 +106,7 @@
op.b_o_s = 0;
op.bytes = hdrsizes[1];
- (const void*) op.packet = vorbishdr;
+ op.packet = (unsigned char*) vorbishdr;
vorbishdr += op.bytes;
if (vorbis_synthesis_headerin(&vi, &vc, &op) < 0)
{
@@ -115,7 +115,7 @@
}
op.bytes = hdrsizes[2];
- (const void*) op.packet = vorbishdr;
+ op.packet = (unsigned char*) vorbishdr;
vorbishdr += op.bytes;
if (vorbis_synthesis_headerin(&vi, &vc, &op) < 0)
{

View file

@ -0,0 +1,11 @@
--- configure.orig Tue Oct 5 14:25:48 2004
+++ configure Tue Oct 5 14:26:14 2004
@@ -3768,7 +3768,7 @@
case "$target" in
i?86*)
- test x$ac_cv_c_compiler_gnu = xyes && DEFAULT_FLAGS="-mcpu=$DEFAULT_FLAGS -march=$DEFAULT_FLAGS -ffast-math -fomit-frame-pointer"
+ test x$ac_cv_c_compiler_gnu = xyes && DEFAULT_FLAGS="-ffast-math -fomit-frame-pointer"
cat >>confdefs.h <<\_ACEOF
#define ARCH_X86 1

View file

@ -0,0 +1,20 @@
--- ffmpeg/libavcodec/libpostproc/postprocess_template.c.orig Tue Oct 5 14:36:15 2004
+++ ffmpeg/libavcodec/libpostproc/postprocess_template.c Tue Oct 5 14:34:29 2004
@@ -49,6 +49,8 @@
"paddb " #a ", " #b " \n\t"
#endif
+int xxx;
+
//FIXME? |255-0| = 1 (shouldnt be a problem ...)
#ifdef HAVE_MMX
/**
@@ -2870,7 +2872,7 @@
);
src+= step; // src points to begin of the 8x8 Block
- int xxx = dc_mask & eq_mask;
+ xxx = dc_mask & eq_mask;
asm volatile(
"movq %4, %%mm6 \n\t"
"pcmpeqb %%mm5, %%mm5 \n\t"

View file

@ -1,18 +0,0 @@
--- ffmpeg/libavformat/flvenc.c.orig Wed Nov 19 10:06:53 2003
+++ ffmpeg/libavformat/flvenc.c Wed Nov 19 10:08:10 2003
@@ -226,11 +226,12 @@
{
ByteIOContext *pb = &s->pb;
FLVContext *flv = s->priv_data;
-
+ int64_t file_size;
+ int flags = 0;
+
Dump(flv,pb,1);
- int64_t file_size = url_ftell(pb);
- int flags = 0;
+ file_size = url_ftell(pb);
flags |= flv->hasAudio ? 4 : 0;
flags |= flv->hasVideo ? 1 : 0;
url_fseek(pb, 4, SEEK_SET);

View file

@ -0,0 +1,11 @@
--- lib/aviread/AsfFileInputStream.cpp.orig Tue Oct 5 14:00:28 2004
+++ lib/aviread/AsfFileInputStream.cpp Tue Oct 5 14:00:38 2004
@@ -18,6 +18,8 @@
#define O_LARGEFILE 0
#endif
+#define lseek64 lseek
+
AVM_BEGIN_NAMESPACE;
#define __MODULE__ "AsfFileInputStream"

View file

@ -0,0 +1,19 @@
--- lib/subtitle/subread.c.orig Tue Oct 5 15:47:53 2004
+++ lib/subtitle/subread.c Tue Oct 5 15:49:02 2004
@@ -100,12 +100,14 @@
if (sl->lines < SUBTITLE_MAX_LINES && txt)
{
int n = 0;
- char* b = trim_spaces(txt);
+ char* b;
+ char* t;
+ b = trim_spaces(txt);
trim_http(b);
// skip color and font-style change - not supported right now
// {c:$00ffff} {y:i}
- char* t = strchr(b, '{');
+ t = strchr(b, '{');
if (t)
{
char u = toupper(t[1]);

View file

@ -1,12 +0,0 @@
--- lib/video/sub_ft.cpp.orig Wed Mar 17 15:25:55 2004
+++ lib/video/sub_ft.cpp Wed Mar 17 15:26:49 2004
@@ -6,7 +6,8 @@
#ifdef HAVE_LIBFREETYPE
-#include <freetype/freetype.h>
+#include <ft2build.h>
+#include FT_FREETYPE_H
#if (FREETYPE_MAJOR > 2) || (FREETYPE_MAJOR == 2 && FREETYPE_MINOR >= 1)
#define HAVE_FREETYPE21

View file

@ -37,50 +37,40 @@ include/avifile/utils.h
include/avifile/version.h
include/avifile/videodecoder.h
include/avifile/videoencoder.h
%%AC3_PASS%%lib/avifile/ac3pass.la
%%AC3_PASS%%lib/avifile/ac3pass.so
lib/avifile/audiodec.la
lib/avifile/audiodec.so
%%FFMPEG%%lib/avifile/ffmpeg.la
%%FFMPEG%%lib/avifile/ffmpeg.so
%%MAD%%lib/avifile/mad_audiodec.la
%%MAD%%lib/avifile/mad_audiodec.so
lib/avifile/mjpeg.la
lib/avifile/mjpeg.so
lib/avifile/mp3lame_audioenc.la
lib/avifile/mp3lame_audioenc.so
%%LAME%%lib/avifile/mp3lamebin_audioenc.la
%%LAME%%lib/avifile/mp3lamebin_audioenc.so
lib/avifile/mpeg_audiodec.la
lib/avifile/mpeg_audiodec.so
%%VIDIX%%lib/avifile/vidix/libgenfb.la
lib/avifile/osmjpeg.so
%%VIDIX%%lib/avifile/vidix/libgenfb.so
%%VIDIX%%lib/avifile/vidix/libmach64.la
%%VIDIX%%lib/avifile/vidix/libmach64.so
%%VIDIX%%lib/avifile/vidix/libmga.la
%%VIDIX%%lib/avifile/vidix/libmga.so
%%VIDIX%%lib/avifile/vidix/libmga_crtc2.la
%%VIDIX%%lib/avifile/vidix/libmga_crtc2.so
%%VIDIX%%lib/avifile/vidix/libnvidia.la
%%VIDIX%%lib/avifile/vidix/libnvidia.so
%%VIDIX%%lib/avifile/vidix/libpm3.la
%%VIDIX%%lib/avifile/vidix/libpm3.so
%%VIDIX%%lib/avifile/vidix/libradeon.la
%%VIDIX%%lib/avifile/vidix/libradeon.so
%%VIDIX%%lib/avifile/vidix/librage128.la
%%VIDIX%%lib/avifile/vidix/librage128.so
%%VORBIS%%lib/avifile/vorbis_audio.la
%%VORBIS%%lib/avifile/vorbis_audio.so
%%WIN32%%lib/avifile/win32.la
%%WIN32%%lib/avifile/win32.so
%%XVID%%lib/avifile/xvid.la
%%XVID%%lib/avifile/xvid.so
%%XVID%%lib/avifile/xvid4.so
lib/libaviplay.a
lib/libaviplay.la
lib/libaviplay.so
lib/libaviplay.so.0
lib/libaviplayavformat.so.0
lib/libaviplayavformat.so
lib/libaviplayavformat.a
lib/libaviplayavcodec.so.0
lib/libaviplayavcodec.so
lib/libaviplayavcodec.a
lib/libaviplaydha.so.0
lib/libaviplaydha.so
lib/libaviplaydha.a
lib/libaviplayvidix.so.0
lib/libaviplayvidix.so
lib/libaviplayvidix.a
%%QT%%lib/libqavm.a
%%QT%%lib/libqavm.la
%%QT%%lib/libqavm.so
%%QT%%lib/libqavm.so.0
libdata/pkgconfig/avifile.pc