IIIMF-related ports: I have forgotten to add two patches
Submitted by: Masanori OZAWA <ozawa@ongs.co.jp>
This commit is contained in:
parent
229037f505
commit
74de9bfdc7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=130352
2 changed files with 72 additions and 0 deletions
|
@ -0,0 +1,34 @@
|
||||||
|
--- leif/unit/phonetic_im/mapfile/Makefile.am.orig Sat Apr 3 11:50:21 2004
|
||||||
|
+++ leif/unit/phonetic_im/mapfile/Makefile.am Wed Mar 2 20:35:05 2005
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
SUBDIRS = mapfile2c
|
||||||
|
LEX = /usr/bin/lex
|
||||||
|
+SED = /usr/bin/sed
|
||||||
|
|
||||||
|
MAPFILES = bengali.mapfile gurmukhi.mapfile hindi.mapfile kannada.mapfile malayalam.mapfile tamil.mapfile telugu.mapfile gujarati.mapfile
|
||||||
|
|
||||||
|
@@ -12,7 +13,7 @@
|
||||||
|
.l.c:
|
||||||
|
$(LEX) $(LFLAGS) $*.l
|
||||||
|
mv lex.yy.c $*.tc
|
||||||
|
- sed \
|
||||||
|
+ $(SED) \
|
||||||
|
-e "/^# line/d" \
|
||||||
|
-e "s/parse_small_token/parse_$*/g" \
|
||||||
|
-e "s/^void yyunput/static void yyunput/g" \
|
||||||
|
@@ -57,10 +58,11 @@
|
||||||
|
-e "s/^# define unput(c).*/# define unput(c) (\*--global_ptr=c)/g" \
|
||||||
|
-e "s/^#define unput(c).*/#define unput(c) (\*--global_ptr=c)/g" \
|
||||||
|
-e "/^#line/d" \
|
||||||
|
- -e "/^static char \*global_ptr\;/i\
|
||||||
|
-#define YY_NO_INPUT" -e "/^static char \*global_ptr\;/i\
|
||||||
|
-#define YY_NO_UNPUT" -e "/^static char \*global_ptr\;/i\
|
||||||
|
-#define input() (\*global_ptr++)" $*.tc > $*.c
|
||||||
|
+ -e "/^static char \*global_ptr\;/{" \
|
||||||
|
+ -e "p" -e "s/.*/#define YY_NO_INPUT/" \
|
||||||
|
+ -e "p" -e "s/.*/#define YY_NO_UNPUT/" \
|
||||||
|
+ -e "p" -e "s/.*/#define input\(\) \(*global_ptr++\)/" \
|
||||||
|
+ -e "}" $*.tc > $*.c
|
||||||
|
rm -f $*.tc
|
||||||
|
|
||||||
|
noinst_LTLIBRARIES = libphonetic_temp.la
|
38
textproc/iiimf-protocol-lib/files/patch-acfiles_check_sys.m4
Normal file
38
textproc/iiimf-protocol-lib/files/patch-acfiles_check_sys.m4
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
--- acfiles/check_sys.m4.orig Tue Sep 14 13:31:27 2004
|
||||||
|
+++ acfiles/check_sys.m4 Wed Mar 2 08:39:25 2005
|
||||||
|
@@ -203,6 +203,11 @@
|
||||||
|
CXX=${CC}
|
||||||
|
fi
|
||||||
|
;;
|
||||||
|
+ cc*:*)
|
||||||
|
+ COMMON_CFLAGS="${COMMON_CFLAGS} -Wall"
|
||||||
|
+ SHLIBCFLAGS='-fpic'
|
||||||
|
+ SHLIBLDFLAGS='-shared'
|
||||||
|
+ ;;
|
||||||
|
*)
|
||||||
|
DEBUG_CXX_CFLAGS="${DEBUG_CXX_CFLAGS} -g"
|
||||||
|
;;
|
||||||
|
@@ -249,8 +254,8 @@
|
||||||
|
COMMON_CXX_CFLAGS="${COMMON_CXX_CFLAGS} -DLinux"
|
||||||
|
;;
|
||||||
|
*freebsd*)
|
||||||
|
- THREAD_LDFLAGS="-pthread"
|
||||||
|
- PTHREAD_LIBS=""
|
||||||
|
+ THREAD_LDFLAGS=""
|
||||||
|
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
@@ -288,9 +293,9 @@
|
||||||
|
THREAD_CXX_CFLAGS="-mt"
|
||||||
|
HAVE_THREAD="uithread"
|
||||||
|
;;
|
||||||
|
- *freebsd*@gcc:*)
|
||||||
|
- THREAD_LDFLAGS="-pthread"
|
||||||
|
- THREAD_LIBS=""
|
||||||
|
+ *freebsd*@cc:*|*freebsd*@gcc:*)
|
||||||
|
+ THREAD_LDFLAGS=""
|
||||||
|
+ THREAD_LIBS="${PTHREAD_LIBS}"
|
||||||
|
HAVE_THREAD="freebsd-pthread"
|
||||||
|
;;
|
||||||
|
*linux*)
|
Loading…
Reference in a new issue