dns/powerdns-recursor: update 3.6.2 -> 3.7.1
- Change MAINTAINER to tremere@cainites.net (maintainer approved) - Delete obsolete patches - Strip MASTER_SITES PR: 197590 Submitted by: Ralf van der Enden <tremere@cainites.net>
This commit is contained in:
parent
d544f310eb
commit
75057c7660
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=379715
6 changed files with 34 additions and 109 deletions
|
@ -2,13 +2,12 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= powerdns-recursor
|
||||
PORTVERSION= 3.6.2
|
||||
PORTVERSION= 3.7.1
|
||||
CATEGORIES= dns ipv6
|
||||
MASTER_SITES= http://downloads.powerdns.com/releases/ \
|
||||
http://mirrors.evolva.ro/powerdns.com/releases/
|
||||
MASTER_SITES= http://downloads.powerdns.com/releases/
|
||||
DISTNAME= pdns-recursor-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sten@blinkenlights.nl
|
||||
MAINTAINER= tremere@cainites.net
|
||||
COMMENT= Advanced DNS recursor
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
@ -17,6 +16,7 @@ BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
|
|||
${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
|
||||
|
||||
USES= gmake tar:bzip2
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
OPTIONS_DEFINE= SETUID LUA STATIC
|
||||
OPTIONS_DEFAULT= SETUID
|
||||
|
@ -43,7 +43,7 @@ GROUPS= pdns
|
|||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MLUA}
|
||||
USES+= lua:51
|
||||
USES+= lua
|
||||
MAKE_ENV+=LUA=1
|
||||
MAKE_ENV+="LUA_CPPFLAGS_CONFIG=-I${LUA_INCDIR}"
|
||||
MAKE_ENV+="LUA_LIBS_CONFIG=-L${LUA_LIBDIR} -llua-${LUA_VER}"
|
||||
|
@ -65,9 +65,7 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's;SBINDIR=/usr/sbin/;SBINDIR=${PREFIX}/sbin/;' \
|
||||
-e 's;BINDIR=/usr/bin/;BINDIR=${PREFIX}/bin/;' \
|
||||
-e 's;SYSCONFDIR=/etc/powerdns/;SYSCONFDIR=${PREFIX}/etc/pdns/;' \
|
||||
${WRKSRC}/Makefile
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/*.8 ${STAGEDIR}${PREFIX}/man/man8/
|
||||
-e 's;/usr/share;${MANPREFIX};' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (pdns-recursor-3.6.2.tar.bz2) = d9abf5bb5982cee1c3ba6eaa684d2777b7c0d3f038e201dd4e7362b4652750a4
|
||||
SIZE (pdns-recursor-3.6.2.tar.bz2) = 200313
|
||||
SHA256 (pdns-recursor-3.7.1.tar.bz2) = e6b0d255a0d8cd023ebd63c50f453a305c649d04873859b4119745d64b8bd36d
|
||||
SIZE (pdns-recursor-3.7.1.tar.bz2) = 245155
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
--- ./Makefile.orig 2014-06-20 11:24:09.000000000 +0200
|
||||
+++ ./Makefile 2014-06-20 13:59:23.858179424 +0200
|
||||
@@ -50,10 +50,10 @@
|
||||
ifeq ($(STATIC),semi)
|
||||
STATICFLAGS=-Wl,-Bstatic -lstdc++ $(LUALIBS) -lgcc -Wl,-Bdynamic -static-libgcc -lm -lc
|
||||
LINKCC=$(CC)
|
||||
- LDFLAGS += -ldl -lm
|
||||
+ LDFLAGS += -lm
|
||||
else
|
||||
ifeq ($(STATIC),full)
|
||||
- STATICFLAGS=-lstdc++ $(LUALIBS) -ldl -lm -static
|
||||
+ STATICFLAGS=-lstdc++ $(LUALIBS) -lm -static
|
||||
LINKCC=$(CC)
|
||||
else
|
||||
LDFLAGS += $(LUALIBS)
|
||||
@@ -101,20 +101,18 @@
|
||||
fi
|
||||
|
||||
install: build-stamp
|
||||
- -mkdir -p $(DESTDIR)/$(SBINDIR)
|
||||
mv pdns_recursor $(DESTDIR)/$(SBINDIR)
|
||||
ifeq ($(STRIP_BINARIES), 1)
|
||||
strip $(DESTDIR)/$(SBINDIR)/pdns_recursor
|
||||
endif
|
||||
- mkdir -p $(DESTDIR)/$(BINDIR)
|
||||
mv rec_control $(DESTDIR)/$(BINDIR)
|
||||
ifeq ($(STRIP_BINARIES), 1)
|
||||
strip $(DESTDIR)/$(BINDIR)/rec_control
|
||||
endif
|
||||
-mkdir -p $(DESTDIR)/$(SYSCONFDIR)
|
||||
$(DESTDIR)/$(SBINDIR)/pdns_recursor --config > $(DESTDIR)/$(SYSCONFDIR)/recursor.conf-dist
|
||||
- -mkdir -p $(DESTDIR)/usr/share/man/man1
|
||||
- cp pdns_recursor.1 rec_control.1 $(DESTDIR)/usr/share/man/man1
|
||||
+ cp pdns_recursor.1 pdns_recursor.8
|
||||
+ cp rec_control.1 rec_control.8
|
||||
$(OS_SPECIFIC_INSTALL)
|
||||
|
||||
clean: binclean
|
|
@ -1,58 +0,0 @@
|
|||
--- ./pdns_recursor.1.orig 2014-06-20 11:24:09.000000000 +0200
|
||||
+++ ./pdns_recursor.1 2014-06-20 14:08:11.302142421 +0200
|
||||
@@ -7,7 +7,7 @@
|
||||
.\" Source: \ \& 3.0
|
||||
.\" Language: English
|
||||
.\"
|
||||
-.TH "PDNS_RECURSOR" "1" "22 March 2008" "\ \& 3\&.0" "\ \&"
|
||||
+.TH "PDNS_RECURSOR" "8" "22 March 2008" "\ \& 3\&.0" "\ \&"
|
||||
.\" -----------------------------------------------------------------
|
||||
.\" * Define some portability stuff
|
||||
.\" -----------------------------------------------------------------
|
||||
@@ -34,7 +34,7 @@
|
||||
\fIpdns_recursor\fR [\-\-daemon] [\-\-local\-address] [\-\-help, \-h] [\-\-allow\-from]
|
||||
.SH "DESCRIPTION"
|
||||
.sp
|
||||
-pdns_recursor(1) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
|
||||
+pdns_recursor(8) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
|
||||
.sp
|
||||
The recursor is configured via a configuration file, but each item in that file can be overridden on the command line\&.
|
||||
.sp
|
||||
@@ -273,7 +273,7 @@
|
||||
Website: \m[blue]\fBhttp://wiki\&.powerdns\&.com\fR\m[], \m[blue]\fBhttp://www\&.powerdns\&.com\fR\m[]
|
||||
.SH "SEE ALSO"
|
||||
.sp
|
||||
-rec_control(1)
|
||||
+rec_control(8)
|
||||
.SH "COPYING"
|
||||
.sp
|
||||
Copyright \(co 2006 PowerDNS\&.COM BV\&. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2\&.
|
||||
--- ./rec_control.1.orig 2014-06-20 11:24:09.000000000 +0200
|
||||
+++ ./rec_control.1 2014-06-20 14:08:32.670140885 +0200
|
||||
@@ -7,7 +7,7 @@
|
||||
.\" Source: \ \& 3.0
|
||||
.\" Language: English
|
||||
.\"
|
||||
-.TH "REC_CONTROL" "1" "19 April 2006" "\ \& 3\&.0" "\ \&"
|
||||
+.TH "REC_CONTROL" "8" "19 April 2006" "\ \& 3\&.0" "\ \&"
|
||||
.\" -----------------------------------------------------------------
|
||||
.\" * Define some portability stuff
|
||||
.\" -----------------------------------------------------------------
|
||||
@@ -34,7 +34,7 @@
|
||||
\fIrec_control\fR [\-\-help] [\-\-socket\-dir] [\-\-socket\-pid] command \&.\&.
|
||||
.SH "DESCRIPTION"
|
||||
.sp
|
||||
-rec_control(1) allows the operator to control a running instance of the pdns_recursor\&.
|
||||
+rec_control(8) allows the operator to control a running instance of the pdns_recursor\&.
|
||||
.sp
|
||||
The commands that can be passed to the recursor are described on \m[blue]\fBhttp://doc\&.powerdns\&.com/rec\-control\&.html\fR\m[]
|
||||
.SH "EXAMPLES"
|
||||
@@ -142,7 +142,7 @@
|
||||
Website: \m[blue]\fBhttp://wiki\&.powerdns\&.com\fR\m[], \m[blue]\fBhttp://www\&.powerdns\&.com\fR\m[]
|
||||
.SH "SEE ALSO"
|
||||
.sp
|
||||
-pdns_recursor(1)
|
||||
+pdns_recursor(8)
|
||||
.SH "COPYING"
|
||||
.sp
|
||||
Copyright \(co 2006 PowerDNS\&.COM BV\&. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2\&.
|
23
dns/powerdns-recursor/files/patch-sendmsg_fix
Normal file
23
dns/powerdns-recursor/files/patch-sendmsg_fix
Normal file
|
@ -0,0 +1,23 @@
|
|||
diff --git a/pdns/pdns_recursor.cc b/pdns/pdns_recursor.cc
|
||||
index fdee0f1..23fca87 100644
|
||||
--- pdns_recursor.cc
|
||||
+++ pdns_recursor.cc
|
||||
@@ -688,6 +688,8 @@ void startDoResolve(void *p)
|
||||
fillMSGHdr(&msgh, &iov, cbuf, 0, (char*)&*packet.begin(), packet.size(), &dc->d_remote);
|
||||
if(dc->d_local.sin4.sin_family)
|
||||
addCMsgSrcAddr(&msgh, cbuf, &dc->d_local);
|
||||
+ else
|
||||
+ msgh.msg_control=NULL;
|
||||
sendmsg(dc->d_socket, &msgh, 0);
|
||||
if(!SyncRes::s_nopacketcache && !variableAnswer ) {
|
||||
t_packetCache->insertResponsePacket(string((const char*)&*packet.begin(), packet.size()),
|
||||
@@ -961,6 +963,9 @@ string* doProcessUDPQuestion(const std::string& question, const ComboAddress& fr
|
||||
if(destaddr.sin4.sin_family) {
|
||||
addCMsgSrcAddr(&msgh, cbuf, &destaddr);
|
||||
}
|
||||
+ else {
|
||||
+ msgh.msg_control=NULL;
|
||||
+ }
|
||||
sendmsg(fd, &msgh, 0);
|
||||
|
||||
if(response.length() >= sizeof(struct dnsheader)) {
|
|
@ -3,5 +3,5 @@ etc/pdns/recursor.conf-dist
|
|||
@exec [ -f %B/recursor.conf ] || cp %B/%f %B/recursor.conf
|
||||
bin/rec_control
|
||||
sbin/pdns_recursor
|
||||
man/man8/pdns_recursor.8.gz
|
||||
man/man8/rec_control.8.gz
|
||||
man/man1/pdns_recursor.1.gz
|
||||
man/man1/rec_control.1.gz
|
||||
|
|
Loading…
Reference in a new issue