Update to 1.0.3.

This commit is contained in:
Adam Weinberger 2004-01-17 04:15:23 +00:00
parent 02e41fe9e8
commit 7535020871
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=98367
11 changed files with 36 additions and 63 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= libgda2
PORTVERSION= 1.0.2
PORTVERSION= 1.0.3
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/1.0
@ -26,6 +26,7 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier glib20 libxslt
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
@ -34,6 +35,10 @@ MAN5= gda-config.5
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/2$//}
post-patch:
@${REINPLACE_CMD} -e "/^SUBDIRS =/s/testing//" \
${WRKSRC}/Makefile.in
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so)

View file

@ -1 +1 @@
MD5 (gnome2/libgda-1.0.2.tar.bz2) = c84cad90fb721c41fc6c47ee2829f4f0
MD5 (gnome2/libgda-1.0.3.tar.bz2) = eb571389cd7624f362315d5180298263

View file

@ -1,11 +1,10 @@
--- Makefile.in.orig Thu Feb 6 23:01:24 2003
+++ Makefile.in Thu Feb 6 23:01:54 2003
@@ -164,7 +164,7 @@
YACC = @YACC@
cxxflags_set = @cxxflags_set@
--- Makefile.in.orig Fri Jan 16 23:06:50 2004
+++ Makefile.in Fri Jan 16 23:07:18 2004
@@ -276,7 +276,6 @@
providers \
report \
tools \
- testing \
data \
doc
-SUBDIRS = po libsql libgda providers report tools testing data doc
+SUBDIRS = po libsql libgda providers report tools data doc
EXTRA_DIST = COPYING libgda.spec intltool-extract.in intltool-merge.in intltool-update.in

View file

@ -1,13 +0,0 @@
--- libgda/gda-command.c.orig Mon Dec 1 14:58:32 2003
+++ libgda/gda-command.c Mon Dec 1 14:59:30 2003
@@ -100,8 +100,9 @@
GdaCommand *
gda_command_copy (GdaCommand *cmd)
{
+ GdaCommand *new_cmd;
g_return_val_if_fail (cmd != NULL, NULL);
- GdaCommand *new_cmd = gda_command_new (gda_command_get_text (cmd),
+ new_cmd = gda_command_new (gda_command_get_text (cmd),
gda_command_get_command_type (cmd),
gda_command_get_options (cmd));
gda_command_set_transaction (new_cmd,

View file

@ -6,7 +6,7 @@
#
PORTNAME= libgda2
PORTVERSION= 1.0.2
PORTVERSION= 1.0.3
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/1.0
@ -26,6 +26,7 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier glib20 libxslt
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
@ -34,6 +35,10 @@ MAN5= gda-config.5
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/2$//}
post-patch:
@${REINPLACE_CMD} -e "/^SUBDIRS =/s/testing//" \
${WRKSRC}/Makefile.in
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so)

View file

@ -1 +1 @@
MD5 (gnome2/libgda-1.0.2.tar.bz2) = c84cad90fb721c41fc6c47ee2829f4f0
MD5 (gnome2/libgda-1.0.3.tar.bz2) = eb571389cd7624f362315d5180298263

View file

@ -1,11 +1,10 @@
--- Makefile.in.orig Thu Feb 6 23:01:24 2003
+++ Makefile.in Thu Feb 6 23:01:54 2003
@@ -164,7 +164,7 @@
YACC = @YACC@
cxxflags_set = @cxxflags_set@
--- Makefile.in.orig Fri Jan 16 23:06:50 2004
+++ Makefile.in Fri Jan 16 23:07:18 2004
@@ -276,7 +276,6 @@
providers \
report \
tools \
- testing \
data \
doc
-SUBDIRS = po libsql libgda providers report tools testing data doc
+SUBDIRS = po libsql libgda providers report tools data doc
EXTRA_DIST = COPYING libgda.spec intltool-extract.in intltool-merge.in intltool-update.in

View file

@ -1,13 +0,0 @@
--- libgda/gda-command.c.orig Mon Dec 1 14:58:32 2003
+++ libgda/gda-command.c Mon Dec 1 14:59:30 2003
@@ -100,8 +100,9 @@
GdaCommand *
gda_command_copy (GdaCommand *cmd)
{
+ GdaCommand *new_cmd;
g_return_val_if_fail (cmd != NULL, NULL);
- GdaCommand *new_cmd = gda_command_new (gda_command_get_text (cmd),
+ new_cmd = gda_command_new (gda_command_get_text (cmd),
gda_command_get_command_type (cmd),
gda_command_get_options (cmd));
gda_command_set_transaction (new_cmd,

View file

@ -6,7 +6,7 @@
#
PORTNAME= libgnomedb
PORTVERSION= 1.0.2
PORTVERSION= 1.0.3
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/libgnomedb/1.0
@ -18,7 +18,8 @@ COMMENT= Library components for the GNOME database frontend
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgda2 gtksourceview
USE_GNOME= gnomeprefix gnomehack libgnomeui libgda2 gtksourceview \
intlhack lthack
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \

View file

@ -1 +1 @@
MD5 (gnome2/libgnomedb-1.0.2.tar.bz2) = 83d4a3c18e3efebde6e748f0c590b898
MD5 (gnome2/libgnomedb-1.0.3.tar.bz2) = a0dda8fab812e201f58a6fbd085f805b

View file

@ -1,10 +0,0 @@
--- configure.orig Fri Jun 13 07:07:05 2003
+++ configure Sun Jun 15 17:15:17 2003
@@ -8612,6 +8612,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'