Update to 3.4.2.
This commit is contained in:
parent
05ae0eb46e
commit
753d91cc22
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=64248
9 changed files with 73 additions and 61 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= nss
|
||||
PORTVERSION= 3.3.1
|
||||
PORTVERSION= 3.4.2
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.mozilla.org/pub/security/nss/releases/NSS_${PORTVERSION:S/./_/g}_RTM/src/
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (nss-3.3.1.tar.gz) = 79c765ae0c54a0f327b85687ce823129
|
||||
MD5 (nss-3.4.2.tar.gz) = c17ff0cfa7ca9757909097d3f5bb7108
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ../coreconf/FreeBSD.mk.orig Tue Sep 19 06:53:08 2000
|
||||
+++ ../coreconf/FreeBSD.mk Wed Dec 19 10:05:26 2001
|
||||
@@ -35,19 +35,19 @@
|
||||
--- ../coreconf/FreeBSD.mk.orig Fri Mar 1 18:08:12 2002
|
||||
+++ ../coreconf/FreeBSD.mk Thu Aug 8 20:16:30 2002
|
||||
@@ -35,9 +35,9 @@
|
||||
|
||||
include $(CORE_DEPTH)/coreconf/UNIX.mk
|
||||
|
||||
|
@ -11,33 +11,30 @@ $FreeBSD$
|
|||
-CC = gcc
|
||||
-CCC = g++
|
||||
+DEFAULT_COMPILER = $(CC)
|
||||
+CC ?= gcc
|
||||
+CCC = $(CXX)
|
||||
RANLIB = ranlib
|
||||
|
||||
ifeq ($(OS_TEST),alpha)
|
||||
CPU_ARCH = alpha
|
||||
else
|
||||
-OS_REL_CFLAGS = -Di386
|
||||
CPU_ARCH = x86
|
||||
@@ -47,6 +47,8 @@
|
||||
endif
|
||||
|
||||
-OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) -ansi -Wall -pipe $(THREAD_FLAG) -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
|
||||
+OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) -ansi -Wall -pipe -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
|
||||
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
|
||||
+OS_LIBS = $(BSD_LDOPTS)
|
||||
+OPTIMIZER =
|
||||
|
||||
#
|
||||
# The default implementation strategy for FreeBSD is pthreads.
|
||||
@@ -55,7 +55,7 @@
|
||||
DSO_CFLAGS = -fPIC
|
||||
DSO_LDOPTS = -shared -Wl,-soname -Wl,$(notdir $@)
|
||||
@@ -57,7 +59,7 @@
|
||||
ifndef CLASSIC_NSPR
|
||||
USE_PTHREADS = 1
|
||||
DEFINES += -D_THREAD_SAFE
|
||||
-THREAD_FLAG = -pthread
|
||||
+DSO_LDFLAGS = -pthread
|
||||
DEFINES += -D_THREAD_SAFE -D_REENTRANT
|
||||
-DSO_LDOPTS += -pthread
|
||||
+DSO_LDOPTS += $(BSD_LDOPTS)
|
||||
endif
|
||||
|
||||
ARCH = freebsd
|
||||
@@ -63,16 +63,15 @@
|
||||
@@ -65,7 +67,7 @@
|
||||
MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
|
||||
|
||||
ifeq ($(MOZ_OBJFORMAT),elf)
|
||||
|
@ -46,14 +43,3 @@ $FreeBSD$
|
|||
else
|
||||
DLL_SUFFIX = so.1.0
|
||||
endif
|
||||
|
||||
DSO_CFLAGS = -fPIC
|
||||
-DSO_LDOPTS = -Bshareable
|
||||
-DSO_LDFLAGS =
|
||||
+DSO_LDOPTS = -shared
|
||||
|
||||
-MKSHLIB = $(LD) $(DSO_LDOPTS)
|
||||
+MKSHLIB = $(CC) $(DSO_LDOPTS) $(BSD_LDOPTS)
|
||||
|
||||
G++INCLUDES = -I/usr/include/g++
|
||||
|
||||
|
|
14
security/nss/files/patch-..::coreconf::command.mk
Normal file
14
security/nss/files/patch-..::coreconf::command.mk
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ../coreconf/command.mk 2002/08/08 17:20:41 1.1
|
||||
+++ ../coreconf/command.mk 2002/08/08 17:20:54
|
||||
@@ -42,7 +42,7 @@
|
||||
LINK_DLL = $(LINK) $(OS_DLLFLAGS) $(DLLFLAGS)
|
||||
LINK_EXE = $(LINK) $(OS_LFLAGS) $(LFLAGS)
|
||||
NFSPWD = $(NSINSTALL_DIR)/nfspwd
|
||||
-CFLAGS = $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
|
||||
+CFLAGS += $(OPTIMIZER) $(OS_CFLAGS) $(XP_DEFINE) $(DEFINES) $(INCLUDES) \
|
||||
$(XCFLAGS)
|
||||
RANLIB = echo
|
||||
TAR = /bin/tar
|
|
@ -1,13 +1,13 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ../coreconf/rules.mk.orig Thu Jun 21 03:56:29 2001
|
||||
+++ ../coreconf/rules.mk Wed Dec 19 10:28:51 2001
|
||||
--- ../coreconf/rules.mk.orig Thu Feb 21 23:23:13 2002
|
||||
+++ ../coreconf/rules.mk Thu Aug 8 20:02:24 2002
|
||||
@@ -106,6 +106,7 @@
|
||||
endif
|
||||
ifdef SHARED_LIBRARY
|
||||
$(INSTALL) -m 775 $(SHARED_LIBRARY) $(SOURCE_LIB_DIR)
|
||||
+ ln -sf $(notdir $(SHARED_LIBRARY)) $(SOURCE_LIB_DIR)/$(notdir $(SHARED_LIBRARY:.so.1=.so))
|
||||
ifeq ($(OS_ARCH),OpenVMS)
|
||||
ifeq ($(OS_TARGET),OpenVMS)
|
||||
$(INSTALL) -m 775 $(SHARED_LIBRARY:$(DLL_SUFFIX)=vms) $(SOURCE_LIB_DIR)
|
||||
endif
|
||||
|
|
13
security/nss/files/patch-cmd::platlibs.mk
Normal file
13
security/nss/files/patch-cmd::platlibs.mk
Normal file
|
@ -0,0 +1,13 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- cmd/platlibs.mk 2002/08/08 18:13:37 1.1
|
||||
+++ cmd/platlibs.mk 2002/08/08 18:14:06
|
||||
@@ -186,6 +186,7 @@
|
||||
-L$(DIST)/lib/ \
|
||||
-lssl3 \
|
||||
-lsmime3 \
|
||||
+ -lsoftokn3 \
|
||||
-lnss3 \
|
||||
-lplc4 \
|
||||
-lplds4 \
|
|
@ -1,16 +1,16 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- lib/ckfw/builtins/Makefile 2001/12/18 12:48:03 1.1
|
||||
+++ lib/ckfw/builtins/Makefile 2001/12/18 12:48:39
|
||||
@@ -53,8 +53,8 @@
|
||||
PLC_STATIC_LIB = $(DIST)/lib/plc4.$(LIB_SUFFIX)
|
||||
PLDS_STATIC_LIB = $(DIST)/lib/plds4.$(LIB_SUFFIX)
|
||||
--- lib/ckfw/builtins/Makefile.orig Sat Feb 16 00:53:42 2002
|
||||
+++ lib/ckfw/builtins/Makefile Thu Aug 8 21:29:48 2002
|
||||
@@ -54,8 +54,8 @@
|
||||
else
|
||||
-PLC_STATIC_LIB = $(DIST)/lib/libplc4.$(LIB_SUFFIX)
|
||||
-PLDS_STATIC_LIB = $(DIST)/lib/libplds4.$(LIB_SUFFIX)
|
||||
+PLC_STATIC_LIB = -lplc4
|
||||
+PLDS_STATIC_LIB = -lplds4
|
||||
endif
|
||||
|
||||
EXTRA_LIBS += \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
+ -lplc4 \
|
||||
+ -lplds4 \
|
||||
$(NULL)
|
||||
|
||||
endif
|
||||
|
|
|
@ -1,16 +1,16 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- lib/fortcrypt/swfort/pkcs11/Makefile 2001/12/18 12:43:20 1.1
|
||||
+++ lib/fortcrypt/swfort/pkcs11/Makefile 2001/12/18 12:44:02
|
||||
@@ -83,8 +83,8 @@
|
||||
PLC_STATIC_LIB = $(DIST)/lib/plc4.$(LIB_SUFFIX)
|
||||
PLDS_STATIC_LIB = $(DIST)/lib/plds4.$(LIB_SUFFIX)
|
||||
else
|
||||
-PLC_STATIC_LIB = $(DIST)/lib/libplc4.$(LIB_SUFFIX)
|
||||
-PLDS_STATIC_LIB = $(DIST)/lib/libplds4.$(LIB_SUFFIX)
|
||||
+PLC_STATIC_LIB = -lplc4
|
||||
+PLDS_STATIC_LIB = -lplds4
|
||||
endif
|
||||
--- lib/fortcrypt/swfort/pkcs11/Makefile.orig Sat Feb 16 00:53:46 2002
|
||||
+++ lib/fortcrypt/swfort/pkcs11/Makefile Thu Aug 8 21:27:33 2002
|
||||
@@ -76,8 +76,8 @@
|
||||
$(DIST)/lib/$(LIB_PREFIX)softokn.$(LIB_SUFFIX) \
|
||||
$(CRYPTO_LIB) \
|
||||
$(DIST)/lib/$(LIB_PREFIX)secutil.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
+ -lplc4 \
|
||||
+ -lplds4 \
|
||||
$(NULL)
|
||||
|
||||
EXTRA_LIBS += \
|
||||
endif
|
||||
|
|
|
@ -7,6 +7,7 @@ bin/checkcert
|
|||
bin/client
|
||||
bin/cmsutil
|
||||
bin/crlutil
|
||||
bin/dbtest
|
||||
bin/derdump
|
||||
bin/digest
|
||||
bin/instinit
|
||||
|
@ -60,13 +61,9 @@ include/nss/security/jar-ds.h
|
|||
include/nss/security/jar.h
|
||||
include/nss/security/jarfile.h
|
||||
include/nss/security/key.h
|
||||
include/nss/security/keydbt.h
|
||||
include/nss/security/keyhi.h
|
||||
include/nss/security/keylow.h
|
||||
include/nss/security/keyt.h
|
||||
include/nss/security/keytboth.h
|
||||
include/nss/security/keythi.h
|
||||
include/nss/security/keytlow.h
|
||||
include/nss/security/nss.h
|
||||
include/nss/security/nssb64.h
|
||||
include/nss/security/nssb64t.h
|
||||
|
@ -80,9 +77,8 @@ include/nss/security/nssckfwc.h
|
|||
include/nss/security/nssckfwt.h
|
||||
include/nss/security/nssckg.h
|
||||
include/nss/security/nssckmdt.h
|
||||
include/nss/security/nssckp.h
|
||||
include/nss/security/nssckt.h
|
||||
include/nss/security/nsscku.h
|
||||
include/nss/security/nssilckt.h
|
||||
include/nss/security/nssilock.h
|
||||
include/nss/security/nsslocks.h
|
||||
include/nss/security/nssrwlk.h
|
||||
|
@ -97,6 +93,7 @@ include/nss/security/pk11pqg.h
|
|||
include/nss/security/pk11sdr.h
|
||||
include/nss/security/pkcs11.h
|
||||
include/nss/security/pkcs11f.h
|
||||
include/nss/security/pkcs11n.h
|
||||
include/nss/security/pkcs11p.h
|
||||
include/nss/security/pkcs11t.h
|
||||
include/nss/security/pkcs11u.h
|
||||
|
@ -125,11 +122,11 @@ include/nss/security/secpkcs5.h
|
|||
include/nss/security/secpkcs7.h
|
||||
include/nss/security/secport.h
|
||||
include/nss/security/secrng.h
|
||||
include/nss/security/secrngt.h
|
||||
include/nss/security/smime.h
|
||||
include/nss/security/ssl.h
|
||||
include/nss/security/sslerr.h
|
||||
include/nss/security/sslproto.h
|
||||
include/nss/security/sslt.h
|
||||
include/nss/security/swfort.h
|
||||
include/nss/security/swfortt.h
|
||||
include/nss/security/watcomfx.h
|
||||
|
@ -141,6 +138,8 @@ lib/libnssckbi.so
|
|||
lib/libnssckbi.so.1
|
||||
lib/libsmime3.so
|
||||
lib/libsmime3.so.1
|
||||
lib/libsoftokn3.so
|
||||
lib/libsoftokn3.so.1
|
||||
lib/libssl3.so
|
||||
lib/libssl3.so.1
|
||||
lib/libswft.so
|
||||
|
|
Loading…
Reference in a new issue