Wipe is a file and block device wiping utility

PR:		ports/77108
Submitted by:	Edson Brandi <ebrandi@fugspbr.org>,
		Mark Laws <mdl@60hz.org>
This commit is contained in:
Pav Lucistnik 2005-03-05 16:04:44 +00:00
parent 5092eea0da
commit 754beeab76
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=130413
7 changed files with 85 additions and 0 deletions

View file

@ -488,6 +488,7 @@
SUBDIR += vulnerability-test-port
SUBDIR += vuxml
SUBDIR += vxquery
SUBDIR += wipe
SUBDIR += wpa_supplicant
SUBDIR += xca
SUBDIR += xinetd

38
security/wipe/Makefile Normal file
View file

@ -0,0 +1,38 @@
# New ports collection makefile for: wipe
# Date created: 04 February 2005
# Whom: Edson Brandi <ebrandi@fugspbr.org>
#
# $FreeBSD$
#
PORTNAME= wipe
PORTVERSION= 2.2.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ebrandi@fugspbr.org
COMMENT= File and block device wiping utility
USE_BZIP2= yes
GNU_CONFIGURE= yes
MAN1= wipe.1
PORTDOCS= CHANGES INSTALL LICENSE README TESTING TODO copyright
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500039
EXTRA_PATCHES= ${PATCHDIR}/500040-patch-blkdev.c
.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/wipe.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/wipe
for i in ${PORTDOCS}; do \
${INSTALL_DATA} ${WRKSRC}/$$i ${DOCSDIR}; \
done
.endif
.include <bsd.port.post.mk>

2
security/wipe/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (wipe-2.2.0.tar.bz2) = 1e1366c6407e7910f6131ebfee9f1ea6
SIZE (wipe-2.2.0.tar.bz2) = 70134

View file

@ -0,0 +1,22 @@
--- blkdev.c.orig Sun Aug 3 16:07:29 2003
+++ blkdev.c Sat Mar 5 00:23:40 2005
@@ -128,6 +128,10 @@
int code;
#ifdef BSD_BLKDEV
+ struct partinfo {
+ struct disklabel *disklab;
+ struct partition *part;
+ };
struct partinfo pinfo;
#endif
@@ -160,7 +164,7 @@
}
#ifdef BSD_BLKDEV
- if (ioctl(f->fd, DIOCGPART, &pinfo))
+ if (ioctl(f->fd, DIOCGDINFO, &pinfo))
{
fprintf(stderr, "\r%s: ioctl failed, can't get disklabel for `%s': %s\n",
argvzero, f->name, strerror(errno));

View file

@ -0,0 +1,16 @@
--- Makefile.in.orig Sat Aug 30 18:18:03 2003
+++ Makefile.in Sat Mar 5 00:24:22 2005
@@ -60,13 +60,6 @@
$(INSTALL_BIN) -d $(bindir)
$(INSTALL_BIN) -s $(BIN_OUT) $(bindir)
$(INSTALL) -d $(mandir)/man1
- $(INSTALL) -o root -m 0644 wipe.1 $(mandir)/man1/
- rm -rf $(datadir)/doc/wipe*
- $(INSTALL) -d $(datadir)/doc/wipe
-
- for file in $(DOCS); do \
- $(INSTALL) -o root -m 0644 $$file $(datadir)/doc/wipe/; \
- done
install_home: $(BIN_OUT)
strip $(BIN_OUT)

5
security/wipe/pkg-descr Normal file
View file

@ -0,0 +1,5 @@
Wipe is a file and block device wiping utility
WWW: http://wipe.sourceforge.net/
Author: Tom Vier <nester@users.sf.net>

1
security/wipe/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/wipe