Add gail 0.6, an implementation of the ATK interfaces for GTK+ widgets.

This commit is contained in:
Maxim Sobolev 2002-02-17 10:27:29 +00:00
parent bf8da69411
commit 756cba40d5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54810
15 changed files with 319 additions and 0 deletions

View file

@ -0,0 +1,33 @@
# New ports collection makefile for: gail
# Date Created: 12 February 2002
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gail
PORTVERSION= 0.6
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= gnomecanvas-2.0:${PORTSDIR}/graphics/libgnomecanvas
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (gnome2/gail-0.6.tar.bz2) = 7b7102c2a99e34a4c0eebd9343f685a6

View file

@ -0,0 +1,45 @@
$FreeBSD: /tmp/pcvs/ports/accessibility/gail/files/Attic/patch-ltmain.sh,v 1.1 2002-02-17 10:27:29 sobomax Exp $
--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
+++ ltmain.sh Sun Feb 3 01:44:17 2002
@@ -1037,8 +1037,16 @@
continue
;;
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
+
-module)
module=yes
+ build_old_libs=no
continue
;;
@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -0,0 +1,27 @@
$FreeBSD$
--- tests/ferret.c 2002/02/17 09:45:53 1.1
+++ tests/ferret.c 2002/02/17 10:10:16
@@ -3,9 +3,9 @@
#define MAX_GROUPS 20
#define MAX_NAME_VALUE 20
-#include <netinet/in.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#include <sys/un.h>
#include <errno.h>
#include <unistd.h>
@@ -239,8 +239,8 @@
static GtkWidget *menuitem_trackmouse = NULL;
static GtkWidget *menuitem_trackfocus = NULL;
-static struct sockaddr_un mag_server = { AF_UNIX , "/tmp/magnifier_socket" };
-static struct sockaddr_un client = { AF_UNIX, "/tmp/mag_client"};
+static struct sockaddr_un mag_server = { 0, AF_UNIX , "/tmp/magnifier_socket" };
+static struct sockaddr_un client = { 0, AF_UNIX, "/tmp/mag_client"};
/* GUI Information for the output window */
typedef struct

View file

@ -0,0 +1 @@
An implementation of the ATK interfaces for GTK+ widgets

View file

@ -0,0 +1,4 @@
Gail, the Gnome Accessibility Implementation library, is implementation of the
ATK interfaces for GTK+ widgets.
WWW: http://www.gnome.org/

View file

@ -0,0 +1,48 @@
include/gail-1.0/util/gail-util.h
include/gail-1.0/util/gailmisc.h
include/gail-1.0/util/gailtextutil.h
lib/libferret.so
lib/libferret.so.0
lib/libgail.so
lib/libgail.so.0
lib/libgailutil.so
lib/libgailutil.so.6
lib/libtestaction.so
lib/libtestaction.so.0
lib/libtestbutton.so
lib/libtestbutton.so.0
lib/libtestcombo.so
lib/libtestcombo.so.0
lib/libtestcomponent.so
lib/libtestcomponent.so.0
lib/libtestimage.so
lib/libtestimage.so.0
lib/libtestmenuitem.so
lib/libtestmenuitem.so.0
lib/libtestnotebook.so
lib/libtestnotebook.so.0
lib/libtestobject.so
lib/libtestobject.so.0
lib/libtestoptionmenu.so
lib/libtestoptionmenu.so.0
lib/libtestpaned.so
lib/libtestpaned.so.0
lib/libtestprops.so
lib/libtestprops.so.0
lib/libtestselection.so
lib/libtestselection.so.0
lib/libteststatusbar.so
lib/libteststatusbar.so.0
lib/libtesttable.so
lib/libtesttable.so.0
lib/libtesttext.so
lib/libtesttext.so.0
lib/libtesttoplevel.so
lib/libtesttoplevel.so.0
lib/libtesttreetable.so
lib/libtesttreetable.so.0
lib/libtestvalues.so
lib/libtestvalues.so.0
libdata/pkgconfig/gail.pc
@dirrm include/gail-1.0/util
@dirrm include/gail-1.0

View file

@ -19,6 +19,7 @@
SUBDIR += flvw
SUBDIR += fox
SUBDIR += fox-xunicode
SUBDIR += gail
SUBDIR += gal
SUBDIR += gdl
SUBDIR += gevas

View file

@ -0,0 +1,33 @@
# New ports collection makefile for: gail
# Date Created: 12 February 2002
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gail
PORTVERSION= 0.6
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= gnomecanvas-2.0:${PORTSDIR}/graphics/libgnomecanvas
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (gnome2/gail-0.6.tar.bz2) = 7b7102c2a99e34a4c0eebd9343f685a6

View file

@ -0,0 +1,45 @@
$FreeBSD: /tmp/pcvs/ports/x11-toolkits/gail/files/Attic/patch-ltmain.sh,v 1.1 2002-02-17 10:27:29 sobomax Exp $
--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
+++ ltmain.sh Sun Feb 3 01:44:17 2002
@@ -1037,8 +1037,16 @@
continue
;;
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
+
-module)
module=yes
+ build_old_libs=no
continue
;;
@@ -2412,6 +2420,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4179,10 +4190,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -0,0 +1,27 @@
$FreeBSD$
--- tests/ferret.c 2002/02/17 09:45:53 1.1
+++ tests/ferret.c 2002/02/17 10:10:16
@@ -3,9 +3,9 @@
#define MAX_GROUPS 20
#define MAX_NAME_VALUE 20
-#include <netinet/in.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#include <sys/un.h>
#include <errno.h>
#include <unistd.h>
@@ -239,8 +239,8 @@
static GtkWidget *menuitem_trackmouse = NULL;
static GtkWidget *menuitem_trackfocus = NULL;
-static struct sockaddr_un mag_server = { AF_UNIX , "/tmp/magnifier_socket" };
-static struct sockaddr_un client = { AF_UNIX, "/tmp/mag_client"};
+static struct sockaddr_un mag_server = { 0, AF_UNIX , "/tmp/magnifier_socket" };
+static struct sockaddr_un client = { 0, AF_UNIX, "/tmp/mag_client"};
/* GUI Information for the output window */
typedef struct

View file

@ -0,0 +1 @@
An implementation of the ATK interfaces for GTK+ widgets

View file

@ -0,0 +1,4 @@
Gail, the Gnome Accessibility Implementation library, is implementation of the
ATK interfaces for GTK+ widgets.
WWW: http://www.gnome.org/

View file

@ -0,0 +1,48 @@
include/gail-1.0/util/gail-util.h
include/gail-1.0/util/gailmisc.h
include/gail-1.0/util/gailtextutil.h
lib/libferret.so
lib/libferret.so.0
lib/libgail.so
lib/libgail.so.0
lib/libgailutil.so
lib/libgailutil.so.6
lib/libtestaction.so
lib/libtestaction.so.0
lib/libtestbutton.so
lib/libtestbutton.so.0
lib/libtestcombo.so
lib/libtestcombo.so.0
lib/libtestcomponent.so
lib/libtestcomponent.so.0
lib/libtestimage.so
lib/libtestimage.so.0
lib/libtestmenuitem.so
lib/libtestmenuitem.so.0
lib/libtestnotebook.so
lib/libtestnotebook.so.0
lib/libtestobject.so
lib/libtestobject.so.0
lib/libtestoptionmenu.so
lib/libtestoptionmenu.so.0
lib/libtestpaned.so
lib/libtestpaned.so.0
lib/libtestprops.so
lib/libtestprops.so.0
lib/libtestselection.so
lib/libtestselection.so.0
lib/libteststatusbar.so
lib/libteststatusbar.so.0
lib/libtesttable.so
lib/libtesttable.so.0
lib/libtesttext.so
lib/libtesttext.so.0
lib/libtesttoplevel.so
lib/libtesttoplevel.so.0
lib/libtesttreetable.so
lib/libtesttreetable.so.0
lib/libtestvalues.so
lib/libtestvalues.so.0
libdata/pkgconfig/gail.pc
@dirrm include/gail-1.0/util
@dirrm include/gail-1.0