Add libtcp4u, a library for easy writing socket-oriented applications.
Submitted by: Juraj Lutter <otis@wilbury.sk>
This commit is contained in:
parent
3468faaa0b
commit
7576696d5d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=117543
6 changed files with 83 additions and 0 deletions
|
@ -289,6 +289,7 @@
|
|||
SUBDIR += librsync
|
||||
SUBDIR += libsocket++
|
||||
SUBDIR += libsocketcpp
|
||||
SUBDIR += libtcp4u
|
||||
SUBDIR += libunp
|
||||
SUBDIR += libunpipc
|
||||
SUBDIR += libvncserver
|
||||
|
|
28
net/libtcp4u/Makefile
Normal file
28
net/libtcp4u/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# New ports collection makefile for: libtcp4u
|
||||
# Date created: 27 November 2001
|
||||
# Whom: Juraj Lutter <otis@sk.freebsd.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libtcp4u
|
||||
PORTVERSION= 3.3.1
|
||||
CATEGORIES= net devel
|
||||
MASTER_SITES= http://membres.lycos.fr/phjounin/zip/ \
|
||||
ftp://ftp.wilbury.sk/pub/FreeBSD/local/distfiles/
|
||||
DISTNAME= tcp4u331
|
||||
|
||||
MAINTAINER= otis@freebsd.sk
|
||||
COMMENT= TCP interface library
|
||||
|
||||
WRKSRC= ${WRKDIR}/tcp4u.331/src
|
||||
PATCH_WRKSRC= ${WRKDIR}/tcp4u.331
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_ZIP= yes
|
||||
|
||||
do-configure::
|
||||
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/../Unix/Makefile
|
||||
${CP} ${WRKSRC}/../Unix/Makefile ${WRKSRC}
|
||||
|
||||
.include <bsd.port.mk>
|
2
net/libtcp4u/distinfo
Normal file
2
net/libtcp4u/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (tcp4u331.zip) = 73a9534ae9b99461ae4067f20bc58b82
|
||||
SIZE (tcp4u331.zip) = 243862
|
38
net/libtcp4u/files/patch-Unix::Makefile
Normal file
38
net/libtcp4u/files/patch-Unix::Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
--- Unix/Makefile.orig Tue Mar 24 12:13:02 1998
|
||||
+++ Unix/Makefile Sat Dec 1 10:53:00 2001
|
||||
@@ -9,15 +9,18 @@
|
||||
# Use :
|
||||
# make install
|
||||
|
||||
-DESTDIR = ../Unix/
|
||||
-COMPIL_FLAGS = -g
|
||||
+PREFIX = %%PREFIX%%
|
||||
+DESTDIRLIB = %%PREFIX%%/lib
|
||||
+DESTDIRINC = %%PREFIX%%/include
|
||||
+
|
||||
+COMPIL_FLAGS = -O2
|
||||
|
||||
|
||||
# SunOS: AR should be declared as ar r
|
||||
AR = ar -r
|
||||
# AR = ar r
|
||||
|
||||
-INSTALL = cp -p
|
||||
+INSTALL = cp -pR
|
||||
RM = rm -f
|
||||
|
||||
|
||||
@@ -51,9 +54,10 @@
|
||||
ranlib $@
|
||||
|
||||
install:: $(TEST_DIRECTORY) lib$(LIB_NAME).a
|
||||
- @if [ -d $(DESTDIR) ]; then set +x; \
|
||||
- else (set -x; $(MKDIRHIER) $(DESTDIR) $(DESTDIR)); fi
|
||||
- $(INSTALL) $(INSTLIBFLAGS) lib$(LIB_NAME).a $(DESTDIR)
|
||||
+ @if [ -d $(DESTDIRLIB) ]; then set +x; \
|
||||
+ else (set -x; $(MKDIRHIER) $(DESTDIRLIB) $(DESTDIRLIB)); fi
|
||||
+ $(INSTALL) $(INSTLIBFLAGS) lib$(LIB_NAME).a $(DESTDIRLIB)
|
||||
+ $(INSTALL) $(TCP4U_INC)/*4u.h $(DESTDIRINC)
|
||||
|
||||
test_directory:
|
||||
@if [ ! -r tcp4u.c ]; then \
|
9
net/libtcp4u/pkg-descr
Normal file
9
net/libtcp4u/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
Library for easy writing socket-oriented applications.
|
||||
Supports TCP and UDP protocols as well as some higher
|
||||
level protocols (HTTP, SMTP).
|
||||
Conctains tcp4u, http4u, tn4u, udp4u.
|
||||
|
||||
WWW: http://membres.tripod.fr/phjounin/
|
||||
|
||||
- otis
|
||||
otis@freebsd.sk
|
5
net/libtcp4u/pkg-plist
Normal file
5
net/libtcp4u/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
|||
include/udp4u.h
|
||||
include/tcp4u.h
|
||||
include/smtp4u.h
|
||||
include/http4u.h
|
||||
lib/libtcp4ux.a
|
Loading…
Reference in a new issue