parent
58bfa1935e
commit
758cb28eaf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=560137
5 changed files with 43 additions and 17 deletions
|
@ -2,13 +2,10 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pysal
|
||||
PORTVERSION= 1.14.4
|
||||
DISTVERSIONSUFFIX= .post2
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 2.2.0
|
||||
CATEGORIES= science python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= PySAL-${PORTVERSION}${DISTVERSIONSUFFIX}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Cross-platform library of spatial analysis functions
|
||||
|
@ -16,12 +13,25 @@ COMMENT= Cross-platform library of spatial analysis functions
|
|||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
BUILD_DEPENDS= ${RUN_DEPENDS}
|
||||
RUN_DEPENDS= ${PYNUMPY} \
|
||||
${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}esda>=2.2.1:science/py-esda@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}giddy>=2.3.0:graphics/py-giddy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}inequality>=1.0.0:science/py-inequality@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}libpysal>=4.2.2:science/py-libpysal@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mapclassify>=2.2.0:graphics/py-mapclassify@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mgwr>=2.1.1:graphics/py-mgwr@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pointpats>=2.1.0:graphics/py-pointpats@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}segregation>=1.2.0:science/py-segregation@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spaghetti>=1.4.1:science/py-spaghetti@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spglm>=1.0.7:math/py-spglm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spint>=1.0.6:math/py-spint@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}splot>=1.1.2:math/py-splot@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spreg>=1.0.4:math/py-spreg@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spvcm>=0.3.0:math/py-spvcm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}tobler>=0.2.0:science/py-tobler@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}urllib3>=0,1:net/py-urllib3@${PY_FLAVOR}
|
||||
|
||||
USES= python:3.6+
|
||||
USES= python:3.7+
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1608366172
|
||||
SHA256 (PySAL-1.14.4.post2.tar.gz) = 9f7c910549f29fd966a4480beb183d8e6a2f813bf5a08c4273499fa9afa398ca
|
||||
SIZE (PySAL-1.14.4.post2.tar.gz) = 17860998
|
||||
TIMESTAMP = 1609598911
|
||||
SHA256 (pysal-2.2.0.tar.gz) = d712156895b1e6c672f6929804bf86ab54d9f5d197b1cb97452c68583a162820
|
||||
SIZE (pysal-2.2.0.tar.gz) = 104835
|
||||
|
|
|
@ -1,5 +0,0 @@
|
|||
--- pysal/config.py.orig 2018-07-17 21:40:06 UTC
|
||||
+++ pysal/config.py
|
||||
@@ -1 +1 @@
|
||||
-check_stable=True
|
||||
+check_stable=False
|
10
science/py-pysal/files/patch-requirements.txt
Normal file
10
science/py-pysal/files/patch-requirements.txt
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- requirements.txt.orig 2020-02-07 04:10:45 UTC
|
||||
+++ requirements.txt
|
||||
@@ -13,5 +13,5 @@ spvcm>=0.3.0
|
||||
tobler>=0.2.0
|
||||
mapclassify>=2.2.0
|
||||
splot>=1.1.2
|
||||
-urllib3<1.25
|
||||
-python-dateutil<=2.8.0
|
||||
+urllib3
|
||||
+python-dateutil
|
11
science/py-pysal/files/patch-setup.py
Normal file
11
science/py-pysal/files/patch-setup.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- setup.py.orig 2020-02-01 23:18:07 UTC
|
||||
+++ setup.py
|
||||
@@ -54,7 +54,7 @@ def setup_package():
|
||||
download_url='https://pypi.python.org/pypi/pysal',
|
||||
license='BSD',
|
||||
packages=find_packages(),
|
||||
- python_requires='>3.6',
|
||||
+ python_requires='>=3.6',
|
||||
test_suite='nose.collector',
|
||||
tests_require=['nose'],
|
||||
keywords='spatial statistics',
|
Loading…
Reference in a new issue