- Unbreak with gcc4.
PR: ports/115323 Submitted by: Ulrich Spoerlein <uspoerlein@gmail.com> Approved by: stas (mentor), maintainer timeout (2 weeks)
This commit is contained in:
parent
9d6b68248f
commit
75a7e399c0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=199627
3 changed files with 30 additions and 6 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= gcombust
|
||||
PORTVERSION= 0.1.55
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.abo.fi/~jmunsin/gcombust/
|
||||
|
||||
|
@ -35,8 +35,10 @@ post-configure:
|
|||
cd ${WRKSRC}/po && ${MAKE} update-po
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/gcombust
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gcombust
|
||||
${INSTALL_DATA} ${WRKSRC}/NEWS ${PREFIX}/share/doc/gcombust
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
22
sysutils/gcombust/files/patch-gcc4
Normal file
22
sysutils/gcombust/files/patch-gcc4
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- src/rip_audio.c.orig 2007-08-08 19:26:25.000000000 +0200
|
||||
+++ src/rip_audio.c 2007-08-08 19:26:54.000000000 +0200
|
||||
@@ -41,7 +41,7 @@
|
||||
char *cdda2wav_path = NULL, *cdda_device_path;
|
||||
char *def_rip_path = NULL;
|
||||
char *cdparanoia_path = NULL, *cdpara_device_path;
|
||||
-static GtkWidget *rip_path_entry;
|
||||
+GtkWidget *rip_path_entry;
|
||||
|
||||
static GtkWidget *rip_win = NULL, *p_win;
|
||||
static GtkWidget *autoscroll_cdda2wav_text, *cdda2wav_text, *cdda2wav_text_scrollbar;
|
||||
--- src/optimize_usage.c.orig 2007-08-08 19:26:00.000000000 +0200
|
||||
+++ src/optimize_usage.c 2007-08-08 19:26:11.000000000 +0200
|
||||
@@ -31,7 +31,7 @@
|
||||
#include "locks.h"
|
||||
#include "globals.h"
|
||||
|
||||
-static GtkWidget *opt_try_harder;
|
||||
+GtkWidget *opt_try_harder;
|
||||
|
||||
static GtkWidget *cdsize_option_menu, *cdsize_selected_label, *cdsector_selected_label;
|
||||
static GtkWidget *used_size_label, *used_sectors_label, *wasted_size_label, *wasted_sectors_label;
|
|
@ -1,6 +1,6 @@
|
|||
bin/gcombust
|
||||
share/doc/gcombust/README
|
||||
share/doc/gcombust/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
share/applications/gcombust.desktop
|
||||
share/locale/da/LC_MESSAGES/gcombust.mo
|
||||
share/locale/de/LC_MESSAGES/gcombust.mo
|
||||
|
@ -20,4 +20,4 @@ share/locale/sk/LC_MESSAGES/gcombust.mo
|
|||
share/locale/sv/LC_MESSAGES/gcombust.mo
|
||||
share/pixmaps/gcombust.xpm
|
||||
@dirrmtry share/applications
|
||||
@dirrm share/doc/gcombust
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue