[patch] update mail/cclient to version 2006j

The c-client and imap-uw are still at version 2004g. The
	patch I am enclosing updates c-client to version 2006j.

PR:		ports/114833
Submitted by:	"Pedro J. Lobo" <pjlobo@sec.upm.es>
Approved by:	maintainer timeout
This commit is contained in:
Edwin Groothuis 2007-09-30 05:58:24 +00:00
parent ab4237740a
commit 75b03803c4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=200420
5 changed files with 347 additions and 215 deletions

View file

@ -6,8 +6,7 @@
# #
PORTNAME= cclient PORTNAME= cclient
PORTVERSION= 2004g PORTVERSION= 2006j
PORTREVISION= 1
PORTEPOCH= 1 PORTEPOCH= 1
CATEGORIES= mail devel ipv6 CATEGORIES= mail devel ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \ MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
@ -17,6 +16,8 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
MASTER_SITE_SUBDIR= . old MASTER_SITE_SUBDIR= . old
DISTNAME= imap-${PORTVERSION} DISTNAME= imap-${PORTVERSION}
EXTRACT_SUFX= .tar.Z EXTRACT_SUFX= .tar.Z
DISTVERSIONSUFFIX= 2
DISTFILES= ${DISTNAME}${DISTVERSIONSUFFIX}${EXTRACT_SUFX}
MAINTAINER= anders@FreeBSD.org MAINTAINER= anders@FreeBSD.org
COMMENT= Mark Crispin's C-client mail access routines COMMENT= Mark Crispin's C-client mail access routines
@ -44,7 +45,7 @@ MAKE_ARGS+= SSLTYPE=unix.nopwd
WRKSRC= ${WRKDIR}/${DISTNAME} WRKSRC= ${WRKDIR}/${DISTNAME}
SHLIBBASE= c-client4 SHLIBBASE= c-client4
SHLIBMAJ= 8 SHLIBMAJ= 9
SHLIBNAME= lib${SHLIBBASE}.so.${SHLIBMAJ} SHLIBNAME= lib${SHLIBBASE}.so.${SHLIBMAJ}
MAKE_ENV= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE} MAKE_ENV= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE}
PLIST_SUB= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE} PLIST_SUB= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE}
@ -67,10 +68,11 @@ post-patch:
post-configure: post-configure:
@${ECHO_MSG} ">> The c-client shared library will be named ${SHLIBNAME}" @${ECHO_MSG} ">> The c-client shared library will be named ${SHLIBNAME}"
HEADERS= c-client.h dummy.h env.h env_unix.h fdstring.h flstring.h \ HEADERS= c-client.h dummy.h env.h env_unix.h fdstring.h flockcyg.h \
fs.h ftl.h imap4r1.h linkage.c linkage.h mail.h mbx.h mh.h \ flocksim.h flstring.h fs.h ftl.h imap4r1.h linkage.h mail.h \
misc.h mx.h netmsg.h newsrc.h nl.h nntp.h osdep.h pseudo.h \ misc.h netmsg.h newsrc.h nl.h nntp.h osdep.h pseudo.h \
rfc822.h smtp.h sslio.h tcp.h tcp_unix.h unix.h utf8.h rfc822.h smtp.h sslio.h tcp.h tcp_unix.h unix.h utf8.h \
utf8aux.h
PORTREV_H= ${WRKDIR}/portrevision.h PORTREV_H= ${WRKDIR}/portrevision.h
post-build: post-build:

View file

@ -1,3 +1,3 @@
MD5 (imap-2004g.tar.Z) = 9a80f58d8d6a0979c13714ae69050020 MD5 (imap-2006j2.tar.Z) = d7900691c415bcc725c1bf2b15e4fb99
SHA256 (imap-2004g.tar.Z) = 958ab8a6a8b5a1a53167793141fe5bf1fbafc012be1d3f70a21f5f2f493ffa6d SHA256 (imap-2006j2.tar.Z) = 5b2ed247fd98f81c7a2d23d0822f602d49b742c19761a9c2dad6753f5f3e806e
SIZE (imap-2004g.tar.Z) = 2246713 SIZE (imap-2006j2.tar.Z) = 2686745

View file

@ -1,151 +1,254 @@
--- src/osdep/unix/Makefile.orig Sat Apr 30 22:51:13 2005 *** src/osdep/unix/Makefile.orig Sun Jun 17 17:37:44 2007
+++ src/osdep/unix/Makefile Sun Jul 1 22:29:26 2007 --- src/osdep/unix/Makefile Mon Jul 23 16:30:12 2007
@@ -22,8 +22,8 @@ ***************
*** 28,36 ****
EXTRAAUTHENTICATORS=
EXTRADRIVERS=mbox EXTRAAUTHENTICATORS=
-PASSWDTYPE=std EXTRADRIVERS=mbox
-SSLTYPE=nopwd ! PASSWDTYPE=std
+PASSWDTYPE=pam ! SSLTYPE=nopwd
+SSLTYPE=unix.nopwd ! IP=4
IP=4
# The optimization level here for GCC ports is set here for a reason. It's
@@ -41,13 +41,13 @@ --- 28,36 ----
# Extended flags needed for SSL. You may need to modify. EXTRAAUTHENTICATORS=
EXTRADRIVERS=mbox
-SSLDIR=/usr/local/ssl ! PASSWDTYPE=pam
-SSLCERTS=$(SSLDIR)/certs ! SSLTYPE=unix.nopwd
+#SSLDIR=/usr/local/ssl ! IP=6
+SSLCERTS=$(PREFIX)/certs
SSLKEYS=$(SSLCERTS)
SSLINCLUDE=$(SSLDIR)/include # The optimization level here for GCC ports is set here for a reason. It's
SSLLIB=$(SSLDIR)/lib ***************
*** 54,66 ****
-SSLCRYPTO=-lcrypto
+SSLCRYPTO=-lcrypto -lcrypt # Extended flags needed for SSL. You may need to modify.
# Older versions of MIT Kerberos also have a libcrypto. If so, you may need ! SSLDIR=/usr/local/ssl
# to use this instead ! SSLCERTS=$(SSLDIR)/certs
@@ -74,7 +74,7 @@ SSLKEYS=$(SSLCERTS)
# AFSLDFLAGS may also need -L/usr/ucblib -lucb SSLINCLUDE=$(SSLDIR)/include
DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\" SSLLIB=$(SSLDIR)/lib
DCELDFLAGS= -ldce
-PAMLDFLAGS= -lpam -ldl ! SSLCRYPTO=-lcrypto
+PAMLDFLAGS= # -lpam -lcrypt
# Older versions of MIT Kerberos also have a libcrypto. If so, you may need
# to use this instead
# Build parameters normally set by the individual port --- 54,66 ----
@@ -111,7 +111,7 @@
# Commands possibly overriden by the individual port # Extended flags needed for SSL. You may need to modify.
ARRC=ar rc ! #SSLDIR=/usr/local/ssl
-CC=cc ! SSLCERTS=$(PREFIX)/certs
+#CC=cc SSLKEYS=$(SSLCERTS)
LN=ln -s SSLINCLUDE=$(SSLDIR)/include
RANLIB=ranlib SSLLIB=$(SSLDIR)/lib
@@ -129,7 +129,7 @@ ! SSLCRYPTO=-lcrypto -lcrypt
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \ # Older versions of MIT Kerberos also have a libcrypto. If so, you may need
unix.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o # to use this instead
-CFLAGS=-g ***************
+CFLAGS+=$(BASECFLAGS) $(EXTRACFLAGS) *** 87,93 ****
# AFSLDFLAGS may also need -L/usr/ucblib -lucb
CAT=cat DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\"
MAKE=make DCELDFLAGS= -ldce
@@ -146,6 +146,10 @@ ! PAMLDFLAGS= -lpam -ldl
PASSWDTYPE=$(PASSWDTYPE) SSLTYPE=$(SSLTYPE) IP=$(IP)
# Build parameters normally set by the individual port
+# Need this for the shared library rule to work correctly --- 87,93 ----
+.SUFFIXES: .o .so # AFSLDFLAGS may also need -L/usr/ucblib -lucb
+SOFILES=${BINARIES:.o=.so} DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\"
+ DCELDFLAGS= -ldce
# Here if no make argument established ! PAMLDFLAGS= # -lpam -lcrypt
missing: osdep.h
@@ -226,13 +230,14 @@ # Build parameters normally set by the individual port
BASECFLAGS="-g -Dconst=" ***************
*** 125,131 ****
bsf: # FreeBSD # Commands possibly overriden by the individual port
- $(BUILD) `$(CAT) SPECIALS` OS=$@ \
+ $(BUILD) `$(CAT) SPECIALS` OS=$@ CHECKPW=pam \ ARRC=ar rc
SIGTYPE=psx CRXTYPE=nfs \ ! CC=cc
SPOOLDIR=/var \ LN=ln -s
ACTIVEFILE=/usr/local/news/lib/active \ RANLIB=ranlib
RSHPATH=/usr/bin/rsh \
- BASECFLAGS="-g -O -pipe" \ --- 125,131 ----
- BASELDFLAGS="-lcrypt" # Commands possibly overriden by the individual port
+ LOCKPGM=$(PREFIX)/libexec/mlock \
+ BASECFLAGS="-DNFSKLUDGE" \ ARRC=ar rc
+ BASELDFLAGS="-lpam" ! #CC=cc
LN=ln -s
bsi: # BSD/i386 RANLIB=ranlib
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
@@ -801,23 +806,31 @@ ***************
*** 149,155 ****
# Build it! dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
-build: clean once $(ARCHIVE) unix.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o mix.o
+build: clean once $(ARCHIVE) $(SHLIBNAME) ! CFLAGS=-g
-all: $(ARCHIVE) CAT=cat
+all: $(ARCHIVE) $(SHLIBNAME) MAKE=make
--- 149,155 ----
$(ARCHIVE): $(BINARIES) dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
sh -c '$(RM) $(ARCHIVE) || true' rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
@$(CAT) ARCHIVE unix.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o mix.o
@$(SH) ARCHIVE ! CFLAGS+=$(BASECFLAGS) $(EXTRACFLAGS)
+$(SHLIBNAME): $(SOFILES) CAT=cat
+ ld -shared -x -soname $(SHLIBNAME) -o $(SHLIBNAME) $(SOFILES) `cat LDFLAGS` MAKE=make
+ ln -s $(SHLIBNAME) lib$(SHLIBBASE).so ***************
+ *** 166,171 ****
+.c.so: osdep.h --- 166,175 ----
+ $(CC) -fPIC -DPIC -c $(CFLAGS) ${@:.so=.c} -o $@ PASSWDTYPE=$(PASSWDTYPE) SSLTYPE=$(SSLTYPE) IP=$(IP)
+
.c.o:
- `$(CAT) CCTYPE` -c `$(CAT) CFLAGS` $*.c + # Need this for the shared library rule to work correctly
+ $(CC) -c $(CFLAGS) $*.c + .SUFFIXES: .o .so
+ SOFILES=${BINARIES:.o=.so}
+
# Cleanup # Here if no make argument established
clean: missing: osdep.h
sh -c '$(RM) auths.c crexcl.c nfstest.c linkage.[ch] siglocal.c osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE $(ARCHIVE) || true' ***************
+ sh -c '$(RM) *.so $(SHLIBNAME)' *** 246,258 ****
BASECFLAGS="-g -Dconst="
# Dependencies bsf: # FreeBSD
@@ -850,7 +863,7 @@ ! $(BUILD) `$(CAT) SPECIALS` OS=$@ \
SIGTYPE=psx CRXTYPE=nfs \
# OS-dependent SPOOLDIR=/var \
ACTIVEFILE=/usr/local/news/lib/active \
-osdep.o:mail.h misc.h env.h fs.h ftl.h nl.h tcp.h \ RSHPATH=/usr/bin/rsh \
+OSDEPS= mail.h misc.h env.h fs.h ftl.h nl.h tcp.h \ BASECFLAGS="$(GCCCFLAGS)" \
osdep.h env_unix.h tcp_unix.h \ ! BASELDFLAGS="-lcrypt"
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c ip_unix.c\
auths.c crexcl.c flockcyg.c flocklnx.c flocksim.c nfstest.c fsync.c \ bsi: # BSD/i386
@@ -864,12 +877,19 @@ $(BUILD) `$(CAT) SPECIALS` OS=$@ \
write.c sslstdio.c \ --- 250,263 ----
strerror.c strpbrk.c strstr.c strtok.c strtoul.c \ BASECFLAGS="-g -Dconst="
OSCFLAGS
+ bsf: # FreeBSD
+osdep.o: $(OSDEPS) ! $(BUILD) `$(CAT) SPECIALS` OS=$@ CHECKPW=pam \
+ $(CC) $(CFLAGS) `$(CAT) OSCFLAGS` -c osdep.c SIGTYPE=psx CRXTYPE=nfs \
+ @echo ======================================================================== SPOOLDIR=/var \
@echo Building OS-dependent module ACTIVEFILE=/usr/local/news/lib/active \
@echo If you get No such file error messages for files x509.h, ssl.h, RSHPATH=/usr/bin/rsh \
@echo pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL + LOCKPGM=$(PREFIX)/libexec/mlock \
@echo is not installed on your system. Either install OpenSSL first BASECFLAGS="$(GCCCFLAGS)" \
@echo or build with command: make `$(CAT) OSTYPE` SSLTYPE=none ! BASELDFLAGS="-lpam"
- `$(CAT) CCTYPE` -c `$(CAT) CFLAGS` `$(CAT) OSCFLAGS` -c osdep.c
+ @echo ======================================================================== bsi: # BSD/i386
+ $(BUILD) `$(CAT) SPECIALS` OS=$@ \
+osdep.so: $(OSDEPS) ***************
+ $(CC) -fPIC -DPIC -c $(CFLAGS) `cat OSCFLAGS` osdep.c -o $@ *** 840,862 ****
osdep.c: osdepbas.c osdepckp.c osdeplog.c osdepssl.c # Build it!
$(CAT) osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
! build: clean once $(ARCHIVE)
! all: $(ARCHIVE)
$(ARCHIVE): $(BINARIES)
sh -c '$(RM) $(ARCHIVE) || true'
@$(CAT) ARCHIVE
@$(SH) ARCHIVE
.c.o:
! `$(CAT) CCTYPE` -c `$(CAT) CFLAGS` $*.c
# Cleanup
clean:
sh -c '$(RM) auths.c crexcl.c ip_unix.c linkage.[ch] siglocal.c osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE $(ARCHIVE) || true'
# Dependencies
--- 845,875 ----
# Build it!
! build: clean once $(ARCHIVE) $(SHLIBNAME)
! all: $(ARCHIVE) $(SHLIBNAME)
$(ARCHIVE): $(BINARIES)
sh -c '$(RM) $(ARCHIVE) || true'
@$(CAT) ARCHIVE
@$(SH) ARCHIVE
+ $(SHLIBNAME): $(SOFILES)
+ ld -shared -x -soname $(SHLIBNAME) -o $(SHLIBNAME) $(SOFILES) `cat LDFLAGS`
+ ln -s $(SHLIBNAME) lib$(SHLIBBASE).so
+
+ .c.so: osdep.h
+ $(CC) -fPIC -DPIC -c `cat CFLAGS` ${@:.so=.c} -o $@
+
.c.o:
! $(CC) -c `cat CFLAGS` $*.c
# Cleanup
clean:
sh -c '$(RM) auths.c crexcl.c ip_unix.c linkage.[ch] siglocal.c osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE $(ARCHIVE) || true'
+ sh -c '$(RM) *.so $(SHLIBNAME)'
# Dependencies
***************
*** 891,897 ****
# OS-dependent
! osdep.o:mail.h misc.h env.h fs.h ftl.h nl.h tcp.h \
osdep.h env_unix.h tcp_unix.h \
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c ip_unix.c\
auths.c crexcl.c flockcyg.c flocklnx.c flocksim.c fsync.c \
--- 904,910 ----
# OS-dependent
! OSDEPS= mail.h misc.h env.h fs.h ftl.h nl.h tcp.h \
osdep.h env_unix.h tcp_unix.h \
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c ip_unix.c\
auths.c crexcl.c flockcyg.c flocklnx.c flocksim.c fsync.c \
***************
*** 905,916 ****
write.c sslstdio.c \
strerror.c strpbrk.c strstr.c strtok.c strtoul.c \
OSCFLAGS
@echo Building OS-dependent module
@echo If you get No such file error messages for files x509.h, ssl.h,
@echo pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL
@echo is not installed on your system. Either install OpenSSL first
@echo or build with command: make `$(CAT) OSTYPE` SSLTYPE=none
! `$(CAT) CCTYPE` -c `$(CAT) CFLAGS` `$(CAT) OSCFLAGS` -c osdep.c
osdep.c: osdepbas.c osdepckp.c osdeplog.c osdepssl.c
$(CAT) osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
--- 918,936 ----
write.c sslstdio.c \
strerror.c strpbrk.c strstr.c strtok.c strtoul.c \
OSCFLAGS
+
+ osdep.o: $(OSDEPS)
+ $(CC) `$(CAT) CFLAGS` `$(CAT) OSCFLAGS` -c osdep.c
+ @echo ========================================================================
@echo Building OS-dependent module
@echo If you get No such file error messages for files x509.h, ssl.h,
@echo pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL
@echo is not installed on your system. Either install OpenSSL first
@echo or build with command: make `$(CAT) OSTYPE` SSLTYPE=none
! @echo ========================================================================
!
! osdep.so: $(OSDEPS)
! $(CC) -fPIC -DPIC -c `$(CAT) CFLAGS` `$(CAT) OSCFLAGS` osdep.c -o $@
osdep.c: osdepbas.c osdepckp.c osdeplog.c osdepssl.c
$(CAT) osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c

View file

@ -1,50 +1,78 @@
--- Makefile.orig Tue Nov 5 01:19:13 2002 *** Makefile.orig Wed May 9 00:50:45 2007
+++ Makefile Wed Nov 27 00:59:07 2002 --- Makefile Mon Jul 23 16:02:26 2007
@@ -256,7 +256,7 @@ ***************
*** 294,300 ****
# Make the IMAP Toolkit
# Make the IMAP Toolkit
-all: SPECIALS c-client rebuild bundled
+all: SPECIALS c-client rebuild ! all: c-client SPECIALS rebuild bundled
c-client: c-client:
@echo Not processed yet. In a first-time build, you must specify @echo Not processed yet. In a first-time build, you must specify
@@ -396,9 +396,6 @@ --- 294,300 ----
@echo + In order to rectify this problem, you MUST build with:
@echo ++ SSLTYPE=$(SSLTYPE).nopwd # Make the IMAP Toolkit
@echo +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
- @echo ! all: c-client SPECIALS rebuild
- @echo Do you want to continue this build anyway? Type y or n please:
- @$(SH) -c 'read x; case "$$x" in y) exit 0;; *) exit 1;; esac' c-client:
@echo Not processed yet. In a first-time build, you must specify
sslnone: ***************
@echo +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ *** 559,567 ****
@@ -411,9 +408,6 @@ @echo + In order to rectify this problem, you MUST build with:
@echo ++ SSLTYPE=nopwd @echo ++ SSLTYPE=$(SSLTYPE).nopwd
@echo + You must also have OpenSSL or equivalent installed. @echo +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
@echo +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ - @echo
- @echo - @echo Do you want to continue this build anyway? Type y or n please:
- @echo Do you want to continue this build anyway? Type y or n please: - @$(SH) -c 'read x; case "$$x" in y) exit 0;; *) (make nounenc;exit 1);; esac'
- @$(SH) -c 'read x; case "$$x" in y) exit 0;; *) exit 1;; esac'
nounenc:
@echo +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
# C compiler types --- 559,564 ----
@@ -434,7 +428,7 @@ ***************
$(TOOLS)/$@ "$(LN)" src/tmail tmail *** 582,590 ****
$(LN) $(TOOLS)/$@ . @echo ++ SSLTYPE=nopwd
@echo + You must also have OpenSSL or equivalent installed.
-build: OSTYPE rebuild rebuildclean bundled @echo +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+build: OSTYPE rebuild rebuildclean - @echo
- @echo Do you want to continue this build anyway? Type y or n please:
OSTYPE: - @$(SH) -c 'read x; case "$$x" in y) exit 0;; *) (make nonossl;exit 1);; esac'
@echo Building c-client for $(BUILDTYPE)...
@@ -453,8 +447,7 @@ nonossl:
@$(SH) -c '(test $(BUILDTYPE) = rebuild -o $(BUILDTYPE) = `$(CAT) OSTYPE`) || (echo Already built for `$(CAT) OSTYPE` -- you must do \"make clean\" first && exit 1)' @echo +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
@echo Rebuilding c-client for `$(CAT) OSTYPE`... --- 579,584 ----
@$(TOUCH) SPECIALS ***************
- $(CD) c-client;$(MAKE) all CC=`$(CAT) CCTYPE` \ *** 659,665 ****
- CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS` $(TOOLS)/$@ "$(LN)" src/tmail tmail
+ $(CD) c-client;$(MAKE) all CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS` $(LN) $(TOOLS)/$@ .
rebuildclean: ! build: OSTYPE rebuild rebuildclean bundled
$(SH) -c '$(RM) rebuild || true'
OSTYPE:
@$(MAKE) ip$(IP)
--- 653,659 ----
$(TOOLS)/$@ "$(LN)" src/tmail tmail
$(LN) $(TOOLS)/$@ .
! build: OSTYPE rebuild rebuildclean
OSTYPE:
@$(MAKE) ip$(IP)
***************
*** 679,686 ****
@$(SH) -c '(test $(BUILDTYPE) = rebuild -o $(BUILDTYPE) = `$(CAT) OSTYPE`) || (echo Already built for `$(CAT) OSTYPE` -- you must do \"make clean\" first && exit 1)'
@echo Rebuilding c-client for `$(CAT) OSTYPE`...
@$(TOUCH) SPECIALS
! $(CD) c-client;$(MAKE) all CC=`$(CAT) CCTYPE` \
! CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS`
rebuildclean:
$(SH) -c '$(RM) rebuild || true'
--- 673,679 ----
@$(SH) -c '(test $(BUILDTYPE) = rebuild -o $(BUILDTYPE) = `$(CAT) OSTYPE`) || (echo Already built for `$(CAT) OSTYPE` -- you must do \"make clean\" first && exit 1)'
@echo Rebuilding c-client for `$(CAT) OSTYPE`...
@$(TOUCH) SPECIALS
! $(CD) c-client;$(MAKE) all CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS`
rebuildclean:
$(SH) -c '$(RM) rebuild || true'

View file

@ -3,17 +3,15 @@ include/c-client/dummy.h
include/c-client/env.h include/c-client/env.h
include/c-client/env_unix.h include/c-client/env_unix.h
include/c-client/fdstring.h include/c-client/fdstring.h
include/c-client/flockcyg.h
include/c-client/flocksim.h
include/c-client/flstring.h include/c-client/flstring.h
include/c-client/fs.h include/c-client/fs.h
include/c-client/ftl.h include/c-client/ftl.h
include/c-client/imap4r1.h include/c-client/imap4r1.h
include/c-client/linkage.c
include/c-client/linkage.h include/c-client/linkage.h
include/c-client/mail.h include/c-client/mail.h
include/c-client/mbx.h
include/c-client/mh.h
include/c-client/misc.h include/c-client/misc.h
include/c-client/mx.h
include/c-client/netmsg.h include/c-client/netmsg.h
include/c-client/newsrc.h include/c-client/newsrc.h
include/c-client/nl.h include/c-client/nl.h
@ -27,6 +25,7 @@ include/c-client/tcp.h
include/c-client/tcp_unix.h include/c-client/tcp_unix.h
include/c-client/unix.h include/c-client/unix.h
include/c-client/utf8.h include/c-client/utf8.h
include/c-client/utf8aux.h
include/c-client/portrevision.h include/c-client/portrevision.h
include/c-client/CFLAGS include/c-client/CFLAGS
include/c-client/LDFLAGS include/c-client/LDFLAGS