Update to 0.91.4.
Submitted by: maintainer
This commit is contained in:
parent
55534f8853
commit
75ba306540
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=339181
5 changed files with 22 additions and 28 deletions
|
@ -2,9 +2,9 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= owncloud-csync
|
||||
PORTVERSION= 0.90.4
|
||||
PORTVERSION= 0.91.4
|
||||
CATEGORIES= net kde
|
||||
MASTER_SITES= http://download.owncloud.com/download/
|
||||
MASTER_SITES= http://download.owncloud.com/desktop/stable/
|
||||
DISTNAME= ocsync-${PORTVERSION}
|
||||
|
||||
MAINTAINER= 6yearold@gmail.com
|
||||
|
@ -39,4 +39,9 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's/^add_subdirectory(doc)//' ${WRKSRC}/CMakeLists.txt
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.for i in ocsync.conf ocsync_exclude.conf
|
||||
@${MV} ${STAGEDIR}${ETCDIR}/$i ${STAGEDIR}${ETCDIR}/$i.sample
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (ocsync-0.90.4.tar.bz2) = f2146577c977dc82a24e0baf84f3970efc3b004f2730669aae3816f48ff15728
|
||||
SIZE (ocsync-0.90.4.tar.bz2) = 4630698
|
||||
SHA256 (ocsync-0.91.4.tar.bz2) = 9ce5d04ff0475be4c3d3bfff43a554980d88277e95de4128a3f18611529b2cb6
|
||||
SIZE (ocsync-0.91.4.tar.bz2) = 6010999
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ./cmake/Modules/DefineCompilerFlags.cmake.orig 2013-09-04 11:15:42.000000000 +0200
|
||||
+++ ./cmake/Modules/DefineCompilerFlags.cmake 2013-09-18 16:29:48.000000000 +0200
|
||||
--- cmake/Modules/11DefineCompilerFlags.cmake 2013-12-17 11:05:41.000000000 +0400
|
||||
+++ cmake/Modules/DefineCompilerFlags.cmake 2013-12-17 11:06:00.579967195 +0400
|
||||
@@ -30,11 +30,6 @@
|
||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
|
||||
endif (WITH_FPIC AND NOT WIN32)
|
||||
|
@ -9,6 +9,6 @@
|
|||
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fstack-protector")
|
||||
- endif (WITH_STACK_PROTECTOR AND NOT WIN32)
|
||||
-
|
||||
if (WITH_OPTIMIZATION)
|
||||
check_c_compiler_flag("-D_FORTIFY_SOURCE=2" WITH_FORTIFY_SOURCE)
|
||||
if (WITH_FORTIFY_SOURCE)
|
||||
if (CMAKE_BUILD_TYPE)
|
||||
string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LOWER)
|
||||
if (CMAKE_BUILD_TYPE_LOWER MATCHES "(release|relwithdebinfo|minsizerel)")
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/std/_c_string.c 2013-02-20 20:39:16.000000000 +0400
|
||||
+++ src/std/c_string.c 2013-03-16 14:19:04.313916478 +0400
|
||||
@@ -83,7 +83,7 @@
|
||||
|
||||
static char *c_iconv(const char* str, enum iconv_direction dir)
|
||||
{
|
||||
- char *in = (char*)str;
|
||||
+ const char *in = (char*)str;
|
||||
size_t size;
|
||||
size_t outsize;
|
||||
char *out;
|
|
@ -1,6 +1,10 @@
|
|||
bin/ocsync
|
||||
%%ETCDIR%%/ocsync.conf
|
||||
%%ETCDIR%%/ocsync_exclude.conf
|
||||
@unexec if cmp -s %D/%%ETCDIR%%/ocsync.conf.sample %D/%%ETCDIR%%/ocsync.conf; then rm -f %D/%%ETCDIR%%/ocsync.conf; fi
|
||||
%%ETCDIR%%/ocsync.conf.sample
|
||||
@exec if [ ! -f %D/%%ETCDIR%%/ocsync.conf ] ; then cp -p %D/%F %B/ocsync.conf; fi
|
||||
@unexec if cmp -s %D/%%ETCDIR%%/ocsync_exclude.conf.sample %D/%%ETCDIR%%/ocsync_exclude.conf; then rm -f %D/%%ETCDIR%%/ocsync_exclude.conf; fi
|
||||
%%ETCDIR%%/ocsync_exclude.conf.sample
|
||||
@exec if [ ! -f %D/%%ETCDIR%%/ocsync_exclude.conf ] ; then cp -p %D/%F %B/ocsync_exclude.conf; fi
|
||||
include/httpbf.h
|
||||
include/ocsync/csync.h
|
||||
include/ocsync/csync_version.h
|
||||
include/ocsync/csync_vio.h
|
||||
|
@ -8,13 +12,10 @@ include/ocsync/csync_vio_file_stat.h
|
|||
include/ocsync/csync_vio_handle.h
|
||||
include/ocsync/csync_vio_method.h
|
||||
include/ocsync/csync_vio_module.h
|
||||
lib/libhttpbflib.a
|
||||
lib/libhttpbf.a
|
||||
lib/libocsync.so
|
||||
lib/libocsync.so.0
|
||||
lib/libocsync.so.0.2.1
|
||||
lib/ocsync-0/ocsync_owncloud.so
|
||||
lib/ocsync-0/ocsync_sftp.so
|
||||
lib/ocsync-0/ocsync_smb.so
|
||||
%%PORTDOCS%%man/man1/ocsync.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/userguide/csync.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/userguide/images/icons/README
|
||||
|
@ -48,6 +49,5 @@ lib/ocsync-0/ocsync_smb.so
|
|||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/userguide/images
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/userguide
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrmtry lib/ocsync-0
|
||||
@dirrmtry include/ocsync
|
||||
@dirrmtry %%ETCDIR%%
|
||||
|
|
Loading…
Reference in a new issue