- Switch to options helpers
- Regenerate patches with `make makepatch`
This commit is contained in:
parent
507c83b05b
commit
75ce42f49d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418913
2 changed files with 9 additions and 7 deletions
|
@ -20,8 +20,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
|
|||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|^HEDITOR=.*|HEDITOR=$$EDITOR|' \
|
||||
${WRKSRC}/hmailedit
|
||||
@${REINPLACE_CMD} -e 's|^HEDITOR=.*|HEDITOR=$$EDITOR|' \
|
||||
${WRKSRC}/hmailedit
|
||||
|
||||
do-build:
|
||||
${CC} ${CFLAGS} -o ${WRKSRC}/hmconv ${WRKSRC}/hmconv1.0pl3.c
|
||||
|
@ -29,6 +29,8 @@ do-build:
|
|||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/hmailedit ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/hmconv ${STAGEDIR}${PREFIX}/bin
|
||||
cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
do-install-DOCS-on:
|
||||
@cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- hmconv1.0pl3.c.orig 1996-07-22 23:16:14.000000000 -0400
|
||||
+++ hmconv1.0pl3.c 2013-06-12 14:24:05.000000000 -0400
|
||||
--- hmconv1.0pl3.c.orig 1996-07-23 03:16:14 UTC
|
||||
+++ hmconv1.0pl3.c
|
||||
@@ -46,6 +46,7 @@
|
||||
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
|||
#include <string.h>
|
||||
|
||||
#define isksc(c) ( (unsigned char) (c) > (unsigned char) '\240' && \
|
||||
@@ -125,6 +126,7 @@
|
||||
@@ -125,6 +126,7 @@ char *optstring;
|
||||
}
|
||||
|
||||
#ifndef KNR
|
||||
|
@ -16,7 +16,7 @@
|
|||
main (int argc, char **argv)
|
||||
#else
|
||||
main (argc,argv)
|
||||
@@ -208,7 +210,7 @@
|
||||
@@ -208,7 +210,7 @@ int convert()
|
||||
|
||||
if ( !ishangul) { /* KSC 5601 doesn't appear, yet */
|
||||
fputs((char *) line,out); /* no conversion */
|
||||
|
|
Loading…
Reference in a new issue