Upgrade from 3.0.0-rc4 to 3.0.0.

<ChangeLog>

--[ Redis 3.0.0 ] Release date: 1 Apr 2015

Changes between RC6 and 3.0.0 stable:

>> General changes

* Fixes to diskless replication. (Oran Agra)
* Test for BLPOP replication on role change. (Salvatore Sanfilippo)
* prepareClientToWrite() error handling improvements. (Salvatore Sanfilippo)
* Remove dict.c no longer used function. (Salvatore Sanfilippo)

>> Cluster changes

None

>> Sentinel changes

None

--[ Redis 3.0.0 RC6 (version 2.9.106) ] Release date: 24 mar 2015

Upgrade urgency: HIGH because of bugs related to Redis Custer and replication.

This is the 6th release candidate of Redis 3.0.0. This release fixes important
issues discovered during stress testing, and implements safest behavior
for blocking operations during clients reshardings, and a new much needed
functionality of Redis Cluster manual failovers.

In order to fix certain bugs quite a bit of refactoring was needed which
is usually non advisabble in a Release Candidate, but needed in order to
end with a clean fix.

>> General changes

* [FIX] Redis (non clustered & clustered) replication bug involving blocking
        operations: see issue #2473. (Salvatore Sanfilippo)

>> Cluster changes

* [FIX] clientsArePaused() fix crashing the old master during manual failover.
        (Salvatore Sanfilippo)
* [FIX] Lua scripts replication in Redis Cluster was totally broken.
        (Salvatore Sanfilippo)
* [FIX] Redirect clients blocked into list operations when the hash slot
        they are blocked into is migrated to another instance or the cluster
        state turns into "fail". (Salvatore Sanfilippo)

* [NEW] TAKEOVER option for CLUSTER FAILOVER implemented. It is now possible
        to fix a cluster manually in the minority side of the partition, for
        example in order to allow for multi DC setups & recovery.
        (Salvatore Sanfilippo)

>> Sentinel changes

No changes in Sentinel.

--[ Redis 3.0.0 RC5 (version 2.9.105) ] Release date: 20 mar 2015

Upgrade urgency: Moderate for Redis Cluster users, low otherwise.

This is the 5th release candidate of Redis 3.0.0, released in order to fix
a moderate bug in Redis Cluster. This RC does not shift in the future the
Redis 3.0.0 final release which is scheduled in a few days (we are in the
process of finishing the documentation for Redis Cluster).

>> General changes

* [FIX] Fix LATENCY command crash. (Salvatore Sanfilippo, thx to Ingmar)
* [FIX] Config: missing activerehashing option support in CONFIG SET added.
        (Salvatore Sanfilippo, thx to Bill Anderson)
* [FIX] Fix for backtrace generation issue. (Mariano Pérez Rodríguez, Matt Stancliff, Salvatore Sanfilippo)

* [NEW] Redis-cli --latency-dist backported from unstable.
        (Salvatore Sanfilippo)

>> Cluster changes

* [FIX] Avoid redundant SELECT in MIGRATE. (Tommy Wang, Salvatore Sanfilippo)
* [FIX] More robust slave check in CLUSTER REPLICATE. (Salvatore Sanfilippo)
* [FIX] Fixed possible Redis Cluster node crash due to wrong separation of
        concerns between getNodeByQuery() and Cluster global state update
        fnuction. (Salvatore Sanfilippo, thx to Ingmar)

* [NEW] Add command CLUSTER MYID to easily featch instance ID. (Michel Martens)

>> Sentinel changes

* [NEW] Support for CLIENT command added. It was missing in the command table.
        (Leandro López)

</ChangeLog>
This commit is contained in:
Sergey A. Osokin 2015-04-07 22:14:16 +00:00
parent 56915055be
commit 75d697262a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=383544
4 changed files with 13 additions and 18 deletions

View file

@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= redis
DISTVERSION= 3.0.0-rc4
DISTVERSION= 3.0.0
CATEGORIES= databases
MASTER_SITES= https://github.com/antirez/redis/archive/
MASTER_SITES= http://download.redis.io/releases/
PKGNAMESUFFIX= -devel
DISTNAME= ${DISTVERSION}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= osa@FreeBSD.org
COMMENT= Persistent key-value database with built-in net interface
@ -23,9 +21,6 @@ LUA_DESC= Use lang/lua instead of builtin lua
LUAJIT_DESC= Use lang/luajit instead of builtin lua
TESTS_DESC= Install lang/tcl for redis unit tests
FETCH_ARGS= -Fpr
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLUA}
@ -50,7 +45,7 @@ USES+= tcl:build
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lpthread -lm -lexecinfo
CONFLICTS?= redis-2.*
CONFLICTS?= redis-3.*
USES+= gmake
MAKE_ENV= "V=yo"

View file

@ -1,2 +1,2 @@
SHA256 (redis/3.0.0-rc4.tar.gz) = 1787b7fd57ec019e84691e881e81a8d8b67cf0d2457bd484d4da8c6eaca4a731
SIZE (redis/3.0.0-rc4.tar.gz) = 1365919
SHA256 (redis-3.0.0.tar.gz) = 654c95c6236692dcb916fccba9a34d0877cc91338c8b6a372511e6eb080e34bf
SIZE (redis-3.0.0.tar.gz) = 1358081

View file

@ -1,5 +1,5 @@
--- src/Makefile.orig 2014-10-11 01:09:55.000000000 +0400
+++ src/Makefile 2014-10-11 01:12:53.000000000 +0400
--- src/Makefile.orig 2015-04-01 17:01:44.000000000 +0300
+++ src/Makefile 2015-04-07 21:30:22.464962000 +0300
@@ -22,7 +22,7 @@
WARN=-Wall -W
OPT=$(OPTIMIZATION)
@ -24,7 +24,7 @@
+ifeq ($(uname_S),FreeBSD)
+ # FreeBSD
+ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
+ FINAL_LDFLAGS= $(LDFLAGS)
+ FINAL_LDFLAGS= $(LDFLAGS) -pthread
+else
ifeq ($(uname_S),AIX)
# AIX

View file

@ -1,11 +1,11 @@
--- src/config.h.orig 2013-02-11 21:47:44.000000000 +0400
+++ src/config.h 2013-02-11 21:50:10.000000000 +0400
@@ -54,7 +54,7 @@
--- src/config.h.orig 2015-04-07 21:24:36.634829000 +0300
+++ src/config.h 2015-04-07 21:24:53.388849000 +0300
@@ -62,7 +62,7 @@
#endif
/* Test for backtrace() */
-#if defined(__APPLE__) || defined(__linux__)
+#if defined(__APPLE__) || defined(__linux__) || defined(__FreeBSD__)
-#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__))
+#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || defined(__FreeBSD__)
#define HAVE_BACKTRACE 1
#endif