net/syncthing: update to 0.10.4
This commit is contained in:
parent
fb9ba05e24
commit
76278ce646
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=372130
3 changed files with 34 additions and 20 deletions
|
@ -2,11 +2,9 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= syncthing
|
||||
PORTVERSION= 0.10.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.10.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= swills@FreeBSD.org
|
||||
COMMENT= Encrypted file sync tool
|
||||
|
@ -21,20 +19,22 @@ USERS= syncthing
|
|||
GROUPS= syncthing
|
||||
|
||||
post-patch:
|
||||
cd ${WRKSRC} ; ${MKDIR} src/github.com/${PORTNAME}/${PORTNAME} ; \
|
||||
${MV} .gitignore CONTRIBUTING.md CONTRIBUTORS Godeps LICENSE \
|
||||
README.md assets build.go build.sh check-contrib.sh cmd gui \
|
||||
internal protocol test src/github.com/${PORTNAME}/${PORTNAME}
|
||||
@cd ${WRKSRC} ; ${MKDIR} src/github.com/${PORTNAME}/${PORTNAME} ; \
|
||||
${MV} CONTRIBUTORS Godeps LICENSE README.md build.go build.sh \
|
||||
assets cmd gui internal protocol src/github.com/${PORTNAME}/${PORTNAME}
|
||||
|
||||
do-build:
|
||||
# timestamp here refers to source, not build time
|
||||
cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME} ; ${SETENV} GOPATH=${WRKSRC} go run build.go
|
||||
cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME} ; \
|
||||
${SETENV} GOPATH=${WRKSRC} go run build.go
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/syncthing ${STAGEDIR}${PREFIX}/bin/
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/syncthing \
|
||||
${STAGEDIR}${PREFIX}/bin/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for x in CONTRIBUTORS LICENSE README.md
|
||||
${INSTALL_MAN} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/${x} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/${x} \
|
||||
${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (syncthing-0.10.1.tar.gz) = 464a8459c097b6a8dcf67454ecaf2b49e9570cb7a41ec38752cbf9b06cf7d68f
|
||||
SIZE (syncthing-0.10.1.tar.gz) = 2954077
|
||||
SHA256 (syncthing-0.10.4.tar.gz) = aff9a358fd9021254afc5c8ec1fd92618eadf622c9dba240666ff41abba3ec00
|
||||
SIZE (syncthing-0.10.4.tar.gz) = 2996470
|
||||
|
|
|
@ -1,23 +1,37 @@
|
|||
--- build.go.orig 2014-10-10 03:17:54.000000000 +0000
|
||||
+++ build.go 2014-10-10 03:21:21.000000000 +0000
|
||||
@@ -299,18 +299,11 @@
|
||||
--- build.go.orig 2014-10-24 08:27:14.000000000 +0000
|
||||
+++ build.go 2014-10-25 12:42:18.706050568 +0000
|
||||
@@ -35,7 +35,6 @@
|
||||
"runtime"
|
||||
"strconv"
|
||||
"strings"
|
||||
- "time"
|
||||
)
|
||||
|
||||
var (
|
||||
@@ -302,24 +301,11 @@
|
||||
}
|
||||
|
||||
func version() string {
|
||||
- v := run("git", "describe", "--always", "--dirty")
|
||||
func getVersion() string {
|
||||
- v, err := runError("git", "describe", "--always", "--dirty")
|
||||
- if err != nil {
|
||||
- return "unknown-dev"
|
||||
- }
|
||||
- v = versionRe.ReplaceAllFunc(v, func(s []byte) []byte {
|
||||
- s[0] = '+'
|
||||
- return s
|
||||
- })
|
||||
- return string(v)
|
||||
+ return string("v0.10.1")
|
||||
+ return string("v0.10.4")
|
||||
}
|
||||
|
||||
func buildStamp() int64 {
|
||||
- bs := run("git", "show", "-s", "--format=%ct")
|
||||
- bs, err := runError("git", "show", "-s", "--format=%ct")
|
||||
- if err != nil {
|
||||
- return time.Now().Unix()
|
||||
- }
|
||||
- s, _ := strconv.ParseInt(string(bs), 10, 64)
|
||||
- return s
|
||||
+ return 1413115780
|
||||
+ return 1414418716
|
||||
}
|
||||
|
||||
func buildUser() string {
|
||||
|
|
Loading…
Reference in a new issue