Update to Wine 1.7.35. This includes the following changes:

- Beginnings of support for OpenGL core contexts.
 - Initial support for glyph placement in DirectWrite.
 - Some more WBEM objects.
 - Various bug fixes.

My fix for PR 188424 is now upstream, so files/patch-alternate-toolchain
is not applicable any more; remove it.

PR:		188424
This commit is contained in:
Gerald Pfeifer 2015-01-24 20:32:15 +00:00
parent a0e397213e
commit 76542d98d0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=377820
4 changed files with 7 additions and 157 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wine
DISTVERSION= 1.7.34
DISTVERSION= 1.7.35
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \

View file

@ -1,4 +1,4 @@
SHA256 (wine-1.7.34.tar.bz2) = 4d5a3b25450fb232aa9d0d0dd859b7d50b8ffb6180f24aefb6eb4e400d32330b
SIZE (wine-1.7.34.tar.bz2) = 21956792
SHA256 (v1.7.34.tar.gz) = 9e71b5d3ce0cd8c4c511c375bcdae74de33d96dbda1d1e70fc7eb8708ee018dc
SIZE (v1.7.34.tar.gz) = 8865976
SHA256 (wine-1.7.35.tar.bz2) = eb2ef652a302c366d3f6ee9315790f162b1c0913d442cb5a856d9f7d95e31cfb
SIZE (wine-1.7.35.tar.bz2) = 22005666
SHA256 (v1.7.35.tar.gz) = f1663938c29ab20c493569a5eaba7711a0f0d47cf5e4b9988f97140de2599b16
SIZE (v1.7.35.tar.gz) = 8896849

View file

@ -1,152 +0,0 @@
--- Make.vars.in
+++ Make.vars.in
@@ -40,6 +40,7 @@ RANLIB = @RANLIB@
STRIP = @STRIP@
LN_S = @LN_S@
TOOLSDIR = @TOOLSDIR@
+LD = @LD@
LDFLAGS = @LDFLAGS@
DLLFLAGS = @DLLFLAGS@
PRELINK = @PRELINK@
--- configure
+++ configure
@@ -732,6 +732,7 @@ BISON
FLEX
TOOLSDIR
TARGETFLAGS
+LD
CPPBIN
ac_ct_CXX
CXXFLAGS
@@ -4736,6 +4737,98 @@ cat >>confdefs.h <<_ACEOF
#define EXEEXT "$ac_exeext"
_ACEOF
+if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}ld", so it can be a program name with args.
+set dummy ${ac_tool_prefix}ld; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_prog_LD+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ if test -n "$LD"; then
+ ac_cv_prog_LD="$LD" # Let the user override the test.
+else
+as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_LD="${ac_tool_prefix}ld"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+fi
+fi
+LD=$ac_cv_prog_LD
+if test -n "$LD"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $LD" >&5
+$as_echo "$LD" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
+fi
+if test -z "$ac_cv_prog_LD"; then
+ ac_ct_LD=$LD
+ # Extract the first word of "ld", so it can be a program name with args.
+set dummy ld; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_prog_ac_ct_LD+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ if test -n "$ac_ct_LD"; then
+ ac_cv_prog_ac_ct_LD="$ac_ct_LD" # Let the user override the test.
+else
+as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_ac_ct_LD="ld"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+fi
+fi
+ac_ct_LD=$ac_cv_prog_ac_ct_LD
+if test -n "$ac_ct_LD"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_LD" >&5
+$as_echo "$ac_ct_LD" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+ if test "x$ac_ct_LD" = x; then
+ LD=""
+ else
+ case $cross_compiling:$ac_tool_warned in
+yes:)
+{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+ac_tool_warned=yes ;;
+esac
+ LD=$ac_ct_LD
+ fi
+else
+ LD="$ac_cv_prog_LD"
+fi
+
case $host in
*-darwin*)
--- configure.ac
+++ configure.ac
@@ -122,6 +122,7 @@ AC_PROG_CXX
dnl We can't use AC_PROG_CPP for winegcc, it uses by default $(CC) -E
AC_CHECK_TOOL(CPPBIN,cpp,cpp)
AC_DEFINE_UNQUOTED(EXEEXT,["$ac_exeext"],[Define to the file extension for executables.])
+AC_CHECK_TOOL(LD,ld)
case $host in
*-darwin*)
--- tools/winegcc/Makefile.in
+++ tools/winegcc/Makefile.in
@@ -16,6 +16,7 @@ winegcc_EXTRADEFS = \
-DCC="\"$(CC)\"" \
-DCPP="\"$(CPPBIN)\"" \
-DCXX="\"$(CXX)\"" \
+ -DLD="\"$(LD)\"" \
-DPRELINK="\"$(PRELINK)\""
winegcc$(EXEEXT): winegcc.o utils.o
--- tools/winegcc/winegcc.c
+++ tools/winegcc/winegcc.c
@@ -1034,6 +1034,10 @@ static void build(struct options* opts)
/* run winebuild to generate the .spec.o file */
spec_args = get_winebuild_args( opts );
strarray_add( spec_args, strmake( "--cc-cmd=%s", build_tool_name( opts, "gcc", CC )));
+ strarray_add( spec_args, strmake( "--ld-cmd=%s", build_tool_name( opts, "ld", LD )));
+
+printf("<<<%s>>>\n",strmake( "--ld-cmd=%s", build_tool_name( opts, "ld" , LD )));
+
spec_o_name = get_temp_file(output_name, ".spec.o");
if (opts->force_pointer_size)
strarray_add(spec_args, strmake("-m%u", 8 * opts->force_pointer_size ));

View file

@ -1638,6 +1638,7 @@ lib/wine/fakedlls/wuaueng.dll
lib/wine/fakedlls/wusa.exe
lib/wine/fakedlls/x3daudio1_7.dll
lib/wine/fakedlls/xapofx1_1.dll
lib/wine/fakedlls/xaudio2_7.dll
lib/wine/fakedlls/xcopy.exe
lib/wine/fakedlls/xinput1_1.dll
lib/wine/fakedlls/xinput1_2.dll
@ -2214,6 +2215,7 @@ lib/wine/wuaueng.dll.so
lib/wine/wusa.exe.so
lib/wine/x3daudio1_7.dll.so
lib/wine/xapofx1_1.dll.so
lib/wine/xaudio2_7.dll.so
lib/wine/xcopy.exe.so
lib/wine/xinput1_1.dll.so
lib/wine/xinput1_2.dll.so