Update to 0.7.0.

Submitted by:	AMAKAWA Shuhei <sa264@cam.ac.uk>
This commit is contained in:
Maxim Sobolev 2001-07-04 14:46:46 +00:00
parent 5a848a3f11
commit 767289e322
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44748
7 changed files with 74 additions and 42 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= scigraphica
PORTVERSION= 0.6.3
PORTREVISION= 1
PORTVERSION= 0.7.0
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://scigraphica.sourceforge.net/src/ \

View file

@ -1 +1 @@
MD5 (sg-0.6.3.tar.gz) = 9531827067c8dba39eb453ba2289af54
MD5 (sg-0.7.0.tar.gz) = 6d70ac37d62d4cb0efea9f6ecb8e8c3c

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- configure.orig Sun Mar 11 12:53:57 2001
+++ configure Sun Mar 11 12:55:30 2001
@@ -3708,7 +3708,7 @@
PY_VVERSION=`python -c 'import sys ; print sys.version[0:5]'`
if test -f $PY_PREFIX/include/python$PY_VERSION/Python.h; then
PY_LIBS="python$PY_VERSION"
- PY_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
+ PY_LIB_LOC="-pthread -L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
array_loc=`find $PY_PREFIX/include/python$PY_VERSION/ -name arrayobject.h | sed s/arrayobject\.h//`
echo arrayobject.h location: $array_loc
PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"

View file

@ -1,11 +0,0 @@
--- examples/Makefile.in 2000/08/31 08:26:13 1.1
+++ examples/Makefile.in 2000/08/31 08:26:37
@@ -114,7 +114,7 @@
EXTRA_DIST = $(EXAMPLES)
-Examplesdir = $(datadir)/examples
+Examplesdir = $(datadir)/examples/sg
Examples_DATA = $(EXAMPLES)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- src/Makefile.in 2001/07/04 14:09:22 1.1
+++ src/Makefile.in 2001/07/04 14:10:08
@@ -139,7 +139,7 @@
INCLUDES = -Ipython $(GTK_CFLAGS) $(GTK_EXTRA_CFLAGS) $(XML_CFLAGS) $(PY_CFLAGS) $(BONOBO_CFLAGS) $(OAF_CFLAGS)
-sga_LDADD = -L./python python/libpint.a $(GTK_LIBS) $(GTK_EXTRA_LIBS) $(XML_LIBS) $(BONOBO_LIBS) $(OAF_LIBS) -L$(PY_LIB_LOC)/config -l$(PY_LIBS) $(PY_EXTRA_LIBS) $(UTIL_LIBS) $(READLINE_LIB)
+sga_LDADD = -L./python python/libpint.a $(GTK_LIBS) $(GTK_EXTRA_LIBS) $(XML_LIBS) $(BONOBO_LIBS) $(OAF_LIBS) -L$(PY_LIB_LOC)/config -pthread -l$(PY_LIBS) $(PY_EXTRA_LIBS) $(UTIL_LIBS) $(READLINE_LIB)
LIBS = @LIBS@

View file

@ -0,0 +1,17 @@
$FreeBSD$
--- src/sg_project_menu.c 2001/07/04 14:27:49 1.1
+++ src/sg_project_menu.c 2001/07/04 14:28:27
@@ -554,9 +554,9 @@
}
if ( getenv("SG_ROOT") )
- g_snprintf(path, 250, "%s/share/scigraphica/examples/%s", getenv("SG_ROOT"), (gchar*)data);
+ g_snprintf(path, 250, "%s/share/gnome/scigraphica/examples/%s", getenv("SG_ROOT"), (gchar*)data);
else
- g_snprintf(path, 250, SG_ROOT "/share/scigraphica/examples/%s", (gchar*)data);
+ g_snprintf(path, 250, SG_ROOT "/share/gnome/scigraphica/examples/%s", (gchar*)data);
sg_project_close();
sg_project_new();

View file

@ -1,15 +1,13 @@
bin/sga
share/gnome/apps/Applications/sg.desktop
share/gnome/examples/sg/3d.sg
share/gnome/examples/sg/multicolumn.sg
share/gnome/examples/sg/polar.sg
share/gnome/examples/sg/simpletest.sg
share/gnome/examples/sg/test.dat
share/gnome/examples/sg/ticks.sg
share/gnome/examples/sg/trigonometric.sg
share/gnome/examples/sg/vectors.sg
share/gnome/help/scigraphica/C/FAQ.html
share/gnome/help/scigraphica/C/Introduction.html
share/gnome/help/scigraphica/C/Tutorial.html
share/gnome/help/scigraphica/C/UserGuide.html
share/gnome/help/scigraphica/C/topic.dat
share/gnome/pixmaps/sg/2d_small.xpm
share/gnome/pixmaps/sg/3d_small.xpm
share/gnome/pixmaps/sg/about_small.xpm
share/gnome/pixmaps/sg/add_column.xpm
share/gnome/pixmaps/sg/arrange.xpm
share/gnome/pixmaps/sg/arrow.xpm
@ -20,8 +18,9 @@ share/gnome/pixmaps/sg/arrow_right.xpm
share/gnome/pixmaps/sg/arrow_up.xpm
share/gnome/pixmaps/sg/autoscale.xpm
share/gnome/pixmaps/sg/bold.xpm
share/gnome/pixmaps/sg/book_small.xpm
share/gnome/pixmaps/sg/bullet.xpm
share/gnome/pixmaps/sg/center.xpm
share/gnome/pixmaps/sg/button_ok.xpm
share/gnome/pixmaps/sg/color.xpm
share/gnome/pixmaps/sg/control.xpm
share/gnome/pixmaps/sg/copy.xpm
@ -29,10 +28,12 @@ share/gnome/pixmaps/sg/cut.xpm
share/gnome/pixmaps/sg/dennied.xpm
share/gnome/pixmaps/sg/empty.xpm
share/gnome/pixmaps/sg/error.xpm
share/gnome/pixmaps/sg/exec_small.xpm
share/gnome/pixmaps/sg/exit_small.xpm
share/gnome/pixmaps/sg/eye.xpm
share/gnome/pixmaps/sg/fitpage.xpm
share/gnome/pixmaps/sg/folder.xpm
share/gnome/pixmaps/sg/font.xpm
share/gnome/pixmaps/sg/font_large.xpm
share/gnome/pixmaps/sg/function_small.xpm
share/gnome/pixmaps/sg/g_2dlayer.xpm
share/gnome/pixmaps/sg/g_3dcontour.xpm
@ -60,7 +61,6 @@ share/gnome/pixmaps/sg/g_surface.xpm
share/gnome/pixmaps/sg/g_vectors.xpm
share/gnome/pixmaps/sg/italic.xpm
share/gnome/pixmaps/sg/layer.xpm
share/gnome/pixmaps/sg/left.xpm
share/gnome/pixmaps/sg/logo.xpm
share/gnome/pixmaps/sg/new.xpm
share/gnome/pixmaps/sg/new_2d.xpm
@ -72,26 +72,33 @@ share/gnome/pixmaps/sg/new_plot.xpm
share/gnome/pixmaps/sg/new_polar.xpm
share/gnome/pixmaps/sg/new_polar_small.xpm
share/gnome/pixmaps/sg/new_sheet.xpm
share/gnome/pixmaps/sg/new_small.xpm
share/gnome/pixmaps/sg/open.xpm
share/gnome/pixmaps/sg/open_small.xpm
share/gnome/pixmaps/sg/paint.xpm
share/gnome/pixmaps/sg/paste.xpm
share/gnome/pixmaps/sg/pixmaps.h
share/gnome/pixmaps/sg/plot_icon.xpm
share/gnome/pixmaps/sg/plot_icon2.xpm
share/gnome/pixmaps/sg/plot_small.xpm
share/gnome/pixmaps/sg/point.xpm
share/gnome/pixmaps/sg/pointers.xpm
share/gnome/pixmaps/sg/polar_small.xpm
share/gnome/pixmaps/sg/preferences_small.xpm
share/gnome/pixmaps/sg/print.xpm
share/gnome/pixmaps/sg/python_small.xpm
share/gnome/pixmaps/sg/reload.xpm
share/gnome/pixmaps/sg/reset.xpm
share/gnome/pixmaps/sg/right.xpm
share/gnome/pixmaps/sg/rotate_x.xpm
share/gnome/pixmaps/sg/rotate_y.xpm
share/gnome/pixmaps/sg/rotate_z.xpm
share/gnome/pixmaps/sg/save.xpm
share/gnome/pixmaps/sg/save_as.xpm
share/gnome/pixmaps/sg/save_as_small.xpm
share/gnome/pixmaps/sg/save_small.xpm
share/gnome/pixmaps/sg/sg.xpm
share/gnome/pixmaps/sg/sg_icon.xpm
share/gnome/pixmaps/sg/sg_small.xpm
share/gnome/pixmaps/sg/sheet_icon.xpm
share/gnome/pixmaps/sg/sheet_icon2.xpm
share/gnome/pixmaps/sg/sheet_small.xpm
@ -116,6 +123,26 @@ share/gnome/pixmaps/sg/warning.xpm
share/gnome/pixmaps/sg/zoom.xpm
share/gnome/pixmaps/sg/zoom_minus.xpm
share/gnome/pixmaps/sg/zoom_plus.xpm
share/gnome/pixmaps/sg/zoomin.xpm
share/gnome/pixmaps/sg/zoomout.xpm
share/gnome/scigraphica/examples/3d.sg
share/gnome/scigraphica/examples/image.sg
share/gnome/scigraphica/examples/multicolumn.sg
share/gnome/scigraphica/examples/polar.sg
share/gnome/scigraphica/examples/py_example1.py
share/gnome/scigraphica/examples/py_example2.py
share/gnome/scigraphica/examples/simpletest.sg
share/gnome/scigraphica/examples/test.dat
share/gnome/scigraphica/examples/ticks.sg
share/gnome/scigraphica/examples/trigonometric.sg
share/gnome/scigraphica/examples/vectors.sg
@dirrm share/gnome/scigraphica/examples
@dirrm share/gnome/scigraphica
@dirrm share/gnome/pixmaps/sg
@dirrm share/gnome/examples/sg
@dirrm share/gnome/examples
@dirrm share/gnome/help/scigraphica/C
@dirrm share/gnome/help/scigraphica
@cwd %%LOCALBASE%%
lib/%%PYTHON_VERSION%%/site-packages/gtkLeastSquares.py
@unexec /bin/rm -f %D/lib/%%PYTHON_VERSION%%/site-packages/gtkLeastSquares.pyc
lib/%%PYTHON_VERSION%%/site-packages/pysga.py
@unexec /bin/rm -f %D/lib/%%PYTHON_VERSION%%/site-packages/pysga.pyc