misc/py-pytorch: update 2.1.2 → 2.2.0
This commit is contained in:
parent
b0f5256f17
commit
76a4e01da2
3 changed files with 8 additions and 17 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= pytorch
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.1.2
|
||||
DISTVERSION= 2.2.0
|
||||
CATEGORIES= misc # machine-learning
|
||||
MASTER_SITES= https://github.com/pytorch/pytorch/releases/download/v${DISTVERSION}/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1703589606
|
||||
SHA256 (pytorch/pytorch-v2.1.2.tar.gz) = 85effbcce037bffa290aea775c9a4bad5f769cb229583450c40055501ee1acd7
|
||||
SIZE (pytorch/pytorch-v2.1.2.tar.gz) = 282894457
|
||||
TIMESTAMP = 1707801358
|
||||
SHA256 (pytorch/pytorch-v2.2.0.tar.gz) = e12d18c3dbb12d7ae2f61f5ab9a21023e3dd179d67ed87279ef96600b9ac08c5
|
||||
SIZE (pytorch/pytorch-v2.2.0.tar.gz) = 287632855
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2023-12-15 02:03:27 UTC
|
||||
--- CMakeLists.txt.orig 2024-01-31 00:58:01 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -139,7 +139,7 @@ set(CPU_INTEL OFF)
|
||||
@@ -145,7 +145,7 @@ set(CPU_INTEL OFF)
|
||||
set(CPU_AARCH64 OFF)
|
||||
set(CPU_INTEL OFF)
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
set(CPU_INTEL ON)
|
||||
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^(aarch64|arm64)")
|
||||
set(CPU_AARCH64 ON)
|
||||
@@ -164,7 +164,7 @@ option(BUILD_DOCS "Build Caffe2 documentation" OFF)
|
||||
@@ -170,7 +170,7 @@ option(BUILD_DOCS "Build Caffe2 documentation" OFF)
|
||||
option(ATEN_NO_TEST "Do not build ATen test binaries" OFF)
|
||||
option(BUILD_BINARY "Build C++ binaries" OFF)
|
||||
option(BUILD_DOCS "Build Caffe2 documentation" OFF)
|
||||
|
@ -27,7 +27,7 @@
|
|||
option(USE_LMDB "Use LMDB" OFF)
|
||||
option(USE_MAGMA "Use MAGMA" ON)
|
||||
option(USE_METAL "Use Metal for Caffe2 iOS build" ON)
|
||||
@@ -408,15 +408,15 @@ option(USE_SYSTEM_CPUINFO "Use system-provided cpuinfo
|
||||
@@ -405,15 +405,15 @@ option(USE_SYSTEM_CPUINFO "Use system-provided cpuinfo
|
||||
# USE_SYSTEM_LIBS being "OFF".
|
||||
option(USE_SYSTEM_LIBS "Use all available system-provided libraries." OFF)
|
||||
option(USE_SYSTEM_CPUINFO "Use system-provided cpuinfo." OFF)
|
||||
|
@ -46,12 +46,3 @@
|
|||
option(USE_SYSTEM_XNNPACK "Use system-provided xnnpack." OFF)
|
||||
option(USE_SYSTEM_ZSTD "Use system-provided zstd." OFF)
|
||||
option(USE_GOLD_LINKER "Use ld.gold to link" OFF)
|
||||
@@ -918,7 +918,7 @@ if(NOT MSVC)
|
||||
append_cxx_flag_if_supported("-fno-math-errno" CMAKE_CXX_FLAGS)
|
||||
append_cxx_flag_if_supported("-fno-trapping-math" CMAKE_CXX_FLAGS)
|
||||
append_cxx_flag_if_supported("-Werror=format" CMAKE_CXX_FLAGS)
|
||||
- append_cxx_flag_if_supported("-Werror=cast-function-type" CMAKE_CXX_FLAGS)
|
||||
+ #append_cxx_flag_if_supported("-Werror=cast-function-type" CMAKE_CXX_FLAGS) # workaround for https://github.com/pytorch/pytorch/issues/116416
|
||||
else()
|
||||
# skip unwanted includes from windows.h
|
||||
add_compile_definitions(WIN32_LEAN_AND_MEAN)
|
||||
|
|
Loading…
Reference in a new issue