- Update to 0.7.1
- Add NO_ARCH - Support options helper - Switch to do-test PR: 205118 Submitted by: maintainer Approved by: mat (mentor) Differential Revision: D4573
This commit is contained in:
parent
f653e9548c
commit
76dfc438d7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=403787
3 changed files with 11 additions and 24 deletions
|
@ -2,7 +2,7 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= logan
|
PORTNAME= logan
|
||||||
PORTVERSION= 0.5.10
|
PORTVERSION= 0.7.1
|
||||||
CATEGORIES= devel python
|
CATEGORIES= devel python
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
|
||||||
|
@ -14,23 +14,26 @@ LICENSE= APACHE20
|
||||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>0:${PORTSDIR}/www/py-django
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>0:${PORTSDIR}/www/py-django
|
||||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>0:${PORTSDIR}/www/py-django \
|
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>0:${PORTSDIR}/www/py-django \
|
||||||
${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
|
${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
|
||||||
${PYTHON_PKGNAMEPREFIX}nose>=1.1.2:${PORTSDIR}/devel/py-nose \
|
${PYTHON_PKGNAMEPREFIX}nose>=1.1.2:${PORTSDIR}/devel/py-nose
|
||||||
${PYTHON_PKGNAMEPREFIX}unittest2:${PORTSDIR}/devel/py-unittest2
|
|
||||||
|
|
||||||
USES= python
|
USES= python
|
||||||
USE_PYTHON= distutils autoplist
|
USE_PYTHON= distutils autoplist
|
||||||
PORTDOCS= README.rst
|
NO_ARCH= yes
|
||||||
|
|
||||||
|
OPTIONS_DEFINE= DOCS
|
||||||
|
|
||||||
|
PORTDOCS= README.rst
|
||||||
DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
|
DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
|
||||||
|
|
||||||
USE_GITHUB= yes
|
USE_GITHUB= yes
|
||||||
GH_ACCOUNT= dcramer
|
GH_ACCOUNT= dcramer
|
||||||
|
GH_TAGNAME= 82a0ca7
|
||||||
|
|
||||||
post-install:
|
post-install-DOCS-on:
|
||||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||||
${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}/README.rst
|
${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}/README.rst
|
||||||
|
|
||||||
check test: build
|
do-test:
|
||||||
cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
|
cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (dcramer-logan-0.5.10_GH0.tar.gz) = 0e85dddfb68fd14aaa245b2ceac09b73c90eb4abeed4ad873911937a522dfc6e
|
SHA256 (dcramer-logan-0.7.1-82a0ca7_GH0.tar.gz) = f54c8111dcb142778259c4f329f0879367bc83bea9e330544c9850fe73f98ec8
|
||||||
SIZE (dcramer-logan-0.5.10_GH0.tar.gz) = 10258
|
SIZE (dcramer-logan-0.7.1-82a0ca7_GH0.tar.gz) = 10436
|
||||||
|
|
|
@ -1,16 +0,0 @@
|
||||||
--- ./setup.py.orig 2014-03-17 18:14:19.000000000 +0200
|
|
||||||
+++ ./setup.py 2014-03-17 18:14:54.000000000 +0200
|
|
||||||
@@ -23,13 +23,6 @@
|
|
||||||
long_description=__doc__,
|
|
||||||
zip_safe=False,
|
|
||||||
install_requires=[],
|
|
||||||
- tests_require=[
|
|
||||||
- 'django>=1',
|
|
||||||
- 'mock>=0.8.0',
|
|
||||||
- 'nose>=1.1.2',
|
|
||||||
- 'unittest2',
|
|
||||||
- ],
|
|
||||||
- test_suite='unittest2.collector',
|
|
||||||
license='Apache License 2.0',
|
|
||||||
include_package_data=True,
|
|
||||||
classifiers=[
|
|
Loading…
Reference in a new issue