- Update to 2.1.3
- Change master sites to RUBYFORGE - Take maintainership - Remove DEPRECATED, EXPIRATION_DATE - Add license (LGPL21) - Add dependencies for devel/sdl_sge, japanese/libskk and devel/sdlskk - Change CONFIGURE_ARGS - Change DOCS, EXAMPLES and add DOCS, EXAMPLES Options - Support STAGEDIR - Remove obsolete REINPLACE - Strip library - Fix the usage of 'ruby' to get rid of the implicit lang/ruby dependency - Add patch, fix build on FreeBSD - Change pkg-descr - Add WWW
This commit is contained in:
parent
b9649039e8
commit
772ab90f62
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=343629
6 changed files with 94 additions and 1 deletions
1
MOVED
1
MOVED
|
@ -5128,7 +5128,6 @@ japanese/gorua||2013-10-21|Has expired: Does not work with Ruby 1.9
|
|||
x11-toolkits/ruby-gtk||2013-10-21|Has expired: Does not work with Ruby 1.9
|
||||
astro/boinc-setiathome-enhanced|astro/boinc-setiathome-v7|2013-10-21|Removed: Project is switching, use astro/boinc-setiathome-v7 instead; broken on 10.0
|
||||
multimedia/ffmpeg-devel|multimedia/ffmpeg|2013-10-21|Use multimedia/ffmpeg instead
|
||||
devel/ruby-sdl||2013-10-22|Has expired: Does not work with Ruby 1.9
|
||||
games/magicmaze||2013-10-22|Has expired: Does not work with Ruby 1.9
|
||||
lang/ruby18|lang/ruby19|2013-10-22|Has expired: Please use lang/ruby19
|
||||
www/rubygem-mongrel_cluster||2013-10-22|Has expired: Does not work with Ruby 1.9
|
||||
|
|
|
@ -4076,6 +4076,7 @@
|
|||
SUBDIR += ruby-rbprof
|
||||
SUBDIR += ruby-robjectteam
|
||||
SUBDIR += ruby-rreadline
|
||||
SUBDIR += ruby-sdl
|
||||
SUBDIR += ruby-setup.rb
|
||||
SUBDIR += ruby-statgrab
|
||||
SUBDIR += ruby-subversion
|
||||
|
|
75
devel/ruby-sdl/Makefile
Normal file
75
devel/ruby-sdl/Makefile
Normal file
|
@ -0,0 +1,75 @@
|
|||
# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= sdl
|
||||
PORTVERSION= 2.1.3
|
||||
CATEGORIES= devel graphics audio ruby
|
||||
MASTER_SITES= RUBYFORGE/ruby${PORTNAME}/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
DISTNAME= ruby${PORTNAME}-${PORTVERSION}
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= nemysis@FreeBSD.org
|
||||
COMMENT= Ruby extension library to use SDL library
|
||||
|
||||
LICENSE= LGPL21
|
||||
|
||||
LIB_DEPENDS= libSGE.so:${PORTSDIR}/devel/sdl_sge \
|
||||
libskk.so:${PORTSDIR}/japanese/libskk \
|
||||
libSDLSKK.so.2.0:${PORTSDIR}/devel/sdlskk
|
||||
|
||||
RUBY_OPENGL_PORTDIR= ${PORTSDIR}/graphics/ruby-opengl
|
||||
RUBY_OPENGL_WRKSRC_CMD= cd ${RUBY_OPENGL_PORTDIR}; ${MAKE} -V WRKSRC
|
||||
|
||||
USE_SDL= mixer image ttf sdl
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_EXTCONF= yes
|
||||
|
||||
CONFIGURE_ARGS= --with-sdl-config="sdl-config" \
|
||||
--enable-opengl --linkoglmodule \
|
||||
--with-x11-dir="${LOCALBASE}" \
|
||||
--disable-pthreads
|
||||
INSTALL_TARGET= site-install
|
||||
|
||||
PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/sdl_ext.so \
|
||||
%%RUBY_SITELIBDIR%%/rubysdl_aliases.rb \
|
||||
%%RUBY_SITELIBDIR%%/rubysdl_compatible_ver1.rb \
|
||||
%%RUBY_SITELIBDIR%%/sdl.rb \
|
||||
%%RUBY_SITELIBDIR%%/sdl1_compatible.rb
|
||||
|
||||
PORTDOCS= *
|
||||
PORTEXAMPLES= *
|
||||
|
||||
DOCSDIR= ${RUBY_MODDOCDIR}
|
||||
EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
|
||||
|
||||
DOCSRCDIR1= ${WRKSRC}
|
||||
DOC_FILES_WRKSRC_JA= NEWS.ja README.ja
|
||||
DOC_FILES_WRKSRC_EN= NEWS.en README.en
|
||||
|
||||
DOCSRCDIRJA= ${WRKSRC}/doc
|
||||
DOCSDIRJA= ${RUBY_MODDOCDIR}/doc
|
||||
DOC_FILESJA= *.rsd *.rb
|
||||
|
||||
DOCSRCDIREN= ${WRKSRC}/doc-en
|
||||
DOCSDIREN= ${RUBY_MODDOCDIR}/doc-en
|
||||
DOC_FILESEN= *.rsd
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ruby/site_ruby/1.9/*/sdl_ext.so
|
||||
@${REINPLACE_CMD} -e 's|ruby|${LOCALBASE}/bin/ruby|g' ${WRKSRC}/doc/rsd.rb
|
||||
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/ja
|
||||
${INSTALL_DATA} ${DOC_FILES_WRKSRC_JA:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}/ja/
|
||||
${INSTALL_DATA} ${DOC_FILES_WRKSRC_EN:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/doc/ja
|
||||
${INSTALL_DATA} ${DOC_FILESJA:S|^|${DOCSRCDIRJA}/|} ${STAGEDIR}${DOCSDIR}/doc/ja/
|
||||
${INSTALL_DATA} ${DOC_FILESEN:S|^|${DOCSRCDIREN}/|} ${STAGEDIR}${DOCSDIR}/doc/
|
||||
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/* ${STAGEDIR}${EXAMPLESDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/ruby-sdl/distinfo
Normal file
2
devel/ruby-sdl/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (ruby/rubysdl-2.1.3.tar.gz) = 77390eac2e7c99208622ab48377a6caaddb1f5f5efdc4bd96d05efacecd94bcd
|
||||
SIZE (ruby/rubysdl-2.1.3.tar.gz) = 795424
|
12
devel/ruby-sdl/files/patch-rubysdl_rwops.c
Normal file
12
devel/ruby-sdl/files/patch-rubysdl_rwops.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- ./rubysdl_rwops.c.orig 2012-04-07 17:50:01.000000000 +0200
|
||||
+++ ./rubysdl_rwops.c 2013-10-16 09:54:34.000000000 +0200
|
||||
@@ -70,6 +70,9 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
+#ifdef close
|
||||
+#undef close
|
||||
+#endif
|
||||
/* WARNING: +obj+ is not marked when GC starts,
|
||||
so you should use `volatile' when this function is used
|
||||
and you should not take out this RWops pointer to ruby's world.
|
4
devel/ruby-sdl/pkg-descr
Normal file
4
devel/ruby-sdl/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
Ruby/SDL is a Ruby extension library to use SDL library.
|
||||
Currently 3D features are unsupported.
|
||||
|
||||
WWW: http://www.kmc.gr.jp/~ohai/rubysdl.en.html
|
Loading…
Reference in a new issue