Update to 0.8.1
This commit is contained in:
parent
63eb78ed72
commit
776de95975
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=423433
4 changed files with 23 additions and 6 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ristretto
|
||||
PORTVERSION= 0.8.0
|
||||
PORTVERSION= 0.8.1
|
||||
CATEGORIES= graphics xfce
|
||||
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}
|
||||
DIST_SUBDIR= xfce4
|
||||
|
@ -15,12 +15,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
|||
|
||||
LIB_DEPENDS= libexif.so:graphics/libexif \
|
||||
libdbus-glib-1.so:devel/dbus-glib \
|
||||
libdbus-1.so:devel/dbus \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libfontconfig.so:x11-fonts/fontconfig
|
||||
|
||||
USES= pkgconfig gettext desktop-file-utils gmake xfce tar:bzip2
|
||||
USES= desktop-file-utils gettext gmake pkgconfig tar:bzip2 xfce
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gtk20 glib20 intltool intlhack
|
||||
USE_GNOME= gtk20 glib20 intltool intlhack cairo
|
||||
INSTALLS_ICONS= yes
|
||||
USE_XFCE= libmenu
|
||||
USE_XORG= x11
|
||||
USE_XORG= ice sm x11
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (xfce4/ristretto-0.8.0.tar.bz2) = 71625324cecda7199acbc95a3ea5132d0dcbf808771e7a209ea2b9503ae4f328
|
||||
SIZE (xfce4/ristretto-0.8.0.tar.bz2) = 541473
|
||||
TIMESTAMP = 1475773758
|
||||
SHA256 (xfce4/ristretto-0.8.1.tar.bz2) = 0b4c90c585166c958d479075b98da6e28ca500bda6f4d3443f20e0a2172030ee
|
||||
SIZE (xfce4/ristretto-0.8.1.tar.bz2) = 538787
|
||||
|
|
11
graphics/ristretto/files/patch-src_main.c
Normal file
11
graphics/ristretto/files/patch-src_main.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/main.c.orig 2016-09-08 07:14:04 UTC
|
||||
+++ src/main.c
|
||||
@@ -256,7 +256,7 @@ cb_rstto_open_files (RsttoOpenFiles *rof
|
||||
*/
|
||||
iter = rstto_main_window_get_iter (RSTTO_MAIN_WINDOW (rof->window));
|
||||
|
||||
- if (file_type != G_FILE_TYPE_DIRECTORY && r_file != NULL)
|
||||
+ if (r_file != NULL && file_type != G_FILE_TYPE_DIRECTORY)
|
||||
{
|
||||
/* Get the file's parent directory */
|
||||
p_file = g_file_get_parent (file);
|
|
@ -1,6 +1,7 @@
|
|||
bin/ristretto
|
||||
share/appdata/ristretto.appdata.xml
|
||||
share/applications/ristretto.desktop
|
||||
share/icons/hicolor/128x128/apps/ristretto.png
|
||||
share/icons/hicolor/16x16/apps/ristretto.png
|
||||
share/icons/hicolor/48x48/apps/ristretto.png
|
||||
share/icons/hicolor/scalable/apps/ristretto.svg
|
||||
|
@ -19,6 +20,7 @@ share/locale/eu/LC_MESSAGES/ristretto.mo
|
|||
share/locale/fi/LC_MESSAGES/ristretto.mo
|
||||
share/locale/fr/LC_MESSAGES/ristretto.mo
|
||||
share/locale/gl/LC_MESSAGES/ristretto.mo
|
||||
share/locale/he/LC_MESSAGES/ristretto.mo
|
||||
share/locale/hr/LC_MESSAGES/ristretto.mo
|
||||
share/locale/hu/LC_MESSAGES/ristretto.mo
|
||||
share/locale/id/LC_MESSAGES/ristretto.mo
|
||||
|
|
Loading…
Reference in a new issue