SDCV(StarDict under Console Version) is simple, cross-platform text-based
utility for work with dictionaries in StarDict's format. The word from "list of words" may be string with leading '/' for using Fuzzy search algorithm, string may contain '?' and '*' for using regexp search. It work in interactive and not interactive mode. WWW: http://sdcv.sourceforge.net/ PR: ports/96836 Submitted by: chinsan <chinsan.tw at gmail.com>
This commit is contained in:
parent
3cb09cc3c1
commit
77887bedcc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=166999
6 changed files with 94 additions and 0 deletions
|
@ -765,6 +765,7 @@
|
|||
SUBDIR += scim-table-imengine
|
||||
SUBDIR += scr2txt
|
||||
SUBDIR += scrollkeeper
|
||||
SUBDIR += sdcv
|
||||
SUBDIR += sdf
|
||||
SUBDIR += sdocbook-xml
|
||||
SUBDIR += senna
|
||||
|
|
65
textproc/sdcv/Makefile
Normal file
65
textproc/sdcv/Makefile
Normal file
|
@ -0,0 +1,65 @@
|
|||
# Ports collection makefile for: sdcv
|
||||
# Date created: 2005/07/07
|
||||
# Whom: chinsan <chinsan.tw@gmail.com>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sdcv
|
||||
PORTVERSION= 0.4.2
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= chinsan.tw@gmail.com
|
||||
COMMENT= A text-based utility for work with dictionaries in StarDict's format
|
||||
|
||||
USE_BZIP2= yes
|
||||
#USE_GCC= 3.3+
|
||||
USE_ICONV= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= glib20
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
.if !defined(WITHOUT_NLS)
|
||||
USE_GETTEXT= yes
|
||||
PLIST_SUB+= NLS=""
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-nls
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
.endif
|
||||
|
||||
MAN1= sdcv.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= Doesn't build on FreeBSD 4.x
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
|
||||
BROKEN= Doesn't build on 64-bit platforms
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
|
||||
${WRKSRC}/doc/sdcv.1
|
||||
@${REINPLACE_CMD} -e '1425 s, install-data,,' \
|
||||
${WRKSRC}/po/Makefile.in.in
|
||||
@${REINPLACE_CMD} -e 's, getopt.h,,g' ${WRKSRC}/src/Makefile.in
|
||||
@${REINPLACE_CMD} -e '146 s|()|(int, char * const [], const char *)|g' \
|
||||
${WRKSRC}/src/getopt.h
|
||||
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
|
||||
${WRKSRC}/src/sdcv.cpp
|
||||
@${REINPLACE_CMD} -e 's,@mandir@/uk,@mandir@,' \
|
||||
${WRKSRC}/doc/uk/Makefile.in
|
||||
.if !defined(WITHOUT_NLS)
|
||||
@${REINPLACE_CMD} -e 's,@USE_NLS@,yes,g' ${WRKSRC}/po/Makefile.in.in
|
||||
@${REINPLACE_CMD} -e 's, getopt.h,,g; s,@USE_NLS@,yes,g' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
textproc/sdcv/distinfo
Normal file
3
textproc/sdcv/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (sdcv-0.4.2.tar.bz2) = f624662b333daa5da2d3e99cef519f17
|
||||
SHA256 (sdcv-0.4.2.tar.bz2) = a164f079e93986814ea2d39f3a49cf9d1b71b01aad908254457fe3d0ded9deb2
|
||||
SIZE (sdcv-0.4.2.tar.bz2) = 181384
|
11
textproc/sdcv/files/patch-configure
Normal file
11
textproc/sdcv/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Mon Apr 24 18:57:24 2006
|
||||
+++ configure Fri May 5 17:24:17 2006
|
||||
@@ -5745,6 +5745,8 @@
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define HAVE_GETTEXT 1
|
||||
+USE_NLS=yes
|
||||
+#define ENABLE_NLS 1
|
||||
_ACEOF
|
||||
|
||||
|
8
textproc/sdcv/pkg-descr
Normal file
8
textproc/sdcv/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
SDCV(StarDict under Console Version) is simple, cross-platform text-based
|
||||
utility for work with dictionaries in StarDict's format.
|
||||
|
||||
The word from "list of words" may be string with leading '/' for using Fuzzy
|
||||
search algorithm, string may contain '?' and '*' for using regexp search.
|
||||
It work in interactive and not interactive mode.
|
||||
|
||||
WWW: http://sdcv.sourceforge.net/
|
6
textproc/sdcv/pkg-plist
Normal file
6
textproc/sdcv/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
bin/sdcv
|
||||
%%NLS%%share/locale/ru/LC_MESSAGES/sdcv.mo
|
||||
%%NLS%%share/locale/sk/LC_MESSAGES/sdcv.mo
|
||||
%%NLS%%share/locale/uk/LC_MESSAGES/sdcv.mo
|
||||
%%NLS%%share/locale/zh_CN/LC_MESSAGES/sdcv.mo
|
||||
%%NLS%%share/locale/zh_TW/LC_MESSAGES/sdcv.mo
|
Loading…
Reference in a new issue