- Fix includedir [1]

- Remove unused patches

PR:		192665 [1]
Submitted by:	johan@stromnet.se [1]
This commit is contained in:
Tijl Coosemans 2014-08-15 07:53:55 +00:00
parent b7857287b0
commit 7790bf20a1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=364947
7 changed files with 2 additions and 61 deletions

View file

@ -2,7 +2,7 @@
PORTNAME= libftdi
PORTVERSION= 0.20
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= http://www.intra2net.com/en/developer/libftdi/download/
@ -38,6 +38,7 @@ PYTHON_USES= python
post-patch:
@${REINPLACE_CMD} \
-e '/includedir/s|/$${PROJECT_NAME}||' \
-e '/SET.*LIB_SUFFIX/s/64/""/' \
-e 's|lib$${LIB_SUFFIX}/pkgconfig|libdata/pkgconfig|' \
${WRKSRC}/CMakeLists.txt

View file

@ -1,10 +0,0 @@
--- examples/baud_test.c.orig 2010-02-03 14:19:36.000000000 +0200
+++ examples/baud_test.c 2010-02-03 14:19:43.000000000 +0200
@@ -31,6 +31,7 @@
#include <sys/time.h>
#include <stdio.h>
+#include <stdlib.h>
#include <unistd.h>
#include <ftdi.h>

View file

@ -1,10 +0,0 @@
--- examples/bitbang.c.orig 2010-02-03 14:25:06.000000000 +0200
+++ examples/bitbang.c 2010-02-03 14:25:13.000000000 +0200
@@ -1,6 +1,7 @@
/* This program is distributed under the GPL, version 2 */
#include <stdio.h>
+#include <stdlib.h>
#include <unistd.h>
#ifdef __WIN32__
#define sleep(x) Sleep(x)

View file

@ -1,10 +0,0 @@
--- examples/bitbang2.c.orig 2010-02-03 14:18:25.000000000 +0200
+++ examples/bitbang2.c 2010-02-03 14:18:34.000000000 +0200
@@ -30,6 +30,7 @@
#include <stdio.h>
+#include <stdlib.h>
#include <unistd.h>
#ifdef __WIN32__
#define usleep(x) Sleep((x+999)/1000)

View file

@ -1,10 +0,0 @@
--- examples/bitbang_ft2232.c.orig 2010-02-03 14:18:48.000000000 +0200
+++ examples/bitbang_ft2232.c 2010-02-03 14:18:57.000000000 +0200
@@ -9,6 +9,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <unistd.h>
#ifdef __WIN32__
#define sleep(x) _sleep(x)

View file

@ -1,10 +0,0 @@
--- examples/find_all.c.orig 2009-03-17 23:06:40.000000000 +0200
+++ examples/find_all.c 2010-02-03 14:17:13.000000000 +0200
@@ -6,6 +6,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <ftdi.h>
int main(void)

View file

@ -1,10 +0,0 @@
--- examples/simple.c.orig 2009-03-17 23:05:53.000000000 +0200
+++ examples/simple.c 2010-02-03 14:17:13.000000000 +0200
@@ -6,6 +6,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <ftdi.h>
int main(void)