graphics/opensubdiv: pet OpenMP handling (+)
Make OpenMP suppport OPTIONal Add patches to pass OpenMP flags to consumers if enabled [1] Mark OPENCL option as prevented to build examples Bump PORTREVISION to force rebuild consumers with new flags Submitted by: Tatsuki Makino via ports ml Approved by: maintainer (implicit)
This commit is contained in:
parent
efcfea1a94
commit
77a55dca0e
4 changed files with 44 additions and 5 deletions
|
@ -1,6 +1,7 @@
|
|||
PORTNAME= opensubdiv
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 3_5_0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES?= graphics
|
||||
|
||||
MAINTAINER= FreeBSD@Shaneware.biz
|
||||
|
@ -22,8 +23,9 @@ USE_GL= egl gl glu glew
|
|||
USE_LDCONFIG= yes
|
||||
CMAKE_ON= NO_CLEW NO_CUDA NO_DX
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES OPENCL PTEX TBB TEST TUTORIALS
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES OPENCL OPENMP PTEX TBB TEST TUTORIALS
|
||||
OPTIONS_DEFAULT= TBB
|
||||
#OPTIONS_EXCLUDE= EXAMPLES
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
DOCS_CMAKE_BOOL_OFF= NO_DOC
|
||||
|
@ -32,7 +34,8 @@ DOCS_BUILD_DEPENDS= rst2html.py:textproc/py-docutils \
|
|||
DOCS_USES= python:build
|
||||
DOCS_PORTDOCS= *
|
||||
|
||||
EXAMPLES_BROKEN= ld: error: undefined symbol: glXGetCurrentContext
|
||||
#EXAMPLES_BROKEN= ld: error: undefined symbol: glXGetCurrentContext
|
||||
#Examples cannot utilize the latest opencl headers
|
||||
EXAMPLES_CMAKE_BOOL_OFF= NO_EXAMPLES
|
||||
EXAMPLES_USES= xorg
|
||||
EXAMPLES_USE= xorg=ice,sm,x11,xcursor,xext,xi,xinerama,xrandr,xxf86vm
|
||||
|
@ -42,6 +45,9 @@ OPENCL_CMAKE_BOOL_OFF= NO_OPENCL
|
|||
OPENCL_CFLAGS= -pthread
|
||||
OPENCL_BUILD_DEPENDS= ${LOCALBASE}/include/CL/cl.h:devel/opencl
|
||||
OPENCL_LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
|
||||
OPENCL_PREVENTS= EXAMPLES
|
||||
|
||||
OPENMP_CMAKE_BOOL_OFF= NO_OMP
|
||||
|
||||
PTEX_DESC= ptex support
|
||||
PTEX_CMAKE_BOOL_OFF= NO_PTEX
|
||||
|
|
11
graphics/opensubdiv/files/patch-opensubdiv_CMakeLists.txt
Normal file
11
graphics/opensubdiv/files/patch-opensubdiv_CMakeLists.txt
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- opensubdiv/CMakeLists.txt.orig 2022-09-26 18:17:44 UTC
|
||||
+++ opensubdiv/CMakeLists.txt
|
||||
@@ -45,6 +45,8 @@ if (NOT NO_LIB)
|
||||
if( OPENMP_FOUND )
|
||||
if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
list(APPEND PLATFORM_CPU_LIBRARIES gomp)
|
||||
+ else()
|
||||
+ list(APPEND PLATFORM_CPU_LIBRARIES OpenMP::OpenMP_CXX)
|
||||
endif()
|
||||
endif()
|
||||
|
|
@ -0,0 +1,22 @@
|
|||
--- opensubdiv/osd/CMakeLists.txt.orig 2022-09-26 18:17:44 UTC
|
||||
+++ opensubdiv/osd/CMakeLists.txt
|
||||
@@ -76,6 +76,8 @@ if(OPENMP_FOUND )
|
||||
|
||||
if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
list(APPEND PLATFORM_CPU_LIBRARIES gomp)
|
||||
+ else()
|
||||
+ list(APPEND PLATFORM_CPU_LIBRARIES OpenMP::OpenMP_CXX)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
@@ -96,10 +98,6 @@ if( TBB_FOUND )
|
||||
)
|
||||
|
||||
list(APPEND PUBLIC_HEADER_FILES ${TBB_PUBLIC_HEADERS})
|
||||
-
|
||||
- if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
- list(APPEND PLATFORM_CPU_LIBRARIES gomp)
|
||||
- endif()
|
||||
|
||||
list(APPEND PLATFORM_CPU_LIBRARIES
|
||||
${TBB_LIBRARIES}
|
|
@ -1,8 +1,8 @@
|
|||
--- regression/CMakeLists.txt.orig 2020-06-30 16:02:18 UTC
|
||||
--- regression/CMakeLists.txt.orig 2022-09-26 18:17:44 UTC
|
||||
+++ regression/CMakeLists.txt
|
||||
@@ -26,14 +26,16 @@ add_subdirectory(common)
|
||||
@@ -28,14 +28,16 @@ if (NOT NO_REGRESSION)
|
||||
|
||||
if (NOT NO_REGRESSION)
|
||||
add_subdirectory(bfr_evaluate)
|
||||
|
||||
- add_subdirectory(hbr_regression)
|
||||
+# uses deprecated api
|
||||
|
|
Loading…
Reference in a new issue