- Update to 0.6

- Take maintainership

PR:		ports/95793
Submitted by:	Rainer Alves <rainer.alves@gmail.com>
This commit is contained in:
Pav Lucistnik 2006-04-15 15:43:17 +00:00
parent 0eda687072
commit 77c0fcc55f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159597
8 changed files with 87 additions and 55 deletions

View file

@ -6,14 +6,13 @@
#
PORTNAME= stegdetect
PORTVERSION= 0.5
PORTREVISION= 3
PORTVERSION= 0.6
CATEGORIES= security
MASTER_SITES= http://www.mirrors.wiretapped.net/security/steganography/stegdetect/ \
http://www.outguess.org/
MASTER_SITES= http://www.outguess.org/ \
http://distfiles.master.finkmirrors.net/
MAINTAINER= ports@FreeBSD.org
COMMENT= An automated tool for detecting steganographic content in jpegs
MAINTAINER= rainer.alves@gmail.com
COMMENT= Automated tool for detecting steganographic content in JPEGs
.if !defined(WITHOUT_X11)
BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
@ -21,21 +20,21 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
# Note: stegdetect includes a modified version of jpeg-6b linked statically
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_REINPLACE= yes
USE_GMAKE= yes
CONFIGURE_ARGS+=--program-prefix=''
MAN1= stegdetect.1 stegbreak.1
.if defined(WITHOUT_X11)
PLIST_SUB+= X11="@comment "
.else
USE_GNOME= gtk12
CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}"
CONFIGURE_ENV+= PATH_GTKCONFIG="${GTK_CONFIG}"
PLIST_SUB+= X11=""
.endif
post-patch:
${REINPLACE_CMD} 's/$$(JPEGLIB)/$$(JPEGLIB) -lcrypto/' \
${WRKSRC}/Makefile.in
${REINPLACE_CMD} 's;/usr/include/event;${LOCALBASE}/include;g' \
${WRKSRC}/configure
.if defined(WITHOUT_X11)
${REINPLACE_CMD} 's/gtk-config//g' ${WRKSRC}/configure
.endif

View file

@ -1,3 +1,3 @@
MD5 (stegdetect-0.5.tar.gz) = 6f3708bb15fd629ced835d12f561e82b
SHA256 (stegdetect-0.5.tar.gz) = 16b19374af45a64fec309b6c6f435bcdb08e4f881d1900a71ba8f8785cd39cc1
SIZE (stegdetect-0.5.tar.gz) = 1278105
MD5 (stegdetect-0.6.tar.gz) = 850a3551b5c450b9f450a919ad021767
SHA256 (stegdetect-0.6.tar.gz) = 71149fc9fc58c44a49a38c7013d22d8a861e45acb1074b6c3004b314c8e81a8d
SIZE (stegdetect-0.6.tar.gz) = 1269001

View file

@ -0,0 +1,47 @@
--- Makefile.in.orig Tue Aug 31 11:59:42 2004
+++ Makefile.in Sat Apr 15 03:04:17 2006
@@ -70,7 +70,7 @@
JPEGDIR = ./jpeg-6b
JPEGINC = -I$(JPEGDIR)
-JPEGLIB = -L$(JPEGDIR) -ljpeg
+JPEGLIB = -L$(JPEGDIR) -ljpeg -lcrypto
JPEGDEP = $(JPEGDIR)/libjpeg.a
FILEDIR = ./file
@@ -330,19 +330,23 @@
@set fnord $(MAKEFLAGS); amf=$$2; \
dot_seen=no; \
target=`echo $@ | sed s/-recursive//`; \
- list='$(SUBDIRS)'; for subdir in $$list; do \
- echo "Making $$target in $$subdir"; \
- if test "$$subdir" = "."; then \
- dot_seen=yes; \
- local_target="$$target-am"; \
- else \
- local_target="$$target"; \
+ if test "$$target" = "install"; then \
+ ($(MAKE) $(AM_MAKEFLAGS) $$target-am) || exit 1; \
+ else \
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ echo "Making $$target in $$subdir"; \
+ if test "$$subdir" = "."; then \
+ dot_seen=yes; \
+ local_target="$$target-am"; \
+ else \
+ local_target="$$target"; \
+ fi; \
+ (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
+ done; \
+ if test "$$dot_seen" = "no"; then \
+ $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
fi; \
- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
- || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
- done; \
- if test "$$dot_seen" = "no"; then \
- $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
fi; test -z "$$fail"
mostlyclean-recursive clean-recursive distclean-recursive \

View file

@ -1,10 +1,10 @@
--- break_jsteg.c Fri Dec 21 01:11:32 2001
+++ /tmp/break_jsteg.c.diff Wed Dec 29 03:32:38 2004
--- break_jsteg.c.orig Sun Aug 29 20:11:00 2004
+++ break_jsteg.c Sat Apr 15 00:05:52 2006
@@ -162,7 +162,7 @@
jstegob->skip = bytes - sizeof(jstegob->coeff);
if (jsbits < max || off + jsbits > bits) {
- warnx(__FUNCTION__": bad size in bits, %d", bits);
- warnx("%s: bad size in bits, %d", __FUNCTION__, bits);
+ warnx("break_jsteg_prepare: bad size in bits, %d", bits);
return (NULL);
}

View file

@ -1,46 +1,46 @@
--- common.c Tue Jan 22 19:25:38 2002
+++ common.c.diff Wed Dec 29 03:35:11 2004
--- common.c.orig Sun Aug 29 20:11:00 2004
+++ common.c Sat Apr 15 00:11:40 2006
@@ -85,7 +85,7 @@
if (datasrc->bytes_in_buffer == 0) {
if (! (*datasrc->fill_input_buffer) (cinfo))
- err(1, __FUNCTION__": fill_input");
- err(1, "%s: fill_input", __FUNCTION__);
+ err(1, "jpeg_getc: fill_input");
}
datasrc->bytes_in_buffer--;
return GETJOCTET(*datasrc->next_input_byte++);
@@ -297,7 +297,7 @@
@@ -308,7 +308,7 @@
dcts = malloc(bits * sizeof (short));
if (dcts == NULL) {
- warn(__FUNCTION__": malloc");
- warn("%s: malloc", __FUNCTION__);
+ warn("prepare_all: malloc");
return (-1);
}
@@ -362,7 +362,7 @@
@@ -374,7 +374,7 @@
if (pdcts != NULL) {
dcts = malloc(bits * sizeof (short));
if (dcts == NULL) {
- warn(__FUNCTION__": malloc");
- warn("%s: malloc", __FUNCTION__);
+ warn("prepare_normal: malloc");
return (-1);
}
}
@@ -410,7 +410,7 @@
@@ -422,7 +422,7 @@
/* XXX - wasteful */
back[comp] = calloc(off, sizeof (char));
if (back[comp] == NULL) {
- warn(__FUNCTION__": calloc");
- warn("%s: calloc", __FUNCTION__);
+ warn("prepare_jphide: calloc");
goto err;
}
}
@@ -418,7 +418,7 @@
@@ -430,7 +430,7 @@
if (pdcts != NULL) {
dcts = malloc(mbits * sizeof (short));
if (dcts == NULL) {
- warn(__FUNCTION__": malloc");
- warn("%s: malloc", __FUNCTION__);
+ warn("prepare_jphide: malloc");
goto err;
}

View file

@ -1,14 +0,0 @@
--- file/Makefile.in.orig Thu Oct 16 11:42:44 2003
+++ file/Makefile.in Thu Oct 16 11:42:50 2003
@@ -504,9 +504,8 @@
done >> $@
magic.inc: magic
- echo -n "\"" > $@
- sed -e 's/\\/\\\\/g' -e 's/"/\\\"/g' magic >> $@
- echo -n "\"" >> $@
+ sed -e 's/\\/\\\\/g' -e 's/"/\\\"/g' \
+ -e 's/^/"/' -e 's/\(.*\)/\1"/' magic > $@
file.1: Makefile file.man
@rm -f $@

View file

@ -1,29 +1,29 @@
--- stegdetect.c Sat Jan 26 23:51:16 2002
+++ /tmp/stegdetect.c.diff Wed Dec 29 03:32:38 2004
@@ -1198,7 +1198,7 @@
flag = 1;
strlcat(outbuf, " f5(***)", sizeof(outbuf));
--- stegdetect.c.orig Sat Apr 15 00:14:05 2006
+++ stegdetect.c Sat Apr 15 00:14:40 2006
@@ -1227,7 +1227,7 @@
strlcat(outbuf, quality(tmp, stars), sizeof(outbuf));
flag = 1;
}
- no_f5:
+ no_f5:;
a_wasted_var = 0;
}
if (scans & FLAG_DOINVIS) {
@@ -1237,7 +1237,7 @@
@@ -1267,7 +1267,7 @@
strlcat(outbuf, tmp, sizeof(outbuf));
}
- no_invisiblesecrets:
+ no_invisiblesecrets:;
a_wasted_var = 0;
}
if ((scans & FLAG_CHECKHDRS)) {
@@ -1301,7 +1301,7 @@
@@ -1332,7 +1332,7 @@
}
free(dcts);
- jsteg_error:
+ jsteg_error:;
a_wasted_var = 0;
}
if ((scans & FLAG_DOOUTGUESS) && prepare_normal(&dcts, &bits) != -1) {

View file

@ -1,5 +1,5 @@
bin/stegdetect
bin/stegbreak
bin/stegcompare
bin/stegdeimage
%%X11%%bin/xsteg
share/stegbreak/rules.ini
@dirrm share/stegbreak