Remove expired ports:

2013-08-10 lang/q: Q-Lang is no longer supported. See lang/pure instead
2013-08-10 audio/q-audio: Q-Lang is no longer supported. See lang/pure instead
2013-08-10 graphics/q-graph: Q-Lang is no longer supported. See lang/pure instead
This commit is contained in:
Rene Ladan 2013-08-11 11:07:12 +00:00
parent 6a292399a7
commit 782e875bd2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=324582
19 changed files with 3 additions and 484 deletions

3
MOVED
View file

@ -4836,3 +4836,6 @@ www/mediawiki118||2013-08-02|Has expired: Unmaintained upstream
sysutils/googlog||2013-08-02|Has expired: no upstream project
www/mod_macro24||2013-08-03|Has expired: part of Apache 2.4.6 and newer
games/kaid||2013-08-07|Has expired: Does not fetch
lang/q||2013-08-11|Has expired: Q-Lang is no longer supported. See lang/pure instead
audio/q-audio||2013-08-11|Has expired: Q-Lang is no longer supported. See lang/pure instead
graphics/q-graph||2013-08-11|Has expired: Q-Lang is no longer supported. See lang/pure instead

View file

@ -643,7 +643,6 @@
SUBDIR += py-xmms2
SUBDIR += pysol-sound-server
SUBDIR += pytone
SUBDIR += q-audio
SUBDIR += qjackctl
SUBDIR += qmpdclient
SUBDIR += qsampler

View file

@ -1,37 +0,0 @@
# Created by: ag@muwiinfa.geschichte.uni-mainz.de Albert Graef
# $FreeBSD$
PORTNAME= audio
PORTVERSION= 2.7
PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF/q-lang/q-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= q-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Q-Audio -- digital audio interface for the Q language
DEPRECATED= Q-Lang is no longer supported. See lang/pure instead
EXPIRATION_DATE=2013-08-10
LIB_DEPENDS= q.8:${PORTSDIR}/lang/q \
jack.0:${PORTSDIR}/audio/jack \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
fftw3:${PORTSDIR}/math/fftw3
BUILD_DEPENDS= ${LOCALBASE}/lib/portaudio2/libportaudio.so.2:${PORTSDIR}/audio/portaudio2
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= pkgconfig
.if defined(.PARSEDIR)
USE_GMAKE= yes
.endif
DATADIR= ${PREFIX}/share/q
CFLAGS+= -I${LOCALBASE}/include/portaudio2 -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib/portaudio2 -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (q-audio-2.7.tar.gz) = 2286d6fee4fddc867af4699072f9991eae4b056cf7650a4546459c9c532fd685
SIZE (q-audio-2.7.tar.gz) = 376283

View file

@ -1,15 +0,0 @@
--- ltmain.sh.orig Thu Jan 8 15:57:49 2004
+++ ltmain.sh Thu Jan 8 15:58:00 2004
@@ -4210,10 +4210,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -1,14 +0,0 @@
This package contains two modules to write digital audio applications in the Q
programming language:
- The audio module implements a (near-)realtime audio interface on top of Phil
Burk's PortAudio library V1.8 (http://www.portaudio.com/).
- The sndfile module allows you to access sound files in various formats using
Erik de Castro Lopo's libsndfile library V1.0 or later
(http://www.zip.com.au/~erikd/libsndfile/).
Also included is a GGI-based wave renderer (draw_wave.q) and a simple
graphical audio player application (audio_player.q).
WWW: http://q-lang.sourceforge.net/

View file

@ -1,17 +0,0 @@
bin/audio_player
lib/q/audio.so
lib/q/audio.a
lib/q/sndfile.so
lib/q/sndfile.a
lib/q/wave.so
lib/q/wave.a
%%DATADIR%%/examples/audio/audio_examp.q
%%DATADIR%%/apps/audio_player/audio_player.q
%%DATADIR%%/apps/audio_player/audio_player.tcl
%%DATADIR%%/lib/audio.q
%%DATADIR%%/lib/sndfile.q
%%DATADIR%%/lib/wave.q
%%DATADIR%%/etc/README-Audio
@dirrm %%DATADIR%%/apps/audio_player
@dirrmtry %%DATADIR%%/apps
@dirrm %%DATADIR%%/examples/audio

View file

@ -878,7 +878,6 @@
SUBDIR += pymorph
SUBDIR += pyro
SUBDIR += pysvg
SUBDIR += q-graph
SUBDIR += qcamview
SUBDIR += qcomicbook
SUBDIR += qcread

View file

@ -1,28 +0,0 @@
# New ports collection makefile for: q-graph
# Date created: 14 August 2003
# Whom: ag@muwiinfa.geschichte.uni-mainz.de Albert Graef
#
# $FreeBSD$
#
PORTNAME= graph
PORTVERSION= 1.8
PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/q-lang/${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= q-
MAINTAINER= gahr@FreeBSD.org
COMMENT= Q-Graph -- graph library and editor for the Q language
DEPRECATED= Q-Lang is no longer supported. See lang/pure instead
EXPIRATION_DATE=2013-08-10
LIB_DEPENDS= q.8:${PORTSDIR}/lang/q
RUN_DEPENDS= ${LOCALBASE}/lib/bwidget/init.tcl:${PORTSDIR}/x11-toolkits/bwidget
DATADIR= ${PREFIX}/share/q
GNU_CONFIGURE= yes
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (graph-1.8.tar.gz) = 8a2bf0b3b47bdd2fbf40c80a410184834068912cc0b1cab1f68dc28e3a920a1e
SIZE (graph-1.8.tar.gz) = 109134

View file

@ -1,10 +0,0 @@
This is Q-Graph, a graph library and editor for the Q programming language.
The package contains:
- graph.q: a graph data structure implemented as a kind of asymmetric
adjacency list dictionary, and a collection of the usual graph operations
- graphed.q: a full-featured graph editor, allows you to create and edit your
input graphs with ease (requires Tcl/Tk)
WWW: http://q-lang.sourceforge.net

View file

@ -1,12 +0,0 @@
bin/graphed
bin/graphed2
%%DATADIR%%/etc/README-Graph
%%DATADIR%%/lib/graph.q
%%DATADIR%%/apps/graphed/graphed.q
%%DATADIR%%/apps/graphed/graphed.tcl
%%DATADIR%%/examples/graph/G
%%DATADIR%%/examples/graph/README
%%DATADIR%%/examples/graph/dijkstra.q
@dirrm %%DATADIR%%/examples/graph
@dirrm %%DATADIR%%/apps/graphed
@dirrmtry %%DATADIR%%/apps

View file

@ -280,7 +280,6 @@
SUBDIR += python31
SUBDIR += python32
SUBDIR += python33
SUBDIR += q
SUBDIR += qore
SUBDIR += qscheme
SUBDIR += racket

View file

@ -1,53 +0,0 @@
# Created by: ag@muwiinfa.geschichte.uni-mainz.de Albert Graef
# $FreeBSD$
PORTNAME= q
PORTVERSION= 7.11
PORTREVISION= 13
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}-lang/${PORTNAME}/${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Q -- equational programming language
DEPRECATED= Q-Lang is no longer supported. See lang/pure instead
EXPIRATION_DATE=2013-08-10
LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick \
curl:${PORTSDIR}/ftp/curl \
freetype.9:${PORTSDIR}/print/freetype2 \
gdbm.4:${PORTSDIR}/databases/gdbm \
gmp.10:${PORTSDIR}/math/gmp \
iodbc.3:${PORTSDIR}/databases/libiodbc \
xml2.5:${PORTSDIR}/textproc/libxml2 \
xslt.2:${PORTSDIR}/textproc/libxslt \
ggi.2:${PORTSDIR}/graphics/libggi
USES= bison iconv
USE_GCC= any
USE_TK= 84+
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-magick="`pkg-config ImageMagick --libs`" \
--with-magick-includes="`pkg-config ImageMagick --cflags`" \
--with-tk="-L${TK_LIBDIR} -L${TCL_LIBDIR} -ltk${TK_VER:S/.//} -ltcl${TCL_VER:S/.//}" \
--with-tk-includes="-I${TK_INCLUDEDIR} -I${TCL_INCLUDEDIR}" \
--with-gdbm="-L${LOCALBASE}/lib -lgdbm" \
--with-gdbm-includes="-I${LOCALBASE}/include" \
--with-curl="`curl-config --libs`" \
--with-curl-includes="`curl-config --cflags`" \
--with-gmp="-L${LOCALBASE}/lib -lgmp" \
--with-gmp-includes="-I${LOCALBASE}/include" \
--with-ggi="-L${LOCALBASE}/lib -lggi" \
--with-ggi-includes="-I${LOCALBASE}/include" \
--with-pthread="${PTHREAD_LIBS}" \
--with-odbc="`iodbc-config --libs`" \
--with-odbc-includes="`iodbc-config --cflags`"
MAN1= q.1
INFO= qdoc
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (q-7.11.tar.gz) = 59b9a0993a7c274c535058ae5ceaf243435be3713f83b53ea311bf7269df98d5
SIZE (q-7.11.tar.gz) = 2147297

View file

@ -1,11 +0,0 @@
--- modules/clib/system.c.orig 2009-04-11 11:45:49.000000000 +0200
+++ modules/clib/system.c 2009-04-11 11:49:40.000000000 +0200
@@ -1689,7 +1689,7 @@
mkvoid,
#endif
#ifdef _POSIX_CPUTIME
- mkint(CLOCK_PROCESS_CPUTIME_ID),
+ mkint(CLOCK_VIRTUAL),
#else
mkvoid,
#endif

View file

@ -1,74 +0,0 @@
--- modules/tk/tk.c.orig 2013-06-03 18:38:51.000000000 +0200
+++ modules/tk/tk.c 2013-06-03 18:43:27.000000000 +0200
@@ -369,9 +369,9 @@
}
}
if (!locked) acquire_lock();
- if (trace || (int)clientData) {
+ if (trace || clientData != NULL) {
int val;
- if ((int)clientData && check_trace(buf, &val)) {
+ if (clientData != NULL && check_trace(buf, &val)) {
clear_buf(&buf, &bufsz);
Tcl_AppendResult(interp, trace?"1":"0", NULL);
trace = val;
@@ -471,7 +471,7 @@
return dequeue();
}
-static void set_result(char *s)
+static void set_result(const char *s)
{
tld_result = malloc(strlen(s)+1);
if (tld_result) strcpy(tld_result, s);
@@ -481,14 +481,16 @@
{
int status;
char *cmd;
+ const char *res;
tld_result = NULL;
if (!tld_interp) return 0;
cmd = malloc(strlen(s)+1);
if (!cmd) return 0;
strcpy(cmd, s);
status = Tcl_Eval(tld_interp, cmd);
- if (tld_interp && tld_interp->result && *tld_interp->result)
- set_result(tld_interp->result);
+ res = Tcl_GetStringResult(tld_interp);
+ if (tld_interp && res && *res)
+ set_result(res);
else if (status == TCL_BREAK)
set_result("invoked \"break\" outside of a loop");
else if (status == TCL_CONTINUE)
@@ -506,6 +508,7 @@
{
Tk_Window mainw;
tld_result = NULL;
+ const char *res;
if (tld_interp) return 1;
/* Just to be safe, if Tcl has been compiled without thread support then we
only allow a single interpreter in the main thread. */
@@ -516,8 +519,9 @@
pthread_setspecific(interp_key, tld_interp);
#endif
if (Tcl_Init(tld_interp) != TCL_OK) {
- if (tld_interp->result && *tld_interp->result)
- set_result(tld_interp->result);
+ res = Tcl_GetStringResult(tld_interp);
+ if (res && *res)
+ set_result(res);
else
set_result("error initializing Tcl");
tk_stop();
@@ -533,8 +537,9 @@
/* oddly, there are no `env' variables passed, and this one is needed */
Tcl_SetVar2(tld_interp, "env", "DISPLAY", getenv("DISPLAY"), TCL_GLOBAL_ONLY);
if (Tk_Init(tld_interp) != TCL_OK) {
- if (tld_interp->result && *tld_interp->result)
- set_result(tld_interp->result);
+ res = Tcl_GetStringResult(tld_interp);
+ if (res && *res)
+ set_result(res);
else
set_result("error initializing Tk");
tk_stop();

View file

@ -1,10 +0,0 @@
Q is a powerful and extensible functional programming language based on the
term rewriting calculus. You specify an arbitrary system of equations which
the interpreter uses as rewrite rules to reduce expressions to normal form. Q
is useful for scientific programming and other advanced applications, and also
as a sophisticated kind of desktop calculator. The distribution includes the Q
programming tools, the standard library, add-on modules for interfacing to GNU
dbm, GNU Octave, GGI, ImageMagick, Tcl/Tk and IBM's Data Explorer, and
an Emacs mode.
WWW: http://q-lang.sourceforge.net/

View file

@ -1,194 +0,0 @@
bin/q
bin/qc
bin/qcc
bin/qld
include/libq.h
include/qint.h
lib/libq.so.8
lib/libq.so
lib/libq.la
lib/libq.a
lib/libqmain.la
lib/libqmain.a
lib/libqint.so.2
lib/libqint.so
lib/libqint.la
lib/libqint.a
lib/q/clib.a
lib/q/clib.la
lib/q/clib.so
lib/q/curl.a
lib/q/curl.la
lib/q/curl.so
lib/q/ggi.a
lib/q/ggi.la
lib/q/ggi.so
lib/q/gdbm.a
lib/q/gdbm.la
lib/q/gdbm.so
lib/q/libtool
lib/q/magick.a
lib/q/magick.la
lib/q/magick.so
lib/q/octave.a
lib/q/octave.la
lib/q/octave.so
lib/q/odbc.a
lib/q/odbc.la
lib/q/odbc.so
lib/q/swig.a
lib/q/swig.la
lib/q/swig.so
lib/q/system.a
lib/q/system.la
lib/q/system.so
lib/q/tk.a
lib/q/tk.la
lib/q/tk.so
lib/q/xml.a
lib/q/xml.la
lib/q/xml.so
%%DATADIR%%/etc/AUTHORS
%%DATADIR%%/etc/COPYING
%%DATADIR%%/etc/ChangeLog
%%DATADIR%%/etc/NEWS
%%DATADIR%%/etc/README
%%DATADIR%%/etc/README-Clib
%%DATADIR%%/etc/README-Curl
%%DATADIR%%/etc/README-Gdbm
%%DATADIR%%/etc/README-GGI
%%DATADIR%%/etc/README-Magick
%%DATADIR%%/etc/README-Octave
%%DATADIR%%/etc/README-ODBC
%%DATADIR%%/etc/README-SWIG
%%DATADIR%%/etc/README-Tk
%%DATADIR%%/etc/README-XML
%%DATADIR%%/etc/q-mode.el
%%DATADIR%%/etc/q.vim
%%DATADIR%%/etc/q.xml
%%DATADIR%%/etc/qexitrc
%%DATADIR%%/etc/qinitrc
%%DATADIR%%/examples/basics.q
%%DATADIR%%/examples/cgi.q
%%DATADIR%%/examples/creverse.c
%%DATADIR%%/examples/creverse.q
%%DATADIR%%/examples/csv.q
%%DATADIR%%/examples/ctype.c
%%DATADIR%%/examples/ctype.q
%%DATADIR%%/examples/curl/curltest.q
%%DATADIR%%/examples/daemon.q
%%DATADIR%%/examples/dfs.q
%%DATADIR%%/examples/dgram.q
%%DATADIR%%/examples/dnf.q
%%DATADIR%%/examples/except.q
%%DATADIR%%/examples/factor.q
%%DATADIR%%/examples/fcntl.q
%%DATADIR%%/examples/fibs.q
%%DATADIR%%/examples/fibs.sh
%%DATADIR%%/examples/fixpt.q
%%DATADIR%%/examples/gamma.q
%%DATADIR%%/examples/gdbm/gdbm_dict.q
%%DATADIR%%/examples/gdbm/testdb.q
%%DATADIR%%/examples/getpass.q
%%DATADIR%%/examples/ggi/bufdemo.q
%%DATADIR%%/examples/ggi/flying_ggis.q
%%DATADIR%%/examples/ggi/font_test.q
%%DATADIR%%/examples/ggi/ggi_demo.q
%%DATADIR%%/examples/globexamp.q
%%DATADIR%%/examples/graph.q
%%DATADIR%%/examples/grid.q
%%DATADIR%%/examples/hashed.q
%%DATADIR%%/examples/huffman.q
%%DATADIR%%/examples/lambda.q
%%DATADIR%%/examples/magick/magicktest.q
%%DATADIR%%/examples/magick/mozilla.png
%%DATADIR%%/examples/magick/mozilla_48x48.rgba
%%DATADIR%%/examples/magick/sprite.q
%%DATADIR%%/examples/menu.q
%%DATADIR%%/examples/newton.q
%%DATADIR%%/examples/odbc/odbc_examp.q
%%DATADIR%%/examples/pipes.q
%%DATADIR%%/examples/popen2.q
%%DATADIR%%/examples/primetest.q
%%DATADIR%%/examples/pty.q
%%DATADIR%%/examples/qint.c
%%DATADIR%%/examples/queens.q
%%DATADIR%%/examples/queens2.q
%%DATADIR%%/examples/queens3.q
%%DATADIR%%/examples/queue.q
%%DATADIR%%/examples/regexamp.q
%%DATADIR%%/examples/rlexamp.q
%%DATADIR%%/examples/rot13.q
%%DATADIR%%/examples/searchtree.q
%%DATADIR%%/examples/select.q
%%DATADIR%%/examples/signal.q
%%DATADIR%%/examples/streams.q
%%DATADIR%%/examples/swig/example.c
%%DATADIR%%/examples/swig/example.i
%%DATADIR%%/examples/swig/qt_examp.cxx
%%DATADIR%%/examples/swig/qt_examp.h
%%DATADIR%%/examples/swig/qt_examp.i
%%DATADIR%%/examples/symbolic.q
%%DATADIR%%/examples/sys.q
%%DATADIR%%/examples/testfont.q
%%DATADIR%%/examples/time.q
%%DATADIR%%/examples/unicode.q
%%DATADIR%%/examples/tk/tix.q
%%DATADIR%%/examples/tk/tk_examp.q
%%DATADIR%%/examples/tk/tk_test.q
%%DATADIR%%/examples/xml/catalog.q
%%DATADIR%%/examples/xml/catalog.xsl
%%DATADIR%%/examples/xml/recipes.q
%%DATADIR%%/examples/xml/recipes.xml
%%DATADIR%%/examples/xml/recipes.xsl
%%DATADIR%%/examples/xml/sample.xml
%%DATADIR%%/examples/xml/xml_examp.q
%%DATADIR%%/lib/array.q
%%DATADIR%%/lib/assert.q
%%DATADIR%%/lib/bag.q
%%DATADIR%%/lib/clib.q
%%DATADIR%%/lib/complex.q
%%DATADIR%%/lib/cond.q
%%DATADIR%%/lib/curl.q
%%DATADIR%%/lib/dict.q
%%DATADIR%%/lib/error.q
%%DATADIR%%/lib/gdbm.q
%%DATADIR%%/lib/getopt.q
%%DATADIR%%/lib/ggi.q
%%DATADIR%%/lib/graphics.q
%%DATADIR%%/lib/hdict.q
%%DATADIR%%/lib/heap.q
%%DATADIR%%/lib/magick.q
%%DATADIR%%/lib/math.q
%%DATADIR%%/lib/octave.q
%%DATADIR%%/lib/odbc.q
%%DATADIR%%/lib/prelude.q
%%DATADIR%%/lib/rational.q
%%DATADIR%%/lib/reftypes.q
%%DATADIR%%/lib/set.q
%%DATADIR%%/lib/sort.q
%%DATADIR%%/lib/stddecl.q
%%DATADIR%%/lib/stdlib.q
%%DATADIR%%/lib/stdtypes.q
%%DATADIR%%/lib/stream.q
%%DATADIR%%/lib/string.q
%%DATADIR%%/lib/swig.q
%%DATADIR%%/lib/system.q
%%DATADIR%%/lib/tk.q
%%DATADIR%%/lib/tuple.q
%%DATADIR%%/lib/typec.q
%%DATADIR%%/lib/xml.q
@dirrm lib/q
@dirrm %%DATADIR%%/lib
@dirrm %%DATADIR%%/examples/xml
@dirrm %%DATADIR%%/examples/tk
@dirrm %%DATADIR%%/examples/swig
@dirrm %%DATADIR%%/examples/odbc
@dirrm %%DATADIR%%/examples/magick
@dirrm %%DATADIR%%/examples/ggi
@dirrm %%DATADIR%%/examples/gdbm
@dirrm %%DATADIR%%/examples/dxl
@dirrm %%DATADIR%%/examples/curl
@dirrm %%DATADIR%%/examples
@dirrm %%DATADIR%%/etc
@dirrm %%DATADIR%%