Update to 1.0

- Switch from gtkmm to wxgtk

PR:		82944
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Tilman Keskinoz 2005-07-04 15:37:00 +00:00
parent 9b91dbfc3e
commit 7840bcb8b5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138468
4 changed files with 23 additions and 26 deletions

View file

@ -7,26 +7,31 @@
#
PORTNAME= graphthing
PORTVERSION= 0.9.5
PORTVERSION= 1.0
CATEGORIES= math
MASTER_SITES= http://graph.seul.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool that allows you to create, manipulate and study graphs
LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk--
LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
USE_BZIP2= yes
USE_GNOME= gnometarget gtk12
USE_GNOME= gnometarget gtk20
USE_BISON= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wxgtk2-2.6-config
PLIST_FILES= bin/graphthing bin/gt
post-patch:
${REINPLACE_CMD} -e "s,\/usr\/include\/gtk-1.2\/gdk\/gdkkeysyms.h,," \
${WRKSRC}/src/depend.1
CPPFLAGS= ${PTHREAD_CFLAGS}
LDFLAGS= ${PTHREAD_LIBS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/graphthing ${PREFIX}/bin
${LN} -sf graphthing ${PREFIX}/bin/gt
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (graphthing-0.9.5.tar.bz2) = 343f958d0b2bb8558006ec92048d8c98
SIZE (graphthing-0.9.5.tar.bz2) = 138622
MD5 (graphthing-1.0.tar.bz2) = 33dda372a386e0e5a55f31ba0bc5ec36
SIZE (graphthing-1.0.tar.bz2) = 127900

View file

@ -0,0 +1,10 @@
--- src/exporter.cc.orig Sun Jul 3 13:27:10 2005
+++ src/exporter.cc Sun Jul 3 18:15:55 2005
@@ -5,6 +5,7 @@
#include <fstream>
#include <iostream>
#include <stdexcept>
+#include <ctime>
#include "config.h"
#include "edge.h"
#include "exporter.h"

View file

@ -1,18 +0,0 @@
--- src/gui.h.orig Thu Feb 24 14:11:10 2005
+++ src/gui.h Thu Feb 24 14:11:12 2005
@@ -140,7 +140,6 @@ public:
class ParamDialog : public Gtk::Dialog
{
protected:
- void ok_click ();
virtual int delete_event_impl (GdkEventAny *ev);
virtual void get_data () = 0;
@@ -148,6 +147,7 @@ protected:
public:
bool cancelled;
+ void ok_click ();
ParamDialog (const String &title = "Prefab Parameter");
};