- Update to 2.16
This commit is contained in:
parent
5734c7e473
commit
788dbc9ae0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=489370
10 changed files with 40 additions and 89 deletions
|
@ -2,43 +2,52 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mandelbulber
|
||||
DISTVERSION= 1.13-1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.16
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF/${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}${DISTVERSION}
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= 3D Mandelbrot fractal renderer
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
LICENSE= GPLv3+
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BROKEN= fails to build
|
||||
LIB_DEPENDS= libgsl.so:math/gsl \
|
||||
libpng.so:graphics/png \
|
||||
libtiff.so:graphics/tiff \
|
||||
liblzo2.so:archivers/lzo2
|
||||
|
||||
USES= desktop-file-utils gmake pkgconfig
|
||||
USE_GNOME= glib20 gtk20
|
||||
BUILD_WRKSRC= ${WRKSRC}/makefiles
|
||||
MAKEFILE= makefile
|
||||
CXXFLAGS+= -DSHARED_DIR=\\\"${DATADIR}\\\"
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= buddhi1980
|
||||
GH_PROJECT= ${PORTNAME}2
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME} share/applications/${PORTNAME}.desktop
|
||||
USES= cmake gnome jpeg localbase:ldflags pkgconfig qt:5
|
||||
USE_QT= core widgets network gui multimedia testlib \
|
||||
qmake_build buildtools_build uitools_build
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
PORTDOCS= README NEWS
|
||||
CMAKE_SOURCE_PATH= ${WRKSRC}/mandelbulber2/cmake
|
||||
|
||||
PORTDOCS= CONTRIBUTING.md README.md RESOURCES.md
|
||||
PORTDATA= *
|
||||
DATADIR= ${PREFIX}/share/${PORTNAME}2
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
OPTIONS_DEFINE= OPENCL OPENMP DOCS
|
||||
OPTIONS_EXCLUDE= OPENMP # not properly supported yet
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/share/mandelbulber|${DATADIR}|' \
|
||||
${WRKSRC}/${PORTNAME}.desktop
|
||||
OPENCL_BUILD_DEPENDS= opencl>=0:devel/opencl
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
|
||||
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
cd ${WRKSRC}/usr/share && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
OPENMP_LIB_DEPENDS= libomp.so:devel/openmp
|
||||
|
||||
post-patch-OPENMP-off:
|
||||
@${REINPLACE_CMD} -e 's|-fopenmp||' \
|
||||
${CMAKE_SOURCE_PATH}/CMakeLists.txt
|
||||
|
||||
post-patch-OPENCL-off:
|
||||
@${REINPLACE_CMD} -e '/find_package.*OpenCL/ d' \
|
||||
${CMAKE_SOURCE_PATH}/CMakeLists.txt
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
|
||||
.endfor
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (mandelbulber1.13-1.tar.gz) = 97edc8b08fc229e68ea58fd835581274b783ff4211b4db87c81efbdef799bd92
|
||||
SIZE (mandelbulber1.13-1.tar.gz) = 1200010
|
||||
TIMESTAMP = 1545751082
|
||||
SHA256 (buddhi1980-mandelbulber2-2.16_GH0.tar.gz) = 1c7b78f4345a2c3527acbc54ac2cd17efd4b7d36cedcd1deb85603cb48c09d8b
|
||||
SIZE (buddhi1980-mandelbulber2-2.16_GH0.tar.gz) = 54566672
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- makefiles/makefile.orig 2012-12-02 20:22:54.000000000 +0400
|
||||
+++ makefiles/makefile 2012-12-13 01:08:10.313933225 +0400
|
||||
@@ -44,7 +44,7 @@
|
||||
mandelbulber: $(OBJS) $(USER_OBJS)
|
||||
@echo 'Building target: $@'
|
||||
@echo 'Invoking: GCC C++ Linker'
|
||||
- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS)
|
||||
+ $(CXX) -o"mandelbulber" -L$(LOCALBASE)/lib $(OBJS) $(USER_OBJS) $(LIBS)
|
||||
@echo 'Finished building target: $@'
|
||||
@echo ' '
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- makefiles/src/subdir.mk.orig 2012-12-02 20:22:54.000000000 +0400
|
||||
+++ makefiles/src/subdir.mk 2012-12-13 01:07:24.472933242 +0400
|
||||
@@ -71,7 +71,7 @@
|
||||
src/%.o: ../src/%.cpp
|
||||
@echo 'Building file: $<'
|
||||
@echo 'Invoking: GCC C++ Compiler'
|
||||
- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
|
||||
+ $(CXX) $(CXXFLAGS) -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
|
||||
@echo 'Finished building: $<'
|
||||
@echo ' '
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- src/netrender.cpp.orig 2012-12-02 20:22:54.000000000 +0400
|
||||
+++ src/netrender.cpp 2012-12-13 01:06:24.748933214 +0400
|
||||
@@ -7,6 +7,7 @@
|
||||
|
||||
#include "netrender.hpp"
|
||||
#include <stdio.h>
|
||||
+#include <netinet/in.h>
|
||||
#ifndef WIN32
|
||||
#include <arpa/inet.h>
|
||||
#endif
|
|
@ -1,10 +0,0 @@
|
|||
--- src/netrender.hpp.orig 2012-12-02 20:22:54.000000000 +0400
|
||||
+++ src/netrender.hpp 2012-12-13 01:05:50.537932343 +0400
|
||||
@@ -19,6 +19,7 @@
|
||||
#include <winsock2.h>
|
||||
#define INET6_ADDRSTRLEN 46
|
||||
#else
|
||||
+ #include <arpa/inet.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netdb.h>
|
||||
#endif
|
|
@ -1,10 +0,0 @@
|
|||
--- src/texture.cpp.orig 2012-12-02 16:22:54 UTC
|
||||
+++ src/texture.cpp
|
||||
@@ -4,6 +4,7 @@
|
||||
* Created on: 2010-02-07
|
||||
* Author: krzysztof
|
||||
*/
|
||||
+#include <cstring>
|
||||
#include <stdio.h>
|
||||
#include "texture.hpp"
|
||||
#include "files.h"
|
|
@ -1,10 +0,0 @@
|
|||
--- src/timeline.cpp.orig 2012-12-02 16:22:54 UTC
|
||||
+++ src/timeline.cpp
|
||||
@@ -6,6 +6,7 @@
|
||||
*/
|
||||
|
||||
#include <cstdlib>
|
||||
+#include <cstring>
|
||||
|
||||
#include "timeline.hpp"
|
||||
#include "files.h"
|
|
@ -5,4 +5,4 @@ Menger Sponge, Quaternion, Trigonometric, Hypercomplex, and Iterated
|
|||
Function Systems (IFS). All of these can be combined into infinite
|
||||
variations with the ability to hybridize different formulas together.
|
||||
|
||||
WWW: http://www.mandelbulber.com/
|
||||
WWW: https://mandelbulber.com/
|
||||
|
|
3
graphics/mandelbulber/pkg-plist
Normal file
3
graphics/mandelbulber/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/mandelbulber2
|
||||
share/applications/mandelbulber2.desktop
|
||||
share/icons/hicolor/256x256/apps/mandelbulber2.png
|
Loading…
Reference in a new issue