- Update to 5.4.2+1.4.2

Submitted by:	Craig Rodrigues <rodrigc(at)crodrigues.org>
This commit is contained in:
Sergey Matveychuk 2004-12-07 13:32:53 +00:00
parent 6638a6806f
commit 7896da2ae5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=123396
11 changed files with 994 additions and 1171 deletions

View file

@ -18,8 +18,8 @@ COMMENT?= The Adaptive Communication Environment (ACE) with The ACE ORB (TAO)
CONFLICTS?= ace-*
ACE_VERSION= 5.4.1
TAO_VERSION= 1.4.1
ACE_VERSION= 5.4.2
TAO_VERSION= 1.4.2
USE_BZIP2= yes
USE_GMAKE= yes
@ -44,22 +44,13 @@ TAO_ROOT= ${ACE_ROOT}/TAO
PLIST_SUB+= TAO=${TAO} TESTS=${TESTS} \
ACE_VERSION=${ACE_VERSION} TAO_VERSION=${TAO_VERSION}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502125
WITHOUT_TAO= yes
pre-extract:
@${ECHO_MSG} "****************************************************"; \
${ECHO_MSG} "* TAO is not build with gcc 3.4 *"; \
${ECHO_MSG} "* so only ACE will build and install *"; \
${ECHO_MSG} "****************************************************"
.endif
.if defined(WITHOUT_TAO)
TAO= "@comment "
PKGNAMESUFFIX?= -notao
.endif
.include <bsd.port.pre.mk>
post-patch:
@${SED} -e "s#%%CFLAGS%%#${CFLAGS}#;s#%%PREFIX%%#${PREFIX}#; \
s#%%PTHREAD_CFLAGS%%#${PTHREAD_CFLAGS}#; \
@ -71,13 +62,12 @@ post-patch:
${CHMOD} a-x Logging_Service/Event_Logging_Service/*; \
${CHMOD} a-x Logging_Service/Notify_Logging_Service/*; \
${CHMOD} a-x Logging_Service/RTEvent_Logging_Service/*; \
${CHMOD} a-x orbsvcs/*.mpb; \
${CHMOD} a-x orbsvcs/FaultTolerance/*; \
${CHMOD} a-x FT_ReplicationManager/*
.if !defined(WITH_TESTS)
@${REINPLACE_CMD} -e "21d" ${ACE_ROOT}/Makefile
@${REINPLACE_CMD} -e "24d" ${TAO_ROOT}/Makefile
@${REINPLACE_CMD} -e "48d" ${TAO_ROOT}/orbsvcs/Makefile
@${REINPLACE_CMD} -e "30d" ${ACE_ROOT}/GNUmakefile
@${REINPLACE_CMD} -e "27d" ${TAO_ROOT}/GNUmakefile
@${REINPLACE_CMD} -e "45d" ${TAO_ROOT}/orbsvcs/GNUmakefile
.endif
pre-build:
@ -95,6 +85,8 @@ do-build:
.endif
.if !defined(WITHOUT_TAO)
@${ECHO_MSG} "===> Building TAO"; \
${GMAKE} -C ${TAO_ROOT}/TAO_IDL ACE_ROOT=${ACE_ROOT} TAO_ROOT=${TAO_ROOT}; \
${LDCONFIG} -m ${TAO_ROOT}/TAO_IDL; \
${GMAKE} -C ${TAO_ROOT} ACE_ROOT=${ACE_ROOT} TAO_ROOT=${TAO_ROOT}
.if defined(WITH_TESTS)
@${TOUCH} ${TOUCH_FLAGS} ${TAO_TESTS_COOKIE}
@ -115,7 +107,7 @@ test:
@if [ -f ${ACE_TESTS_COOKIE} ]; then \
${ECHO_MSG} "===> Running tests."; \
${ECHO_MSG} "===> ACE tests:"; \
cd ${ACE_ROOT}/tests; ./run_test.pl; \
cd ${ACE_ROOT}/tests; env ACE_ROOT=${ACE_ROOT} ./run_test.pl; \
if [ -f ${TAO_TESTS_COOKIE} ]; then \
${ECHO_MSG} "===> TAO tests:"; \
${ECHO_MSG} " NOT IMPLEMENTED YET. Run them with:"; \
@ -165,7 +157,7 @@ do-install:
.endif
@${ECHO_MSG} "Installing libraries into ${PREFIX}/lib"; \
cd ${ACE_ROOT}/ace; \
cd ${ACE_ROOT}/lib; \
for f in `${FIND} . -maxdepth 1 -name "lib*.so.${ACE_VERSION}" -o \
-name "lib*.so.${TAO_VERSION}" -not -name "*Test*"`; do \
${INSTALL_DATA} $${f} ${PREFIX}/lib; \
@ -183,7 +175,7 @@ do-install:
${GREP} -v test | ${GREP} -v FTRT_Event_Service`; do \
${INSTALL_PROGRAM} $${f} ${PREFIX}/bin; \
done; \
for f in `find utils -type f -perm +a+x`; do \
for f in `find utils -type f -perm +a+x -not -name "*test*"`; do \
${INSTALL_PROGRAM} $${f} ${PREFIX}/bin; \
done; \
for f in `${FIND} orbsvcs/FTRT_Event_Service -type f -perm +a+x`; do \

View file

@ -1,2 +1,2 @@
MD5 (ACE-5.4.1+TAO-1.4.1.tar.bz2) = 403220fba7cbc33c6f18047bc6f1a3c3
SIZE (ACE-5.4.1+TAO-1.4.1.tar.bz2) = 14206098
MD5 (ACE-5.4.2+TAO-1.4.2.tar.bz2) = 71d394a1973bc64bddea2e9b26286ae2
SIZE (ACE-5.4.2+TAO-1.4.2.tar.bz2) = 14042566

View file

@ -1,231 +1 @@
/* -*- C++ -*- */
// config-freebsd.h,v 4.48 2003/08/09 04:43:51 dhinton Exp
// The following configuration file is designed to work for FreeBSD
#ifndef ACE_CONFIG_H
#define ACE_CONFIG_H
#include /**/ "ace/pre.h"
#if !defined (ACE_MT_SAFE)
# define ACE_MT_SAFE 1
#endif
#if ACE_MT_SAFE
// Yes, we do have threads.
# define ACE_HAS_THREADS 1
#else
// Set to 0 since that's what config-posix.h checks for.
# define ACE_HAS_THREADS 0
#endif /* ACE_MT_SAFE */
#include "ace/config-posix.h"
#include <osreldate.h>
// Make sure we source in the OS version.
#if ! defined (__ACE_INLINE__)
#define __ACE_INLINE__
#endif /* ! __ACE_INLINE__ */
#define ACE_SIZEOF_LONG_DOUBLE 12
#if defined (__GNUG__)
# include "ace/config-g++-common.h"
#endif /* __GNUG__ */
#if defined (ACE_HAS_PENTIUM)
# undef ACE_HAS_PENTIUM
#endif /* ACE_HAS_PENTIUM */
// Platform specific directives
// gcc defines __FreeBSD__ automatically for us.
#ifdef ACE_HAS_THREADS
#if !defined (_THREAD_SAFE)
#define _THREAD_SAFE
#endif /* _THREAD_SAFE */
#endif
#define ACE_HAS_GPERF
#define ACE_HAS_ALT_CUSERID
#define ACE_HAS_RECURSIVE_THR_EXIT_SEMANTICS
#define ACE_HAS_SIG_MACROS
// Optimize ACE_Handle_Set for select().
#define ACE_HAS_HANDLE_SET_OPTIMIZED_FOR_SELECT
#define ACE_HAS_NONCONST_SELECT_TIMEVAL
#define ACE_HAS_CHARPTR_DL
#define ACE_NEEDS_SCHED_H
// Use of <malloc.h> is deprecated.
#define ACE_LACKS_MALLOC_H
// This won't be necessary after it is fixed in the system include headers.
extern "C" { char * cuserid (char *s); }
// Platform supports POSIX timers via struct timespec.
#define ACE_HAS_POSIX_TIME
#define ACE_HAS_UALARM
// Platform defines struct timespec but not timespec_t
#define ACE_LACKS_TIMESPEC_T
#define ACE_LACKS_SYSTIME_H
#if (__FreeBSD_version < 501000)
#define ACE_LACKS_STDINT_H
#endif
#define ACE_LACKS_STRRECVFD
#define ACE_HAS_SIN_LEN
// Platform supports System V IPC (most versions of UNIX, but not Win32)
#define ACE_HAS_SYSV_IPC
// Compiler/platform contains the <sys/syscall.h> file.
#define ACE_HAS_SYSCALL_H
#define ACE_HAS_SIGINFO_T
#define ACE_HAS_REENTRANT_FUNCTIONS
#define ACE_LACKS_NETDB_REENTRANT_FUNCTIONS
#define ACE_HAS_2_PARAM_ASCTIME_R_AND_CTIME_R
#if (__FreeBSD_version < 501000)
#define ACE_LACKS_PWD_REENTRANT_FUNCTIONS
#endif
#define ACE_HAS_CONSISTENT_SIGNAL_PROTOTYPES
#define ACE_LACKS_SIGINFO_H
#define ACE_LACKS_SI_ADDR
// Compiler/platform supports SVR4 signal typedef
#define ACE_HAS_SVR4_SIGNAL_T
// Compiler/platform supports alloca().
// Although ACE does have alloca() on this compiler/platform combination, it is
// disabled by default since it can be dangerous. Uncomment the following line
// if you ACE to use it.
//#define ACE_HAS_ALLOCA
// Compiler/platform supports SVR4 dynamic linking semantics..
#define ACE_HAS_SVR4_DYNAMIC_LINKING
// Compiler/platform correctly calls init()/fini() for shared libraries.
#define ACE_HAS_AUTOMATIC_INIT_FINI
// Explicit dynamic linking permits "lazy" symbol resolution
#define ACE_HAS_RTLD_LAZY_V
// platform supports POSIX O_NONBLOCK semantics
#define ACE_HAS_POSIX_NONBLOCK
// platform supports IP multicast
#define ACE_HAS_IP_MULTICAST
// Lacks perfect filtering, must bind group address.
#if !defined ACE_LACKS_PERFECT_MULTICAST_FILTERING
# define ACE_LACKS_PERFECT_MULTICAST_FILTERING 1
#endif /* ACE_LACKS_PERFECT_MULTICAST_FILTERING */
// Compiler/platform has <alloca.h>
//#define ACE_HAS_ALLOCA_H
// Compiler/platform has the getrusage() system call.
#define ACE_HAS_GETRUSAGE
// Compiler/platform defines the sig_atomic_t typedef.
#define ACE_HAS_SIG_ATOMIC_T
// Compiler/platform supports sys_siglist array.
// *** This refers to (_sys_siglist) instead of (sys_siglist)
// #define ACE_HAS_SYS_SIGLIST
// Compiler/platform defines a union semun for SysV shared memory.
#define ACE_HAS_SEMUN
// Compiler supports the ssize_t typedef.
#define ACE_HAS_SSIZE_T
// Compiler/platform supports strerror ().
#define ACE_HAS_STRERROR
// Compiler/platform provides the sockio.h file.
#define ACE_HAS_SOCKIO_H
// Defines the page size of the system.
#define ACE_PAGE_SIZE 4096
// Platform provides <sys/filio.h> header.
#define ACE_HAS_SYS_FILIO_H
// Compiler/platform supports SVR4 gettimeofday() prototype
#define ACE_HAS_SUNOS4_GETTIMEOFDAY
// #define ACE_HAS_TIMEZONE_GETTIMEOFDAY
// Turns off the tracing feature.
#if !defined (ACE_NTRACE)
#define ACE_NTRACE 1
#endif /* ACE_NTRACE */
#define ACE_HAS_MSG
#define ACE_HAS_4_4BSD_SENDMSG_RECVMSG
#if (__FreeBSD_version < 500100)
# define ACE_HAS_NONCONST_MSGSND
#endif
// Thread specific settings
// Yes, we do have threads.
#ifdef ACE_HAS_THREADS
#if !defined (ACE_MT_SAFE)
# define ACE_MT_SAFE 1
#endif /* ! ACE_MT_SAFE */
#endif /* ACE_HAS_THREADS */
#define ACE_LACKS_THREAD_PROCESS_SCOPING
#define ACE_LACKS_CONDATTR_PSHARED
#define ACE_LACKS_MUTEXATTR_PSHARED
#define ACE_HAS_THREAD_SPECIFIC_STORAGE
#define ACE_HAS_DIRENT
#define ACE_HAS_SIGWAIT
#define ACE_HAS_TERM_IOCTLS
#define ACE_USES_NEW_TERMIOS_STRUCT
#define TCGETS TIOCGETA
#define TCSETS TIOCSETA
#define ACE_HAS_UCONTEXT_T
#define ACE_HAS_SOCKLEN_T
#define ACE_HAS_GETIFADDRS
#define ACE_HAS_PTHREADS_UNIX98_EXT
#ifndef ACE_HAS_SNPRINTF
#define ACE_HAS_SNPRINTF
#endif
// Note, on FreeBSD 5, POSIX aio is now an optional kernel module which
// must be loaded.
// Read the aio(4) man page for what to do, otherwise any aio_* call
// will coredump.
// By default use Proactor which does not use POSIX Real-time Signals
#ifdef ACE_HAS_AIO_CALLS
#ifndef ACE_POSIX_AIOCB_PROACTOR
#define ACE_POSIX_AIOCB_PROACTOR
#endif /* ACE_POSIX_AIOCB_PROACTOR */
#endif /* ACE_HAS_AIO_CALLS */
/* FreeBSD does not define sigval_t */
#include <sys/signal.h>
typedef union sigval sigval_t;
#define ACE_LACKS_STROPTS_H
#include /**/ "ace/post.h"
#endif /* ACE_CONFIG_H */
#include <ace/config-freebsd.h>

View file

@ -1,11 +1,12 @@
--- Makefile.orig Tue Dec 2 10:18:36 2003
+++ Makefile Tue Dec 2 10:18:52 2003
@@ -20,8 +20,6 @@
netsvcs \
tests \
apps \
- examples \
- performance-tests \
websvcs \
Kokyu
--- GNUmakefile.orig Mon Dec 6 02:23:28 2004
+++ GNUmakefile Mon Dec 6 02:24:35 2004
@@ -26,9 +26,7 @@
$(KEEP_GOING)@cd ASNMP && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd ACEXML && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd apps && $(MAKE) -f $(MAKEFILE) $(@)
- $(KEEP_GOING)@cd examples && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd netsvcs && $(MAKE) -f $(MAKEFILE) $(@)
- $(KEEP_GOING)@cd performance-tests && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd tests && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd websvcs && $(MAKE) -f $(MAKEFILE) $(@)

View file

@ -1,15 +1,12 @@
--- TAO/Makefile.orig Mon Jan 5 10:18:45 1970
+++ TAO/Makefile Fri Jan 16 02:08:11 2004
@@ -23,11 +23,7 @@
TAO_IDL \
tests \
orbsvcs \
- examples \
- performance-tests \
- utils \
- docs/tutorials/Quoter \
- CIAO
+ utils
--- TAO/GNUmakefile.orig Mon Dec 6 02:26:28 2004
+++ TAO/GNUmakefile Mon Dec 6 02:27:44 2004
@@ -24,9 +24,6 @@
$(KEEP_GOING)@cd TAO_IDL && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd tao && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd orbsvcs && $(MAKE) -f $(MAKEFILE) $(@)
- $(KEEP_GOING)@cd examples && $(MAKE) -f $(MAKEFILE) $(@)
- $(KEEP_GOING)@cd docs && $(MAKE) -f $(MAKEFILE) $(@)
- $(KEEP_GOING)@cd performance-tests && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd tests && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd utils && $(MAKE) -f $(MAKEFILE) $(@)
CLONE = Makefile \
tao \

View file

@ -1,16 +1,10 @@
--- TAO/orbsvcs/Makefile.orig Thu Jan 15 22:51:35 2004
+++ TAO/orbsvcs/Makefile Thu Jan 15 22:52:27 2004
@@ -43,10 +43,9 @@
Trading_Service \
LoadBalancer \
TAO_Service \
- PSS \
- tests \
- performance-tests \
- examples
+ PSS
+
+DIRS += tests
--- TAO/orbsvcs/GNUmakefile.orig Mon Dec 6 02:28:37 2004
+++ TAO/orbsvcs/GNUmakefile Mon Dec 6 02:30:00 2004
@@ -42,7 +42,5 @@
$(KEEP_GOING)@cd Dump_Schedule && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd CosEvent_Service && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd Concurrency_Service && $(MAKE) -f $(MAKEFILE) $(@)
- $(KEEP_GOING)@cd performance-tests && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd tests && $(MAKE) -f $(MAKEFILE) $(@)
- $(KEEP_GOING)@cd examples && $(MAKE) -f $(MAKEFILE) $(@)
ifeq ($(minimum_corba),0)
ifneq (Compilers 4.2,$(findstring Compilers 4.2,$(CC_VERSION)))

View file

@ -0,0 +1,123 @@
--- ace/OS_NS_time.h.orig Thu Jun 11 23:14:04 1970
+++ ace/OS_NS_time.h Mon Dec 6 02:46:06 2004
@@ -4,7 +4,7 @@
/**
* @file OS_NS_time.h
*
- * OS_NS_time.h,v 1.8 2004/06/20 16:51:08 jtc Exp
+ * $Id: OS_NS_time.h,v 1.12 2004/11/12 00:03:08 gmaxey Exp $
*
* @author Douglas C. Schmidt <schmidt@cs.wustl.edu>
* @author Jesper S. M|ller<stophph@diku.dk>
@@ -25,6 +25,7 @@
# pragma once
# endif /* ACE_LACKS_PRAGMA_ONCE */
+#include "ace/OS_NS_errno.h"
#include "ace/Basic_Types.h"
#include "ace/os_include/os_time.h"
#include "ace/ACE_export.h"
@@ -105,10 +106,6 @@
#endif /* ACE_PSOS_HAS_TIME */
#if defined (ACE_HAS_WINCE)
- /// Supporting data for ctime and ctime_r functions on WinCE.
- const wchar_t *day_of_week_name[7];
- const wchar_t *month_name[12];
-
// WinCE doesn't have most of the standard C library time functions. It
// also doesn't define struct tm. SYSTEMTIME has pretty much the same
// info though, so we can map it when needed. Define struct tm here and
@@ -137,48 +134,35 @@
*/
inline long ace_timezone()
{
-#if !defined (VXWORKS) && !defined (ACE_PSOS) && !defined (CHORUS)
-# if defined (ACE_HAS_WINCE)
+#if defined (ACE_HAS_WINCE)
TIME_ZONE_INFORMATION tz;
GetTimeZoneInformation (&tz);
return tz.Bias * 60;
-# elif defined (ACE_WIN32) && !defined (ACE_HAS_DINKUM_STL)
+#elif defined (ACE_WIN32) && !defined (ACE_HAS_DINKUM_STL)
return _timezone; // For Win32.
-# elif defined (ACE_WIN32) && defined (ACE_HAS_DINKUM_STL)
+#elif defined (ACE_WIN32) && defined (ACE_HAS_DINKUM_STL)
time_t tod = time(0); // get current time
time_t t1 = mktime(gmtime(&tod)); // convert without timezone
time_t t2 = mktime(localtime(&tod)); // convert with timezone
return difftime(t1, t2); // compute difference in seconds
-# elif defined (ACE_HAS_TIMEZONE_GETTIMEOFDAY) \
- && !defined (__linux__) \
- && !defined (__FreeBSD__) \
- && !defined (__NetBSD__)
+#elif defined (ACE_HAS_TIMEZONE)
+ // The XPG/POSIX specification requires that tzset() be called to
+ // set the global variable <timezone>.
+ ::tzset();
+ return timezone;
+#elif defined (ACE_HAS_TIMEZONE_GETTIMEOFDAY)
// The XPG/POSIX specification does not require gettimeofday to
// set the timezone struct (it leaves the behavior of passing a
- // non-null struct undefined). We know gettimeofday() on Linux
- // *BSD systems does not set the timezone, so we avoid using it
- // and use the global variable <timezone> instead.
- //
- // @note As of this writing, OpenBSD does not provide the global
- // variable timezone.
- //
- // @todo It would be better if we had a feature test macro that
- // could be used instead of a list of operating systems.
+ // non-null struct undefined).
long result = 0;
struct timeval time;
struct timezone zone;
ACE_UNUSED_ARG (result);
ACE_OSCALL (::gettimeofday (&time, &zone), int, -1, result);
return zone.tz_minuteswest * 60;
-# else /* ACE_HAS_TIMEZONE_GETTIMEOFDAY */
- // The XPG/POSIX specification requires that tzset() be called to
- // set the global variable <timezone>.
- ::tzset();
- return timezone;
-# endif /* ACE_HAS_TIMEZONE_GETTIMEOFDAY */
-#else
+#else
ACE_NOTSUP_RETURN (0);
-#endif /* !ACE_HAS_WINCE && !VXWORKS && !ACE_PSOS */
+#endif
}
@@ -217,6 +201,8 @@
# endif // ACE_LACKS_LONGLONG_T
# elif defined (ACE_PSOS)
typedef ACE_UINT64 ACE_hrtime_t;
+# elif defined (_TNS_R_TARGET)
+typedef long long ACE_hrtime_t;
# else /* !ACE_WIN32 && !ACE_PSOS */
# if defined (ACE_HAS_HI_RES_TIMER) && !defined (ACE_LACKS_LONGLONG_T)
/* hrtime_t is defined on systems (Suns) with ACE_HAS_HI_RES_TIMER */
@@ -227,8 +213,22 @@
# endif /* ACE_WIN32 */
+# if defined (ACE_HRTIME_T_IS_BASIC_TYPE)
+# define ACE_HRTIME_CONVERSION(VAL) (VAL)
+# define ACE_HRTIME_TO_U64(VAL) ACE_U_LongLong(VAL)
+# else
+# define ACE_HRTIME_CONVERSION(VAL) ACE_U64_TO_U32(VAL)
+# define ACE_HRTIME_TO_U64(VAL) (VAL)
+# endif
+
namespace ACE_OS {
+
+# if defined (ACE_HAS_WINCE)
+ /// Supporting data for ctime and ctime_r functions on WinCE.
+ const wchar_t *day_of_week_name[];
+ const wchar_t *month_name[];
+# endif /* ACE_HAS_WINCE */
# if defined (CHORUS) && !defined (CHORUS_4)
// We must format this code as follows to avoid confusing OSE.

View file

@ -0,0 +1,11 @@
--- tests/GNUmakefile.orig Mon Dec 6 03:10:52 2004
+++ tests/GNUmakefile Mon Dec 6 03:11:14 2004
@@ -19,7 +19,7 @@
include $(ACE_ROOT)/include/makeinclude/macros.GNU
-all: Test_Output MT_Reactor_Upcall_Test ACE_Init_Test ACE_Test ARGV_Test Aio_Platform_Test Arg_Shifter_Test Atomic_Op_Test Auto_IncDec_Test Barrier_Test Basic_Types_Test Bound_Ptr_Test Buffer_Stream_Test Bug_1576_Regression_Test CDR_Array_Test CDR_File_Test CDR_Test Cache_Map_Manager_Test Cached_Accept_Conn_Test Cached_Allocator_Test Cached_Conn_Test Capabilities_Test Codecs_Test Collection_Test Config_Test Conn_Test DLL_Test DLL_Test_Lib DLList_Test Date_Time_Test Dev_Poll_Reactor_Test Dirent_Test Dynamic_Priority_Test Enum_Interfaces_Test Env_Value_Test FIFO_Test FlReactor_Test Framework_Component_DLL Framework_Component_Test Future_Set_Test Future_Test Get_Opt_Test Handle_Set_Test Hash_Map_Bucket_Iterator_Test Hash_Map_Manager_Test High_Res_Timer_Test INET_Addr_Test INET_Addr_Test_IPV6 IOStream_Test Lazy_Map_Manager_Test Log_Msg_Test Logging_Strategy_Test MEM_Stream_Test MM_Shared_Memory_Test MT_Reactor_Timer_Test MT_Ref_Counted_Event_Handler_Test MT_Reference_Counted_Notify_Test MT_SOCK_Test Malloc_Test Map_Manager_Test Map_Test Max_Default_Port_Test Max_Default_Port_Test_IPV6 Mem_Map_Test Message_Block_Test Message_Queue_Notifications_Test Message_Queue_Test Message_Queue_Test_Ex Multicast_Test Multicast_Test_IPV6 Multihomed_INET_Addr_Test Multihomed_INET_Addr_Test_IPV6 Naming_Test New_Fail_Test NonBlocking_Conn_Test Notify_Performance_Test OS_Test Object_Manager_Test Obstack_Test OrdMultiSet_Test Pipe_Test Priority_Buffer_Test Priority_Reactor_Test Priority_Task_Test Proactor_Scatter_Gather_Test Proactor_Test Proactor_Test_IPV6 Proactor_Timer_Test Process_Manager_Test Process_Mutex_Test Process_Strategy_Test RB_Tree_Test Reactor_Dispatch_Order_Test Reactor_Exceptions_Test Reactor_Notification_Queue_Test Reactor_Notify_Test Reactor_Performance_Test Reactor_Registration_Test Reactor_Timer_Test Reactors_Test Reader_Writer_Test Recursive_Condition_Bug_Test Recursive_Condition_Test Recursive_Mutex_Test Refcounted_Auto_Ptr_Test Reference_Counted_Event_Handler_Test Reverse_Lock_Test SOCK_Connector_Test SOCK_Dgram_Bcast_Test SOCK_Dgram_Test SOCK_Send_Recv_Test SOCK_Send_Recv_Test_IPV6 SOCK_Test SOCK_Test_IPv6 SPIPE_Test SString_Test SV_Shared_Memory_Test Semaphore_Test Service_Config_DLL Service_Config_Test Signal_Test Sigset_Ops_Test Simple_Message_Block_Test Svc_Handler_Test TP_Reactor_Test TSS_Static_Test TSS_Test Task_Ex_Test Task_Test Thread_Manager_Test Thread_Mutex_Test Thread_Pool_Reactor_Resume_Test Thread_Pool_Reactor_Test Thread_Pool_Test Time_Service_Test Time_Value_Test Timeprobe_Test Timer_Cancellation_Test Timer_Queue_Reference_Counting_Test Timer_Queue_Test TkReactor_Test Token_Strategy_Test Tokens_Test UPIPE_SAP_Test UUIDTest Unbounded_Set_Test_Ex Upgradable_RW_Test Vector_Test WFMO_Reactor_Test XtReactor_Test
+all: Test_Output MT_Reactor_Upcall_Test ACE_Init_Test ACE_Test ARGV_Test Aio_Platform_Test Arg_Shifter_Test Atomic_Op_Test Auto_IncDec_Test Barrier_Test Basic_Types_Test Bound_Ptr_Test Buffer_Stream_Test Bug_1576_Regression_Test CDR_Array_Test CDR_File_Test CDR_Test Cache_Map_Manager_Test Cached_Accept_Conn_Test Cached_Allocator_Test Cached_Conn_Test Capabilities_Test Codecs_Test Collection_Test Config_Test Conn_Test DLL_Test DLL_Test_Lib DLList_Test Date_Time_Test Dev_Poll_Reactor_Test Dirent_Test Dynamic_Priority_Test Enum_Interfaces_Test Env_Value_Test FIFO_Test FlReactor_Test Framework_Component_DLL Framework_Component_Test Future_Set_Test Future_Test Get_Opt_Test Handle_Set_Test Hash_Map_Bucket_Iterator_Test Hash_Map_Manager_Test High_Res_Timer_Test INET_Addr_Test INET_Addr_Test_IPV6 IOStream_Test Lazy_Map_Manager_Test Log_Msg_Test Logging_Strategy_Test MEM_Stream_Test MM_Shared_Memory_Test MT_Reactor_Timer_Test MT_Ref_Counted_Event_Handler_Test MT_Reference_Counted_Notify_Test MT_SOCK_Test Malloc_Test Map_Manager_Test Map_Test Max_Default_Port_Test Max_Default_Port_Test_IPV6 Mem_Map_Test Message_Block_Test Message_Queue_Notifications_Test Message_Queue_Test Message_Queue_Test_Ex Multicast_Test Multicast_Test_IPV6 Multihomed_INET_Addr_Test Multihomed_INET_Addr_Test_IPV6 Naming_Test New_Fail_Test NonBlocking_Conn_Test Notify_Performance_Test OS_Test Object_Manager_Test Obstack_Test OrdMultiSet_Test Pipe_Test Priority_Buffer_Test Priority_Reactor_Test Priority_Task_Test Process_Manager_Test Process_Mutex_Test Process_Strategy_Test RB_Tree_Test Reactor_Dispatch_Order_Test Reactor_Exceptions_Test Reactor_Notification_Queue_Test Reactor_Notify_Test Reactor_Performance_Test Reactor_Registration_Test Reactor_Timer_Test Reactors_Test Reader_Writer_Test Recursive_Condition_Bug_Test Recursive_Condition_Test Recursive_Mutex_Test Refcounted_Auto_Ptr_Test Reference_Counted_Event_Handler_Test Reverse_Lock_Test SOCK_Connector_Test SOCK_Dgram_Bcast_Test SOCK_Dgram_Test SOCK_Send_Recv_Test SOCK_Send_Recv_Test_IPV6 SOCK_Test SOCK_Test_IPv6 SPIPE_Test SString_Test SV_Shared_Memory_Test Semaphore_Test Service_Config_DLL Service_Config_Test Signal_Test Sigset_Ops_Test Simple_Message_Block_Test Svc_Handler_Test TP_Reactor_Test TSS_Static_Test TSS_Test Task_Ex_Test Task_Test Thread_Manager_Test Thread_Mutex_Test Thread_Pool_Reactor_Resume_Test Thread_Pool_Reactor_Test Thread_Pool_Test Time_Service_Test Time_Value_Test Timeprobe_Test Timer_Cancellation_Test Timer_Queue_Reference_Counting_Test Timer_Queue_Test TkReactor_Test Token_Strategy_Test Tokens_Test UPIPE_SAP_Test UUIDTest Unbounded_Set_Test_Ex Upgradable_RW_Test Vector_Test WFMO_Reactor_Test XtReactor_Test
$(KEEP_GOING)@cd RMCast && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd SSL && $(MAKE) -f $(MAKEFILE) $(@)

View file

@ -0,0 +1,10 @@
--- TAO/orbsvcs/tests/Security/GNUmakefile.orig Tue Dec 7 12:10:52 2004
+++ TAO/orbsvcs/tests/Security/GNUmakefile Tue Dec 7 12:11:04 2004
@@ -24,7 +24,6 @@
$(KEEP_GOING)@cd Big_Request && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd Callback && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd Crash_Test && $(MAKE) -f $(MAKEFILE) $(@)
- $(KEEP_GOING)@cd MT_IIOP_SSL && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd MT_SSLIOP && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd Secure_Invocation && $(MAKE) -f $(MAKEFILE) $(@)
$(KEEP_GOING)@cd SecurityLevel1 && $(MAKE) -f $(MAKEFILE) $(@)

File diff suppressed because it is too large Load diff

View file

@ -7,7 +7,6 @@
PORTNAME= ace
PORTVERSION= ${ACE_VERSION}
PORTREVISION= 1
PKGNAMESUFFIX=
COMMENT= The Adaptive Communication Environment for C++