- Update to version 0.6.4 (This is bugfix release, which fixes some of
software bugs) - Mark it as broken on 4.x (missing sys/statvfs.h) - Port now requires KDEBASE instead KDELIBS PR: ports/90420 Submitted by: Rashid N. Achilov <shelton@ns.granch.ru>
This commit is contained in:
parent
5f4d62af14
commit
78aa3c31e6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=152112
2 changed files with 8 additions and 15 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= smb4k
|
||||
PORTVERSION= 0.6.3
|
||||
PORTVERSION= 0.6.4
|
||||
CATEGORIES= net kde
|
||||
MASTER_SITES= http://download.berlios.de/smb4k/
|
||||
|
||||
|
@ -16,9 +16,7 @@ COMMENT= KDE 3.x SMB Network browser and SMB shares mounting center
|
|||
RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
|
||||
smbstatus:${PORTSDIR}/net/samba3
|
||||
|
||||
BROKEN= Does not compile
|
||||
|
||||
USE_KDELIBS_VER= 3
|
||||
USE_KDEBASE_VER= 3
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -31,6 +29,12 @@ PLIST_SUB= DOCSDIR=${DOCSDIR}
|
|||
USE_AUTOTOOLS= libtool:15
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= "does not build on 4.x (missing sys/statvfs.h)"
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.for i in smb2awk smb2nsmbrc
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/${i} ${PREFIX}/bin
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- smb4k/core/smb4kfileio.cpp.bak Mon Oct 31 17:09:18 2005
|
||||
+++ smb4k/core/smb4kfileio.cpp Mon Oct 31 17:09:18 2005
|
||||
@@ -221,7 +221,7 @@
|
||||
contents.append( "smb4k_mount\t"+m_config->readPathEntry( "smb4k_mount" )+"\t$(Smb4KUsers)\tuid=root\tgid=root\tenv=PASSWD,USER" );
|
||||
#else
|
||||
contents.append( "smb4k_kill\t"+m_config->readPathEntry( "smb4k_kill" )+"\t$(Smb4KUsers)\tuid=root\tgid=wheel" );
|
||||
- contents.append( "smb4k_umount\t"+m_config->readPathEntry( "smb4k_umount" )+"\t$(Smb4KUsers)\tuid=root\tgid=wheel" );item
|
||||
+ contents.append( "smb4k_umount\t"+m_config->readPathEntry( "smb4k_umount" )+"\t$(Smb4KUsers)\tuid=root\tgid=wheel" );
|
||||
contents.append( "smb4k_mount\t"+m_config->readPathEntry( "smb4k_mount" )+"\t$(Smb4KUsers)\tuid=root\tgid=wheel\tsetenv=HOME=$CALLER_HOME\tenv=PASSWD,USER" );
|
||||
#endif
|
||||
contents.append( "# End of Smb4K user entries." );
|
Loading…
Reference in a new issue