Add port of libxkbfile from X.Org release 6.7.0.
This commit is contained in:
parent
570af025bc
commit
78ca695845
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108714
6 changed files with 87 additions and 0 deletions
|
@ -109,6 +109,7 @@
|
|||
SUBDIR += libsx
|
||||
SUBDIR += libxfce4mcs
|
||||
SUBDIR += libxfce4util
|
||||
SUBDIR += libxkbfile
|
||||
SUBDIR += libxklavier
|
||||
SUBDIR += linux-XFree86-libs
|
||||
SUBDIR += linux-gnomelibs
|
||||
|
|
35
x11/libxkbfile/Makefile
Normal file
35
x11/libxkbfile/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: libxkbfile
|
||||
# Date Created: 7 May 2004
|
||||
# Whom: Eric Anholt <anholt@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libxkbfile
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://freedesktop.org/~xorg/X11R6.7.0/src/
|
||||
DISTNAME= X11R6.7.0-src1
|
||||
|
||||
MAINTAINER= x11@FreeBSD.org
|
||||
COMMENT= XKB file library
|
||||
|
||||
LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
|
||||
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions \
|
||||
${LIB_PC_DEPENDS}
|
||||
RUN_DEPENDS= ${LIB_PC_DEPENDS}
|
||||
|
||||
CONFLICTS= XFree86-libraries-*
|
||||
|
||||
USE_IMAKE= yes
|
||||
USE_X_PREFIX= no
|
||||
PREFIX?= ${X11BASE}
|
||||
DIST_SUBDIR= xorg
|
||||
INSTALLS_SHLIB= yes
|
||||
WRKSRC= ${WRKDIR}/xc/lib/xkbfile
|
||||
EXTRACT_AFTER_ARGS= | ${TAR} -xf - xc/lib/xkbfile
|
||||
|
||||
post-patch:
|
||||
${LN} -s ${WRKSRC}/exports/include/X11 ${WRKSRC}/
|
||||
|
||||
.include <bsd.port.mk>
|
2
x11/libxkbfile/distinfo
Normal file
2
x11/libxkbfile/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (xorg/X11R6.7.0-src1.tar.gz) = 22465263bae7a2e9f5ad77e172cf1ab5
|
||||
SIZE (xorg/X11R6.7.0-src1.tar.gz) = 30039655
|
34
x11/libxkbfile/files/patch-Imakefile
Normal file
34
x11/libxkbfile/files/patch-Imakefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- Imakefile.orig Thu Mar 4 09:47:14 2004
|
||||
+++ Imakefile Sat May 8 14:39:42 2004
|
||||
@@ -5,24 +5,19 @@
|
||||
|
||||
XCOMM $XFree86: xc/lib/xkbfile/Imakefile,v 3.5 2003/10/15 21:23:38 herrb Exp $
|
||||
|
||||
-#define DoNormalLib NormalLibxkbfile
|
||||
-#define DoSharedLib SharedLibxkbfile
|
||||
-#define DoExtraLib SharedLibxkbfile
|
||||
-#define DoDebugLib DebugLibxkbfile
|
||||
-#define DoProfileLib ProfileLibxkbfile
|
||||
+#define DoNormalLib YES
|
||||
+#define DoSharedLib YES
|
||||
+#define DoExtraLib YES
|
||||
+#define DoDebugLib NO
|
||||
+#define DoProfileLib NO
|
||||
#define HasSharedData NO
|
||||
#define LibName xkbfile
|
||||
#define SoRev SOXKBFILEREV
|
||||
+SOXKBFILEREV = 1.0
|
||||
#define IncSubdir X11
|
||||
#define IncSubSubdir extensions
|
||||
|
||||
-#ifdef SharedxkbfileReqs
|
||||
-REQUIREDLIBS = SharedxkbfileReqs
|
||||
-#endif
|
||||
-
|
||||
-#if !BuildXKBfilelib
|
||||
-#define LibBuild NO
|
||||
-#endif
|
||||
+REQUIREDLIBS = $(LDPRELIB) $(XONLYLIB)
|
||||
|
||||
SRCS = xkbtext.c xkbdraw.c xkbmisc.c xkbatom.c xkberrs.c \
|
||||
cout.c xkbout.c xkmout.c \
|
6
x11/libxkbfile/pkg-descr
Normal file
6
x11/libxkbfile/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
This package contains the XKB file library.
|
||||
|
||||
WWW: http://www.freedesktop.org/Software/xorg
|
||||
|
||||
- Eric Anholt
|
||||
anholt@FreeBSD.org
|
9
x11/libxkbfile/pkg-plist
Normal file
9
x11/libxkbfile/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
include/X11/extensions/XKBbells.h
|
||||
include/X11/extensions/XKBconfig.h
|
||||
include/X11/extensions/XKBfile.h
|
||||
include/X11/extensions/XKBrules.h
|
||||
include/X11/extensions/XKM.h
|
||||
include/X11/extensions/XKMformat.h
|
||||
lib/libxkbfile.a
|
||||
lib/libxkbfile.so
|
||||
lib/libxkbfile.so.1
|
Loading…
Reference in a new issue