2008-10-19 x11-wm/flwm: Project is dead, and uses obsolete version of fltk

2008-09-19 x11-wm/kahakai: "Development ceased"
2008-08-24 palm/synce-gnomevfs: No longer supported by developers
2008-08-24 palm/synce-kde: No longer supported by developers
2008-08-24 palm/synce-multisync: No longer supported by developers
2008-12-06 shells/ksh93-devel: This port is Outdated.  Please use shells/ksh93
2008-09-19 sysutils/dtc-toaster: Has been broken for more than 6 months
2008-09-19 sysutils/dusage: Has been broken for more than 6 months
2008-09-19 games/linux-alienarena: Has been broken for more than 6 months
This commit is contained in:
Martin Wilke 2008-12-07 19:49:39 +00:00
parent 948660c780
commit 78cdba8e1a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=223968
50 changed files with 9 additions and 917 deletions

1
LEGAL
View file

@ -169,7 +169,6 @@ doomsrc.zip games/doom Requested by id Software
dr_freebsd_*.zip sysutils/megarc Must be downloaded manually
drweb-qmail-*.tar.gz security/drweb-qmail Non-commercial or evaluation use
dsnake-* games/dsnake License prohibits any reselling
dusage.tar.Z sysutils/dusage Peaceware
eagle-*.tgz cad/linux-eagle Usage permitted for
non-commercial purposes only
eawpats* audio/eawpats Some of the patches are not

9
MOVED
View file

@ -3670,3 +3670,12 @@ emulators/linux_dist-gentoo-stage2||2008-11-24|Removed
mail/libspf-alt||2008-12-03|Removed
devel/php5-pcre|lang/php5|2008-12-07|Integrated in base php
portuguese/aspell|portuguese/aspell-pt_PT|2008-12-07|Repocopy finished for proper package naming
x11-wm/flwm||2008-12-07|Has expired: Project is dead, and uses obsolete version of fltk
x11-wm/kahakai||2008-12-07|Has expired: "Development ceased"
palm/synce-gnomevfs||2008-12-07|Has expired: No longer supported by developers
palm/synce-kde||2008-12-07|Has expired: No longer supported by developers
palm/synce-multisync||2008-12-07|Has expired: No longer supported by developers
shells/ksh93-devel||2008-12-07|Has expired: This port is Outdated. Please use shells/ksh93
sysutils/dtc-toaster||2008-12-07|Has expired: Has been broken for more than 6 months
sysutils/dusage||2008-12-07|Has expired: Has been broken for more than 6 months
games/linux-alienarena||2008-12-07|Has expired: Has been broken for more than 6 months

View file

@ -437,7 +437,6 @@
SUBDIR += libshhcards
SUBDIR += lincity
SUBDIR += lincity-ng
SUBDIR += linux-alienarena
SUBDIR += linux-americasarmy
SUBDIR += linux-darwinia-demo
SUBDIR += linux-defcon

View file

@ -1,100 +0,0 @@
# New ports collection makefile for: Alien Arena 2006
# Date created: 2005-11-12
# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
#
# $FreeBSD$
#
PORTNAME= alienarena
PORTVERSION= 2007.610
PORTEPOCH= 1
CATEGORIES= games linux
MASTER_SITES= ftp://ftp.simtel.com/pub/gamezone/31/5/17/
PKGNAMEPREFIX= linux-
DISTNAME= ${PORTNAME}2007-20071011-linux
MAINTAINER= alepulver@FreeBSD.org
COMMENT= Alien Arena 2006 (Linux version)
RUN_DEPENDS= ${DATADIR}/arena/default.cfg:${PORTSDIR}/games/alienarena-data
BROKEN= needs missing/outdated Linux dependencies (need new linux_compat port and FreeBSD 7); use native instead for now
DEPRECATED= Has been broken for more than 6 months
EXPIRATION_DATE=2008-09-19
USE_ZIP= yes
USE_LINUX= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}2007
OPTIONS= CLIENT "Install client" on \
DEDICATED "Install dedicated server" on \
SDL "Install client that uses SDL for sound" on
SUB_LIST= LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
LIBDIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
.include <bsd.port.pre.mk>
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
defined(WITHOUT_SDL)
IGNORE= needs at least one executable (CLIENT, DEDICATED or SDL)
.endif
.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SDL)
# FIXME: needs OpenSSL 0.9.8 and libidn for Linux (not updated/available).
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libcurl.so.3:${PORTSDIR}/ftp/linux-curl \
${LINUXBASE}/lib/libssl.so.5:${PORTSDIR}/security/linux-openssl
USE_GL= linux
.endif
.if !defined(WITHOUT_CLIENT)
AA_SCRIPTS+= linux-alienarena
AA_TARGETS+= crx
PLIST_SUB+= CLIENT=""
.else
PLIST_SUB+= CLIENT="@comment "
.endif
.if !defined(WITHOUT_DEDICATED)
AA_SCRIPTS+= linux-alienarena-ded
AA_TARGETS+= crded
PLIST_SUB+= DEDICATED=""
.else
PLIST_SUB+= DEDICATED="@comment "
.endif
.if !defined(WITHOUT_SDL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
AA_SCRIPTS+= linux-alienarena-sdl
AA_TARGETS+= crx.sdl
PLIST_SUB+= SDL=""
.else
PLIST_SUB+= SDL="@comment "
.endif
SUB_FILES+= ${AA_SCRIPTS}
do-install:
${MKDIR} ${LIBDIR}/arena ${LIBDIR}/data1
cd ${WRKSRC} && \
${INSTALL_PROGRAM} arena/game.so ${LIBDIR}/arena && \
${INSTALL_PROGRAM} data1/game.so ${LIBDIR}/data1
${LN} -sf ${DATADIR}/arena/* ${LIBDIR}/arena
${LN} -sf ${DATADIR}/botinfo ${LIBDIR}
${LN} -sf ${DATADIR}/data1/* ${LIBDIR}/data1
.for f in ${AA_SCRIPTS}
${INSTALL_SCRIPT} ${WRKDIR}/${f} ${PREFIX}/bin
.endfor
.for f in ${AA_TARGETS}
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${LIBDIR}
.endfor
post-install:
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (alienarena2007-20071011-linux.zip) = 7ebb0dfeec4be80311921a075379c8dc
SHA256 (alienarena2007-20071011-linux.zip) = 33036bd0dec77ae06c113d8e06718bd6f9e42efb634ee304c3fd9d48184c2e20
SIZE (alienarena2007-20071011-linux.zip) = 245067302

View file

@ -1,5 +0,0 @@
#!/bin/sh
cd %%LIBDIR%% || exit 1
exec ./crded +set port 27910 "$@"

View file

@ -1,5 +0,0 @@
#!/bin/sh
cd %%LIBDIR%% || exit 1
exec ./crx.sdl "$@"

View file

@ -1,5 +0,0 @@
#!/bin/sh
cd %%LIBDIR%% || exit 1
exec ./crx +set "$@"

View file

@ -1,18 +0,0 @@
AA2K7 is the latest version of a freeware online deathmatch game that was
first introduced to the public in October, 2004. Since that initial release,
nearly every aspect of the game has been revamped, in fact, much of the
content and code from the November 2005 release of Alien Arena 2006 has been
redone as well. It's like an entirely new game, and it may shock people just
how much it has improved in less than a year's time. With 35 levels, five
modes of play, loads of mutators, built-in bots, 11 player characters, 8
weapons(with alt-fire modes), the game has an endless supply of replayability.
With so many new features, AA2K7 is nearly an entirely new game when held in
comparison to it's predecessor. With the trials and tribulations of software
development, endless hours of playing, gathering feedback, COR Entertainment
has been able to not only fine tune and perfect it's flagship game, but add
completely new dimensions to it.
Note: this port contains the Linux version of Alien Arena. See
"games/alienarena" for the native version.
WWW: http://red.planetarena.org/

View file

@ -1,15 +0,0 @@
==============================================================================
Alien Arena (Linux version) has been installed.
The OSS (native FreeBSD sound) version of Alien Arena 2006 (named
"linux-alienarena") uses by default a slow sound speed, which causes a notable
delay. To solve this you have to run it once like this:
$ linux-alienarena +set sndspeed <speed>
Where <speed> could be 22050 and 44100 for example (the default that has the
delay is 11025, and the SDL version uses 22050). The value of "sndspeed" will
be saved in the configuration file for future runs.
==============================================================================

View file

@ -1,33 +0,0 @@
%%CLIENT%%bin/linux-alienarena
%%DEDICATED%%bin/linux-alienarena-ded
%%SDL%%bin/linux-alienarena-sdl
%%LIBDIR%%/arena/default.cfg
%%LIBDIR%%/arena/game.so
%%LIBDIR%%/arena/maps.lst
%%LIBDIR%%/arena/motd.txt
%%LIBDIR%%/arena/pics
%%LIBDIR%%/arena/server.cfg
%%LIBDIR%%/botinfo
%%DEDICATED%%%%LIBDIR%%/crded
%%CLIENT%%%%LIBDIR%%/crx
%%SDL%%%%LIBDIR%%/crx.sdl
%%LIBDIR%%/data1/default.cfg
%%LIBDIR%%/data1/env
%%LIBDIR%%/data1/fonts
%%LIBDIR%%/data1/game.so
%%LIBDIR%%/data1/gfx
%%LIBDIR%%/data1/levelshots
%%LIBDIR%%/data1/maps
%%LIBDIR%%/data1/maps.lst
%%LIBDIR%%/data1/models
%%LIBDIR%%/data1/particles
%%LIBDIR%%/data1/pics
%%LIBDIR%%/data1/players
%%LIBDIR%%/data1/scripts
%%LIBDIR%%/data1/sound
%%LIBDIR%%/data1/sprites
%%LIBDIR%%/data1/textures
%%LIBDIR%%/data1/vehicles
@dirrm %%LIBDIR%%/data1
@dirrm %%LIBDIR%%/arena
@dirrm %%LIBDIR%%

View file

@ -35,14 +35,11 @@
SUBDIR += py-synce-librra
SUBDIR += romeo
SUBDIR += sitescooper
SUBDIR += synce-gnomevfs
SUBDIR += synce-gvfs
SUBDIR += synce-hal
SUBDIR += synce-kde
SUBDIR += synce-librapi2
SUBDIR += synce-libsynce
SUBDIR += synce-librra
SUBDIR += synce-multisync
SUBDIR += synce-serial
SUBDIR += synce-sync-engine
SUBDIR += synce-trayicon

View file

@ -1,36 +0,0 @@
# New ports collection makefile for: synce-gnomevfs
# Date created: 28 August 2003
# Whom: Sam Lawrance <boris@brooknet.com.au>
#
# $FreeBSD$
#
PORTNAME= synce-gnomevfs
PORTVERSION= 0.9.0
PORTREVISION= 6
CATEGORIES= palm
MASTER_SITES= SF/synce
MAINTAINER= ports@logvinov.com
COMMENT= Gnome VFS module for WinCE devices
LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomeprefix gnometarget gnomevfs2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
--with-libsynce=${LOCALBASE}
BROKEN= No longer supported by developers
DEPRECATED= ${BROKEN}
EXPIRATION_DATE= 2008-08-24
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
post-patch:
${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/src/Makefile.in
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (synce-gnomevfs-0.9.0.tar.gz) = 1fa8d653297331479edcd5d983a0f75e
SHA256 (synce-gnomevfs-0.9.0.tar.gz) = 2dc8d4905b81e4303e9131dd8f737e7facae9ca7065ec7f9faba15238774b5cd
SIZE (synce-gnomevfs-0.9.0.tar.gz) = 303885

View file

@ -1,26 +0,0 @@
--- src/libsyncevfs.c.orig Sun Aug 22 21:06:29 2004
+++ src/libsyncevfs.c Sat Jan 8 18:40:37 2005
@@ -126,8 +126,9 @@
{
if (!initialized_rapi)
{
+ HRESULT hr;
MUTEX_LOCK (mutex);
- HRESULT hr = CeRapiInit();
+ hr = CeRapiInit();
MUTEX_UNLOCK (mutex);
if (FAILED(hr))
@@ -145,9 +146,10 @@
static int get_location(GnomeVFSURI *uri, gchar **location)/*{{{*/
{
- int result = INDEX_INVALID;
- *location = NULL;
+ int result;
gchar **path = NULL;
+ *location = NULL;
+ result = INDEX_INVALID;
path = g_strsplit(gnome_vfs_unescape_string(gnome_vfs_uri_get_path(uri),"\\"), "/", 0);

View file

@ -1,5 +0,0 @@
SynCE is a project for connecting to devices running Windows CE or Pocket PC.
Gnomevfs gives Gnome applications like Nautilus the ability to access the file
system on a Windows CE device via gnomevfs.
WWW: http://synce.sourceforge.net/

View file

@ -1,9 +0,0 @@
bin/synce-in-computer-folder
etc/gnome-vfs-2.0/modules/synce-module.conf
share/pixmaps/synce/synce-color.png
share/synce/synce-in-computer-folder.sh
lib/gnome-vfs-2.0/modules/libsyncevfs.a
lib/gnome-vfs-2.0/modules/libsyncevfs.la
lib/gnome-vfs-2.0/modules/libsyncevfs.so
@dirrmtry share/pixmaps/synce
@dirrmtry share/synce

View file

@ -1,44 +0,0 @@
# New ports collection makefile for: rapip
# Date created: 15 June 2003
# Whom: Sam Lawrance <boris@brooknet.com.au>
#
# $FreeBSD$
PORTNAME= synce-kde
PORTVERSION= 0.9.1
PORTREVISION= 5
CATEGORIES= palm
MASTER_SITES= SF/synce
MAINTAINER= ports@FreeBSD.org
COMMENT= SynCE KDE Utilities
LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce \
rapi.2:${PORTSDIR}/palm/synce-librapi2 \
rra.0:${PORTSDIR}/palm/synce-librra \
dynamite.0:${PORTSDIR}/archivers/libdynamite \
orange.0:${PORTSDIR}/archivers/liborange \
unshield.0:${PORTSDIR}/archivers/unshield
RUN_DEPENDS+= synce-serial-start:${PORTSDIR}/palm/synce-serial
BROKEN= No longer supported by developers
DEPRECATED= ${BROKEN}
EXPIRATION_DATE= 2008-08-24
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_ICONV= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
INSTALLS_ICONS= yes
USE_GETTEXT= yes
PORTDOCS= *
DOCSDIR= ${PREFIX}/share/doc/HTML/en/raki
post-install:
${INSTALL} -c -o root -g wheel ${WRKSRC}/rapip/.libs/kio_rapip.lai ${PREFIX}/lib/kde3/kio_rapip.la
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (synce-kde-0.9.1.tar.gz) = 213ea85f85414b9f05f4252028bce134
SHA256 (synce-kde-0.9.1.tar.gz) = 53635dddc4a08af1010c226857e3ad8643ed142429d9d4c0f862b5a7ff329fd2
SIZE (synce-kde-0.9.1.tar.gz) = 900696

View file

@ -1,6 +0,0 @@
SynCE is a project for connecting to devices running Windows CE or Pocket PC.
Synce-KDE provides KDE users transparent access to the files and information
on their Windows CE device as if it were a local folder. It also provides
a system tray application and PDA connection manager.
WWW: http://synce.sourceforge.net/

View file

@ -1,48 +0,0 @@
bin/raki
bin/vdccm
include/rakiapi.h
include/rakisyncfactory.h
include/rakisyncplugin.h
include/rapiwrapper.h
include/rra.h
lib/kde3/kio_rapip.a
lib/kde3/kio_rapip.la
lib/kde3/kio_rapip.so
share/applnk/Utilities/raki.desktop
share/apps/konqueror/servicemenus/cab_install.desktop
share/apps/raki/Infbeg.wav
share/apps/raki/Infend.wav
share/apps/raki/scripts/dccm.sh
share/apps/raki/scripts/vdccm.sh
share/apps/raki/tips
share/icons/hicolor/16x16/apps/raki.png
share/icons/hicolor/16x16/apps/raki_bw.png
share/icons/hicolor/16x16/apps/rapip.png
share/icons/hicolor/16x16/apps/rapip_bw.png
share/icons/hicolor/22x22/apps/raki.png
share/icons/hicolor/22x22/apps/raki_bw.png
share/icons/hicolor/22x22/apps/rapip.png
share/icons/hicolor/22x22/apps/rapip_bw.png
share/icons/hicolor/32x32/apps/raki.png
share/icons/hicolor/32x32/apps/raki_bw.png
share/icons/hicolor/32x32/apps/rapip.png
share/icons/hicolor/32x32/apps/rapip_bw.png
share/icons/hicolor/48x48/apps/raki.png
share/icons/hicolor/48x48/apps/raki_bw.png
share/icons/hicolor/48x48/apps/rapip.png
share/icons/hicolor/48x48/apps/rapip_bw.png
share/icons/hicolor/64x64/apps/raki.png
share/icons/hicolor/64x64/apps/raki_bw.png
share/icons/hicolor/64x64/apps/rapip.png
share/icons/hicolor/64x64/apps/rapip_bw.png
share/locale/de/LC_MESSAGES/synce-kde.mo
share/locale/fr/LC_MESSAGES/synce-kde.mo
share/mimelnk/application/x-raki.desktop
share/services/rapip.protocol
share/servicetypes/rakisynchronizer.desktop
%%PORTDOCS%%%%DOCSDIR%%/index.docbook
%%PORTDOCS%%%%DOCSDIR%%/index.cache.bz2
%%PORTDOCS%%%%DOCSDIR%%/common
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/apps/raki/scripts
@dirrm share/apps/raki

View file

@ -1,39 +0,0 @@
# New ports collection makefile for: synce-multisync
# Date created: September 2004
# Whom: Sam Lawrance <boris@brooknet.com.au>
#
# $FreeBSD$
#
PORTNAME= synce-multisync_plugin
PORTVERSION= 0.9.0
PORTREVISION= 8
CATEGORIES= palm deskutils
MASTER_SITES= SF/synce
MAINTAINER= ports@FreeBSD.org
COMMENT= SynCE synchronisation plugin for Multisync
LIB_DEPENDS= rra.0:${PORTSDIR}/palm/synce-librra \
synce.0:${PORTSDIR}/palm/synce-libsynce
BUILD_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync
RUN_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync
USE_GNOME= gnomeprefix gnometarget gnomevfs2
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
--with-libsynce=${LOCALBASE} \
--with-librra=${LOCALBASE} \
--with-multisync-include=${LOCALBASE}/include/multisync
CONFIGURE_ENV+= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
BROKEN= No longer supported by developers
DEPRECATED= ${BROKEN}
EXPIRATION_DATE= 2008-08-24
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (synce-multisync_plugin-0.9.0.tar.gz) = 0273cac4d2bce299aec8a51b08101985
SHA256 (synce-multisync_plugin-0.9.0.tar.gz) = 70f1a0e4bbeaf71f7403af95aac56eeb7aae0791e2303521e2d0e682c815a94d
SIZE (synce-multisync_plugin-0.9.0.tar.gz) = 327269

View file

@ -1,4 +0,0 @@
This plugin adds a SynCE connector to Multisync, making it possible to sync
your Pocket PC with any other Multisync supported device or software.
WWW: http://synce.sourceforge.net/

View file

@ -1,7 +0,0 @@
lib/multisync/libsynce_plugin.a
lib/multisync/libsynce_plugin.la
lib/multisync/libsynce_plugin.so
lib/multisync/libsynce_plugin.so.0
share/synce/synce_multisync_plugin.glade
@dirrm share/synce
@dirrmtry lib/multisync

View file

@ -18,7 +18,6 @@
SUBDIR += heirloom-sh
SUBDIR += ibsh
SUBDIR += ksh93
SUBDIR += ksh93-devel
SUBDIR += mksh
SUBDIR += nologinmsg
SUBDIR += osh

View file

@ -1,92 +0,0 @@
# New ports collection makefile for: ksh93
# Date created: 2008-10-29
# Whom: Joe Kelsey <joe@zircon.seattle.wa.us>
#
# $FreeBSD$
#
# This port is intended to allow interested users to easily install the
# beta versions of ksh93 releases.
#
# WARNING:
#
# No official FreeBSD support is provided to anything related to the
# ksh93 beta testing process. Anyone who uses this port is personally
# responsible for signing up and monitoring the ast-users and
# ast-developers mailing lists and for personally reporting any ksh93
# problems on thos mailing lists. If you try to report a ksh93-devel
# problem on the FreeBSD bug list, I will ignore it completely.
#
# I will attempt to keep the date of the beta port more or less current,
# but I will not make sure that the date is correct at all times.
# Keeping the date current in a rapidly changing beta schedule will
# depend on how quickly the various port updaters respond to correction
# notices and whether or not the ports tree is even open. The best
# thing to do is to personally monitor the ast-users and ast-developers
# mailing lists and keep the date correct on your own copy of the port.
#
# Cannot have both ksh93 and ksh93-devel on the same machine.
#
# Visit http://www.research.att.com/sw/ for information about the
# mailing lists.
#
PORTNAME= ksh93-devel
PORTVERSION= ${VERSION:S/-//g}
CATEGORIES= shells
MASTER_SITES= http://www.research.att.com/sw/download/beta/
DISTNAME= ${PORTNAME}-${VERSION}
DISTFILES= INIT.${VERSION}.tgz ast-ksh.${VERSION}.tgz
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= joe@zircon.seattle.wa.us
COMMENT= Official AT&T Beta release of KornShell 93
EXPIRATION_DATE= 2008-12-06
DEPRECATED= This port is Outdated. Please use shells/ksh93
CONFLICTS= ksh93-200*
MANUAL_PACKAGE_BUILD=Doesn't build in tinderbox environment
VERSION= 2008-10-31
RESTRICTED= Source recipient must acknowledge license
FETCH_ENV= HTTP_AUTH='basic:*:I accept www.opensource.org/licenses/cpl:.'
FETCH_CMD= /usr/bin/fetch -Rr # see bin/76134
NO_WRKSUBDIR= yes
MAKE_ENV= CCFLAGS="${CFLAGS}"
.if defined(WANT_STATIC)
MAKE_ENV+= LDFLAGS=-static
.endif
MAN1= ksh93.1
.include <bsd.port.pre.mk>
INSTALLROOT= ${WRKSRC}/arch/freebsd${OSREL:R}.${ARCH}
do-build:
@cd ${WRKSRC} && ${SETENV} -i ${MAKE_ENV} ${SH} bin/package make
do-install:
${INSTALL_PROGRAM} ${INSTALLROOT}/bin/ksh ${PREFIX}/bin/ksh93
${INSTALL_MAN} ${INSTALLROOT}/man/man1/sh.1 \
${MANPREFIX}/man/man1/ksh93.1
${MKDIR} ${PREFIX}/share/examples/ksh93-devel
.for fun in dirs popd pushd
${INSTALL_SCRIPT} ${INSTALLROOT}/fun/${fun} \
${PREFIX}/share/examples/ksh93-devel/
.endfor
post-install:
@${ECHO} "updating /etc/shells"
@${CP} /etc/shells /etc/shells.bak
@(${GREP} -v ${PREFIX}/bin/ksh93 /etc/shells.bak; \
${ECHO_CMD} ${PREFIX}/bin/ksh93) >/etc/shells
@${RM} -f /etc/shells.bak
test: build
@cd ${WRKSRC}/src/cmd/ksh93/tests && \
${SETENV} SHELL=${INSTALLROOT}/bin/ksh \
${INSTALLROOT}/bin/ksh shtests
.include <bsd.port.post.mk>

View file

@ -1,6 +0,0 @@
MD5 (ksh93-devel/INIT.2008-10-31.tgz) = bf4f4a8ef0d6b1fbd0930633241048fe
SHA256 (ksh93-devel/INIT.2008-10-31.tgz) = 3b61ac0dce13a290cce379c83db9420fe9f2da979f1f1b4fab93370f0484e758
SIZE (ksh93-devel/INIT.2008-10-31.tgz) = 350827
MD5 (ksh93-devel/ast-ksh.2008-10-31.tgz) = 2332d5da307f5d01f105588b61d2c293
SHA256 (ksh93-devel/ast-ksh.2008-10-31.tgz) = 9c7cdddfc1db18b50b95d8f9eeb40c4fb8bcb33bc2d53c5856398436cd56ecf8
SIZE (ksh93-devel/ast-ksh.2008-10-31.tgz) = 1777421

View file

@ -1,15 +0,0 @@
KSH93-DEVEL is the beta-test version of the latest ksh93 package.
KSH-93 is the most recent version of the KornShell Language described
in "The KornShell Command and Programming Language," by Morris
Bolsky and David Korn of AT&T Bell Laboratories. The KornShell is
a shell programming language, which is upward compatible with "sh"
(the Bourne Shell), and is intended to conform to the IEEE P1003.2/ISO
9945.2 Shell and Utilities standard. KSH-93 provides an enhanced
programming environment in addition to the major command-entry
features of the BSD shell "csh". With KSH-93, medium-sized programming
tasks can be performed at shell-level without a significant loss
in performance. In addition, "sh" scripts can be run on KSH-93
without modification.
WWW: http://www.kornshell.com/

View file

@ -1,8 +0,0 @@
@comment $FreeBSD$
bin/ksh93
@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
%%EXAMPLESDIR%%/dirs
%%EXAMPLESDIR%%/popd
%%EXAMPLESDIR%%/pushd
@dirrm %%EXAMPLESDIR%%

View file

@ -157,13 +157,11 @@
SUBDIR += downtime
SUBDIR += dt
SUBDIR += dtc
SUBDIR += dtc-toaster
SUBDIR += du2ps
SUBDIR += dump9660
SUBDIR += dupfind
SUBDIR += duplicity
SUBDIR += durep
SUBDIR += dusage
SUBDIR += dvd+rw-tools
SUBDIR += dvdbackup
SUBDIR += dvdimagecmp

View file

@ -1,33 +0,0 @@
# New ports collection makefile for: dtc-toaster
# Date created: 20 November 2006
# Whom: Marc G. Fournier <scrappy@freebsd.org>
#
# $FreeBSD$
#
PORTREVISION= 6
PKGNAMESUFFIX= -toaster
MAINTAINER= scrappy@freebsd.org
BROKEN= Conflicting MySQL dependencies
DEPRECATED= Has been broken for more than 6 months
EXPIRATION_DATE=2008-09-19
CONFLICTS= dtc-[0-9]*
WITH_WEBALIZER=yes
WITH_AWSTATS=yes
WITH_MHONARC=yes
WITH_MLMMJ=yes
WITH_PUREFTPD=yes
WITH_POSTFIX=yes
WITH_CYRUS_IMAPD=yes
WITH_APACHE2=yes
WITH_PHP5=yes
DESCR= ${.CURDIR}/pkg-descr
MASTERDIR= ${.CURDIR}/../dtc
.include "${MASTERDIR}/Makefile"

View file

@ -1,7 +0,0 @@
This port is meant to build and provide a full installation of DTC, including
all dependencies required to use it. This isn't the only possible configuration
of applications to run with it, see the main port for the various apps that
can be used.
WWW: http://www.gplhost.com/software-dtc.html

View file

@ -1,33 +0,0 @@
# New ports collection makefile for: dusage
# Date created: 22 January 2006
# Whom: Jeffrey H. Johnson <CPE1704TKS@bellsouth.net>
#
# $FreeBSD$
#
PORTNAME= dusage
PORTVERSION= 19900227
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.unicamp.br/pub/unix-c/sysadmin/ \
http://ftp.br.xemacs.org/pub/unix-c/sysadmin/
DISTNAME= dusage
EXTRACT_SUFX= .tar.Z
MAINTAINER= CPE1704TKS@bellsouth.net
COMMENT= Report about disk space in use, change since last run, etc
BROKEN= Unfetchable
DEPRECATED= Has been broken for more than 6 months
EXPIRATION_DATE=2008-09-19
NO_BUILD= yes
USE_PERL5= yes
NO_CDROM= may not be sold
RESTRICTED= may not be used to harm any living creature including the world and the universe
ALL_TARGET= ${PORTNAME}
MAN1= dusage.1
PLIST_FILES= bin/dusage
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
SIZE (dusage.tar.Z) = 10436
MD5 (dusage.tar.Z) = f2d95cdf9bb7747cdc855079142b9e23
SHA256 (dusage.tar.Z) = 4010c9c543c0d20a27d823c44d1e51a6f1245f6480abfbdde0be661482f05b5f

View file

@ -1,8 +0,0 @@
*** Makefile.orig Sun Jan 22 01:18:50 2006
--- Makefile Sun Jan 22 01:20:04 2006
***************
*** 0 ****
--- 1,3 ----
+ install:
+ install -m 755 dusage.pl ${PREFIX}/bin/dusage
+ install -m 644 dusage.1 ${PREFIX}/man/man1

View file

@ -1,18 +0,0 @@
Guarding disk space is one of the problems of system management.
Using a list of pathnames, this program filters the output of du(1) to
find the amount of disk space used for each of the paths (actually, it
collects all values in one single du run). It adds the new value to
the list, shifting old values up. It then generates a nice report of
the amount of disk space occupied in each of the specified paths,
together with the amount it grew (or shrinked) since the previous run,
and since 7 runs ago. When run daily, this gives daily and weekly
figures.
This program requires perl version 3.0, patchlevel 4 or higher.
Copyright 1990 Johan Vromans, all rights reserved.
Peaceware. This program may be used, modified and distributed as long as
this copyright notice remains part of the source. It may not be sold, or
be used to harm any living creature including the world and the universe.

View file

@ -53,7 +53,6 @@
SUBDIR += fluxconf
SUBDIR += fluxspace
SUBDIR += fluxter
SUBDIR += flwm
SUBDIR += fvwm
SUBDIR += fvwm-crystal
SUBDIR += fvwm2
@ -70,7 +69,6 @@
SUBDIR += ion-2
SUBDIR += jewel
SUBDIR += jwm
SUBDIR += kahakai
SUBDIR += kappdock
SUBDIR += kompmgr
SUBDIR += larswm

View file

@ -1,39 +0,0 @@
# New ports collection makefile for: flwm
# Date created: 12 February 1999
# Whom: Dima Sivachenko <dima@chg.ru>
#
# $FreeBSD$
#
PORTNAME= flwm
PORTVERSION= 1.00
PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= gj
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The Fast Light Window Manager
DEPRECATED= Project is dead, and uses obsolete version of fltk
EXPIRATION_DATE= 2008-10-19
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
MAKE_ENV+= PTHREAD_LIBS=${PTHREAD_LIBS}
GNU_CONFIGURE= yes
MAN1= flwm.1
PLIST_FILES= bin/flwm
.include <bsd.port.pre.mk>
# could be a problem if both versions of freetype are installed
.if exists(${LOCALBASE}/include/freetype1/freetype/freetype.h)
CONFIGURE_ARGS= --includedir="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype1"
.elif exists(${LOCALBASE}/include/freetype2/freetype/freetype.h)
CONFIGURE_ARGS= --includedir="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2"
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (flwm-1.00.tgz) = 75047b2ddcac30eecfb380773177d54d
SHA256 (flwm-1.00.tgz) = f4df1a0a5699fead28d4737253b40fb999d1d610d48d4f1af46b51af84a94084
SIZE (flwm-1.00.tgz) = 61747

View file

@ -1,26 +0,0 @@
--- Rotated.C.orig Fri Aug 27 21:53:28 2004
+++ Rotated.C Fri Aug 27 12:02:59 2004
@@ -27,6 +27,7 @@
/* ********************************************************************** */
#include <FL/x.H>
+#include <X11/Xft/Xft.h>
#include <FL/fl_draw.H>
#include "Rotated.H"
#include <stdlib.h>
@@ -352,6 +353,7 @@
static XRotFontStruct* font;
void draw_rotated(const char* text, int n, int x, int y, int angle) {
+#if XFT_MAJOR < 2
if (!text || !*text) return;
/* make angle positive ... */
if (angle < 0) do angle += 360; while (angle < 0);
@@ -365,6 +367,7 @@
font = XRotLoadFont(fl_display, fl_xfont, dir);
}
XRotDrawString(fl_display, font, fl_window, fl_gc, x, y, text, n);
+#endif
}
#ifndef FLWM

View file

@ -1,11 +0,0 @@
--- Makefile.orig Tue Sep 19 20:49:19 2000
+++ Makefile Tue Sep 19 20:50:18 2000
@@ -5,7 +5,7 @@
CXXFILES = main.C Frame.C Rotated.C Menu.C FrameWindow.C Desktop.C Hotkeys.C
-LIBS = -lfltk
+LIBS = -lfltk -lGL ${PTHREAD_LIBS}
MANPAGE = 1

View file

@ -1,49 +0,0 @@
--- configure.orig Wed Jan 5 05:14:02 2000
+++ configure Tue Sep 19 20:43:39 2000
@@ -681,9 +681,9 @@
if test "$ac_test_CFLAGS" = set; then
CFLAGS="$ac_save_CFLAGS"
elif test $ac_cv_prog_cc_g = yes; then
- CFLAGS="-g -O2"
+ CFLAGS="$CXXFLAGS"
else
- CFLAGS="-O2"
+ CFLAGS="$CXXFLAGS"
fi
else
GCC=
@@ -813,9 +813,9 @@
if test "$ac_test_CXXFLAGS" = set; then
CXXFLAGS="$ac_save_CXXFLAGS"
elif test $ac_cv_prog_cxx_g = yes; then
- CXXFLAGS="-g -O2"
+ CXXFLAGS="$CXXFLAGS"
else
- CXXFLAGS="-O2"
+ CXXFLAGS="$CXXFLAGS"
fi
else
GXX=
@@ -1805,9 +1805,9 @@
if test -n "$GXX"; then
# GNU C compiler
# -Wno-return-type is necessary for Xlib header files on many systems:
- CFLAGS="$CFLAGS -Wall -Wno-return-type -O2 $X_CFLAGS"
+ CFLAGS="$CFLAGS -Wall -Wno-return-type $CFLAGS $X_CFLAGS"
CFLAGS_D="$CFLAGS -Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
- CXXFLAGS="$CXXFLAGS -Wall -Wno-return-type -O2 $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS -Wall -Wno-return-type $CXXFLAGS $X_CFLAGS"
CXXFLAGS_D="$CXXFLAGS -Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
else
if test "`(uname) 2>/dev/null`" = IRIX; then
--- configure.orig Fri Aug 27 21:44:46 2004
+++ configure Fri Aug 27 21:49:27 2004
@@ -1807,7 +1807,7 @@
# -Wno-return-type is necessary for Xlib header files on many systems:
CFLAGS="$CFLAGS -Wall -Wno-return-type $CFLAGS $X_CFLAGS"
CFLAGS_D="$CFLAGS -Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
- CXXFLAGS="$CXXFLAGS -Wall -Wno-return-type $CXXFLAGS $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS -Wall -Wno-return-type $includedir $CXXFLAGS $X_CFLAGS"
CXXFLAGS_D="$CXXFLAGS -Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
else
if test "`(uname) 2>/dev/null`" = IRIX; then

View file

@ -1,11 +0,0 @@
--- main.C.orig Sun Jan 5 16:07:31 2003
+++ main.C Sun Jan 5 16:07:41 2003
@@ -351,7 +351,7 @@
}
int main(int argc, char** argv) {
- program_name = filename_name(argv[0]);
+ program_name = fl_filename_name(argv[0]);
int i; if (Fl::args(argc, argv, i, arg) < argc) Fl::error(
"options are:\n"
" -d[isplay] host:#.#\tX display & screen to use\n"

View file

@ -1,5 +0,0 @@
Flwm is a very small and fast X window manager. Its main features are
the lack of icons and the "sideways" title-bars.
--Dima
dima@chg.ru

View file

@ -1,62 +0,0 @@
# New ports collection makefile for: kahakai
# Date created: 10 March 2004
# Whom: Greg J. <xcas@cox.net>
#
# $FreeBSD$
#
PORTNAME= kahakai
PORTVERSION= 0.6.2
PORTREVISION= 8
CATEGORIES= x11-wm
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Kahakai window manager
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13 \
${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/artwiz-fonts:${PORTSDIR}/x11-fonts/artwiz-fonts
BROKEN= Does not compile
#DEPRECATED= Has been broken for more than 6 months
EXPIRATION_DATE=2008-09-19
DEPRECATED= "Development ceased"
USE_AUTOTOOLS= libtool:15
USE_PERL5_BUILD=yes
USE_BZIP2= yes
USE_XORG= x11 xft
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_PYTHON= yes
USE_GCC= 3.4
USE_EFL= imlib2
MAN1= kahakai.1
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS=${PTHREAD_CFLAGS} \
LDFLAGS=-L${LOCALBASE}/lib \
LIBS=${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
.if ${ARCH} == "alpha"
BROKEN= "Does not compile on alpha 4.x"
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/tmp/ktest|${LOCALBASE}|' \
${WRKSRC}/data/styles/Default.kastyle.in
@${REINPLACE_CMD} -e 's|bool max|bool wmax|' \
${WRKSRC}/src/Window.hh
@${REINPLACE_CMD} -e 's|flags.max|flags.wmax|g' \
${WRKSRC}/src/*.cc
pre-install:
@${REINPLACE_CMD} -e 's|^None|globals()["None"]|' \
${WRKSRC}/src/kahakai.py
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (kahakai-0.6.2.tar.bz2) = 84f1501035d1fbab7eb46121a47b0dd8
SHA256 (kahakai-0.6.2.tar.bz2) = c18fb9d1c7bc350bfa6dccbdd9f9fc702f795a4d3e60483f0a6b3ed956e58490
SIZE (kahakai-0.6.2.tar.bz2) = 697492

View file

@ -1,10 +0,0 @@
--- src/Screen.cc.orig Sat Feb 7 17:50:59 2004
+++ src/Screen.cc Fri Aug 13 20:27:46 2004
@@ -63,6 +63,7 @@
#include <sstream>
#include <iostream>
#include <iomanip>
+#include <cerrno>
using std::cout;
using std::cerr;

View file

@ -1,4 +0,0 @@
Kahakai is a fork of the Waimea window manager. It can be scripted
in Python.
WWW: http://kahakai.sourceforge.net

View file

@ -1,44 +0,0 @@
bin/hsetroot
bin/kahakai
lib/kahakai/libkahakai_swig_python.a
lib/kahakai/libkahakai_swig_python.la
lib/kahakai/libkahakai_swig_python.so
lib/kahakai/libkahakai_swig_python.so.0
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/COPYING
%%DOCSDIR%%/NEWS
%%DOCSDIR%%/README
%%DOCSDIR%%/kastyleformat.txt
%%DOCSDIR%%/userconfig-migration-0.5
share/kahakai/cmd.gdb
share/kahakai/config
share/kahakai/home_autostart
share/kahakai/home_config
share/kahakai/home_userconfig.py
share/kahakai/menu
share/kahakai/scripts/actions.py
share/kahakai/scripts/actions.pyc
share/kahakai/scripts/actions.pyo
share/kahakai/scripts/configparser.py
share/kahakai/scripts/configparser.pyc
share/kahakai/scripts/configparser.pyo
share/kahakai/scripts/events.py
share/kahakai/scripts/events.pyc
share/kahakai/scripts/events.pyo
share/kahakai/scripts/filelist.pl
share/kahakai/scripts/kahakai.py
share/kahakai/scripts/kahakai.pyc
share/kahakai/scripts/kahakai.pyo
share/kahakai/scripts/macros.py
share/kahakai/scripts/macros.pyc
share/kahakai/scripts/macros.pyo
share/kahakai/scripts/procinfo.pl
share/kahakai/scripts/styles.py
share/kahakai/scripts/stylesdir.pl
share/kahakai/styles/Default.kastyle
share/kahakai/styles/Default.png
@dirrm lib/kahakai
@dirrm %%DOCSDIR%%
@dirrm share/kahakai/scripts
@dirrm share/kahakai/styles
@dirrm share/kahakai