Finish repo-copy of old py-wxPython 2.4.2 to py-wxPython24.
This commit is contained in:
parent
82a4b9601a
commit
78eb4756a7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=135153
6 changed files with 1 additions and 1596 deletions
|
@ -156,7 +156,7 @@
|
|||
SUBDIR += py-qt
|
||||
SUBDIR += py-tkinter
|
||||
SUBDIR += py-wmgeneral
|
||||
SUBDIR += py-wxPython
|
||||
SUBDIR += py-wxPython24
|
||||
SUBDIR += py-xlib
|
||||
SUBDIR += qscintilla
|
||||
SUBDIR += qt145
|
||||
|
|
|
@ -1,56 +0,0 @@
|
|||
# New ports collection makefile for: wxPython
|
||||
# Date created: September 18, 1999
|
||||
# Whom: nectar@FreeBSD.ORG
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= wxPython
|
||||
PORTVERSION= 2.4.2.4
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= x11-toolkits python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= wxpython
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= ${PORTNAME}Src-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Python bindings for the wxWidgets/GTK GUI toolkit
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/wxPython
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS=yes
|
||||
PYDISTUTILS_BUILDARGS= WX_CONFIG="${WX_CONFIG}"
|
||||
DEMO_DIR= ${PYTHONPREFIX_SITELIBDIR}/wxPython/demo
|
||||
|
||||
post-build:
|
||||
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/demo
|
||||
.if !defined(DEBUG_FLAGS)
|
||||
@${FIND} ${WRKSRC} -name "*.so" | ${XARGS} strip
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${DEMO_DIR}
|
||||
.for glob in *.py *.pyc
|
||||
@${INSTALL_DATA} ${WRKSRC}/demo/${glob} ${DEMO_DIR}
|
||||
.endfor
|
||||
.for dir in bitmaps bmp_source data
|
||||
@${MKDIR} ${DEMO_DIR}/${dir}
|
||||
.for glob in *
|
||||
@${INSTALL_DATA} ${WRKSRC}/demo/${dir}/${glob} ${DEMO_DIR}/${dir}
|
||||
.endfor
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
|
||||
WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.4-config
|
||||
CONFIGURE_ARGS+= --enable-gtk2
|
||||
PYDISTUTILS_BUILDARGS+= WXPORT=gtk2
|
||||
PYDISTUTILS_INSTALLARGS:= ${PYDISTUTILS_INSTALLARGS} ${PYDISTUTILS_BUILDARGS}
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
MD5 (wxPythonSrc-2.4.2.4.tar.gz) = ea4eb68e10a0c2a9be643b35dcb78e41
|
||||
SIZE (wxPythonSrc-2.4.2.4.tar.gz) = 13130195
|
|
@ -1,111 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- setup.py.orig Fri Mar 21 01:49:39 2003
|
||||
+++ setup.py Fri Apr 18 18:02:09 2003
|
||||
@@ -152,6 +152,16 @@
|
||||
|
||||
|
||||
#----------------------------------------------------------------------
|
||||
+# Check for some environment variables
|
||||
+#----------------------------------------------------------------------
|
||||
+
|
||||
+try: gtk_config = os.environ['GTK_CONFIG']
|
||||
+except KeyError: gtk_config = 'gtk-config'
|
||||
+
|
||||
+try: sys_libs = os.environ['LIBS'].split()
|
||||
+except KeyError: sys_libs = []
|
||||
+
|
||||
+#----------------------------------------------------------------------
|
||||
# Check for build flags on the command line
|
||||
#----------------------------------------------------------------------
|
||||
|
||||
@@ -434,7 +444,7 @@
|
||||
|
||||
if WXPORT == 'gtk':
|
||||
WXPLAT = '__WXGTK__'
|
||||
- portcfg = os.popen('gtk-config --cflags', 'r').read()[:-1]
|
||||
+ portcfg = os.popen(gtk_config + ' --cflags', 'r').read()[:-1]
|
||||
elif WXPORT == 'gtk2':
|
||||
WXPLAT = '__WXGTK__'
|
||||
GENDIR = 'gtk' # no code differences so use the same generated sources
|
||||
@@ -457,6 +467,7 @@
|
||||
|
||||
libdirs = []
|
||||
libs = []
|
||||
+ libs.extend(sys_libs)
|
||||
|
||||
Verify_WX_CONFIG()
|
||||
|
||||
@@ -691,8 +702,8 @@
|
||||
if BUILD_OGL:
|
||||
msg('Preparing OGL...')
|
||||
location = 'contrib/ogl'
|
||||
- OGLLOC = opj(location, 'contrib/src/ogl')
|
||||
- OGLINC = opj(location, 'contrib/include')
|
||||
+ OGLLOC = opj(location, '../../../contrib/src/ogl')
|
||||
+ OGLINC = opj(location, '../../../contrib/include')
|
||||
|
||||
swig_files = ['ogl.i', 'oglbasic.i', 'oglshapes.i', 'oglshapes2.i',
|
||||
'oglcanvas.i']
|
||||
@@ -740,9 +751,9 @@
|
||||
if BUILD_STC:
|
||||
msg('Preparing STC...')
|
||||
location = 'contrib/stc'
|
||||
- STCLOC = opj(location, 'contrib/src/stc')
|
||||
- STCINC = opj(location, 'contrib/include')
|
||||
- STC_H = opj(location, 'contrib/include/wx/stc')
|
||||
+ STCLOC = opj(location, '../../../contrib/src/stc')
|
||||
+ STCINC = opj(location, '../../../contrib/include')
|
||||
+ STC_H = opj(location, '../../../contrib/include/wx/stc')
|
||||
|
||||
if IN_CVS_TREE:
|
||||
# Check if gen_iface needs to be run for the wxSTC sources
|
||||
@@ -885,8 +896,8 @@
|
||||
if BUILD_XRC:
|
||||
msg('Preparing XRC...')
|
||||
location = 'contrib/xrc'
|
||||
- XMLLOC = opj(location, 'contrib/src/xrc')
|
||||
- XMLINC = opj(location, 'contrib/include')
|
||||
+ XMLLOC = opj(location, '../../../contrib/src/xrc')
|
||||
+ XMLINC = opj(location, '../../../contrib/include')
|
||||
|
||||
swig_files = ['xrc.i']
|
||||
|
||||
@@ -974,8 +985,8 @@
|
||||
if BUILD_GIZMOS:
|
||||
msg('Preparing GIZMOS...')
|
||||
location = 'contrib/gizmos'
|
||||
- GIZMOLOC = opj(location, 'contrib/src/gizmos')
|
||||
- GIZMOINC = opj(location, 'contrib/include')
|
||||
+ GIZMOLOC = opj(location, '../../../contrib/src/gizmos')
|
||||
+ GIZMOINC = opj(location, '../../../contrib/include')
|
||||
|
||||
swig_files = ['gizmos.i']
|
||||
|
||||
@@ -1052,8 +1063,8 @@
|
||||
if BUILD_CANVAS:
|
||||
msg('Preparing CANVAS...')
|
||||
location = 'contrib/canvas'
|
||||
- CANVASLOC = opj(location, 'contrib/src/canvas')
|
||||
- CANVASINC = opj(location, 'contrib/include')
|
||||
+ CANVASLOC = opj(location, '../../../contrib/src/canvas')
|
||||
+ CANVASINC = opj(location, '../../../contrib/include')
|
||||
|
||||
swig_files = ['canvas.i']
|
||||
|
||||
@@ -1091,10 +1102,10 @@
|
||||
if BUILD_ART2D:
|
||||
msg('Preparing ART2D...')
|
||||
location = 'contrib/art2d'
|
||||
- ART2DLOC = opj(location, 'modules/canvas/src')
|
||||
- ART2DINC = opj(location, 'modules/canvas/include')
|
||||
- EXPATLOC = opj(location, 'modules/expat')
|
||||
- EXPATINC = opj(location, 'modules/expat/include')
|
||||
+ ART2DLOC = opj(location, '../../../modules/canvas/src')
|
||||
+ ART2DINC = opj(location, '../../../modules/canvas/include')
|
||||
+ EXPATLOC = opj(location, '../../../modules/expat')
|
||||
+ EXPATINC = opj(location, '../../../modules/expat/include')
|
||||
|
||||
swig_files = ['art2d.i',
|
||||
'art2d_misc.i',
|
|
@ -1,12 +0,0 @@
|
|||
From the home page:
|
||||
wxPython is a GUI toolkit for the Python programming language. It allows
|
||||
Python programmers to create programs with a robust, highly functional
|
||||
graphical user interface, simply and easily. It is implemented as a Python
|
||||
extension module (native code) that wraps the popular wxWidgets cross-
|
||||
platform GUI library, which is written in C++.
|
||||
|
||||
wxPython is a cross-platform toolkit. This means that the same program
|
||||
will run on multiple platforms without modification. Currently supported
|
||||
platforms are Microsoft Windows, and most Unix or unix-like systems.
|
||||
|
||||
WWW: http://www.wxpython.org/
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue