[NEW PORT] math/plman: A Propositional Logic sentence shell/interpreter
PLMan, or Propositional LogicMan, is a user-friendly and powerful propositional logic (sometimes called sentential logic or propositional calculus) sentence shell/interpreter written in Java, capable of handling many existing propositional systems of propositional logic, especially the important ones. Author: Takayuki Hoshi <hoshi103@chapman.edu> WWW: http://plman.sourceforge.net/ PR: ports/90277 Submitted by: Nicola Vitale <nivit@email.it>
This commit is contained in:
parent
de91c1f36d
commit
7902abf653
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151700
6 changed files with 80 additions and 0 deletions
|
@ -208,6 +208,7 @@
|
|||
SUBDIR += php5-bcmath
|
||||
SUBDIR += php5-gmp
|
||||
SUBDIR += physcalc
|
||||
SUBDIR += plman
|
||||
SUBDIR += ploticus
|
||||
SUBDIR += ploticus-nox11
|
||||
SUBDIR += plplot
|
||||
|
|
49
math/plman/Makefile
Normal file
49
math/plman/Makefile
Normal file
|
@ -0,0 +1,49 @@
|
|||
# New ports collection makefile for: plman
|
||||
# Date created: 2005-12-12
|
||||
# Whom: Nicola Vitale <nivit@email.it>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= plman
|
||||
PORTVERSION= 2.5.1
|
||||
CATEGORIES= math java
|
||||
MASTER_SITES= http://${PORTNAME}.sourceforge.net/dist/ \
|
||||
http://nivi.interfree.it/distfiles/${PORTNAME}.sourceforge.net/
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION:C/\./_/g}
|
||||
EXTRACT_SUFX= .zip
|
||||
|
||||
MAINTAINER= nivit@email.it
|
||||
COMMENT= A Propositional Logic sentence shell/interpreter
|
||||
|
||||
RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
USE_JAVA= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_ZIP= yes
|
||||
|
||||
JAVA_VERSION= 1.4+
|
||||
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
|
||||
REPLACE_FILES= ${WRKSRC}/bin/${PORTNAME}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
FIND_DATA= lib
|
||||
FIND_DOCS= docs
|
||||
|
||||
post-patch:
|
||||
for FILE in ${REPLACE_FILES}; do \
|
||||
${REINPLACE_CMD} -e "/%%DATADIR%%/s//${DATADIR:S/\//\\\//g}/g" $${FILE} ;\
|
||||
done;
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
|
||||
${MKDIR} ${DATADIR}/${FIND_DATA}
|
||||
cd ${WRKSRC} && ${FIND} ${FIND_DATA} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC}/${FIND_DOCS} && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
math/plman/distinfo
Normal file
3
math/plman/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (plman2_5_1.zip) = c10b7e110a266360edfc72be23df7f50
|
||||
SHA256 (plman2_5_1.zip) = b558d6b1afbdc0ed06a0c920ff8bdc7b7502c6ced968302300074c7867111a88
|
||||
SIZE (plman2_5_1.zip) = 1372138
|
11
math/plman/files/patch-bin-plman
Normal file
11
math/plman/files/patch-bin-plman
Normal file
|
@ -0,0 +1,11 @@
|
|||
$FreeBSD$
|
||||
--- bin/plman Tue Nov 23 11:32:50 2004
|
||||
+++ bin/plman.port Mon Dec 12 12:57:36 2005
|
||||
@@ -1,6 +1,6 @@
|
||||
#! /bin/sh
|
||||
|
||||
-PLMAN_PATH='MODIFY HERE!!' # Example: ~/bin/plman
|
||||
+PLMAN_PATH='%%DATADIR%%' # Example: ~/bin/plman
|
||||
|
||||
# Execute plman
|
||||
java -classpath "${PLMAN_PATH}/lib/plman.jar":"${PLMAN_PATH}/lib/ant.jar" PropositionalLogicParser $*
|
8
math/plman/pkg-descr
Normal file
8
math/plman/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
PLMan, or Propositional LogicMan, is a user-friendly and powerful
|
||||
propositional logic (sometimes called sentential logic or
|
||||
propositional calculus) sentence shell/interpreter written in Java,
|
||||
capable of handling many existing propositional systems of
|
||||
propositional logic, especially the important ones.
|
||||
|
||||
Author: Takayuki Hoshi <hoshi103@chapman.edu>
|
||||
WWW: http://plman.sourceforge.net/
|
8
math/plman/pkg-plist
Normal file
8
math/plman/pkg-plist
Normal file
|
@ -0,0 +1,8 @@
|
|||
@comment $FreeBSD$
|
||||
bin/plman
|
||||
%%PORTDOCS%%%%DOCSDIR%%/PLMan_Users_Manual.pdf
|
||||
%%DATADIR%%/lib/ant.jar
|
||||
%%DATADIR%%/lib/plman.jar
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm %%DATADIR%%/lib
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue