Add graphics/imlib2-webp, an imlib2 plugin for webp images
PR: 232871 Submitted by: Greg V <greg@unrelenting.technology>
This commit is contained in:
parent
69a1868c0d
commit
7917b97073
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=487245
5 changed files with 43 additions and 0 deletions
|
@ -383,6 +383,7 @@
|
|||
SUBDIR += imgv
|
||||
SUBDIR += imlib2
|
||||
SUBDIR += imlib2_loaders
|
||||
SUBDIR += imlib2-webp
|
||||
SUBDIR += impressive
|
||||
SUBDIR += imv
|
||||
SUBDIR += inkscape
|
||||
|
|
24
graphics/imlib2-webp/Makefile
Normal file
24
graphics/imlib2-webp/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= imlib2-webp
|
||||
PORTVERSION= 20160601
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= greg@unrelenting.technology
|
||||
COMMENT= WebP image loader plugin for Imlib 2
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
|
||||
libwebp.so:graphics/webp
|
||||
|
||||
USES= gmake pkgconfig
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= gawen947
|
||||
GH_TAGNAME= 79b3da58f48
|
||||
|
||||
MAKEFILE= makefile
|
||||
PLIST_FILES= lib/imlib2/loaders/webp.so
|
||||
|
||||
.include <bsd.port.mk>
|
3
graphics/imlib2-webp/distinfo
Normal file
3
graphics/imlib2-webp/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1541024397
|
||||
SHA256 (gawen947-imlib2-webp-20160601-79b3da58f48_GH0.tar.gz) = 375cf08518d26055faebd22ad587324c4f86c625cebbee712a8b30786030449b
|
||||
SIZE (gawen947-imlib2-webp-20160601-79b3da58f48_GH0.tar.gz) = 6415
|
11
graphics/imlib2-webp/files/patch-makefile
Normal file
11
graphics/imlib2-webp/files/patch-makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- makefile.orig 2018-10-31 22:21:03 UTC
|
||||
+++ makefile
|
||||
@@ -2,7 +2,7 @@ include commands.mk
|
||||
|
||||
OPTS := -O2
|
||||
CFLAGS := -std=c99 $(OPTS) $(shell imlib2-config --cflags) -fPIC -Wall
|
||||
-LDFLAGS := $(shell imlib2-config --libs) -lwebp
|
||||
+LDFLAGS := $(shell imlib2-config --libs) $(shell pkg-config --libs libwebp)
|
||||
|
||||
SRC = $(wildcard *.c)
|
||||
OBJ = $(foreach obj, $(SRC:.c=.o), $(notdir $(obj)))
|
4
graphics/imlib2-webp/pkg-descr
Normal file
4
graphics/imlib2-webp/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
A WebP image loader for Imlib2.
|
||||
Allows e.g. viewing WebP images in feh.
|
||||
|
||||
WWW: https://www.hauweele.net/~gawen/imlib2-webp.html
|
Loading…
Reference in a new issue