- Fix the installation error
- Sanitize OPTIONS and make them actually work - Trim Makefile header while here - Reformat port description text and remove old-school attribution Reported by: pointyhat-west
This commit is contained in:
parent
c6418bd78d
commit
791f4eddb9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323279
3 changed files with 27 additions and 50 deletions
|
@ -1,9 +1,5 @@
|
|||
# New ports collection makefile for: nakenchat
|
||||
# Date created: 01 July 2003
|
||||
# Whom: Michael Kohn (mike@mikekohn.net)
|
||||
#
|
||||
# Created by: Michael Kohn <mike@mikekohn.net>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= nakenchat
|
||||
PORTVERSION= 2.12
|
||||
|
@ -16,46 +12,27 @@ COMMENT= Small (under 50k) chat server with many features
|
|||
HAS_CONFIGURE= yes
|
||||
USE_RC_SUBR= nakenchat
|
||||
|
||||
OPTIONS_DEFINE= KEEPALIVEOFF USERCHANLISTOFF DEBUG HIDDENCAVES DOTQ FUSERLIST ELITEFILTER
|
||||
OPTIONS_DEFINE= NOKEEPALIVE NOUSERCHANLIST DEBUG HIDDENCAVES DOTQ \
|
||||
FUSERLIST ELITEFILTER
|
||||
|
||||
KEEPALIVEOFF_DESC= Disable socket keepalive option
|
||||
USERCHANLISTOFF_DESC= Disable userlist based on channel
|
||||
NOKEEPALIVE_DESC= Disable socket keepalive option
|
||||
NOUSERCHANLIST_DESC= Disable userlist based on channel
|
||||
DEBUG_DESC= Compile in debug code
|
||||
HIDDENCAVES_DESC= Enable hidden caves feature
|
||||
DOTQ_DESC= compile in .Q option
|
||||
FUSERLIST_DESC= support to save current userlist to a file
|
||||
DOTQ_DESC= Compile in .Q option
|
||||
FUSERLIST_DESC= Support saving current userlist to a file
|
||||
ELITEFILTER_DESC= Enable the 3li73 filter
|
||||
|
||||
NOKEEPALIVE_CONFIGURE_ON= --disable-keepalive
|
||||
NOUSERCHANLIST_CONFIGURE_ON= --disable-userchanlist
|
||||
DEBUG_CONFIGURE_ON= --enable-debug
|
||||
HIDDENCAVES_CONFIGURE_ON= --enable-hidden-caves
|
||||
DOTQ_CONFIGURE_ON= --enable-dotQ
|
||||
FUSERLIST_CONFIGURE_ON= --enable-whofile
|
||||
ELITEFILTER_CONFIGURE_ON= --enable-elite
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MWITH_KEEPALIVEOFF}
|
||||
CONFIGURE_ARGS+= --disable-keepalive
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MWITH_USERCHANLISTOFF}
|
||||
CONFIGURE_ARGS+= --disable-userchanlist
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MWITH_DEBUG}
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MWITH_HIDDENCAVES}
|
||||
CONFIGURE_ARGS+= --enable-hidden-caves
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MWITH_DOTQ}
|
||||
CONFIGURE_ARGS+= --enable-dotQ
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MWITH_FUSERLIST}
|
||||
CONFIGURE_ARGS+= --enable-whofile
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MWITH_ELITEFILTER}
|
||||
CONFIGURE_ARGS+= --enable-elite
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@if [ ! -f ${PREFIX}/etc/nakenchat.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/nakenchat.conf.sample ${PREFIX}/etc/nakenchat.conf ; \
|
||||
|
|
|
@ -1,15 +1,19 @@
|
|||
--- ./Makefile.orig 2007-06-27 22:06:34.000000000 -0400
|
||||
+++ ./Makefile 2008-11-23 14:24:11.028905510 -0500
|
||||
@@ -30,12 +30,7 @@
|
||||
@@ -28,14 +28,9 @@
|
||||
install:
|
||||
@if [ ! -d $(PREFIX)/bin ]; then mkdir $(PREFIX)/bin; fi;
|
||||
@if [ ! -d $(PREFIX)/etc ]; then mkdir $(PREFIX)/etc; fi;
|
||||
cp nakenchat $(PREFIX)/bin
|
||||
cp nakenpasswd $(PREFIX)/bin
|
||||
- cp nakenchat $(PREFIX)/bin
|
||||
- cp nakenpasswd $(PREFIX)/bin
|
||||
- @echo "cp nakenchat.conf $(PREFIX)/etc"
|
||||
- @if [ -f $(PREFIX)/etc/nakenchat.conf ]; then \
|
||||
- echo "$(PREFIX)/etc/nakenchat.conf exists."; \
|
||||
- else \
|
||||
- cp nakenchat.conf $(PREFIX)/etc; \
|
||||
- fi
|
||||
+ cp src/nakenchat $(PREFIX)/bin
|
||||
+ cp src/nakenpasswd $(PREFIX)/bin
|
||||
+ cp nakenchat.conf $(PREFIX)/etc/nakenchat.conf.sample;
|
||||
|
||||
clean:
|
||||
|
|
|
@ -1,11 +1,7 @@
|
|||
Small chat server written in C. The compiled code is still under
|
||||
50k (at this time around 40k). The chat offers many features
|
||||
including private channels, gagging, squelching, banning,
|
||||
censoring, and much more. Users can connect to the chat through
|
||||
many ways including telnet and a Java applet through a webpage.
|
||||
Small chat server written in C. The compiled code is still under 50k (at
|
||||
this time around 40k). The chat offers many features including private
|
||||
channels, gagging, squelching, banning, censoring, and much more. Users
|
||||
can connect to the chat through many ways, including telnet and a Java
|
||||
applet through a webpage.
|
||||
|
||||
WWW: http://nakenchat.naken.cc/
|
||||
|
||||
-Michael Kohn
|
||||
|
||||
mike@mikekohn.net
|
||||
|
|
Loading…
Reference in a new issue