Update to 0.32.
This commit is contained in:
parent
a585574c6c
commit
79981ed203
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41980
5 changed files with 11 additions and 93 deletions
|
@ -6,12 +6,12 @@
|
|||
#
|
||||
|
||||
PORTNAME= opengl
|
||||
PORTVERSION= 0.31
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.32
|
||||
CATEGORIES= graphics ruby
|
||||
MASTER_SITES= http://www2.giganet.net/~yoshi/
|
||||
MASTER_SITES= http://www.ruby-lang.org/~knu/
|
||||
#MASTER_SITES= http://www2.giganet.net/~yoshi/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
DISTNAME= rbogl
|
||||
DISTNAME= rbogl-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
|
@ -22,17 +22,17 @@ USE_RUBY_EXTCONF= yes
|
|||
|
||||
USE_MESA= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/oglmodule
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
CONFIGURE_ARGS= --with-ruby-dir="${LOCALBASE}" --with-x11-dir="${X11BASE}"
|
||||
INSTALL_TARGET= site-install
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_EXAMPLESDIR}/opengl
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${RUBY_EXAMPLESDIR}/opengl/
|
||||
${MKDIR} ${RUBY_DOCDIR}/opengl/ja
|
||||
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${RUBY_DOCDIR}/opengl/
|
||||
${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_DOCDIR}/opengl/ja/
|
||||
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
|
||||
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
|
||||
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${RUBY_DOCDIR}/${PORTNAME}/
|
||||
${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_DOCDIR}/${PORTNAME}/ja/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (ruby/rbogl.tgz) = b5a063733ea63236038e3ed8e98a93a4
|
||||
MD5 (ruby/rbogl-0.32.tgz) = 161eb91ac50aa20b5786f1c2fe8bf6a8
|
||||
|
|
|
@ -1,64 +0,0 @@
|
|||
--- extconf.rb.orig Wed Feb 16 01:31:59 2000
|
||||
+++ extconf.rb Fri Sep 8 12:36:47 2000
|
||||
@@ -26,8 +26,8 @@
|
||||
glu_libname = "glu32"
|
||||
glut_libname = "glut"
|
||||
else
|
||||
- $CFLAGS="-I/usr/local/include -I. -I/usr/X11R6/include"
|
||||
- $LDFLAGS="-L/usr/local/lib -L/usr/X11R6/lib"
|
||||
+ dir_config("x11")
|
||||
+ dir_config("ruby")
|
||||
$libs = append_library($libs, "Xmu")
|
||||
$libs = append_library($libs, "X11")
|
||||
gl_libname = "GL"
|
||||
@@ -47,13 +47,15 @@
|
||||
}
|
||||
}
|
||||
File.unlink("Makefile")
|
||||
- modules = modules + "opengl.#{CONFIG[\"DLEXT\"]}"
|
||||
+ modules = modules + "opengl.#{CONFIG['DLEXT']}"
|
||||
ogl_flg = true
|
||||
else
|
||||
p "can't create OpenGL module!"
|
||||
exit 1
|
||||
end
|
||||
|
||||
+$libs.sub!(/-L\. -l\$\(RUBY_INSTALL_NAME\) /, '')
|
||||
+
|
||||
$objs = ["glut.o"]
|
||||
have_library("Xi", "XAllowDeviceEvents") &&
|
||||
have_library("Xext", "XMITMiscGetBugMode") &&
|
||||
@@ -67,7 +69,7 @@
|
||||
}
|
||||
}
|
||||
File.unlink("Makefile")
|
||||
- modules = "glut.#{CONFIG[\"DLEXT\"]} " + modules
|
||||
+ modules = "glut.#{CONFIG['DLEXT']} " + modules
|
||||
glut_flg = true
|
||||
end
|
||||
|
||||
@@ -76,11 +78,11 @@
|
||||
SHELL = /bin/sh
|
||||
all: #{modules}
|
||||
|
||||
-opengl.#{CONFIG[\"DLEXT\"]}: rbogl.c ogl.c glu.c rbogl.h
|
||||
+opengl.#{CONFIG['DLEXT']}: rbogl.c ogl.c glu.c rbogl.h
|
||||
@echo Now Making opengl extend module
|
||||
@$(MAKE) -f Makefile.ogl
|
||||
|
||||
-glut.#{CONFIG[\"DLEXT\"]}: glut.c
|
||||
+glut.#{CONFIG['DLEXT']}: glut.c
|
||||
@echo Now Making glut extend module
|
||||
@$(MAKE) -f Makefile.glut
|
||||
|
||||
@@ -94,6 +96,10 @@
|
||||
install: #{modules}
|
||||
#{"\t@$(MAKE) -f Makefile.ogl install" if (ogl_flg)}
|
||||
#{"\t@$(MAKE) -f Makefile.glut install" if (glut_flg)}
|
||||
+
|
||||
+site-install: #{modules}
|
||||
+#{"\t@$(MAKE) -f Makefile.ogl site-install" if (ogl_flg)}
|
||||
+#{"\t@$(MAKE) -f Makefile.glut site-install" if (glut_flg)}
|
||||
MAKEFILE
|
||||
}
|
||||
|
|
@ -1,16 +0,0 @@
|
|||
--- ogl.c.orig Mon Aug 7 01:20:07 2000
|
||||
+++ ogl.c Sun Oct 15 16:50:45 2000
|
||||
@@ -4211,7 +4211,13 @@
|
||||
#if defined(GL_VERSION_1_1)
|
||||
rb_define_const(mOGL, "CLIENT_PIXEL_STORE_BIT", INT2NUM(GL_CLIENT_PIXEL_STORE_BIT));
|
||||
rb_define_const(mOGL, "CLIENT_VERTEX_ARRAY_BIT", INT2NUM(GL_CLIENT_VERTEX_ARRAY_BIT));
|
||||
+#if defined(GL_CLIENT_ALL_ATTRIB_BITS)
|
||||
+ /* For Mesa 3.2 and XFree86 4.0 */
|
||||
rb_define_const(mOGL, "CLIENT_ALL_ATTRIB_BITS", INT2NUM(GL_CLIENT_ALL_ATTRIB_BITS));
|
||||
+#elif defined(GL_ALL_CLIENT_ATTRIB_BITS)
|
||||
+ /* For Mesa 3.2.1 */
|
||||
+ rb_define_const(mOGL, "CLIENT_ALL_ATTRIB_BITS", INT2NUM(GL_ALL_CLIENT_ATTRIB_BITS));
|
||||
+#endif
|
||||
#endif /* GL_VERSION_1_1 */
|
||||
|
||||
rb_global_variable(&g_current_sel_buffer);
|
|
@ -29,7 +29,6 @@
|
|||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/mipmap.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/model.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/movelight.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/nurbs.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/pickdepth.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/plane.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/planet.rb
|
||||
|
@ -43,7 +42,6 @@
|
|||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/teaambient.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/teapots.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/tess.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/test.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/texbind.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/texgen.rb
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/opengl/texturesurf.rb
|
||||
|
|
Loading…
Reference in a new issue