Upgrade to 2.33

PR:		ports/30989
Submitted by:	maintainer
This commit is contained in:
Vanilla I. Shu 2001-10-03 03:32:02 +00:00
parent cce07a6f6e
commit 799f5b00ad
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48372
4 changed files with 19 additions and 37 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= balance
PORTVERSION= 2.28
PORTVERSION= 2.33
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= balance

View file

@ -1 +1 @@
MD5 (balance-2.28.tar.gz) = 66df77083edd0d4700d11d76e2de076c
MD5 (balance-2.33.tar.gz) = b38da3e03218a9adb50356a00eda3b07

View file

@ -0,0 +1,17 @@
--- Makefile.orig Tue Oct 2 09:53:26 2001
+++ Makefile Tue Oct 2 09:53:52 2001
@@ -1,12 +1,12 @@
# $Id: Makefile,v 1.20 2001/09/15 22:30:46 tommy Exp $
#CFLAGS=-g -I.
-CFLAGS=-O
+#CFLAGS=-O
# uncomment for Solaris:
# LIBRARIES=-lsocket -lnsl
-CC=gcc
+#CC=gcc
RELEASE=2.33
balance: balance.c

View file

@ -1,35 +0,0 @@
--- ../balance-2.28.orig/Makefile Mon Jul 30 03:20:11 2001
+++ Makefile Mon Jul 30 03:21:16 2001
@@ -1,11 +1,11 @@
# $Id: Makefile,v 1.12 2001/07/18 17:07:12 tommy Exp tommy $
-CFLAGS=-g -I.
+#CFLAGS=-g -I.
# uncomment for Solaris:
# LIBRARIES=-lsocket -lnsl
-CC=gcc
+#CC=gcc
RELEASE=2.28
balance: balance.c
--- ../balance-2.28.orig/balance.c Mon Jul 30 03:20:11 2001
+++ balance.c Mon Jul 30 03:22:23 2001
@@ -26,6 +26,7 @@
// thanks to Anthony Baxter
//
+#include <sys/types.h>
#include <stdio.h>
#include <strings.h>
#include <ctype.h>
@@ -34,7 +35,7 @@
#include <netinet/in.h>
#include <arpa/inet.h>
#include <signal.h>
-#include <malloc.h>
+#include <stdlib.h>
#ifdef __FreeBSD__
#define MYBSD 1