- Fix build on 4.x

PR:		ports/84404
Submitted by:	Ports Fury
This commit is contained in:
Sergey Matveychuk 2005-08-01 14:49:21 +00:00
parent e417b927b7
commit 79e843bb8a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140668
7 changed files with 197 additions and 20 deletions

View file

@ -17,27 +17,20 @@ COMMENT= A C++ library helps development of 3D applications
BUILD_DEPENDS= ${QMAKE}:${PORTSDIR}/devel/qmake
WRKSRC= ${WRKDIR}/${DISTNAME}/QGLViewer
USE_QT_VER= 3
MAKE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
QTDIR=${X11BASE}
MAKE_ARGS= PREFIX=${PREFIX}
QMAKE= ${LOCALBASE}/bin/qmake
MAKE_ENV= QTDIR="${QT_PREFIX}"
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
DOCSDIR= ${PREFIX}/share/doc/QGLViewer
PORTDOCS= *
do-build:
@(cd ${WRKSRC}/QGLViewer && ${SETENV} ${MAKE_ENV} ${QMAKE} ${MAKE_ARGS} && \
${SETENV} ${MAKE_ENV} ${MAKE})
QMAKE?= ${LOCALBASE}/bin/qmake
QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
do-install:
@(cd ${WRKSRC}/QGLViewer && ${SETENV} ${MAKE_ENV} ${MAKE} install)
post-install:
@${FIND} ${PREFIX}/include/QGLViewer ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${PREFIX}/include/QGLViewer -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
do-configure:
cd ${CONFIGURE_WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
-spec ${QMAKESPEC} QGLViewer.pro PREFIX="${PREFIX}"
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- VRender/BSPSortMethod.cpp.orig Thu Jun 30 02:06:00 2005
+++ VRender/BSPSortMethod.cpp Tue Jul 5 12:42:55 2005
@@ -44,6 +44,8 @@
*****************************************************************************/
+#include <stdio.h>
+
#include "VRender.h"
#include "Primitive.h"
#include "SortMethod.h"

View file

@ -0,0 +1,11 @@
--- VRender/Exporter.h.orig Thu Jun 30 02:06:00 2005
+++ VRender/Exporter.h Tue Jul 5 12:41:58 2005
@@ -49,6 +49,8 @@
// Set of classes for exporting in various formats, like EPS, XFig3.2, SVG.
+#include <stdio.h>
+
#include "Primitive.h"
namespace vrender

View file

@ -0,0 +1,10 @@
--- VRender/Vector2.cpp.orig Thu Jun 30 02:06:00 2005
+++ VRender/Vector2.cpp Tue Jul 5 12:53:56 2005
@@ -44,6 +44,7 @@
*****************************************************************************/
+#include <vector>
#include "Vector2.h"
#include "Vector3.h"
#include "Functions.h"

View file

@ -0,0 +1,10 @@
--- VRender/Vector3.cpp.orig Thu Jun 30 02:06:00 2005
+++ VRender/Vector3.cpp Tue Jul 5 12:53:29 2005
@@ -45,6 +45,7 @@
*****************************************************************************/
#include <iostream>
+#include <vector>
#include "Vector3.h"
#include "NVector3.h"
#include "Functions.h"

View file

@ -0,0 +1,11 @@
--- vec.h.orig Thu Jun 30 02:06:00 2005
+++ vec.h Tue Jul 5 12:33:19 2005
@@ -69,7 +69,7 @@
// If your compiler complains the "The class "qglviewer::Vec" has no member "x"."
// Add your architecture Q_OS_XXXX flag (see qglobal.h) in this list.
-#if defined (Q_OS_IRIX) || defined (Q_OS_AIX) || defined (Q_OS_HPUX)
+#if defined (Q_OS_IRIX) || defined (Q_OS_AIX) || defined (Q_OS_HPUX) || defined(Q_OS_FREEBSD)
# define UNION_NOT_SUPPORTED
#endif

View file

@ -1,6 +1,137 @@
include/QGLViewer/camera.h
include/QGLViewer/config.h
include/QGLViewer/constraint.h
include/QGLViewer/domUtils.h
include/QGLViewer/frame.h
include/QGLViewer/icon.h
include/QGLViewer/keyFrameInterpolator.h
include/QGLViewer/manipulatedCameraFrame.h
include/QGLViewer/manipulatedFrame.h
include/QGLViewer/mouseGrabber.h
include/QGLViewer/qglviewer.cw
include/QGLViewer/qglviewer.h
include/QGLViewer/quaternion.h
include/QGLViewer/vec.h
lib/libQGLViewer.prl
lib/libQGLViewer.so
lib/libQGLViewer.so.2
lib/libQGLViewer.so.2.0
lib/libQGLViewer.so.2.0.0
@exec ln -sf %D/lib/libQGLViewer.so.2.0.0 %D/lib/libQGLViewer.so
@exec ln -sf %D/lib/libQGLViewer.so.2.0.0 %D/lib/libQGLViewer.so.2
@exec ln -sf %D/lib/libQGLViewer.so.2.0.0 %D/lib/libQGLViewer.so.2.0
@unexec rm -f %D/lib/libQGLViewer.so %D/lib/libQGLViewer.so.2 %D/lib/libQGLViewer.so.2.0 2>&1 >/dev/null || true
%%DOCSDIR%%/changeLog.html
%%DOCSDIR%%/commented.html
%%DOCSDIR%%/developer.html
%%DOCSDIR%%/download.html
%%DOCSDIR%%/faq.html
%%DOCSDIR%%/features.html
%%DOCSDIR%%/images/3dsViewer.jpg
%%DOCSDIR%%/images/agora.jpg
%%DOCSDIR%%/images/anaglyph.jpg
%%DOCSDIR%%/images/animation.jpg
%%DOCSDIR%%/images/backgroundImage.jpg
%%DOCSDIR%%/images/callback.jpg
%%DOCSDIR%%/images/constrainedCamera.jpg
%%DOCSDIR%%/images/constrainedFrame.jpg
%%DOCSDIR%%/images/css.png
%%DOCSDIR%%/images/designerplugin.jpg
%%DOCSDIR%%/images/drawLight.jpg
%%DOCSDIR%%/images/dvonn.jpg
%%DOCSDIR%%/images/eventRecorder.jpg
%%DOCSDIR%%/images/fastDraw.jpg
%%DOCSDIR%%/images/frameTransform.jpg
%%DOCSDIR%%/images/interface.jpg
%%DOCSDIR%%/images/keyFrames.jpg
%%DOCSDIR%%/images/keyboardAndMouse.jpg
%%DOCSDIR%%/images/linux.png
%%DOCSDIR%%/images/luxo.jpg
%%DOCSDIR%%/images/mac.png
%%DOCSDIR%%/images/manipulatedFrame.jpg
%%DOCSDIR%%/images/mouseGrabber.jpg
%%DOCSDIR%%/images/multiSelect.jpg
%%DOCSDIR%%/images/multiView.jpg
%%DOCSDIR%%/images/openGL.png
%%DOCSDIR%%/images/qglviewer.ico
%%DOCSDIR%%/images/qglviewer.icon.png
%%DOCSDIR%%/images/qglviewer.png
%%DOCSDIR%%/images/qglviewer.small.png
%%DOCSDIR%%/images/qt.png
%%DOCSDIR%%/images/quarto.jpg
%%DOCSDIR%%/images/screenCoordSystem.jpg
%%DOCSDIR%%/images/select.jpg
%%DOCSDIR%%/images/simpleViewer.jpg
%%DOCSDIR%%/images/sphere.png
%%DOCSDIR%%/images/stereoViewer.jpg
%%DOCSDIR%%/images/terrain.jpg
%%DOCSDIR%%/images/textureViewer.jpg
%%DOCSDIR%%/images/thumbnail.jpg
%%DOCSDIR%%/images/windows.png
%%DOCSDIR%%/images/x3dViewer.jpg
%%DOCSDIR%%/images/xhtml.png
%%DOCSDIR%%/index.html
%%DOCSDIR%%/installUnix.html
%%DOCSDIR%%/installWindows.html
%%DOCSDIR%%/intro.html
%%DOCSDIR%%/keyboard.html
%%DOCSDIR%%/mouse.html
%%DOCSDIR%%/qglviewer.css
%%DOCSDIR%%/refManual/annotated.html
%%DOCSDIR%%/refManual/classQGLViewer-members.html
%%DOCSDIR%%/refManual/classQGLViewer.html
%%DOCSDIR%%/refManual/classqglviewer_1_1AxisPlaneConstraint-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1AxisPlaneConstraint.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Camera-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Camera.html
%%DOCSDIR%%/refManual/classqglviewer_1_1CameraConstraint-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1CameraConstraint.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Constraint-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Constraint.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Frame-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Frame.html
%%DOCSDIR%%/refManual/classqglviewer_1_1KeyFrameInterpolator-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1KeyFrameInterpolator.html
%%DOCSDIR%%/refManual/classqglviewer_1_1LocalConstraint-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1LocalConstraint.html
%%DOCSDIR%%/refManual/classqglviewer_1_1ManipulatedCameraFrame-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1ManipulatedCameraFrame.html
%%DOCSDIR%%/refManual/classqglviewer_1_1ManipulatedFrame-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1ManipulatedFrame.html
%%DOCSDIR%%/refManual/classqglviewer_1_1MouseGrabber-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1MouseGrabber.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Quaternion-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Quaternion.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Vec-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1Vec.html
%%DOCSDIR%%/refManual/classqglviewer_1_1WorldConstraint-members.html
%%DOCSDIR%%/refManual/classqglviewer_1_1WorldConstraint.html
%%DOCSDIR%%/refManual/doxygen.css
%%DOCSDIR%%/refManual/doxygen.png
%%DOCSDIR%%/refManual/functions.html
%%DOCSDIR%%/refManual/functions_0x62.html
%%DOCSDIR%%/refManual/functions_0x63.html
%%DOCSDIR%%/refManual/functions_0x64.html
%%DOCSDIR%%/refManual/functions_0x65.html
%%DOCSDIR%%/refManual/functions_0x66.html
%%DOCSDIR%%/refManual/functions_0x67.html
%%DOCSDIR%%/refManual/functions_0x68.html
%%DOCSDIR%%/refManual/functions_0x69.html
%%DOCSDIR%%/refManual/functions_0x6b.html
%%DOCSDIR%%/refManual/functions_0x6c.html
%%DOCSDIR%%/refManual/functions_0x6d.html
%%DOCSDIR%%/refManual/functions_0x6e.html
%%DOCSDIR%%/refManual/functions_0x6f.html
%%DOCSDIR%%/refManual/functions_0x70.html
%%DOCSDIR%%/refManual/functions_0x71.html
%%DOCSDIR%%/refManual/functions_0x72.html
%%DOCSDIR%%/refManual/functions_0x73.html
%%DOCSDIR%%/refManual/functions_0x74.html
%%DOCSDIR%%/refManual/functions_0x75.html
%%DOCSDIR%%/refManual/functions_0x76.html
%%DOCSDIR%%/refManual/functions_0x77.html
%%DOCSDIR%%/refManual/functions_0x7a.html
%%DOCSDIR%%/refManual/functions_0x7e.html
%%DOCSDIR%%/refManual/hierarchy.html
%%DOCSDIR%%/refManual/index.html
%%DOCSDIR%%/techFaq.html
@dirrm %%DOCSDIR%%/refManual
@dirrm %%DOCSDIR%%/images
@dirrm %%DOCSDIR%%
@dirrm include/QGLViewer