*/*: convert Makefile patches to MAKE_ARGS after "Move man pages to share/man"

Replaced patches for Makefiles with "MAKE_ARGS+=MANDIR=${PREFIX}/share/man"

Reported by:	danfe, mat
Approved by:	portmgr (blanket)
This commit is contained in:
Vladimir Druzenko 2024-03-11 01:49:41 +03:00
parent 4747a5be5b
commit 79f8f9c8f5
10 changed files with 10 additions and 52 deletions

View File

@ -14,6 +14,8 @@ LICENSE= BSD3CLAUSE
USES= cpe
MAKE_ARGS+= MANDIR=${PREFIX}/share/man/man
CPE_VENDOR= mpd_project
OPTIONS_DEFINE= DOCS NG_IPACCT RADIUS

View File

@ -1,11 +0,0 @@
--- doc/Makefile.orig 2020-09-06 14:33:02 UTC
+++ doc/Makefile
@@ -13,7 +13,7 @@ MPD_DOC_FILES+= mpd*.html
MPD_DOC_FILES+= mpd.ps
MAN8= mpd5.8
-MANDIR= ${PREFIX}/man/man
+MANDIR= ${PREFIX}/share/man/man
depend:

View File

@ -16,6 +16,8 @@ LICENSE= BSD2CLAUSE
USES= uidfix
MAKE_ARGS+= MAN1DIR=${PREFIX}/share/man/man1
# CCACHE has options, so may need d4p, make d4p not ccache friendly
# to avoid circular dependency
NO_CCACHE= yes

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2016-07-08 14:49:08 UTC
+++ Makefile
@@ -5,10 +5,15 @@ RM?= rm
@@ -5,7 +5,12 @@ RM?= rm
MAN= ${PROG}.1.gz
PROG= dialog4ports
CFLAGS+= -Wall -pedantic
@ -13,8 +13,4 @@
+LDADD+= -lm
PREFIX?= /usr/local
BINDIR= ${PREFIX}/bin
-MAN1DIR= ${PREFIX}/man/man1
+MAN1DIR= ${PREFIX}/share/man/man1
BSD_INSTALL_PROGRAM?= install -m 0555
BSD_INSTALL_DATA?= install -m 0444
MAN1DIR= ${PREFIX}/man/man1

View File

@ -12,6 +12,8 @@ LICENSE= BSD2CLAUSE
USES= tar:xz
MAKE_ARGS+= MANDIR=${PREFIX}/share/man/man
PLIST_FILES= etc/pam.d/unix-selfauth \
libexec/unix-selfauth-helper \
share/man/man8/unix-selfauth-helper.8.gz

View File

@ -1,11 +0,0 @@
--- Makefile.orig 2023-07-13 18:59:16 UTC
+++ Makefile
@@ -9,7 +9,7 @@ BINMODE= 4555
DIRS+= MAN8DIR
MAN= ${PROG}.8
MAN8= ${MAN}
-MANDIR= ${PREFIX}/man/man
+MANDIR= ${PREFIX}/share/man/man
MAN8DIR= ${MANDIR}8
CONFS= unix-selfauth

View File

@ -11,7 +11,7 @@ LICENSE= BSD2CLAUSE
USES= ncurses uidfix
GNU_CONFIGURE= yes
MAKE_ARGS+= LDFLAGS="${LDFLAGS} -lncurses"
MAKE_ARGS+= LDFLAGS="${LDFLAGS} -lncurses" MANDIR=${PREFIX}/share/man/man
ONLY_FOR_ARCHS= i386 amd64

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig 1999-11-02 13:33:30 UTC
+++ Makefile.in
@@ -9,7 +9,7 @@ SRCS= lmmon.c
PREFIX= @prefix@
BINDIR= $(PREFIX)/bin
-MANDIR= $(PREFIX)/man/man
+MANDIR= $(PREFIX)/share/man/man
PROG= lmmon
MAN8= lmmon.8

View File

@ -21,7 +21,7 @@ ALTQ_DESC= ALTQ support for queue statistics
.include <bsd.port.options.mk>
MAKE_ARGS= LOCALBASE="${PREFIX}"
MAKE_ARGS= LOCALBASE="${PREFIX}" MANDIR=${PREFIX}/share/man/man
CFLAGS+= -DHAVE_SNPRINTF=1 -DHAVE_VSNPRINTF=1

View File

@ -1,11 +0,0 @@
--- Makefile.orig 2023-11-13 12:00:08 UTC
+++ Makefile
@@ -13,7 +13,7 @@ MAN= pftop.8
CFLAGS+= -Wall -Wno-unneeded-internal-declaration -DOS_LEVEL=${OSLEVEL}
LDADD+= -L${LOCALBASE}/lib -lcurses -lpfctl
-MANDIR=${LOCALBASE}/man/man
+MANDIR=${LOCALBASE}/share/man/man
BINDIR=${LOCALBASE}/sbin
.y.c: