Update dns/dnscrypt-wrapper to 0.2.2
PR: 216899 Submitted by: freebsd@toyingwithfate.com Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D9482
This commit is contained in:
parent
e3216a8797
commit
7a5fb5edb7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433647
4 changed files with 6 additions and 54 deletions
|
@ -1,22 +1,21 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dnscrypt-wrapper
|
||||
PORTVERSION= 0.2.1
|
||||
PORTVERSION= 0.2.2
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= dns
|
||||
|
||||
MAINTAINER= freebsd@toyingwithfate.com
|
||||
COMMENT= Adds dnscrypt support to any name resolver
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE= ISCL
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libsodium.so:security/libsodium \
|
||||
libevent.so:devel/libevent2
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Cofyc
|
||||
GH_ACCOUNT= cofyc
|
||||
|
||||
USERS= _dnscrypt-wrapper
|
||||
ETCDNSCRYPTWRAPPER= ${PREFIX}/etc/${PORTNAME}
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (Cofyc-dnscrypt-wrapper-v0.2.1_GH0.tar.gz) = 28c9936e90fc5602821353ca34c3180a047ae9eff08e0373cfa582e6af0c4e90
|
||||
SIZE (Cofyc-dnscrypt-wrapper-v0.2.1_GH0.tar.gz) = 52026
|
||||
TIMESTAMP = 1486543775
|
||||
SHA256 (cofyc-dnscrypt-wrapper-v0.2.2_GH0.tar.gz) = 6ac2a813d05a3d985da5b9ecce7147e1d3062b23e173ad7c99e7e2719b5a12a8
|
||||
SIZE (cofyc-dnscrypt-wrapper-v0.2.2_GH0.tar.gz) = 45976
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
--- Makefile.orig 2016-07-08 19:10:05 UTC
|
||||
+++ Makefile
|
||||
@@ -7,7 +7,7 @@ all::
|
||||
|
||||
### Defaults
|
||||
|
||||
-BASIC_CFLAGS = -O2 -std=c99 -Wall -I./argparse
|
||||
+BASIC_CFLAGS = -std=c99 -Wall -I./argparse
|
||||
BASIC_LDFLAGS = -lm -lsodium
|
||||
|
||||
# Guard against environment variables
|
||||
@@ -29,13 +29,13 @@ uname_P := $(shell sh -c 'uname -p 2>/de
|
||||
uname_V := $(shell sh -c 'uname -v 2>/dev/null || echo not')
|
||||
|
||||
# CFLAGS and LDFLAGS are for users to override
|
||||
-CFLAGS = -g -O2 -Wall
|
||||
-LDFLAGS =
|
||||
+CFLAGS ?= -g -O2 -Wall
|
||||
+LDFLAGS ?=
|
||||
STRIP ?= strip
|
||||
|
||||
# We use ALL_* variants
|
||||
-ALL_CFLAGS = $(CFLAGS) $(BASIC_CFLAGS)
|
||||
-ALL_LDFLAGS = $(LDFLAGS) $(BASIC_LDFLAGS)
|
||||
+ALL_CFLAGS = $(BASIC_CFLAGS) $(CFLAGS)
|
||||
+ALL_LDFLAGS = $(BASIC_LDFLAGS) $(LDFLAGS)
|
||||
|
||||
ifdef PREFIX
|
||||
prefix = $(PREFIX)
|
|
@ -1,19 +0,0 @@
|
|||
--- argparse/Makefile.orig 2016-07-08 19:10:50 UTC
|
||||
+++ argparse/Makefile
|
||||
@@ -1,10 +1,13 @@
|
||||
# Defaults
|
||||
-BASIC_CFLAGS = -Wall -O3 -g -ggdb -fPIC
|
||||
+CFLAGS ?= -O3 -g -ggdb
|
||||
+LDFLAGS ?=
|
||||
+
|
||||
+BASIC_CFLAGS = -Wall -fPIC
|
||||
BASIC_LDFLAGS = -lm
|
||||
|
||||
# We use ALL_* variants
|
||||
-ALL_CFLAGS = $(CFLAGS) $(BASIC_CFLAGS)
|
||||
-ALL_LDFLAGS = $(LDFLAGS) $(BASIC_LDFLAGS)
|
||||
+ALL_CFLAGS = $(BASIC_CFLAGS) $(CFLAGS)
|
||||
+ALL_LDFLAGS = $(BASIC_LDFLAGS) $(LDFLAGS)
|
||||
|
||||
LIBNAME=libargparse
|
||||
|
Loading…
Reference in a new issue