- Update to 2.32 [1]
- Remove leading, undefined article from COMMENT - Add graphics/ImageMagick to RUN_DEPENDS - Enable garbage collection via devel/boehm-gc-threaded [1] - Sort variables - Use autotools [1] - Use texlive, and don't install files already installed by it [1] - Use options helpers - Add option OFFSCREEN (default off) to enable offscreen rendering using OSMesa library - Add support for stage dir [1] - Strip binary file asy - Add files/patch-configure.ac and files/patch-settings.cc - Remove Author field, and use a single space after WWW in pkg-descr [1] Release Notes: http://sourceforge.net/projects/asymptote/files/2.32/ PR: ports/190196 [1] Submitted by: Shin-ya Murakami <murashin@gfd-dennou.org>
This commit is contained in:
parent
a156183d0d
commit
7a6cad39c4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=355661
7 changed files with 237 additions and 90 deletions
|
@ -2,8 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= asymptote
|
||||
PORTVERSION= 2.16
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 2.32
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= SF
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
|
||||
|
@ -11,108 +11,94 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
|
|||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= nivit@FreeBSD.org
|
||||
COMMENT= A powerful script-based vector graphics language
|
||||
COMMENT= Powerful script-based vector graphics language
|
||||
|
||||
LICENSE= GPLv3 LGPL3
|
||||
LICENSE_COMB= dual
|
||||
|
||||
RUN_DEPENDS= gv:${PORTSDIR}/print/gv \
|
||||
${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
|
||||
${PYTHON_PKGNAMEPREFIX}imaging>=1.1.6_3:${PORTSDIR}/graphics/py-imaging
|
||||
LIB_DEPENDS= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
|
||||
RUN_DEPENDS= animate:${PORTSDIR}/graphics/ImageMagick \
|
||||
gv:${PORTSDIR}/print/gv \
|
||||
${PYTHON_PKGNAMEPREFIX}imaging>=1.1.6_3:${PORTSDIR}/graphics/py-imaging \
|
||||
${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
|
||||
|
||||
ALL_TARGET= asy asy-keywords.el
|
||||
|
||||
CONFIGURE_ARGS= --enable-gc
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
INSTALL_TARGET= install-asy
|
||||
|
||||
MAKE_ENV= ${CONFIGURE_ENV} ASYMPTOTE_HOME=${WRKDIR} HOME=${WRKDIR}
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
# it requires boehm-gc 7.X with Pthread enabled
|
||||
CONFIGURE_ARGS= --disable-gc
|
||||
|
||||
USE_GHOSTSCRIPT=yes
|
||||
USE_TEX= latex
|
||||
USE_GL= glut
|
||||
USES= gmake perl5
|
||||
USE_AUTOTOOLS= autoconf aclocal
|
||||
USE_GHOSTSCRIPT=yes
|
||||
USE_GL= glut
|
||||
USE_PERL5= build
|
||||
USE_PYTHON= yes
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
USE_TEX= dvipsk formats texlive
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--with-latex=${LOCALBASE}/share/texmf/tex/latex \
|
||||
--with-context=${LOCALBASE}/share/texmf/tex/context/third
|
||||
CONFIGURE_ENV= LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}"
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
MAKE_ENV+= ${CONFIGURE_ENV}
|
||||
|
||||
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
|
||||
PLIST_SUB= MKTEXLSR=${MKTEXLSR}
|
||||
|
||||
ALL_TARGET= asy asy-keywords.el
|
||||
INSTALL_TARGET= install-asy install-texhash
|
||||
|
||||
# Options
|
||||
OPTIONS_DEFINE= EXAMPLES GSL FFTW READLINE #DOCS MANPAGES
|
||||
OPTIONS_DEFAULT= EXAMPLES GSL FFTW READLINE #MANPAGES
|
||||
DOCS_BUILD_DEPENDS= texi2dvi:${PORTSDIR}/print/texinfo
|
||||
DOCS_CONFIGURE_WITH= docdir=${DOCSDIR}
|
||||
|
||||
GSL_DESC= Enable GNU Scientific library
|
||||
FFTW_CONFIGURE_ENABLE= fftw
|
||||
FFTW_DESC= Use FFTW to compute the Discrete Fourier Transform
|
||||
FFTW_LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3
|
||||
|
||||
GSL_CONFIGURE_ENABLE= gsl
|
||||
GSL_DESC= Enable GNU Scientific library
|
||||
GSL_LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
|
||||
|
||||
MANPAGES_BUILD_DEPENDS= texi2dvi:${PORTSDIR}/print/texinfo
|
||||
|
||||
OFFSCREEN_CONFIGURE_ENABLE= offscreen
|
||||
OFFSCREEN_DESC= Enable offscreen rendering using OSMesa library
|
||||
OFFSCREEN_LIB_DEPENDS= libOSMesa.so:${PORTSDIR}/graphics/libosmesa
|
||||
OPTIONS_DEFAULT= FFTW GSL MANPAGES READLINE
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES FFTW GSL MANPAGES OFFSCREEN READLINE
|
||||
|
||||
READLINE_CONFIGURE_ENABLE= readline
|
||||
READLINE_DESC= ${LIBEDIT_DESC}
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
# Documentation
|
||||
#.if ${PORT_OPTIONS:MDOCS}
|
||||
# teTeX is too old to compile the asymptote documentation
|
||||
.if 0
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
ALL_TARGET+= html
|
||||
CONFIGURE_ARGS+= --with-docdir=${DOCSDIR}
|
||||
INSTALL_TARGET+= install-html
|
||||
.endif
|
||||
|
||||
#.if ${PORT_OPTIONS:MMANPAGES}
|
||||
# teTeX is too old to compile the asymptote documentation
|
||||
.if 0
|
||||
MAN1= asy.1 xasy.1x
|
||||
.if ${PORT_OPTIONS:MMANPAGES}
|
||||
INFO= asy-faq
|
||||
ALL_TARGET+= man
|
||||
INSTALL_TARGET+= install-man
|
||||
.endif
|
||||
|
||||
#.if ${PORT_OPTIONS:MMANPAGES} || ${PORT_OPTIONS:MDOCS}
|
||||
# teTeX is too old to compile the asymptote documentation
|
||||
.if 0
|
||||
USE_TEX+= dvipsk:build
|
||||
BUILD_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick \
|
||||
makeinfo:${PORTSDIR}/textproc/texi2html \
|
||||
svn:${PORTSDIR}/devel/subversion \
|
||||
texi2dvi:${PORTSDIR}/print/texinfo
|
||||
.endif
|
||||
|
||||
# Examples
|
||||
.if !${PORT_OPTIONS:MEXAMPLES}
|
||||
post-install:
|
||||
@${RM} -R ${EXAMPLESDIR}
|
||||
@${RM} -R ${STAGEDIR}${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
# Optimizations
|
||||
.if ${PORT_OPTIONS:MGSL}
|
||||
LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
|
||||
CONFIGURE_ARGS+= --enable-gsl
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-gsl
|
||||
.endif
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},1' -i.bak ${WRKSRC}/settings.cc
|
||||
|
||||
.if ${PORT_OPTIONS:MFFTW}
|
||||
LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
|
||||
CONFIGURE_ARGS+= --enable-fftw
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-fftw
|
||||
.endif
|
||||
run-autotools:
|
||||
@(cd ${CONFIGURE_WRKSRC} && \
|
||||
${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} --force --install)
|
||||
|
||||
.if ${PORT_OPTIONS:MREADLINE}
|
||||
CONFIGURE_ARGS+= --enable-readline
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-readline
|
||||
.endif
|
||||
post-install:
|
||||
@(cd ${STAGEDIR}${PREFIX}/bin && \
|
||||
${LN} -sf ../share/asymptote/GUI/xasy.py xasy)
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/asy
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (asymptote-2.16.src.tgz) = 523694782a6fe82652b2893482cbe314b139893721887517be3e6820466f48fa
|
||||
SIZE (asymptote-2.16.src.tgz) = 1802976
|
||||
SHA256 (asymptote-2.32.src.tgz) = 2035035e02774598312d5588da2685d20fb85a378ea2bbe48b825c5442b18fa5
|
||||
SIZE (asymptote-2.32.src.tgz) = 1794495
|
||||
|
|
|
@ -1,6 +1,14 @@
|
|||
--- Makefile.in 2008-11-27 19:43:50.000000000 +0100
|
||||
+++ Makefile.in.port 2008-11-30 13:19:46.000000000 +0100
|
||||
@@ -55,7 +55,7 @@
|
||||
--- ./Makefile.in.orig 2014-05-22 18:11:41.000000000 +0200
|
||||
+++ ./Makefile.in 2014-05-27 05:26:25.000000000 +0200
|
||||
@@ -53,7 +53,6 @@
|
||||
EXEXTRA = piicon.eps *.views *.dat *.bib
|
||||
DOCEXTRA = *.asy *.csv *.dat latexusage.tex externalprc.tex pixel.pdf
|
||||
KEYWORDS = base $(ASYMPTOTE_SITEDIR)
|
||||
-LATEXFILES = asymptote.sty asycolors.sty ocg.sty latexmkrc
|
||||
CONTEXTFILES = colo-asy.tex
|
||||
ASY = ./asy -dir base -config "" -render=0
|
||||
|
||||
@@ -84,7 +83,7 @@
|
||||
asydir = $(datadir)/asymptote
|
||||
GUIdir = $(asydir)/GUI
|
||||
docdir = $(DESTDIR)@docdir@
|
||||
|
@ -8,4 +16,18 @@
|
|||
+exampledir = $(datadir)/examples/asymptote
|
||||
animationsdir = $(exampledir)/animations
|
||||
latexdir = $(DESTDIR)@latexdir@
|
||||
INSTALL = @INSTALL@
|
||||
contextdir = $(DESTDIR)@contextdir@
|
||||
@@ -234,13 +233,11 @@
|
||||
${INSTALL} -p -m 644 base/*.asy $(addprefix base/,$(EXTRA)) \
|
||||
asy-keywords.el $(asydir)
|
||||
${INSTALL} -p -m 755 GUI/*.py $(GUIdir)
|
||||
- ln -sf @datadir@/asymptote/GUI/xasy.py $(bindir)/$(XNAME)
|
||||
${INSTALL} -p -m 644 examples/*.asy $(addprefix examples/,$(EXEXTRA)) \
|
||||
doc/extra/*.asy $(addprefix doc/,$(DOCEXTRA)) $(exampledir)
|
||||
${INSTALL} -p -m 644 examples/animations/*.asy \
|
||||
examples/animations/inlinemovie.tex \
|
||||
examples/animations/inlinemovie3.tex $(animationsdir)
|
||||
- -${INSTALL} -p -m 644 $(addprefix doc/,$(LATEXFILES)) $(latexdir)
|
||||
-${INSTALL} -p -m 644 $(addprefix doc/,$(CONTEXTFILES)) $(contextdir)
|
||||
|
||||
install-html: html
|
||||
|
|
16
math/asymptote/files/patch-configure.ac
Normal file
16
math/asymptote/files/patch-configure.ac
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- ./configure.ac.orig 2014-05-22 18:12:40.000000000 +0200
|
||||
+++ ./configure.ac 2014-05-27 05:26:25.000000000 +0200
|
||||
@@ -1,4 +1,3 @@
|
||||
-# -*- Autoconf -*-
|
||||
# Run autoheader and autoconf to produce a header and configure script from
|
||||
# this file.
|
||||
|
||||
@@ -160,7 +159,7 @@
|
||||
CPPFLAGS=$CPPFLAGS" $INCL"
|
||||
AC_CHECK_HEADER(gc.h,
|
||||
AC_CHECK_LIB([gc],[GC_malloc],[
|
||||
- LIBS=$LIBS"-lgc "
|
||||
+ LIBS=$LIBS"-lgc-threaded "
|
||||
AC_MSG_NOTICE([enabling system $GCNAME])],[
|
||||
GCDIR=$GCFILE
|
||||
INCL="-I\$(GC)/include"
|
15
math/asymptote/files/patch-settings.cc
Normal file
15
math/asymptote/files/patch-settings.cc
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- ./settings.cc.orig 2014-05-22 18:11:31.000000000 +0200
|
||||
+++ ./settings.cc 2014-05-27 05:26:36.000000000 +0200
|
||||
@@ -94,10 +94,10 @@
|
||||
#ifdef __APPLE__
|
||||
string defaultPDFViewer="open";
|
||||
#else
|
||||
-string defaultPDFViewer="acroread";
|
||||
+string defaultPDFViewer="gv";
|
||||
#endif
|
||||
string defaultGhostscript="gs";
|
||||
-string defaultGhostscriptLibrary="/usr/lib/libgs.so";
|
||||
+string defaultGhostscriptLibrary="/usr/local/lib/libgs.so";
|
||||
string defaultDisplay="display";
|
||||
string defaultAnimate="animate";
|
||||
void queryRegistry() {}
|
|
@ -8,5 +8,4 @@ it is a programming language, as opposed to just a graphics program:
|
|||
it can therefore exploit the best features of script (command-driven)
|
||||
and graphical user interface (GUI) methods.
|
||||
|
||||
Author: Andy Hammerlindl, John Bowman, and Tom Prince
|
||||
WWW: http://asymptote.sourceforge.net/
|
||||
WWW: http://asymptote.sourceforge.net/
|
||||
|
|
|
@ -1,5 +1,89 @@
|
|||
bin/asy
|
||||
bin/xasy
|
||||
info/asymptote/Bode.png
|
||||
info/asymptote/CAD1.png
|
||||
info/asymptote/CDlabel.png
|
||||
info/asymptote/GaussianSurface.png
|
||||
info/asymptote/HermiteSpline.png
|
||||
info/asymptote/Hobbycontrol.png
|
||||
info/asymptote/Hobbydir.png
|
||||
info/asymptote/asymptote.info
|
||||
info/asymptote/axis3.png
|
||||
info/asymptote/bezier.png
|
||||
info/asymptote/bezier2.png
|
||||
info/asymptote/beziercurve.png
|
||||
info/asymptote/bigdiagonal.png
|
||||
info/asymptote/binarytreetest.png
|
||||
info/asymptote/brokenaxis.png
|
||||
info/asymptote/colons.png
|
||||
info/asymptote/colors.png
|
||||
info/asymptote/cube.png
|
||||
info/asymptote/cylinderskeleton.png
|
||||
info/asymptote/datagraph.png
|
||||
info/asymptote/diagonal.png
|
||||
info/asymptote/diatom.png
|
||||
info/asymptote/dots.png
|
||||
info/asymptote/eetomumu.png
|
||||
info/asymptote/elliptic.png
|
||||
info/asymptote/errorbars.png
|
||||
info/asymptote/exp.png
|
||||
info/asymptote/filegraph.png
|
||||
info/asymptote/flow.png
|
||||
info/asymptote/flowchartdemo.png
|
||||
info/asymptote/generalaxis.png
|
||||
info/asymptote/generalaxis3.png
|
||||
info/asymptote/graphmarkers.png
|
||||
info/asymptote/grid3xyz.png
|
||||
info/asymptote/hatch.png
|
||||
info/asymptote/helix.png
|
||||
info/asymptote/histogram.png
|
||||
info/asymptote/icon.png
|
||||
info/asymptote/image.png
|
||||
info/asymptote/imagecontour.png
|
||||
info/asymptote/irregularcontour.png
|
||||
info/asymptote/join.png
|
||||
info/asymptote/join3.png
|
||||
info/asymptote/knots.png
|
||||
info/asymptote/labelsquare.png
|
||||
info/asymptote/latexusage.png
|
||||
info/asymptote/leastsquares.png
|
||||
info/asymptote/legend.png
|
||||
info/asymptote/lineargraph.png
|
||||
info/asymptote/lineargraph0.png
|
||||
info/asymptote/linetype.png
|
||||
info/asymptote/log2graph.png
|
||||
info/asymptote/loggraph.png
|
||||
info/asymptote/loggrid.png
|
||||
info/asymptote/logimage.png
|
||||
info/asymptote/logo.png
|
||||
info/asymptote/logticks.png
|
||||
info/asymptote/makepen.png
|
||||
info/asymptote/markers1.png
|
||||
info/asymptote/markers2.png
|
||||
info/asymptote/mexicanhat.png
|
||||
info/asymptote/monthaxis.png
|
||||
info/asymptote/multicontour.png
|
||||
info/asymptote/onecontour.png
|
||||
info/asymptote/parametricgraph.png
|
||||
info/asymptote/penfunctionimage.png
|
||||
info/asymptote/penimage.png
|
||||
info/asymptote/planes.png
|
||||
info/asymptote/quartercircle.png
|
||||
info/asymptote/saddle.png
|
||||
info/asymptote/scaledgraph.png
|
||||
info/asymptote/secondaryaxis.png
|
||||
info/asymptote/shadedtiling.png
|
||||
info/asymptote/slopefield1.png
|
||||
info/asymptote/square.png
|
||||
info/asymptote/subpictures.png
|
||||
info/asymptote/superpath.png
|
||||
info/asymptote/tile.png
|
||||
info/asymptote/triangulate.png
|
||||
info/asymptote/unitcircle3.png
|
||||
info/asymptote/vectorfield.png
|
||||
info/asymptote/westnile.png
|
||||
man/man1/asy.1.gz
|
||||
man/man1/xasy.1x.gz
|
||||
%%DATADIR%%/CAD.asy
|
||||
%%DATADIR%%/GUI/CubicBezier.py
|
||||
%%DATADIR%%/GUI/UndoRedoStack.py
|
||||
|
@ -23,6 +107,7 @@ bin/xasy
|
|||
%%DATADIR%%/asy-keywords.el
|
||||
%%DATADIR%%/asy-mode.el
|
||||
%%DATADIR%%/asy.vim
|
||||
%%DATADIR%%/asy_filetype.vim
|
||||
%%DATADIR%%/asymptote.py
|
||||
%%DATADIR%%/babel.asy
|
||||
%%DATADIR%%/bezulate.asy
|
||||
|
@ -98,6 +183,22 @@ bin/xasy
|
|||
%%DATADIR%%/unicode.asy
|
||||
%%DATADIR%%/version.asy
|
||||
%%DATADIR%%/x11colors.asy
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CAD.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TeXShopAndAsymptote.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.ascii
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section2.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section3.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section4.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section5.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section6.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section7.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section8.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-faq.html/section9.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asy-latex.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asyRefCard.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/asymptote.pdf
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/100d.views
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1overx.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BezierPatch.asy
|
||||
|
@ -118,6 +219,7 @@ bin/xasy
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NURBSsurface.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Pythagoras.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/PythagoreanTree.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/RiemannSphere.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/RiemannSurface.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/RiemannSurfaceRoot.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Sierpinski.asy
|
||||
|
@ -159,6 +261,7 @@ bin/xasy
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/centroidfg.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cheese.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/circles.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/circumcircle.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clockarray.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coag.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/colons.asy
|
||||
|
@ -249,6 +352,9 @@ bin/xasy
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/labelbox.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/labelsquare.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/laserlattice.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/latexusage-1.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/latexusage-2.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/latexusage-3.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/latexusage.tex
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/latticeshading.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/layers.asy
|
||||
|
@ -318,6 +424,7 @@ bin/xasy
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quilt.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rainbow.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/randompath3.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/refs.bib
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ring.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/roll.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/roundpath.asy
|
||||
|
@ -377,6 +484,7 @@ bin/xasy
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trefoilknot.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/triads.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/triangle.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/triangles.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/triangulate.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/triceratops.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trumpet.asy
|
||||
|
@ -407,17 +515,18 @@ bin/xasy
|
|||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xxsq01x-1.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xxsq01y.asy
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/yingyang.asy
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/animations
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
|
||||
share/texmf/tex/context/third/asymptote/colo-asy.tex
|
||||
share/texmf/tex/latex/asymptote/asycolors.sty
|
||||
share/texmf/tex/latex/asymptote/asymptote.sty
|
||||
share/texmf/tex/latex/asymptote/latexmkrc
|
||||
share/texmf/tex/latex/asymptote/ocg.sty
|
||||
@dirrm %%DATADIR%%/GUI
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm share/texmf/tex/latex/asymptote
|
||||
@dirrm share/texmf/tex/context/third/asymptote
|
||||
@dirrm share/texmf/tex/context/third
|
||||
@unexec %%MKTEXLSR%% %D/share/texmf
|
||||
@exec %%MKTEXLSR%% %D/share/texmf
|
||||
%%TEXMFLOCALDIR%%/tex/context/third/asymptote/colo-asy.tex
|
||||
@dirrmtry info/asymptote
|
||||
@dirrmtry %%DATADIR%%/GUI
|
||||
@dirrmtry %%DATADIR%%
|
||||
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/asy-faq.html
|
||||
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
|
||||
%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/animations
|
||||
%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/tex/context/third/asymptote
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/tex/context/third
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/tex/context
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/tex/latex/asymptote
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/tex/latex
|
||||
@dirrmtry %%TEXMFLOCALDIR%%/tex
|
||||
@dirrmtry %%TEXMFLOCALDIR%%
|
||||
|
|
Loading…
Reference in a new issue