Update to 0.4.99.1 as in Deluge 0.5 Release Candidate 1.
This commit is contained in:
parent
9f6e81248b
commit
7a73c12247
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=186837
12 changed files with 184 additions and 114 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= deluge
|
||||
PORTVERSION= 0.4.90.3
|
||||
PORTVERSION= 0.4.99.1
|
||||
CATEGORIES= net-p2p python
|
||||
MASTER_SITES= http://deluge-torrent.org/downloads/
|
||||
|
||||
|
@ -17,7 +17,7 @@ LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost
|
|||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
|
||||
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
|
||||
|
||||
USE_GNOME= pygtk2
|
||||
USE_GNOME= pygtk2 desktopfileutils
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS=yes
|
||||
|
||||
|
@ -27,8 +27,9 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
|
||||
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' ${WRKSRC}/setup.py
|
||||
|
||||
.ifndef (NOPORTDOCS)
|
||||
post-install:
|
||||
@-update-desktop-database
|
||||
.ifndef (NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for i in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (deluge-0.4.90.3.tar.gz) = eecdbae003a9240d93ec023d7a81cd97
|
||||
SHA256 (deluge-0.4.90.3.tar.gz) = ab20445917020c05984e252be46f188155cbf928dcd93ae6dff2b5ec727ad8fc
|
||||
SIZE (deluge-0.4.90.3.tar.gz) = 470203
|
||||
MD5 (deluge-0.4.99.1.tar.gz) = 631c45e864a27df4925ecec8e8db415f
|
||||
SHA256 (deluge-0.4.99.1.tar.gz) = 596a6141c4e5a006cf26127e0fc3614c9517a66025d1227153312a418ce43af2
|
||||
SIZE (deluge-0.4.99.1.tar.gz) = 512688
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- setup.py.orig Thu Mar 1 18:27:45 2007
|
||||
+++ setup.py Fri Mar 2 18:38:43 2007
|
||||
@@ -44,7 +44,7 @@
|
||||
--- setup.py.orig Tue Mar 6 21:43:47 2007
|
||||
+++ setup.py Tue Mar 6 21:45:44 2007
|
||||
@@ -51,7 +51,7 @@
|
||||
#
|
||||
|
||||
removals = ['-g', '-DNDEBUG', '-O2', '-Wstrict-prototypes']
|
||||
|
@ -9,7 +9,7 @@
|
|||
|
||||
if pythonVersion == '2.5':
|
||||
cv_opt = sysconfig.get_config_vars()["CFLAGS"]
|
||||
@@ -78,12 +78,14 @@
|
||||
@@ -85,12 +85,14 @@
|
||||
deluge_core = Extension('deluge_core',
|
||||
include_dirs = ['./libtorrent', './libtorrent/include',
|
||||
'./libtorrent/include/libtorrent',
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
Index: /trunk/src/deluge_core.cpp
|
||||
===================================================================
|
||||
--- src/deluge_core.cpp (revision 205)
|
||||
+++ src/deluge_core.cpp (revision 292)
|
||||
@@ -861,4 +861,7 @@
|
||||
"pieces", py_pieces
|
||||
);
|
||||
+
|
||||
+ Py_DECREF(py_pieces); // Assuming the previous line does NOT steal the ref, then this is
|
||||
+ // needed!
|
||||
|
||||
PyTuple_SetItem(ret, i, peer_info);
|
|
@ -1,35 +1,15 @@
|
|||
Index: /trunk/src/delugegtk.py
|
||||
===================================================================
|
||||
--- src/delugegtk.py (revision 288)
|
||||
+++ src/delugegtk.py (revision 289)
|
||||
@@ -695,6 +695,5 @@
|
||||
self.wtree.get_widget("toolbutton_pause").set_stock_id(gtk.STOCK_MEDIA_PAUSE)
|
||||
except KeyError:
|
||||
- pass
|
||||
- self.saved_peer_info = None
|
||||
+ pass
|
||||
|
||||
|
||||
@@ -744,8 +743,5 @@
|
||||
unique_id = self.get_selected_torrent()
|
||||
|
||||
- self.saved_peer_info = self.manager.get_torrent_peer_info(unique_id)
|
||||
-
|
||||
-
|
||||
- new_peer_info = self.saved_peer_info
|
||||
+ new_peer_info = self.manager.get_torrent_peer_info(unique_id)
|
||||
|
||||
new_ips = {}
|
||||
@@ -782,4 +778,12 @@
|
||||
dcommon.frate(peer["download_speed"]),
|
||||
dcommon.frate(peer["upload_speed"])])
|
||||
+ #print new_ips
|
||||
+ #print curr_ips
|
||||
+ #print new_peer_info
|
||||
+ del new_peer_info
|
||||
+ del new_ips
|
||||
+ del curr_ips
|
||||
+
|
||||
+
|
||||
|
||||
elif tab == 2: #File List
|
||||
--- src/delugegtk.py.orig Tue Mar 6 20:46:00 2007
|
||||
+++ src/delugegtk.py Tue Mar 6 22:42:58 2007
|
||||
@@ -33,9 +33,9 @@
|
||||
def __init__(self):
|
||||
APP = 'deluge'
|
||||
DIR = os.path.join(dcommon.INSTALL_PREFIX, 'share', 'locale')
|
||||
- locale.setlocale(locale.LC_ALL, '')
|
||||
- locale.bindtextdomain(APP, DIR)
|
||||
- locale.textdomain(APP)
|
||||
+# locale.setlocale(locale.LC_ALL, '')
|
||||
+# locale.bindtextdomain(APP, DIR)
|
||||
+# locale.textdomain(APP)
|
||||
gettext.bindtextdomain(APP, DIR)
|
||||
gettext.textdomain(APP)
|
||||
gettext.install(APP, DIR)
|
||||
|
|
|
@ -49,8 +49,72 @@ share/applications/deluge.desktop
|
|||
%%DATADIR%%/plugins/TorrentSearch/searchdlg.glade
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
share/locale/bg/LC_MESSAGES/deluge.mo
|
||||
share/locale/ca/LC_MESSAGES/deluge.mo
|
||||
share/locale/cs/LC_MESSAGES/deluge.mo
|
||||
share/locale/da/LC_MESSAGES/deluge.mo
|
||||
share/locale/de/LC_MESSAGES/deluge.mo
|
||||
share/locale/el/LC_MESSAGES/deluge.mo
|
||||
share/locale/en_CA/LC_MESSAGES/deluge.mo
|
||||
share/locale/en_GB/LC_MESSAGES/deluge.mo
|
||||
share/locale/es/LC_MESSAGES/deluge.mo
|
||||
share/locale/et/LC_MESSAGES/deluge.mo
|
||||
share/locale/eu/LC_MESSAGES/deluge.mo
|
||||
share/locale/fi/LC_MESSAGES/deluge.mo
|
||||
share/locale/fr/LC_MESSAGES/deluge.mo
|
||||
share/locale/gl/LC_MESSAGES/deluge.mo
|
||||
share/locale/he/LC_MESSAGES/deluge.mo
|
||||
share/locale/hr/LC_MESSAGES/deluge.mo
|
||||
share/locale/hu/LC_MESSAGES/deluge.mo
|
||||
share/locale/it/LC_MESSAGES/deluge.mo
|
||||
share/locale/ja/LC_MESSAGES/deluge.mo
|
||||
share/locale/ko/LC_MESSAGES/deluge.mo
|
||||
share/locale/la/LC_MESSAGES/deluge.mo
|
||||
share/locale/lt/LC_MESSAGES/deluge.mo
|
||||
share/locale/lv/LC_MESSAGES/deluge.mo
|
||||
share/locale/nb/LC_MESSAGES/deluge.mo
|
||||
share/locale/nl/LC_MESSAGES/deluge.mo
|
||||
share/locale/pl/LC_MESSAGES/deluge.mo
|
||||
share/locale/pt/LC_MESSAGES/deluge.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/deluge.mo
|
||||
share/locale/ru/LC_MESSAGES/deluge.mo
|
||||
share/locale/sk/LC_MESSAGES/deluge.mo
|
||||
share/locale/sl/LC_MESSAGES/deluge.mo
|
||||
share/locale/sr/LC_MESSAGES/deluge.mo
|
||||
share/locale/sv/LC_MESSAGES/deluge.mo
|
||||
share/locale/tr/LC_MESSAGES/deluge.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/deluge.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/deluge.mo
|
||||
share/pixmaps/deluge.xpm
|
||||
@dirrmtry share/pixmaps
|
||||
@dirrmtry share/locale/zh_TW/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_TW
|
||||
@dirrmtry share/locale/zh_CN/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_CN
|
||||
@dirrmtry share/locale/sr/LC_MESSAGES
|
||||
@dirrmtry share/locale/sr
|
||||
@dirrmtry share/locale/sl/LC_MESSAGES
|
||||
@dirrmtry share/locale/sl
|
||||
@dirrmtry share/locale/sk/LC_MESSAGES
|
||||
@dirrmtry share/locale/sk
|
||||
@dirrmtry share/locale/pt/LC_MESSAGES
|
||||
@dirrmtry share/locale/pt
|
||||
@dirrmtry share/locale/pl/LC_MESSAGES
|
||||
@dirrmtry share/locale/pl
|
||||
@dirrmtry share/locale/la/LC_MESSAGES
|
||||
@dirrmtry share/locale/la
|
||||
@dirrmtry share/locale/ko/LC_MESSAGES
|
||||
@dirrmtry share/locale/ko
|
||||
@dirrmtry share/locale/gl/LC_MESSAGES
|
||||
@dirrmtry share/locale/gl
|
||||
@dirrmtry share/locale/fi/LC_MESSAGES
|
||||
@dirrmtry share/locale/fi
|
||||
@dirrmtry share/locale/el/LC_MESSAGES
|
||||
@dirrmtry share/locale/el
|
||||
@dirrmtry share/locale/cs/LC_MESSAGES
|
||||
@dirrmtry share/locale/cs
|
||||
@dirrmtry share/locale/ca/LC_MESSAGES
|
||||
@dirrmtry share/locale/ca
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm %%DATADIR%%/plugins/TorrentSearch
|
||||
@dirrm %%DATADIR%%/plugins/NetworkHealth
|
||||
|
@ -63,3 +127,5 @@ share/pixmaps/deluge.xpm
|
|||
@dirrm %%DATADIR%%
|
||||
@dirrmtry share/applications
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/deluge
|
||||
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
|
||||
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= deluge
|
||||
PORTVERSION= 0.4.90.3
|
||||
PORTVERSION= 0.4.99.1
|
||||
CATEGORIES= net-p2p python
|
||||
MASTER_SITES= http://deluge-torrent.org/downloads/
|
||||
|
||||
|
@ -17,7 +17,7 @@ LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost
|
|||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
|
||||
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
|
||||
|
||||
USE_GNOME= pygtk2
|
||||
USE_GNOME= pygtk2 desktopfileutils
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS=yes
|
||||
|
||||
|
@ -27,8 +27,9 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
|
||||
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' ${WRKSRC}/setup.py
|
||||
|
||||
.ifndef (NOPORTDOCS)
|
||||
post-install:
|
||||
@-update-desktop-database
|
||||
.ifndef (NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for i in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (deluge-0.4.90.3.tar.gz) = eecdbae003a9240d93ec023d7a81cd97
|
||||
SHA256 (deluge-0.4.90.3.tar.gz) = ab20445917020c05984e252be46f188155cbf928dcd93ae6dff2b5ec727ad8fc
|
||||
SIZE (deluge-0.4.90.3.tar.gz) = 470203
|
||||
MD5 (deluge-0.4.99.1.tar.gz) = 631c45e864a27df4925ecec8e8db415f
|
||||
SHA256 (deluge-0.4.99.1.tar.gz) = 596a6141c4e5a006cf26127e0fc3614c9517a66025d1227153312a418ce43af2
|
||||
SIZE (deluge-0.4.99.1.tar.gz) = 512688
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- setup.py.orig Thu Mar 1 18:27:45 2007
|
||||
+++ setup.py Fri Mar 2 18:38:43 2007
|
||||
@@ -44,7 +44,7 @@
|
||||
--- setup.py.orig Tue Mar 6 21:43:47 2007
|
||||
+++ setup.py Tue Mar 6 21:45:44 2007
|
||||
@@ -51,7 +51,7 @@
|
||||
#
|
||||
|
||||
removals = ['-g', '-DNDEBUG', '-O2', '-Wstrict-prototypes']
|
||||
|
@ -9,7 +9,7 @@
|
|||
|
||||
if pythonVersion == '2.5':
|
||||
cv_opt = sysconfig.get_config_vars()["CFLAGS"]
|
||||
@@ -78,12 +78,14 @@
|
||||
@@ -85,12 +85,14 @@
|
||||
deluge_core = Extension('deluge_core',
|
||||
include_dirs = ['./libtorrent', './libtorrent/include',
|
||||
'./libtorrent/include/libtorrent',
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
Index: /trunk/src/deluge_core.cpp
|
||||
===================================================================
|
||||
--- src/deluge_core.cpp (revision 205)
|
||||
+++ src/deluge_core.cpp (revision 292)
|
||||
@@ -861,4 +861,7 @@
|
||||
"pieces", py_pieces
|
||||
);
|
||||
+
|
||||
+ Py_DECREF(py_pieces); // Assuming the previous line does NOT steal the ref, then this is
|
||||
+ // needed!
|
||||
|
||||
PyTuple_SetItem(ret, i, peer_info);
|
|
@ -1,35 +1,15 @@
|
|||
Index: /trunk/src/delugegtk.py
|
||||
===================================================================
|
||||
--- src/delugegtk.py (revision 288)
|
||||
+++ src/delugegtk.py (revision 289)
|
||||
@@ -695,6 +695,5 @@
|
||||
self.wtree.get_widget("toolbutton_pause").set_stock_id(gtk.STOCK_MEDIA_PAUSE)
|
||||
except KeyError:
|
||||
- pass
|
||||
- self.saved_peer_info = None
|
||||
+ pass
|
||||
|
||||
|
||||
@@ -744,8 +743,5 @@
|
||||
unique_id = self.get_selected_torrent()
|
||||
|
||||
- self.saved_peer_info = self.manager.get_torrent_peer_info(unique_id)
|
||||
-
|
||||
-
|
||||
- new_peer_info = self.saved_peer_info
|
||||
+ new_peer_info = self.manager.get_torrent_peer_info(unique_id)
|
||||
|
||||
new_ips = {}
|
||||
@@ -782,4 +778,12 @@
|
||||
dcommon.frate(peer["download_speed"]),
|
||||
dcommon.frate(peer["upload_speed"])])
|
||||
+ #print new_ips
|
||||
+ #print curr_ips
|
||||
+ #print new_peer_info
|
||||
+ del new_peer_info
|
||||
+ del new_ips
|
||||
+ del curr_ips
|
||||
+
|
||||
+
|
||||
|
||||
elif tab == 2: #File List
|
||||
--- src/delugegtk.py.orig Tue Mar 6 20:46:00 2007
|
||||
+++ src/delugegtk.py Tue Mar 6 22:42:58 2007
|
||||
@@ -33,9 +33,9 @@
|
||||
def __init__(self):
|
||||
APP = 'deluge'
|
||||
DIR = os.path.join(dcommon.INSTALL_PREFIX, 'share', 'locale')
|
||||
- locale.setlocale(locale.LC_ALL, '')
|
||||
- locale.bindtextdomain(APP, DIR)
|
||||
- locale.textdomain(APP)
|
||||
+# locale.setlocale(locale.LC_ALL, '')
|
||||
+# locale.bindtextdomain(APP, DIR)
|
||||
+# locale.textdomain(APP)
|
||||
gettext.bindtextdomain(APP, DIR)
|
||||
gettext.textdomain(APP)
|
||||
gettext.install(APP, DIR)
|
||||
|
|
|
@ -49,8 +49,72 @@ share/applications/deluge.desktop
|
|||
%%DATADIR%%/plugins/TorrentSearch/searchdlg.glade
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
share/locale/bg/LC_MESSAGES/deluge.mo
|
||||
share/locale/ca/LC_MESSAGES/deluge.mo
|
||||
share/locale/cs/LC_MESSAGES/deluge.mo
|
||||
share/locale/da/LC_MESSAGES/deluge.mo
|
||||
share/locale/de/LC_MESSAGES/deluge.mo
|
||||
share/locale/el/LC_MESSAGES/deluge.mo
|
||||
share/locale/en_CA/LC_MESSAGES/deluge.mo
|
||||
share/locale/en_GB/LC_MESSAGES/deluge.mo
|
||||
share/locale/es/LC_MESSAGES/deluge.mo
|
||||
share/locale/et/LC_MESSAGES/deluge.mo
|
||||
share/locale/eu/LC_MESSAGES/deluge.mo
|
||||
share/locale/fi/LC_MESSAGES/deluge.mo
|
||||
share/locale/fr/LC_MESSAGES/deluge.mo
|
||||
share/locale/gl/LC_MESSAGES/deluge.mo
|
||||
share/locale/he/LC_MESSAGES/deluge.mo
|
||||
share/locale/hr/LC_MESSAGES/deluge.mo
|
||||
share/locale/hu/LC_MESSAGES/deluge.mo
|
||||
share/locale/it/LC_MESSAGES/deluge.mo
|
||||
share/locale/ja/LC_MESSAGES/deluge.mo
|
||||
share/locale/ko/LC_MESSAGES/deluge.mo
|
||||
share/locale/la/LC_MESSAGES/deluge.mo
|
||||
share/locale/lt/LC_MESSAGES/deluge.mo
|
||||
share/locale/lv/LC_MESSAGES/deluge.mo
|
||||
share/locale/nb/LC_MESSAGES/deluge.mo
|
||||
share/locale/nl/LC_MESSAGES/deluge.mo
|
||||
share/locale/pl/LC_MESSAGES/deluge.mo
|
||||
share/locale/pt/LC_MESSAGES/deluge.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/deluge.mo
|
||||
share/locale/ru/LC_MESSAGES/deluge.mo
|
||||
share/locale/sk/LC_MESSAGES/deluge.mo
|
||||
share/locale/sl/LC_MESSAGES/deluge.mo
|
||||
share/locale/sr/LC_MESSAGES/deluge.mo
|
||||
share/locale/sv/LC_MESSAGES/deluge.mo
|
||||
share/locale/tr/LC_MESSAGES/deluge.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/deluge.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/deluge.mo
|
||||
share/pixmaps/deluge.xpm
|
||||
@dirrmtry share/pixmaps
|
||||
@dirrmtry share/locale/zh_TW/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_TW
|
||||
@dirrmtry share/locale/zh_CN/LC_MESSAGES
|
||||
@dirrmtry share/locale/zh_CN
|
||||
@dirrmtry share/locale/sr/LC_MESSAGES
|
||||
@dirrmtry share/locale/sr
|
||||
@dirrmtry share/locale/sl/LC_MESSAGES
|
||||
@dirrmtry share/locale/sl
|
||||
@dirrmtry share/locale/sk/LC_MESSAGES
|
||||
@dirrmtry share/locale/sk
|
||||
@dirrmtry share/locale/pt/LC_MESSAGES
|
||||
@dirrmtry share/locale/pt
|
||||
@dirrmtry share/locale/pl/LC_MESSAGES
|
||||
@dirrmtry share/locale/pl
|
||||
@dirrmtry share/locale/la/LC_MESSAGES
|
||||
@dirrmtry share/locale/la
|
||||
@dirrmtry share/locale/ko/LC_MESSAGES
|
||||
@dirrmtry share/locale/ko
|
||||
@dirrmtry share/locale/gl/LC_MESSAGES
|
||||
@dirrmtry share/locale/gl
|
||||
@dirrmtry share/locale/fi/LC_MESSAGES
|
||||
@dirrmtry share/locale/fi
|
||||
@dirrmtry share/locale/el/LC_MESSAGES
|
||||
@dirrmtry share/locale/el
|
||||
@dirrmtry share/locale/cs/LC_MESSAGES
|
||||
@dirrmtry share/locale/cs
|
||||
@dirrmtry share/locale/ca/LC_MESSAGES
|
||||
@dirrmtry share/locale/ca
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm %%DATADIR%%/plugins/TorrentSearch
|
||||
@dirrm %%DATADIR%%/plugins/NetworkHealth
|
||||
|
@ -63,3 +127,5 @@ share/pixmaps/deluge.xpm
|
|||
@dirrm %%DATADIR%%
|
||||
@dirrmtry share/applications
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/deluge
|
||||
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
|
||||
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
|
||||
|
|
Loading…
Reference in a new issue