Remove net/xmlrpc++ per deprecation note.
This commit is contained in:
parent
edbca44ced
commit
7a78e9d895
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=243585
8 changed files with 1 additions and 93 deletions
1
MOVED
1
MOVED
|
@ -4193,3 +4193,4 @@ databases/ruby-dbd_proxy||2009-10-29|Has expired: no longer under development
|
|||
databases/ruby-dbd_interbase||2009-10-29|Has expired: no longer under development
|
||||
textproc/p5-XML-LibXML-Common|textproc/p5-XML-LibXML|2009-10-30|merged
|
||||
misc/bibletime-kde4|misc/bibletime|2009-10-30|Renamed now that KDE dependencies are removed
|
||||
net/xmlrpc++||2009-10-31|Unmaintained upstream and on the FreeBSD side
|
||||
|
|
|
@ -1080,7 +1080,6 @@
|
|||
SUBDIR += xipdump
|
||||
SUBDIR += xipmsg
|
||||
SUBDIR += xisp
|
||||
SUBDIR += xmlrpc++
|
||||
SUBDIR += xmlrpc-c
|
||||
SUBDIR += xmlrpc-c-devel
|
||||
SUBDIR += xmlrpc-epi
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: xmlrpc++
|
||||
# Date created: Nov 13, 2003
|
||||
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= xmlrpc++
|
||||
PORTVERSION= 0.7
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= SF/xmlrpcpp/xmlrpc%2B%2B/Version%20${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A C++ implementation of the XML-RPC protocol
|
||||
|
||||
DEPRECATED= depends on old version of GCC, no maintainer, not used by any other port, dead upstream
|
||||
EXPIRATION_DATE=2009-10-13
|
||||
|
||||
USE_GCC= 3.4
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|^CXX|#CXX|" -e "s|^CXXFLAGS|#CXXFLAGS|" \
|
||||
-e "s|tests$$||" ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/include/xmlrpc++
|
||||
${INSTALL_DATA} ${WRKSRC}/src/XmlRpc*.h ${PREFIX}/include/xmlrpc++
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/libXmlRpc.a ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (xmlrpc++0.7.tar.gz) = d88f0f9c36d938316d672d16f6c37d7e
|
||||
SHA256 (xmlrpc++0.7.tar.gz) = 39fc78ec6d15865009eef19241f58aa1a8e3685ce0f0c59a66ae44787d8d267f
|
||||
SIZE (xmlrpc++0.7.tar.gz) = 64037
|
|
@ -1,11 +0,0 @@
|
|||
--- test/Validator.cpp.orig Thu Nov 13 14:47:39 2003
|
||||
+++ test/Validator.cpp Thu Nov 13 14:47:56 2003
|
||||
@@ -137,7 +137,7 @@
|
||||
{
|
||||
std::cerr << "ModerateSizeArrayCheck\n";
|
||||
std::string s = params[0][0];
|
||||
- s += params[0][params[0].size()-1];
|
||||
+ s += (std::string)params[0][params[0].size()-1];
|
||||
result = s;
|
||||
}
|
||||
} moderateSizeArrayCheck(&s);
|
|
@ -1,13 +0,0 @@
|
|||
--- src/XmlRpcDispatch.cpp.orig Sun Jan 25 23:10:04 2004
|
||||
+++ src/XmlRpcDispatch.cpp Sun Jan 25 23:10:36 2004
|
||||
@@ -6,6 +6,10 @@
|
||||
#include <math.h>
|
||||
#include <sys/timeb.h>
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/time.h>
|
||||
+#include <unistd.h>
|
||||
+
|
||||
#if defined(_WINDOWS)
|
||||
# include <winsock2.h>
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
XmlRpc++ is a C++ implementation of the XML-RPC protocol. The XmlRpc protocol
|
||||
was designed to make remote procedure calls easy: it encodes data in a simple
|
||||
XML format and uses HTTP for communication. XmlRpc++ is designed to make it
|
||||
easy to incorporate XML-RPC client and server support into C++ applications.
|
||||
|
||||
Features:
|
||||
* Easy - This library is easy to incorporate into C++ applications. No
|
||||
other libraries are required, other than your system's socket
|
||||
libraries. Simple XML parsing and HTTP support are built in.
|
||||
* Fast - All IO is non-blocking, so a slow client or network will not
|
||||
slow down the server.
|
||||
* Portable - Written in standard C++ to the POSIX and Windows sockets
|
||||
APIs. You do need a fairly recent compiler (g++ 3.1 or
|
||||
MSVC++ .Net or MSVC++ 6 with the STL patches.)
|
||||
|
||||
* Free - This library is released under the GNU LGPL.
|
||||
|
||||
WWW: http://xmlrpcpp.sourceforge.net/
|
|
@ -1,13 +0,0 @@
|
|||
include/xmlrpc++/XmlRpc.h
|
||||
include/xmlrpc++/XmlRpcClient.h
|
||||
include/xmlrpc++/XmlRpcDispatch.h
|
||||
include/xmlrpc++/XmlRpcException.h
|
||||
include/xmlrpc++/XmlRpcServer.h
|
||||
include/xmlrpc++/XmlRpcServerConnection.h
|
||||
include/xmlrpc++/XmlRpcServerMethod.h
|
||||
include/xmlrpc++/XmlRpcSocket.h
|
||||
include/xmlrpc++/XmlRpcSource.h
|
||||
include/xmlrpc++/XmlRpcUtil.h
|
||||
include/xmlrpc++/XmlRpcValue.h
|
||||
@dirrm include/xmlrpc++
|
||||
lib/libXmlRpc.a
|
Loading…
Reference in a new issue