Allow staging/packaging as a regular user:

- pycompile only once, previously it would pycompile 3 imported modules
  (getopt, struct and py_compile) and make them read-only, and later try
  to pycompile them again and fail
- ranlib before installing archive read-only

With hat:	portmgr
This commit is contained in:
Antoine Brodin 2014-04-05 09:04:28 +00:00
parent c40ec5a9e0
commit 7acf693fdf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=350207

View file

@ -1,6 +1,6 @@
--- ./Makefile.pre.in.orig 2013-04-06 18:02:34.000000000 +0400
+++ ./Makefile.pre.in 2013-04-07 22:30:19.000000000 +0400
@@ -281,9 +281,9 @@
--- ./Makefile.pre.in.orig 2013-11-10 07:36:41.000000000 +0000
+++ ./Makefile.pre.in 2014-04-04 09:16:00.000000000 +0000
@@ -285,9 +285,9 @@
##########################################################################
# AST
@ -12,3 +12,28 @@
AST_C= $(AST_C_DIR)/Python-ast.c
AST_ASDL= $(srcdir)/Parser/Python.asdl
@@ -1006,12 +1006,12 @@
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
fi
PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
- $(PYTHON_FOR_BUILD) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
+ $(PYTHON_FOR_BUILD) -B -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
-d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
- $(PYTHON_FOR_BUILD) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
+ $(PYTHON_FOR_BUILD) -B -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
-d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
@@ -1089,8 +1089,8 @@
if test "$(SO)" = .dll; then \
$(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
else \
+ $(RANLIB) $(LIBRARY) ; \
$(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
fi; \
else \
echo Skip install of $(LIBRARY) - use make frameworkinstall; \