net/ndpi: update to 1.5.0
PR: 192700 Submitted by: maintainer
This commit is contained in:
parent
582199510d
commit
7ae164d451
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=365509
5 changed files with 86 additions and 13 deletions
|
@ -2,22 +2,30 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ndpi
|
||||
PORTVERSION= 1.4.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.5.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= SF/ntop/nDPI
|
||||
DISTNAME= nDPI-${PORTVERSION}_r7023
|
||||
DISTNAME= libndpi-${PORTVERSION}_r8115
|
||||
|
||||
MAINTAINER= 5u623l20@gmail.com
|
||||
COMMENT= ntop-maintained superset of the popular OpenDPI library
|
||||
COMMENT= NTOP-maintained superset of the popular OpenDPI library
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
LIB_DEPENDS= libjson-c.so:${PORTSDIR}/devel/json-c
|
||||
|
||||
CONFIGURE_ARGS= --with-pic
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/json-c
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
LIBS+= -ljson-c
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USES= libtool pathfix pkgconfig
|
||||
USES= libtool pathfix pkgconfig compiler:c++11-lang
|
||||
WRKSRC= ${WRKDIR}/libndpi-${PORTVERSION}
|
||||
|
||||
PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
|
||||
PLIST_SUB= MAJOR_VER=${PORTVERSION}
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libndpi.so.1.0.0
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (nDPI-1.4.0_r7023.tar.gz) = a06b45cbe9336d40acb7892a3399f41e7e341a37fd2526d0b242587d21bd4197
|
||||
SIZE (nDPI-1.4.0_r7023.tar.gz) = 522464
|
||||
SHA256 (libndpi-1.5.0_r8115.tar.gz) = c37b572b1a46643bfc127af197735c47c7895517ab397a4e5489c0ea82602740
|
||||
SIZE (libndpi-1.5.0_r8115.tar.gz) = 1140853
|
||||
|
|
18
net/ndpi/files/patch-configure
Normal file
18
net/ndpi/files/patch-configure
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- configure.orig 2014-08-16 00:57:46.212599224 +0600
|
||||
+++ configure 2014-08-16 00:58:17.728596731 +0600
|
||||
@@ -12619,13 +12619,13 @@
|
||||
|
||||
|
||||
|
||||
-SVN_RELEASE=`svn info . | grep "^Revision"|cut -d " " -f 2`
|
||||
+SVN_RELEASE="2014-08-13 21:10:03 +0600 (Wed, 13 Aug 2014)"
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
#define NDPI_SVN_RELEASE "r${SVN_RELEASE}"
|
||||
_ACEOF
|
||||
|
||||
-SVN_DATE=`svn info . | grep "^Last Changed Date"|cut -d " " -f 4-`
|
||||
+SVN_DATE="8122"
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
#define NDPI_SVN_DATE "${SVN_DATE}"
|
43
net/ndpi/files/patch-example_Makefile.in
Normal file
43
net/ndpi/files/patch-example_Makefile.in
Normal file
|
@ -0,0 +1,43 @@
|
|||
--- example/Makefile.in.orig 2014-08-16 02:17:06.480271669 +0600
|
||||
+++ example/Makefile.in 2014-08-16 02:20:49.689257564 +0600
|
||||
@@ -98,8 +98,7 @@
|
||||
am_ndpiReader_OBJECTS = ndpiReader.$(OBJEXT)
|
||||
ndpiReader_OBJECTS = $(am_ndpiReader_OBJECTS)
|
||||
ndpiReader_LDADD = $(LDADD)
|
||||
-ndpiReader_DEPENDENCIES = $(top_builddir)/src/lib/libndpi.la \
|
||||
- third-party/json-c/libjson-c.la
|
||||
+ndpiReader_DEPENDENCIES = $(top_builddir)/src/lib/libndpi.la
|
||||
AM_V_lt = $(am__v_lt_@AM_V@)
|
||||
am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
|
||||
am__v_lt_0 = --silent
|
||||
@@ -287,9 +286,9 @@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-AM_CPPFLAGS = -I$(top_srcdir)/src/include -I third-party/json-c
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
|
||||
AM_CFLAGS = @PTHREAD_CFLAGS@
|
||||
-LDADD = $(top_builddir)/src/lib/libndpi.la third-party/json-c/libjson-c.la @PTHREAD_LIBS@
|
||||
+LDADD = $(top_builddir)/src/lib/libndpi.la @PTHREAD_LIBS@
|
||||
ndpiReader_SOURCES = ndpiReader.c
|
||||
EXTRA_DIST = third-party
|
||||
all: all-am
|
||||
@@ -627,17 +626,11 @@
|
||||
|
||||
|
||||
# Explictely state that to build ndpiReader.o we first need json_config.h.
|
||||
-ndpiReader.o: third-party/json-c/libjson-c.la
|
||||
-
|
||||
-third-party/json-c/libjson-c.la:
|
||||
- cd third-party/json-c && ./configure
|
||||
- cd third-party/json-c && make libjson-c.la
|
||||
+ndpiReader.o:
|
||||
|
||||
clean-local:
|
||||
- cd third-party/json-c && make clean
|
||||
|
||||
distclean-local:
|
||||
- cd third-party/json-c && make distclean
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
@ -1,13 +1,17 @@
|
|||
bin/ndpiReader
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/linux_compat.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_api.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_debug_functions.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_define.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_macros.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_protocols_osdpi.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_public_functions.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_main.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_protocol_ids.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_protocols.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_typedefs.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_unix.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_win32.h
|
||||
lib/libndpi.a
|
||||
lib/libndpi.so
|
||||
lib/libndpi.so.1
|
||||
lib/libndpi.so.1.0.4
|
||||
lib/libndpi.so.1.0.0
|
||||
libdata/pkgconfig/libndpi.pc
|
||||
@dirrm include/libndpi-%%MAJOR_VER%%/libndpi
|
||||
@dirrm include/libndpi-%%MAJOR_VER%%
|
||||
|
|
Loading…
Reference in a new issue