- Update security/libfprint to 0.7.0
- Fix MASTER_SITES - Add LICENSE / LICENSE_FILE - Add missing dependencies: nspr and pixman - Remove unnecessary dependency: ssl - Re-generate patches using make makepatch PR: 230039 Approved by: maintainer
This commit is contained in:
parent
1c9edad518
commit
7aed89abb6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=475404
7 changed files with 24 additions and 19 deletions
|
@ -2,21 +2,25 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libfprint
|
||||
PORTVERSION= 0.6.0
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 0.7.0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://people.freedesktop.org/~hadess/
|
||||
MASTER_SITES= https://people.freedesktop.org/~anarsoul/
|
||||
|
||||
MAINTAINER= lichray@gmail.com
|
||||
COMMENT= Library for fingerprint reader devices
|
||||
|
||||
LICENSE= LGPL21
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libMagickCore-6.so:graphics/ImageMagick \
|
||||
libnss3.so:security/nss
|
||||
libnss3.so:security/nss \
|
||||
libnspr4.so:devel/nspr
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= libtool pathfix pkgconfig tar:xz ssl
|
||||
USES= libtool pathfix pkgconfig tar:xz
|
||||
USE_LDCONFIG= yes
|
||||
USE_GNOME= glib20
|
||||
USE_XORG= pixman
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
CPPFLAGS+= -DHAVE_MEMMEM
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (libfprint-0.6.0.tar.xz) = 2583fcb7d542a918c023776f188067fcedec614e65494dd52bc4d661be803cbe
|
||||
SIZE (libfprint-0.6.0.tar.xz) = 531572
|
||||
TIMESTAMP = 1532525845
|
||||
SHA256 (libfprint-0.7.0.tar.xz) = 863eee8cf4cbc56776cf08e5b98e30e130f3394b6db95bf8e01addb6bf08f1f3
|
||||
SIZE (libfprint-0.7.0.tar.xz) = 550484
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- config.h.in~ 2011-04-18 12:02:59.000000000 -0500
|
||||
+++ config.h.in 2011-10-01 23:12:01.979122045 -0500
|
||||
@@ -117,3 +117,8 @@
|
||||
--- config.h.in.orig 2017-05-14 16:27:23 UTC
|
||||
+++ config.h.in
|
||||
@@ -140,3 +140,8 @@
|
||||
#ifndef __cplusplus
|
||||
#undef inline
|
||||
#endif
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ./libfprint/drivers/vfs301.c.ORIG 2013-06-26 14:13:00.000000000 +0200
|
||||
+++ ./libfprint/drivers/vfs301.c 2014-04-21 11:09:12.000000000 +0200
|
||||
--- libfprint/drivers/vfs301.c.orig 2017-01-05 17:18:55 UTC
|
||||
+++ libfprint/drivers/vfs301.c
|
||||
@@ -27,7 +27,7 @@
|
||||
#include <stdio.h>
|
||||
#include <assert.h>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ./libfprint/drivers/vfs301_proto.c.ORIG 2013-06-26 14:13:00.000000000 +0200
|
||||
+++ ./libfprint/drivers/vfs301_proto.c 2014-04-21 11:09:19.000000000 +0200
|
||||
--- libfprint/drivers/vfs301_proto.c.orig 2013-01-12 13:18:37 UTC
|
||||
+++ libfprint/drivers/vfs301_proto.c
|
||||
@@ -33,7 +33,7 @@
|
||||
#include <stdio.h>
|
||||
#include <assert.h>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ./libfprint/drivers/vfs301_proto.h.ORIG 2013-06-26 14:13:00.000000000 +0200
|
||||
+++ ./libfprint/drivers/vfs301_proto.h 2014-04-21 11:09:27.000000000 +0200
|
||||
--- libfprint/drivers/vfs301_proto.h.orig 2013-01-12 13:18:37 UTC
|
||||
+++ libfprint/drivers/vfs301_proto.h
|
||||
@@ -18,7 +18,7 @@
|
||||
* License along with this library; if not, write to the Free Software
|
||||
* Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- libfprint/Makefile.in~ 2011-10-01 23:20:55.218924048 -0500
|
||||
+++ libfprint/Makefile.in 2011-10-01 23:23:50.108796610 -0500
|
||||
@@ -1195,7 +1195,7 @@ info: info-am
|
||||
--- libfprint/Makefile.in.orig 2017-05-14 16:27:17 UTC
|
||||
+++ libfprint/Makefile.in
|
||||
@@ -1578,7 +1578,7 @@ info: info-am
|
||||
|
||||
info-am:
|
||||
|
||||
|
|
Loading…
Reference in a new issue