Update to 2.5.7 and unbreak.

PR:		ports/77650
Submitted by:	Johan van Selst
This commit is contained in:
Thierry Thomas 2005-02-19 17:17:06 +00:00
parent 94e2a9a251
commit 7b00c80ee8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=129286
5 changed files with 57 additions and 37 deletions

View file

@ -6,12 +6,11 @@
#
PORTNAME= ccscript
PORTVERSION= 2.5.6
PORTREVISION= 1
PORTVERSION= 2.5.7
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
MASTER_SITE_SUBDIR= ccaudio/:gnu \
MASTER_SITE_SUBDIR= ccscript/:gnu \
bayonne/:sf
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gnu \
${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
@ -25,14 +24,10 @@ USE_GNOME= gnometarget
GNU_CONFIGURE= yes
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER= 15
MAN3= ScriptCommand.3cc ScriptImage.3cc ScriptInterp.3cc \
ScriptModule.3cc ScriptSymbol.3cc Script_Locks.3cc \
Script_Package.3cc Script_Property.3cc Script_Session.3cc
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 503001
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (ccscript-2.5.6.tar.gz) = c0e664ab13e054b37e0f7da40a7b488e
SIZE (ccscript-2.5.6.tar.gz) = 375473
MD5 (ccscript-2.5.7.tar.gz) = ef0f87184828bdc5e52ce58ab9ba3d3a
SIZE (ccscript-2.5.7.tar.gz) = 247988

View file

@ -1,15 +0,0 @@
--- config/ltmain.sh.orig Fri Feb 20 17:50:28 2004
+++ config/ltmain.sh Fri Feb 20 17:50:39 2004
@@ -5428,10 +5428,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -1,11 +0,0 @@
--- src/script.cpp.orig Fri Feb 20 17:51:13 2004
+++ src/script.cpp Fri Feb 20 17:52:01 2004
@@ -1209,7 +1209,7 @@
#endif
for(;;)
{
- scrname = dir.getName();
+ scrname = (char*)dir.getName();
if(!scrname)
break;
ext = strchr(scrname, '.');

View file

@ -0,0 +1,51 @@
--- src/script.h.orig Thu Feb 17 19:01:10 2005
+++ src/script.h Thu Feb 17 19:00:29 2005
@@ -550,11 +550,6 @@ protected:
virtual unsigned long getTrapMask(const char *trapname);
/**
- * Default compiler syntax to accept any syntax.
- */
- char *chkIgnore(Line *line, ScriptImage *img);
-
- /**
* Module based script checker.
*/
char *chkModule(Line *line, ScriptImage *img);
@@ -598,15 +593,6 @@ protected:
char *chkNoArgs(Line *line, ScriptImage *img);
/**
- * Script compiler syntax check for commands that require
- * one or more arguments to be present.
- *
- * @return syntax error message string or NULL.
- * @param line statement.
- */
- char *chkHasArgs(Line *line, ScriptImage *img);
-
- /**
* Load a set of keywords into the system keyword table. This
* provides a convenient method of initializing and adding to
* the keyword indexes.
@@ -658,6 +644,20 @@ public:
virtual int mapnicmp(const char *s1, const char *s2, size_t n)
{return strnicmp(s1, s2, n);};
+
+ /**
+ * Script compiler syntax check for commands that require
+ * one or more arguments to be present.
+ *
+ * @return syntax error message string or NULL.
+ * @param line statement.
+ */
+ char *chkHasArgs(Line *line, ScriptImage *img);
+
+ /**
+ * Default compiler syntax to accept any syntax.
+ */
+ char *chkIgnore(Line *line, ScriptImage *img);
};
/**