* New port:
This is development version of net/bird dynamic routing software. It provides ALPHA support for the following: - VPNv4 RR - LDP - L3VPN Submitted by: melifaro
This commit is contained in:
parent
f70f6f5568
commit
7b2e3e4ebd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=285285
8 changed files with 136 additions and 0 deletions
|
@ -50,6 +50,7 @@
|
|||
SUBDIR += bindtest
|
||||
SUBDIR += binkd
|
||||
SUBDIR += bird
|
||||
SUBDIR += bird-devel
|
||||
SUBDIR += bird6
|
||||
SUBDIR += bittwist
|
||||
SUBDIR += blam
|
||||
|
|
52
net/bird-devel/Makefile
Normal file
52
net/bird-devel/Makefile
Normal file
|
@ -0,0 +1,52 @@
|
|||
# New ports collection makefile for: bird
|
||||
# Date created: 8 November 2011
|
||||
# Whom: Alexander V. Chernikov <melifaro@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= bird
|
||||
PORTVERSION= 20111107
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://bird.mpls.in/distfiles/bird/
|
||||
PKGNAMESUFFIX= -devel
|
||||
|
||||
MAINTAINER= melifaro@ipfw.ru
|
||||
COMMENT= Dynamic IP routing daemon (devel version)
|
||||
|
||||
CONFLICTS= bird-[0-9]*
|
||||
|
||||
USE_BISON= build
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-mpls
|
||||
|
||||
OPTIONS= KMPLS "Enable kernel MPLS support" Off
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
USE_RC_SUBR= bird
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_KMPLS)
|
||||
CONFIGURE_ARGS+= --enable-kmpls
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@if [ ! -f ${PREFIX}/etc/bird.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/bird.conf.example ${PREFIX}/etc/bird.conf ; \
|
||||
${CHMOD} 0640 ${PREFIX}/etc/bird.conf ; \
|
||||
fi
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} =====================================================================
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} " WARNING: Please take a look on kern/134931"
|
||||
@${ECHO_MSG} " WARNING: before using multiple fibs!"
|
||||
@${ECHO_MSG} " 8.2-STABLE kernel patch available here:"
|
||||
@${ECHO_MSG} " http://static.ipfw.ru/patches/rtsock_82S-20110725.diff"
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} =====================================================================
|
||||
@${ECHO_MSG}
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
net/bird-devel/distinfo
Normal file
2
net/bird-devel/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (bird-20111107.tar.gz) = b8dfa1869cae81fae493b3596d4b038a27e72c2d73d3be7b961c9b636333e79e
|
||||
SIZE (bird-20111107.tar.gz) = 3512093
|
32
net/bird-devel/files/bird.in
Normal file
32
net/bird-devel/files/bird.in
Normal file
|
@ -0,0 +1,32 @@
|
|||
#!/bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: bird
|
||||
# REQUIRE: LOGIN
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
|
||||
# to enable this service:
|
||||
#
|
||||
# bird_enable (bool): Set to NO by default.
|
||||
# Set it to YES to enable bird.
|
||||
# bird_config (path): Set to %%PREFIX%%/etc/bird.conf
|
||||
# by default.
|
||||
#
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="bird"
|
||||
rcvar=${name}_enable
|
||||
|
||||
command=%%PREFIX%%/sbin/${name}
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
: ${bird_enable="NO"}
|
||||
: ${bird_config="%%PREFIX%%/etc/bird.conf"}
|
||||
|
||||
command_args="-c $bird_config"
|
||||
|
||||
run_rc_command "$1"
|
15
net/bird-devel/files/patch-tools-Makefile.in
Normal file
15
net/bird-devel/files/patch-tools-Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- tools/Makefile.in.orig 2009-08-16 22:42:37.000000000 +0200
|
||||
+++ tools/Makefile.in 2009-09-16 22:22:07.000000000 +0200
|
||||
@@ -60,11 +60,7 @@
|
||||
if test -n "@CLIENT@" ; then \
|
||||
$(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
|
||||
fi
|
||||
- if ! test -f $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; then \
|
||||
- $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; \
|
||||
- else \
|
||||
- echo "Not overwriting old bird@SUFFIX@.conf" ; \
|
||||
- fi
|
||||
+ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf.example ; \
|
||||
|
||||
install-docs:
|
||||
$(INSTALL) -d $(DESTDIR)/$(docdir)
|
13
net/bird-devel/files/patch-tools-Rules.in
Normal file
13
net/bird-devel/files/patch-tools-Rules.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- tools/Rules.in.orig 2010-10-10 21:48:20.000000000 +0200
|
||||
+++ tools/Rules.in 2010-12-18 15:00:27.000000000 +0100
|
||||
@@ -66,9 +66,7 @@
|
||||
subdir: all.o
|
||||
|
||||
all.o: $(objs)
|
||||
-# $(LD) -r -o $@ $^
|
||||
-# Changed to $(CC) because $(LD) has problems with crosscompiling
|
||||
- $(CC) -nostdlib -r -o $@ $^
|
||||
+ $(LD) -r -o $@ $^
|
||||
|
||||
endif
|
||||
|
16
net/bird-devel/pkg-descr
Normal file
16
net/bird-devel/pkg-descr
Normal file
|
@ -0,0 +1,16 @@
|
|||
The BIRD project aims to develop a fully functional dynamic IP routing daemon.
|
||||
|
||||
- Both IPv4 and IPv6
|
||||
- Multiple routing tables
|
||||
- BGP
|
||||
- RIP
|
||||
- OSPF
|
||||
- LDP
|
||||
- L3VPN
|
||||
- Static routes
|
||||
- Inter-table protocol
|
||||
- Command-line interface
|
||||
- Soft reconfiguration
|
||||
- Powerful language for route filtering
|
||||
|
||||
WWW: http://bird.mpls.in/
|
5
net/bird-devel/pkg-plist
Normal file
5
net/bird-devel/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
|||
@unexec if cmp -s %D/etc/bird.conf.example %D/etc/bird.conf; then rm -f %D/etc/bird.conf; fi
|
||||
etc/bird.conf.example
|
||||
@exec if [ ! -f %D/etc/bird.conf ] ; then cp -p %D/%F %B/bird.conf; fi
|
||||
sbin/bird
|
||||
sbin/birdc
|
Loading…
Reference in a new issue